Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Unable to get sis191 Ethernet Card working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
mimosinnet
Guru
Guru


Joined: 10 Aug 2006
Posts: 525
Location: Barcelona, Spain

PostPosted: Tue Dec 25, 2007 7:44 am    Post subject: Unable to get sis191 Ethernet Card working Reply with quote

I am unable to get the ethernet working on a Fujitsu Esprimo Mobile v5535.

My card:
Code:
# lspci
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] 191 Gigabit Ethernet Adapter (rev 02)


sis190 module gets loaded:
Code:
# lsmod
Module                  Size  Used by
sis190                 20036  0
mii                     6912  1 sis190


Nevertheless, the ethernet devices does not show on ifconfig. This is the relevant dmesg info:
Code:
sis190 Gigabit Ethernet driver 1.2 loaded.
ACPI: PCI Interrupt 0000:00:04.0[A] -> GSI 19 (level, low) -> IRQ 19
PCI: Setting latency timer of device 0000:00:04.0 to 64
ieee80211_crypt: registered algorithm 'NULL'
0000:00:04.0: Read MAC address from APC.
0000:00:04.0: Can not find ISA bridge.
ACPI: PCI interrupt for device 0000:00:04.0 disabled
sis190: probe of 0000:00:04.0 failed with error -5


I have found in google the following suggestion, but it does not solve the issue:
Code:
echo 100 > /sys/class/firmware/timeout


Any hints would be appreciated.


Last edited by mimosinnet on Wed Dec 26, 2007 10:23 pm; edited 2 times in total
Back to top
View user's profile Send private message
mimosinnet
Guru
Guru


Joined: 10 Aug 2006
Posts: 525
Location: Barcelona, Spain

PostPosted: Tue Dec 25, 2007 10:04 pm    Post subject: Reply with quote

I have found this page, giving some clues on what to do.

One of the errors given by dmesg was:
Code:
0000:00:04.0: Can not find ISA bridge


My ISA bridge device number is:
Code:
# lspci -nn
00:02.0 ISA bridge [0601]: Silicon Integrated Systems [SiS] SiS968 [MuTIOL Media IO] [1039:0968] (rev 01)


I have had a look into the module sis190.c in /usr/src/linux/drivers/net, and the ISA bridge device number of my board does not appear.
Code:
# grep -C 10 isa_bridge sis190.c
 isa_bridge = pci_get_device(PCI_VENDOR_ID_SI, 0x0965, NULL);
        if (!isa_bridge)
                isa_bridge = pci_get_device(PCI_VENDOR_ID_SI, 0x0966, NULL);
        if (!isa_bridge) {
                net_probe(tp, KERN_INFO "%s: Can not find ISA bridge.\n",
                          pci_name(pdev));
                return -EIO;
        }


If I change the number from 0965 to my board number (0968) and recompile the kernel, I do not get the ISA error any more, but I am getting another error:
Code:
# dmesg | grep -C 10 sis190
sis190 Gigabit Ethernet driver 1.2 loaded.
ACPI: PCI Interrupt 0000:00:04.0[A] -> GSI 19 (level, low) -> IRQ 19
PCI: Setting latency timer of device 0000:00:04.0 to 64
ieee80211_crypt: registered algorithm 'NULL'
ieee80211: 802.11 data/management/control stack, git-1.1.13
ieee80211: Copyright (C) 2004-2005 Intel Corporation <jketreno@linux.intel.com>
0000:00:04.0: Read MAC address from APC.
0000:00:04.0: Unknown PHY transceiver at address 1


I would very much appreciate any help on how to get the ethernet card working.
Back to top
View user's profile Send private message
mimosinnet
Guru
Guru


Joined: 10 Aug 2006
Posts: 525
Location: Barcelona, Spain

PostPosted: Wed Dec 26, 2007 10:30 pm    Post subject: Reply with quote

I have finally been able to get my sis191 card working by patching the kernel. I have taken the patch from Francois Romieu in bugzilla kernel.

I have saved the diff file in /usr/src/linux, and then applied the patch with:
Code:
patch -p1 -i [i]patchfile[/i]


I recompiled the kernel and it worked.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum