Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200712-03 ] GNU Emacs: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1571

PostPosted: Sun Dec 09, 2007 8:26 pm    Post subject: [ GLSA 200712-03 ] GNU Emacs: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: GNU Emacs: Multiple vulnerabilities (GLSA 200712-03)
Severity: normal
Exploitable: remote
Date: December 09, 2007
Bug(s): #197958, #200297
ID: 200712-03

Synopsis

Two vulnerabilities were found in GNU Emacs possibly leading to the execution of arbitrary code.

Background

GNU Emacs is a highly extensible and customizable text editor.

Affected Packages

Package: app-editors/emacs
Vulnerable: < 22.1-r3
Unaffected: >= 22.1-r3
Unaffected: >= 21.4-r14 < 21.5
Unaffected: < 19
Architectures: All supported architectures


Description

Drake Wilson reported that the hack-local-variables() function in GNU Emacs 22 does not properly match assignments of local variables in a file against a list of unsafe or risky variables, allowing to override them (CVE-2007-5795). Andreas Schwab (SUSE) discovered a stack-based buffer overflow in the format function when handling values with high precision (CVE-2007-6109).

Impact

Remote attackers could entice a user to open a specially crafted file in GNU Emacs, possibly leading to the execution of arbitrary Emacs Lisp code (via CVE-2007-5795) or arbitrary code (via CVE-2007-6109) with the privileges of the user running GNU Emacs.

Workaround

The first vulnerability can be worked around by setting the "enable-local-variables" option to "nil", disabling the processing of local variable lists. GNU Emacs prior to version 22 is not affected by this vulnerability. There is no known workaround for the second vulnerability at this time.

Resolution

All GNU Emacs users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=app-editors/emacs-22.1-r3"


References

CVE-2007-5795
CVE-2007-6109
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum