Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[PALUDIS] Support thread (current v. 0.26.*) - Part 5
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
zxy
Veteran
Veteran


Joined: 06 Jan 2006
Posts: 1160
Location: in bed in front of the computer

PostPosted: Thu Oct 25, 2007 11:52 am    Post subject: [PALUDIS] Support thread (current v. 0.26.*) - Part 5 Reply with quote

PALUDIS SUPPORT THREAD - 0.26.2 is in the paludis repository and gentoo tree
Many news, so just take a look here to what's new:

  • IMPORTANT

    Please report bugs to trac, or use the paludis-user mailing list if you're not sure. Any reports made here will likely not been seen or fixed by Paludis developers.

  • ABOUT

    This thread is the part 5 of the old Paludis Support thread - Part 4. It has been splitted with the upcomming 0.26.* versions of Paludis.

    This front post will be updated from time to time. The old first post will not.

    Paludis is a portage alternative.

    I created this thread for everybody that has problems with using paludis or has something useful to contribute to others about paludis.
    Paludis is different than portage in command line and configs differ, too.
    Any help, info, shortcut, howto or a tip is welcome here.

  • LINKS

    (links changed - UPDATED)
    From paludis home page:
    • The link to paludis homepage: http://paludis.pioto.org/
    • Introduction
    • Bugs, Requests, Support
    • Overview
    • FAQ
    • Clients (programs that come with paludis)
    • Configuration
    • API

      Other resources:

      Share your experiences with paludis here: [ Poll ] Are you satisfied with Paludis

      paludis-extras overlay
      (eclass added so please follow the upgrade instructions)
      Now includes:
      • app-paludis/paludis-hooks-0.3.3 - collection of hooks for paludis (basicaly comming from this thread)
          * ask - truc, zxy
          * check-security-updates
          * collision-protect - dleverton
          * compress-man
          * log-mailer
          * paludis-wrapper - truc, zxy
          * sync-disks - zxy
          * undo-prelink - dleverton
          * update-eix - pioto; contributors bo.andersen, truc
      • app-portage/portage-utils (paludis version) -- truc
      • app-portage/gentoolkit (revdep-rebuild modified for paludis) -- jordan83, zxy
      • app-paludis/etc-paludis (etc-update modified for paludis) -- jordan83
      • app-admin/eselect-paludis-hooks - manage hooks with eselect -- zxy
      • app-paludis/paludis-wrapper (a wrapper script for --nice and --ask) -- truc, zxy
      • sys-apps/module-rebuild (module-rebuild ported to paludis) -- zxy, truc


      Install instructions and change logs are here:

      where you can also find some of the scripts from this and previous thread.

      This overlay is unsupported by paludis and gentoo devs. Do not bother them about it. You can ask questions on paludis-extras overlay thread or on IRC freenode: #paludis-extras.

    • INSTALLATION

      Paludis is in portage and is available in ~arch. For migrating see the guide in the links section.


    • KNOWN ISSUES - DIFFERENCES BETWEEN PORTAGE AND PALUDIS

      If you encounter any problems read the docs on Paludis homepage.
      You can see the FAQ page here: http://paludis.pioto.org/faq

      Check HERE: [url]http://paludis.pioto.org/faq/different.html]/url] to read about differences between portage and paludis.

      There is many things in this and the previous thread, too. And don't forget the wiki.


    • THIS THREAD, THE PREVIOUS THREAD AND WIKI INCLUDE

      In this thread and in the wiki you can find how to make the following work with Paludis:

      • eix
      • revdep-rebuild (it will be removed when 0.26.0 comes out -- reconcilio is included in alphas)
      • ccache
      • portage-utils
      • zsh scripts
      • hooks
        for
        • manage orphaned files after unmerging; for prelinked libraries(by dleverton)
        • collision-protect] (by dleverton)
        see this thread: http://forums.gentoo.org/viewtopic-t-536458.html
      • various tips, tricks, Q & A


      and more...


Enjoy using Paludis,
zxy


It is NOT alowed to start FLAMEWARS here. Go to other threads if you search for a fight!!!!!
For fights go here for example:
http://forums.gentoo.org/viewtopic-t-495257-start-0-postdays-0-postorder-asc-highlight-.html
and there are many more there on the forums (probably LOCKED, though :wink: ).
_________________
Nature does not hurry, yet everything is accomplished.
Lao Tzu


Last edited by zxy on Fri May 30, 2008 2:39 am; edited 14 times in total
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Sat Apr 25, 2009 10:15 am    Post subject: Reply with quote

Since I updated paludis to 0.36.1 I get this weird and somewhat idiotic warning:

Code:
paludis@1240653574: [WARNING paludis_environment.dodgy_script_config] In thread ID '27098':
  ... In program paludis (--show-reasons summary --show-use-descriptions new --continue-on-failure if-satisfied --dl-downgrade warning --log-level warning) -ip world:                                                                                                                                     
  ... When making environment from specification '':                                                                                                 
  ... When loading paludis configuration:                                                                                                             
  ... When loading environment.conf:                                                                                                                 
  ... It looks like you configured Paludis using a dodgy broken script you found on the forums. Unfortunately, your system is probably now broken beyond repair. Please start again, and have more care when deciding how to set things up.


Anyone has a hint what the problem really is? Furthermore I remember to initially set up paludis with the portage2paludis script provided by the paludis devs.
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
Mr. Tao
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jul 2007
Posts: 145

PostPosted: Sat Apr 25, 2009 11:45 am    Post subject: Reply with quote

Phlogiston wrote:
Since I updated paludis to 0.36.1 I get this weird and somewhat idiotic warning:

It looks like you configured Paludis using a dodgy broken script you found on the forums. Unfortunately, your system is probably now broken beyond repair. Please start again, and have more care when deciding how to set things up.
Have you app-paludis/paludis-wrapper installed?
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Sat Apr 25, 2009 11:50 am    Post subject: Reply with quote

Mr. Tao wrote:
Phlogiston wrote:
Since I updated paludis to 0.36.1 I get this weird and somewhat idiotic warning:

It looks like you configured Paludis using a dodgy broken script you found on the forums. Unfortunately, your system is probably now broken beyond repair. Please start again, and have more care when deciding how to set things up.
Have you app-paludis/paludis-wrapper installed?


No I don't.
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Sat Apr 25, 2009 12:08 pm    Post subject: Reply with quote

If you have anything installed from paludis-extras, you'll get that warning.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Sat Apr 25, 2009 1:12 pm    Post subject: Reply with quote

loftwyr wrote:
If you have anything installed from paludis-extras, you'll get that warning.


How childish is that? grr

IMHO I don't use anything from extras, but I'll check.

/edit. I can't find any package installed from that overlay here. Maybe its some orphaned file, any idea?
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
Powerc
n00b
n00b


Joined: 25 Apr 2009
Posts: 6

PostPosted: Sat Apr 25, 2009 2:52 pm    Post subject: Reply with quote

Phlogiston wrote:
Since I updated paludis to 0.36.1 I get this weird and somewhat idiotic warning:

Code:
paludis@1240653574: [WARNING paludis_environment.dodgy_script_config] In thread ID '27098':
  ... In program paludis (--show-reasons summary --show-use-descriptions new --continue-on-failure if-satisfied --dl-downgrade warning --log-level warning) -ip world:                                                                                                                                     
  ... When making environment from specification '':                                                                                                 
  ... When loading paludis configuration:                                                                                                             
  ... When loading environment.conf:                                                                                                                 
  ... It looks like you configured Paludis using a dodgy broken script you found on the forums. Unfortunately, your system is probably now broken beyond repair. Please start again, and have more care when deciding how to set things up.


Anyone has a hint what the problem really is? Furthermore I remember to initially set up paludis with the portage2paludis script provided by the paludis devs.


I'm having same problem with 0.36.1. I have nothing from paludis-extra either so maybe it has something to do with paludis config files. I installed paludis again with paludis2protage script and emerged 0.36.0 back and problem is gone. Hopefully someone figures out what causes this behaviour.
Back to top
View user's profile Send private message
Powerc
n00b
n00b


Joined: 25 Apr 2009
Posts: 6

PostPosted: Sat Apr 25, 2009 3:05 pm    Post subject: Reply with quote

Can anyone help me with other problem that I have? It seems that I can't sync anything from overlays that uses svn:

Code:
crb powerc # playman -a voip

You should now run:
  paludis -s x-voip
crb powerc # paludis -s x-voip
paludis@1240671748: [QA e.repo_name.unusable] Couldn't open repo_name file in '/var/paludis/repositories/voip/profiles/', falling back to generated name 'x-voip' (ignore this message if you have yet to sync this repository).
paludis@1240671748: [QA e.repo_name.unusable] Couldn't open repo_name file in '/var/paludis/repositories/voip/profiles/', falling back to generated name 'x-voip' (ignore this message if you have yet to sync this repository).
Sync x-voip
/usr/libexec/paludis/syncers/dosvn: line 84: svn: command not found
Output log: /var/log/paludis/1240671748-sync-x-voip.out

Sync error:
  * In program paludis -s x-voip:
  * When performing sync action from command line:
  * When executing sync task:
  * When syncing repository 'x-voip':
  * When syncing repository 'x-voip':
  * sync of '/var/paludis/repositories/voip' from 'svn://overlays.gentoo.org/proj/voip/trunk' failed

Sync x-voip failed


 * Regenerating cache for installable repositories...
paludis@1240671749: [QA e.repo_name.unusable] Couldn't open repo_name file in '/var/paludis/repositories/voip/profiles/', falling back to generated name 'x-voip' (ignore this message if you have yet to sync this repository).
paludis@1240671749: [QA e.repo_name.unusable] Couldn't open repo_name file in '/var/paludis/repositories/voip/profiles/', falling back to generated name 'x-voip' (ignore this message if you have yet to sync this repository).
Regenerating cache for layman...
Regenerating cache for virtuals...
Regenerating cache for gentoo...
Regenerating cache for THE...
Regenerating cache for x-voip...

Unhandled exception:
  * In program paludis --log-level qa --regenerate-installable-cache:
  * When performing cache regeneration action from command line:
  * When generating repository names cache at '/var/paludis/repositories/voip/.cache/names/x-voip':
  * mkdir '/var/paludis/repositories/voip/.cache/names' failed: No such file or directory (paludis::FSError)
 * Done regenerating cache for installable repositories

 * Cleaning write cache for ebuild format repositories...
paludis@1240671751: [QA e.repo_name.unusable] Couldn't open repo_name file in '/var/paludis/repositories/voip/profiles/', falling back to generated name 'x-voip' (ignore this message if you have yet to sync this repository).
paludis@1240671751: [QA e.repo_name.unusable] Couldn't open repo_name file in '/var/paludis/repositories/voip/profiles/', falling back to generated name 'x-voip' (ignore this message if you have yet to sync this repository).
paludis@1240671751: [QA e.repo_name.unusable] Couldn't open repo_name file in '/var/paludis/repositories/voip/profiles/', falling back to generated name 'x-voip' (ignore this message if you have yet to sync this repository).
paludis@1240671751: [QA e.repo_name.unusable] Couldn't open repo_name file in '/var/paludis/repositories/voip/profiles/', falling back to generated name 'x-voip' (ignore this message if you have yet to sync this repository).
paludis@1240671751: [QA e.repo_name.unusable] Couldn't open repo_name file in '/var/paludis/repositories/voip/profiles/', falling back to generated name 'x-voip' (ignore this message if you have yet to sync this repository).
paludis@1240671751: [QA e.repo_name.unusable] Couldn't open repo_name file in '/var/paludis/repositories/voip/profiles/', falling back to generated name 'x-voip' (ignore this message if you have yet to sync this repository).
rm -fr /var/cache/paludis/metadata/THE/*
paludis@1240671751: [QA e.repo_name.unusable] Couldn't open repo_name file in '/var/paludis/repositories/voip/profiles/', falling back to generated name 'x-voip' (ignore this message if you have yet to sync this repository).
paludis@1240671751: [QA e.repo_name.unusable] Couldn't open repo_name file in '/var/paludis/repositories/voip/profiles/', falling back to generated name 'x-voip' (ignore this message if you have yet to sync this repository).
paludis@1240671751: [QA e.repo_name.unusable] Couldn't open repo_name file in '/var/paludis/repositories/voip/profiles/', falling back to generated name 'x-voip' (ignore this message if you have yet to sync this repository).
paludis@1240671751: [QA e.repo_name.unusable] Couldn't open repo_name file in '/var/paludis/repositories/voip/profiles/', falling back to generated name 'x-voip' (ignore this message if you have yet to sync this repository).
rm -fr /var/cache/paludis/metadata/zen-overlay/*
 * Done cleaning write cache for ebuild format repositories
paludis@1240671752: [QA e.repo_name.unusable] Couldn't open repo_name file in '/var/paludis/repositories/voip/profiles/', falling back to generated name 'x-voip' (ignore this message if you have yet to sync this repository).
paludis@1240671752: [QA e.repo_name.unusable] Couldn't open repo_name file in '/var/paludis/repositories/voip/profiles/', falling back to generated name 'x-voip' (ignore this message if you have yet to sync this repository).

 * No unread news items found


sync with THE and zen-overlay works fine btw.
Back to top
View user's profile Send private message
krisse
Guru
Guru


Joined: 15 Mar 2005
Posts: 318
Location: Sweden

PostPosted: Sat Apr 25, 2009 3:11 pm    Post subject: Reply with quote

Powerc wrote:
Can anyone help me with other problem that I have? It seems that I can't sync anything from overlays that uses svn:

Code:
[...]
Sync x-voip
/usr/libexec/paludis/syncers/dosvn: line 84: svn: command not found
Output log: /var/log/paludis/1240671748-sync-x-voip.out
[...]


sync with THE and zen-overlay works fine btw.


Now this is probably a silly question, but since it says "svn: command not found" --- have you got subversion installed? As in, is there, in fact, a svn command for paludis to run?

And, if so and the problem lies elsewhere, it seems the Output log referenced might be a good place to start looking for the culprit?
Back to top
View user's profile Send private message
Powerc
n00b
n00b


Joined: 25 Apr 2009
Posts: 6

PostPosted: Sat Apr 25, 2009 3:30 pm    Post subject: Reply with quote

krisse wrote:
Powerc wrote:
Can anyone help me with other problem that I have? It seems that I can't sync anything from overlays that uses svn:

Code:
[...]
Sync x-voip
/usr/libexec/paludis/syncers/dosvn: line 84: svn: command not found
Output log: /var/log/paludis/1240671748-sync-x-voip.out
[...]


sync with THE and zen-overlay works fine btw.


Now this is probably a silly question, but since it says "svn: command not found" --- have you got subversion installed? As in, is there, in fact, a svn command for paludis to run?

And, if so and the problem lies elsewhere, it seems the Output log referenced might be a good place to start looking for the culprit?


Thanks for help! How embarassing that subversion wasn't actually installed in my system and everything seems to work now. :oops: :lol:


Last edited by Powerc on Sat Apr 25, 2009 3:31 pm; edited 1 time in total
Back to top
View user's profile Send private message
krisse
Guru
Guru


Joined: 15 Mar 2005
Posts: 318
Location: Sweden

PostPosted: Sat Apr 25, 2009 3:31 pm    Post subject: Reply with quote

Phlogiston wrote:
Since I updated paludis to 0.36.1 I get this weird and somewhat idiotic warning:

Code:
paludis@1240653574: [WARNING paludis_environment.dodgy_script_config] In thread ID '27098':
  ... In program paludis (--show-reasons summary --show-use-descriptions new --continue-on-failure if-satisfied --dl-downgrade warning --log-level warning) -ip world:                                                                                                                                     
  ... When making environment from specification '':                                                                                                 
  ... When loading paludis configuration:                                                                                                             
  ... When loading environment.conf:                                                                                                                 
  ... It looks like you configured Paludis using a dodgy broken script you found on the forums. Unfortunately, your system is probably now broken beyond repair. Please start again, and have more care when deciding how to set things up.


Anyone has a hint what the problem really is? Furthermore I remember to initially set up paludis with the portage2paludis script provided by the paludis devs.


I've got paludis-extra stuff installed, and I don't get this complaint. So it might be something else than paludiswrapper or some such.

If I'd venture a guess here, the complaint seems to stem from environment.conf, according to the output you posted. What have you got in your environment.conf? (If you, indeed, have one. If you don't, I'd suggest you create one, containing some appropriate values.)
Back to top
View user's profile Send private message
krisse
Guru
Guru


Joined: 15 Mar 2005
Posts: 318
Location: Sweden

PostPosted: Sat Apr 25, 2009 3:33 pm    Post subject: Reply with quote

Powerc wrote:
Thanks for help! How embarassing... subversion wasn't actually installed in my system and everything seems to work now. :oops: :lol:


No problem! Glad I could be of assistance. (And happy to hear it was that easy to fix. ;) )

In my experience, it's always those "small", and thus easily overlooked things, that usually cause the biggest headaches. x-D
Back to top
View user's profile Send private message
ahf
n00b
n00b


Joined: 19 Mar 2009
Posts: 10
Location: Copenhagen, Denmark

PostPosted: Sat Apr 25, 2009 3:53 pm    Post subject: Reply with quote

Phlogiston wrote:
Anyone has a hint what the problem really is? Furthermore I remember to initially set up paludis with the portage2paludis script provided by the paludis devs.


You either used PFG, which generates highly broken configs that can't easily be fixed, or you made the same dumb mistake when configuring things that they did.

Either way, you've screwed up your config and you should start again and not do things you don't understand.
_________________
Alexander Færøy
http://www.0x90.dk/
Back to top
View user's profile Send private message
ahf
n00b
n00b


Joined: 19 Mar 2009
Posts: 10
Location: Copenhagen, Denmark

PostPosted: Sat Apr 25, 2009 3:53 pm    Post subject: Reply with quote

loftwyr wrote:
If you have anything installed from paludis-extras, you'll get that warning.


This is entirely untrue. This has absolutely nothing to do with paludis-extras. Stop spreading lies.
_________________
Alexander Færøy
http://www.0x90.dk/
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Sat Apr 25, 2009 4:26 pm    Post subject: Reply with quote

krisse wrote:

If I'd venture a guess here, the complaint seems to stem from environment.conf, according to the output you posted. What have you got in your environment.conf? (If you, indeed, have one. If you don't, I'd suggest you create one, containing some appropriate values.)


I have one, that is empty... and that should be no problem, I added the world entry but it didn't help.
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
ahf
n00b
n00b


Joined: 19 Mar 2009
Posts: 10
Location: Copenhagen, Denmark

PostPosted: Sat Apr 25, 2009 4:47 pm    Post subject: Reply with quote

Phlogiston wrote:
I have one, that is empty... and that should be no problem, I added the world entry but it didn't help.


If you have an empty environment.conf, you won't get that message. Seriously, just own up to using PFG already, and stop confusing everyone with inaccurate reports.
_________________
Alexander Færøy
http://www.0x90.dk/
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Sat Apr 25, 2009 4:49 pm    Post subject: Reply with quote

ahf wrote:
Phlogiston wrote:
I have one, that is empty... and that should be no problem, I added the world entry but it didn't help.


If you have an empty environment.conf, you won't get that message. Seriously, just own up to using PFG already, and stop confusing everyone with inaccurate reports.


Hu what? What is PFG? And this is not inaccurate.

/edit: It was a wrong option in the environment.conf, I checked the wrong file somhow.
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
ahf
n00b
n00b


Joined: 19 Mar 2009
Posts: 10
Location: Copenhagen, Denmark

PostPosted: Sat Apr 25, 2009 5:02 pm    Post subject: Reply with quote

Phlogiston wrote:
Hu what? What is PFG? And this is not inaccurate.


PFG is Portage Free Gentoo; a horrible script for "configuring" Paludis and get rid of Portage.

Please see http://git.pioto.org/gitweb/paludis.git?a=commit;h=fc937452cf70da78a35ca021114024713972f76f
_________________
Alexander Færøy
http://www.0x90.dk/
Back to top
View user's profile Send private message
nixnut
Administrator
Administrator


Joined: 09 Apr 2004
Posts: 10973
Location: the dutch mountains

PostPosted: Sun Apr 26, 2009 3:58 pm    Post subject: Reply with quote

Split off some nonsense. Repeats while mean the end of this thread.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Mr. Tao
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jul 2007
Posts: 145

PostPosted: Sun Apr 26, 2009 11:20 pm    Post subject: Reply with quote

ahf wrote:
If you have an empty environment.conf, you won't get that message. Seriously, just own up to using PFG already, and stop confusing everyone with inaccurate reports.
This doesn't have to do anything with PFG as q-reinitialize.conf hook specifically asked for setting this kw.
Back to top
View user's profile Send private message
grolsch
n00b
n00b


Joined: 23 Jul 2008
Posts: 31
Location: Scotland

PostPosted: Mon Apr 27, 2009 9:49 am    Post subject: Reply with quote

With Portage I used to issue 'emerge -j4 --load-average=6 foo' which made a huge difference to compiling time. I'm wondering if Paludis has a similar option?,
Back to top
View user's profile Send private message
ahf
n00b
n00b


Joined: 19 Mar 2009
Posts: 10
Location: Copenhagen, Denmark

PostPosted: Mon Apr 27, 2009 2:38 pm    Post subject: Reply with quote

Mr. Tao wrote:
ahf wrote:
If you have an empty environment.conf, you won't get that message. Seriously, just own up to using PFG already, and stop confusing everyone with inaccurate reports.
This doesn't have to do anything with PFG as q-reinitialize.conf hook specifically asked for setting this kw.


It does? Funny, because setting that in environment.conf doesn't do anything.
_________________
Alexander Færøy
http://www.0x90.dk/
Back to top
View user's profile Send private message
ahf
n00b
n00b


Joined: 19 Mar 2009
Posts: 10
Location: Copenhagen, Denmark

PostPosted: Mon Apr 27, 2009 2:40 pm    Post subject: Reply with quote

grolsch wrote:
With Portage I used to issue 'emerge -j4 --load-average=6 foo' which made a huge difference to compiling time. I'm wondering if Paludis has a similar option?,


It doesn't.

Unfortunately, the way Portage does it goes against the constraints specified in PMS, which has been shown to lead to systems breaking.
_________________
Alexander Færøy
http://www.0x90.dk/
Back to top
View user's profile Send private message
Bill Cosby
Guru
Guru


Joined: 22 Jan 2005
Posts: 430
Location: Aachen, Germany

PostPosted: Sat May 02, 2009 8:56 am    Post subject: Reply with quote

Recently I get the following error for the X11 overlay:

Code:
paludis@1241254409: [WARNING e.ebuild.configuration.master_repository] In thread ID '7446':
  ... In program paludis -s:
  ... When making environment from specification '':
  ... When loading paludis environment:
  ... When creating repository from file '/etc/paludis/repositories/x11-overlay.conf:
  ... When making ebuild repository from repo_file '/etc/paludis/repositories/x11-overlay.conf':
  ... Key 'master_repository' in '/etc/paludis/repositories/x11-overlay.conf' will override '/var/paludis/repositories/x11-overlay/metadata/layout.conf'.


The problem is that lately no packages from this repository are recognized, paludis wants to downgrade the previously installed packages from this repo.
Did the X11 overly change something paludis can't handle?
Does anyone know more?
_________________
The Creature from Jekyll Island.
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Sat May 02, 2009 12:42 pm    Post subject: Reply with quote

The X11 downgrades are due to some of the packages being masked in advance by the main repository package.mask.

The message there can be ignored or you can edit one of the two files.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum