Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200710-13 ] Ampache: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Sat Oct 13, 2007 12:26 pm    Post subject: [ GLSA 200710-13 ] Ampache: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: Ampache: Multiple vulnerabilities (GLSA 200710-13)
Severity: low
Exploitable: remote
Date: October 13, 2007
Bug(s): #189607
ID: 200710-13

Synopsis

An SQL injection vulnerability and a possible identity theft have been discovered in Ampache.

Background

Ampache is a PHP-based tool for managing, updating and playing audio files via a web interface.

Affected Packages

Package: www-apps/ampache
Vulnerable: < 3.3.3.5
Unaffected: >= 3.3.3.5
Architectures: All supported architectures


Description

LT discovered that the "match" parameter in albums.php is not properly sanitized before being processed. The Ampache development team also reported an error when handling user sessions.

Impact

A remote attacker could provide malicious input to the application, possibly resulting in the execution of arbitrary SQL code. He could also entice a user to open a specially crafted link to steal the user's session.

Workaround

There is no known workaround at this time.

Resolution

All Ampache users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/ampache-3.3.3.5"


References

CVE-2007-4437
CVE-2007-4438
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum