Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Apache upgrade to 2.2.6 w/Coldfusion (mod_jrun20.so)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
hanj
Veteran
Veteran


Joined: 19 Aug 2003
Posts: 1264

PostPosted: Sun Nov 18, 2007 8:42 pm    Post subject: Apache upgrade to 2.2.6 w/Coldfusion (mod_jrun20.so) Reply with quote

Hello

Trying to upgrade Apache from 2.0.58-r2 to 2.2.6, but what's throwing a wrench in the works.. is that it's a ColdFusion server as well.

When I add this to the config:

Code:
LoadModule jrun_module /opt/coldfusionmx7/runtime/lib/wsconfig/1/mod_jrun20.so
<IfModule mod_jrun20.c>
    JRunConfig Verbose false
    JRunConfig Apialloc false
    JRunConfig Ssl false
    JRunConfig Ignoresuffixmap false
    JRunConfig Serverstore /opt/coldfusionmx7/runtime/lib/wsconfig/1/jrunserver.store
    JRunConfig Bootstrap xxx.xxx.xxx.xxx:51011
    #JRunConfig Errorurl <optionally redirect to this URL on errors>
    #JRunConfig ProxyRetryInterval 600
    #JRunConfig ConnectTimeout 15
    #JRunConfig RecvTimeout 300
    #JRunConfig SendTimeout 15
    AddHandler jrun-handler .jsp .jws .cfm .cfml .cfc .cfr .cfswf
</IfModule>



I get the following configuration error:
apache2ctl configtest
Code:
 * Checking Apache Configuration ...
 * Apache2 has detected a syntax error in your configuration files:
apache2: Syntax error on line 169 of /etc/apache2/httpd.conf: Syntax error on line 93 of /etc/apache2/modules.d/00_default_settings.conf: Cannot load /opt/coldfusionmx7/runtime/lib/wsconfig/1/mod_jrun20.so into server: /opt/coldfusionmx7/runtime/lib/wsconfig/1/mod_jrun20.so: undefined symbol: ap_run_http_method


I'm assuming that I need to update this particular mod_jrun20.so, but unclear on how to do this. It appears this was bundled with coldfusionmx7.

Any suggestions??

Thanks!
hanji
_________________
Server Admin Blog - Uno-Code.com | Gentoo Hosting at Rackspace!
Back to top
View user's profile Send private message
steveb
Advocate
Advocate


Joined: 18 Sep 2002
Posts: 4564

PostPosted: Sun Nov 18, 2007 8:58 pm    Post subject: Reply with quote

Apache 2.2 is not supported in CF7. Upgrade to CF8 if you need/want Apache 2.2 support.

// SteveB
Back to top
View user's profile Send private message
hanj
Veteran
Veteran


Joined: 19 Aug 2003
Posts: 1264

PostPosted: Sun Nov 18, 2007 9:12 pm    Post subject: Reply with quote

Thanks Steveb

I just saw this.. but I think this is a scary jump with the possibility for things to go very bad.
http://kb.adobe.com/selfservice/viewContent.do?externalId=8001e97&sliceId=2

I'll take a look at the update for CF8. How is the install/upgrade procedure for that?

Thanks as always.
hanji
_________________
Server Admin Blog - Uno-Code.com | Gentoo Hosting at Rackspace!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum