Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200710-09 ] NX 2.1: User-assisted execution of arbitrary code
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1571

PostPosted: Tue Oct 09, 2007 11:26 pm    Post subject: [ GLSA 200710-09 ] NX 2.1: User-assisted execution of arbitr Reply with quote

Gentoo Linux Security Advisory

Title: NX 2.1: User-assisted execution of arbitrary code (GLSA 200710-09)
Severity: normal
Exploitable: remote
Date: October 09, 2007
Bug(s): #192712
ID: 200710-09

Synopsis


NX in the 2.1 series uses XFree86 4.3 code which is prone to an integer
overflow vulnerability.


Background


NoMachine's NX establishes remote connections to X11 desktops over
small bandwidth links. NX and NX Node are the compression core
libraries, whereas NX is used by FreeNX and NX Node by the binary-only
NX servers.


Affected Packages

Package: net-misc/nx
Vulnerable: < 3.0.0
Unaffected: >= 3.0.0
Architectures: All supported architectures

Package: net-misc/nxnode
Vulnerable: < 3.0.0-r3
Unaffected: >= 3.0.0-r3
Architectures: All supported architectures


Description


Chris Evans reported an integer overflow within the FreeType PCF font
file parser (CVE-2006-1861). NX and NX Node are vulnerable to this due
to shipping XFree86 4.3.0, which includes the vulnerable FreeType code.


Impact


A remote attacker could exploit these integer overflows by enticing a
user to load a specially crafted PCF font file which might lead to the
execution of arbitrary code with the privileges of the user on the
machine running the NX server.


Workaround


There is no known workaround at this time.


Resolution


All NX users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=net-misc/nx-3.0.0"

All NX Node users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=net-misc/nxnode-3.0.0-r3"


References

CVE-2006-1861
GLSA 200607-02


Last edited by GLSA on Mon Jun 10, 2013 4:26 am; edited 5 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum