Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200709-15 ] BEA JRockit: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1547

PostPosted: Sun Sep 23, 2007 10:26 pm    Post subject: [ GLSA 200709-15 ] BEA JRockit: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: BEA JRockit: Multiple vulnerabilities (GLSA 200709-15)
Severity: normal
Exploitable: remote
Date: September 23, 2007
Bug(s): #190686
ID: 200709-15

Synopsis

BEA JRockit contains several vulnerabilities, some of which may allow the execution of arbitrary code.

Background

BEA JRockit provides tools, utilities, and a complete runtime environment for developing and running applications using the Java programming language.

Affected Packages

Package: dev-java/jrockit-jdk-bin
Vulnerable: < 1.5.0.11_p1
Unaffected: >= 1.5.0.11_p1
Architectures: All supported architectures


Description

An integer overflow vulnerability exists in the embedded ICC profile image parser (CVE-2007-2788), an unspecified vulnerability exists in the font parsing implementation (CVE-2007-4381), and an error exists when processing XSLT stylesheets contained in XSLT Transforms in XML signatures (CVE-2007-3716), among other vulnerabilities.

Impact

A remote attacker could trigger the integer overflow to execute arbitrary code or crash the JVM through a specially crafted file. Also, an attacker could perform unauthorized actions via an applet that grants certain privileges to itself because of the font parsing vulnerability. The error when processing XSLT stylesheets can be exploited to execute arbitrary code. Other vulnerabilities could lead to establishing restricted network connections to certain services, Cross Site Scripting and Denial of Service attacks.

Workaround

There is no known workaround at this time for all these vulnerabilities.

Resolution

All BEA JRockit users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-java/jrockit-jdk-bin-1.5.0.11_p1"


References

CVE-2007-2788
CVE-2007-2789
CVE-2007-3004
CVE-2007-3005
CVE-2007-3503
CVE-2007-3698
CVE-2007-3716
CVE-2007-3922
CVE-2007-4381
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum