Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200709-12 ] Poppler: Two buffer overflow vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Wed Sep 19, 2007 10:26 pm    Post subject: [ GLSA 200709-12 ] Poppler: Two buffer overflow vulnerabilit Reply with quote

Gentoo Linux Security Advisory

Title: Poppler: Two buffer overflow vulnerabilities (GLSA 200709-12)
Severity: normal
Exploitable: remote
Date: September 19, 2007
Bug(s): #188863
ID: 200709-12

Synopsis


Poppler is vulnerable to an integer overflow and a stack overflow.


Background


Poppler is a cross-platform PDF rendering library originally based on
Xpdf.


Affected Packages

Package: app-text/poppler
Vulnerable: < 0.5.4-r2
Unaffected: >= 0.5.4-r2
Architectures: All supported architectures


Description


Poppler and Xpdf are vulnerable to an integer overflow in the
StreamPredictor::StreamPredictor function, and a stack overflow in the
StreamPredictor::getNextLine function. The original vulnerability was
discovered by Maurycy Prodeus. Note: Gentoo's version of Xpdf is
patched to use the Poppler library, so the update to Poppler will also
fix Xpdf.


Impact


By enticing a user to view a specially crafted program with a
Poppler-based PDF viewer such as Gentoo's Xpdf, Epdfview, or Evince, a
remote attacker could cause an overflow, potentially resulting in the
execution of arbitrary code with the privileges of the user running the
application.


Workaround


There is no known workaround at this time.


Resolution


All Poppler users should upgrade to the latest version of Poppler:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=app-text/poppler-0.5.4-r2"


References

CVE-2007-3387


Last edited by GLSA on Thu Mar 08, 2012 4:24 am; edited 2 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum