Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
EAddress Pilot Conduit
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
edibiase
n00b
n00b


Joined: 22 Apr 2002
Posts: 2

PostPosted: Mon Apr 22, 2002 8:20 pm    Post subject: EAddress Pilot Conduit Reply with quote

Hello,

I'm trying to get my mother's Visor Prism working with Evolution through the gnome-pilot stuff. All of the Evolution conduits appear to work except EAddress, which gives me the following error (from the gpilot output):

libgpilotdcm-WARNING **: unable to g_module_open (/usr/lib/gnome-pilot/conduits/libeaddress_conduit.so), reason /usr/lib/gnome-pilot/conduits/libeaddress_conduit.so: undefined symbol: g_unichar_isalpha

Does anyone know what I need to do to correct this error? It would seem like re-emerging Evolution might work, but what should be done differently?
Back to top
View user's profile Send private message
keschrich
n00b
n00b


Joined: 09 Apr 2002
Posts: 69
Location: Branford, CT

PostPosted: Mon Apr 22, 2002 11:32 pm    Post subject: Reply with quote

The EAddress conduit has been broken from the start in Gentoo, as far as I know anyway. I just got word from a friend of mine recently that he's found a way to get around it, although I havn't had a chance to talk to him in detail about it yet. I'll send another post with his solution as soon as I get ahold of him and test it out for myself.

Ken
Back to top
View user's profile Send private message
edibiase
n00b
n00b


Joined: 22 Apr 2002
Posts: 2

PostPosted: Mon Apr 22, 2002 11:40 pm    Post subject: Reply with quote

It looks like it may be fixed, but I don't know for sure (compiling now).

From the evolution-1.0.3-r5 ChangeLog entry:

Quote:
22 Apr 2002; Martin Schlemmer <azarah@gentoo.org> evolution-1.0.3-r.ebuild :

Resolve bug #334.


What's bug #334, you ask? "Evolution's EAddress gnome-pilot conduit fails"!

I think this will make a strong case to my mother about why her computer is running Gentoo Linux over, as she put it, "A Microsoft thing."
Back to top
View user's profile Send private message
keschrich
n00b
n00b


Joined: 09 Apr 2002
Posts: 69
Location: Branford, CT

PostPosted: Tue Apr 23, 2002 12:18 am    Post subject: Reply with quote

The following was posted previously on a different topic by a guest user. I just tested it out and it works like a charm. I'm not sure as to what the line in question actually was supposed to do, it must have been there for a reason, but either way it works following his suggestion.

Quote:
Ximian has been notified that there's a bug in Evolution that hampers compilation of the contact conduit used in palm synchronization.

In the mean time, I recommend the following workaround: edit the .ebuild file for whichever version of evolution you're using, and comment out the line

libtoolize -- copy --force

(line 39 in 1.0.3-r4) I feel dirty, but it works.


Actually I had it in line 69 in 1.0.3-r4, maybe a typo?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum