Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[emerge] Erreur lors de la compilation de Boson
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Sun Aug 05, 2007 8:40 pm    Post subject: [emerge] Erreur lors de la compilation de Boson Reply with quote

Bonsoir,

J'ai essayé d'installer Boson (un jeu de stratégie 3D qui a l'air assez sympa) mais la compilation s'arrête sur l'erreur suivante :
Code:
Undefined reference to `QGLWidget::glInit()'
boufodesignermain.o:(.rodata._ZTV11FormPreview[vtable for FormPreview]+0x200): undefined reference to `QGLWidget::glDraw()'
boufodesignermain.o:(.rodata._ZTI11FormPreview[typeinfo for FormPreview]+0x8): undefined reference to `typeinfo for QGLWidget'
../../../boson/boufo/.libs/libboufo.a(boufoimage.o): In function `BoUfoImageIO::setImage(QImage const&)':
boufoimage.cpp:(.text+0x5d7): undefined reference to `QGLWidget::convertToGLFormat(QImage const&)'
collect2: ld returned 1 exit status
make[4]: *** [boufodesigner] Erreur 1
make[4]: quittant le répertoire « /var/tmp/portage/games-strategy/boson-0.11-r1/work/boson-all-0.11/boson/boufo/designer »
make[3]: *** [all-recursive] Erreur 1
make[3]: quittant le répertoire « /var/tmp/portage/games-strategy/boson-0.11-r1/work/boson-all-0.11/boson/boufo »
make[2]: *** [all-recursive] Erreur 1
make[2]: quittant le répertoire « /var/tmp/portage/games-strategy/boson-0.11-r1/work/boson-all-0.11/boson »
make[1]: *** [all-recursive] Erreur 1
make[1]: quittant le répertoire « /var/tmp/portage/games-strategy/boson-0.11-r1/work/boson-all-0.11 »
make: *** [all] Erreur 2

!!! ERROR: games-strategy/boson-0.11-r1 failed.
Call stack:
  ebuild.sh, line 1632:   Called dyn_compile
  ebuild.sh, line 983:   Called qa_call 'src_compile'
  ebuild.sh, line 44:   Called src_compile
  boson-0.11-r1.ebuild, line 31:   Called kde_src_compile
  kde.eclass, line 170:   Called kde_src_compile 'all'
  kde.eclass, line 340:   Called kde_src_compile 'myconf' 'configure' 'make'
  kde.eclass, line 336:   Called die

!!! died running emake, kde_src_compile:make
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/games-strategy/boson-0.11-r1/temp/build.log'.

Je n'ai pas de chance. Toutes mes compilations de jeu plantent... :(
_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2579
Location: 92

PostPosted: Sun Aug 05, 2007 8:44 pm    Post subject: Reply with quote

Essaye la version 0.13, qui est masquée.
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Sun Aug 05, 2007 9:21 pm    Post subject: Reply with quote

Qt 3 est compilé avec le support de l'OpenGL ?

Vérifie les USE.
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2579
Location: 92

PostPosted: Sun Aug 05, 2007 9:37 pm    Post subject: Reply with quote

Bien vu ;)
J'avais remarqué l'erreur mais ne me rappelais pas qu'il y avait un flag opengl (pourtant activé ^^) pour Qt.
Back to top
View user's profile Send private message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Wed Aug 08, 2007 8:38 pm    Post subject: Reply with quote

J'ai bien recompilé QT avec USE="opengl" mais j'obtiens toujours la même erreur.
_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Wed Aug 08, 2007 8:46 pm    Post subject: Reply with quote

Neuromancien wrote:
J'ai bien recompilé QT avec USE="opengl" mais j'obtiens toujours la même erreur.


Tu as bien recompilé Qt 3 avec le USE opengl ?

Que dit :
Code:
equery uses "=x11-libs/qt-3*"

_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Tue Aug 21, 2007 12:21 pm    Post subject: Reply with quote

Desintegr wrote:

Tu as bien recompilé Qt 3 avec le USE opengl ?

Comment recompiler Qt 3 ? Je ne le trouve pas dans la liste des paquets.
_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2869
Location: Grenoble, France

PostPosted: Tue Aug 21, 2007 12:28 pm    Post subject: Reply with quote

Qt3 est toujours disponible dans l'arbre.
man emerge pour savoir comment l'installer.
Back to top
View user's profile Send private message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Tue Aug 21, 2007 2:23 pm    Post subject: Reply with quote

J'ai recompilé Qt3 avec USE="opengl" mais la compilation de Boson me donne toujours une erreur :
Code:
!!! ERROR: games-strategy/boson-0.11-r1 failed.
Call stack:
  ebuild.sh, line 1632:   Called dyn_compile
  ebuild.sh, line 983:   Called qa_call 'src_compile'
  ebuild.sh, line 44:   Called src_compile
  boson-0.11-r1.ebuild, line 31:   Called kde_src_compile
  kde.eclass, line 170:   Called kde_src_compile 'all'
  kde.eclass, line 340:   Called kde_src_compile 'myconf' 'configure' 'make'
  kde.eclass, line 322:   Called econf '--with-gl' '--with-x' '--enable-mitshm' '--without-xinerama' '--with-qt-dir=/usr/qt/3' '--enable-mt' '--with-qt-libraries=/usr/qt/3/lib' '--disable-dependency-tracking' '--disable-debug' '--without-debug' '--without-arts' '--with-extra-includes=/usr/kde/3.5/include' '--with-extra-libs=/usr/kde/3.5/lib'
  ebuild.sh, line 586:   Called die

!!! econf failed

_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
julroy67
Apprentice
Apprentice


Joined: 03 Feb 2007
Posts: 209
Location: Alsace >> /dev/null

PostPosted: Tue Aug 21, 2007 5:09 pm    Post subject: Reply with quote

Donne nous la partie plus haute pour les erreurs, ce que tu as donné ne nous aide pas à savoir d'où vient le problème.
_________________
63n700 L1nux P0w44 !

Intel Core2Quad 6600
Abit FP-IN9 SLI Fatal1ty Nforce 580i
Nvidia GeForce 8600 GTS
2 Go RAM DDR800 Corsair

Actualité des jeux sous Linux
Back to top
View user's profile Send private message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Tue Aug 21, 2007 5:59 pm    Post subject: Reply with quote

Code:
checking whether make sets $(MAKE)... yes
checking for kde-config... /usr/kde/3.5/bin/kde-config
/usr/kde/3.5/bin/kde-config: error while loading shared libraries: libexpat.so.0: cannot open shared object file: No such file or directory
configure: error: /usr/kde/3.5/bin/kde-config --prefix outputed the non existant prefix '' for kdelibs.
                    This means it has been moved since you installed it.
                    This won't work. Please recompile kdelibs for the new prefix.

J'ai essayé de recompiler kdelibs, ce qui me donne :
Code:
../mDNSCore/mDNS.c: In function ‘mDNS_RegisterService’:
../mDNSCore/mDNS.c:6855: erreur interne du compilateur: Erreur de segmentation
Veuillez soumettre un rapport complet d'anomalies,
avec le source pré-traité si nécessaire.
Consultez <URL:http://bugs.gentoo.org/> pour plus de détail.
The bug is not reproducible, so it is likely a hardware or OS problem.
make: *** [objects/prod/mDNS.c.o] Erreur 1

!!! ERROR: net-misc/mDNSResponder-107.6-r5 failed.
Call stack:
  ebuild.sh, line 1632:   Called dyn_compile
  ebuild.sh, line 983:   Called qa_call 'src_compile'
  ebuild.sh, line 44:   Called src_compile
  mDNSResponder-107.6-r5.ebuild, line 51:   Called die

!!! make failed
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/net-misc/mDNSResponder-107.6-r5/temp/build.log'.

_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
julroy67
Apprentice
Apprentice


Joined: 03 Feb 2007
Posts: 209
Location: Alsace >> /dev/null

PostPosted: Tue Aug 21, 2007 6:43 pm    Post subject: Reply with quote

Ton problème se situe plutôt du coté de expat, essaie de recompiler expat.
_________________
63n700 L1nux P0w44 !

Intel Core2Quad 6600
Abit FP-IN9 SLI Fatal1ty Nforce 580i
Nvidia GeForce 8600 GTS
2 Go RAM DDR800 Corsair

Actualité des jeux sous Linux
Back to top
View user's profile Send private message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Tue Aug 21, 2007 7:07 pm    Post subject: Reply with quote

julroy67 wrote:
Ton problème se situe plutôt du coté de expat, essaie de recompiler expat.

J'ai déjà eu ce problème avec expat et j'ai dû tout recompiler... :(
_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
julroy67
Apprentice
Apprentice


Joined: 03 Feb 2007
Posts: 209
Location: Alsace >> /dev/null

PostPosted: Wed Aug 22, 2007 11:14 am    Post subject: Reply with quote

Arf pas super :( je peux pas t'en dire plus.
_________________
63n700 L1nux P0w44 !

Intel Core2Quad 6600
Abit FP-IN9 SLI Fatal1ty Nforce 580i
Nvidia GeForce 8600 GTS
2 Go RAM DDR800 Corsair

Actualité des jeux sous Linux
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4912

PostPosted: Wed Aug 22, 2007 11:25 am    Post subject: Reply with quote

Ce problème avec expat (la bête noir du moment) c'est pas de recompiler expat c'est plutôt de recompiler les paquets qui l'utilise. Le mieux pour ça c'est un bon ptit revdep-rebuild, il s'en sort pas trop mal. Après on peut appliquer aussi une mise à jour (ça fait pas de mal)
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum