Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg X11 7.2 on xbox 1.5, Fatal Server Error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
koan
Apprentice
Apprentice


Joined: 01 May 2006
Posts: 163
Location: Melbourne

PostPosted: Tue Aug 21, 2007 4:41 am    Post subject: Xorg X11 7.2 on xbox 1.5, Fatal Server Error Reply with quote

Hello, I am having some trouble getting xorg to start on my gentoo Xbox.

My kernel is the standard xbox 2.6.16.26 kernel, and xorg is version 7.2

I am using nvxbox from http://xbox-linux.cvs.sourceforge.net/xbox-linux/

I get the following errors in Xorg:

Code:
(EE) NVXBOX(0): V_BIOS address 0x7bbb0 out of range
(EE) AIGLX: DRI module not loaded


I am not convinced that these are relevant. After the first error in the logs, X goes through the normal video driver initialisation, finding a suitable mode that works. It seems to be happy, then issues the second error then goes on to initialise the mouse and keyboard drivers.

The screen blanks, and then fills with garbage, like it failed to initialise properly - though there does seem to be some activity on the screen, like something is being written.

Finally in the logs, I get:

Code:
Backtrace:
0: X(xf86SigHandler+0x88) [0x80cd8b8]
1: /usr/lib/xorg/modules/drivers//nvxbox_drv.so [0xb7c09a8e]
2: /usr/lib/xorg/modules//libramdac.so(xf86SetCursor+0x15c) [0xb7b1c7bc]


Any ideas how I can go about diagnosing this? Does anyone know what the error sequence is - did the error occur at 0 or 2 above?

Thanks,

Paul
Back to top
View user's profile Send private message
Anubious
n00b
n00b


Joined: 17 Aug 2006
Posts: 46

PostPosted: Mon Sep 03, 2007 11:34 am    Post subject: Reply with quote

it wouldnt even build for me, so i just downloaded gentoox and took the driver from there, as well as a few other things
Back to top
View user's profile Send private message
koan
Apprentice
Apprentice


Joined: 01 May 2006
Posts: 163
Location: Melbourne

PostPosted: Mon Sep 03, 2007 12:35 pm    Post subject: Reply with quote

Turns out it was pretty straight forward. I wasn't loading the fbdev driver.
Once that was in, it worked fine.
Back to top
View user's profile Send private message
jflatt
n00b
n00b


Joined: 01 Mar 2005
Posts: 16

PostPosted: Fri Dec 28, 2007 11:13 pm    Post subject: Reply with quote

Can you be a little more specific? The xorg fbdev driver? The kernel fb module?
Back to top
View user's profile Send private message
koan
Apprentice
Apprentice


Joined: 01 May 2006
Posts: 163
Location: Melbourne

PostPosted: Sat Dec 29, 2007 1:30 am    Post subject: Reply with quote

I am not near my xbox for the next few days, but as I recall, it was the xorg fbdev driver, loaded in the "screen" section.
Back to top
View user's profile Send private message
DrAgOnTuX
Apprentice
Apprentice


Joined: 22 Aug 2006
Posts: 176
Location: Switzerland

PostPosted: Fri Jan 04, 2008 4:24 am    Post subject: Reply with quote

@koan can you post your xorg.conf?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum