Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200708-09 ] Mozilla products: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1571

PostPosted: Wed Aug 15, 2007 12:26 am    Post subject: [ GLSA 200708-09 ] Mozilla products: Multiple vulnerabilitie Reply with quote

Gentoo Linux Security Advisory

Title: Mozilla products: Multiple vulnerabilities (GLSA 200708-09)
Severity: normal
Exploitable: remote
Date: August 14, 2007
Bug(s): #185737, #187205
ID: 200708-09

Synopsis

Multiple vulnerabilities have been reported in Mozilla Firefox, Thunderbird, SeaMonkey and XULRunner, some of which may allow user-assisted arbitrary remote code execution.

Background

Mozilla Firefox is an open-source web browser from the Mozilla Project, and Mozilla Thunderbird an email client. The SeaMonkey project is a community effort to deliver production-quality releases of code derived from the application formerly known as the 'Mozilla Application Suite'. XULRunner is a Mozilla runtime package that can be used to bootstrap XUL+XPCOM applications like Firefox and Thunderbird.

Affected Packages

Package: www-client/mozilla-firefox
Vulnerable: < 2.0.0.6
Unaffected: >= 2.0.0.6
Architectures: All supported architectures

Package: www-client/mozilla-firefox-bin
Vulnerable: < 2.0.0.6
Unaffected: >= 2.0.0.6
Architectures: All supported architectures

Package: mail-client/mozilla-thunderbird
Vulnerable: < 2.0.0.6
Unaffected: >= 2.0.0.6
Architectures: All supported architectures

Package: mail-client/mozilla-thunderbird-bin
Vulnerable: < 2.0.0.6
Unaffected: >= 2.0.0.6
Architectures: All supported architectures

Package: www-client/seamonkey
Vulnerable: < 1.1.4
Unaffected: >= 1.1.4
Architectures: All supported architectures

Package: www-client/seamonkey-bin
Vulnerable: < 1.1.4
Unaffected: >= 1.1.4
Architectures: All supported architectures

Package: net-libs/xulrunner
Vulnerable: < 1.8.1.6
Unaffected: >= 1.8.1.6
Architectures: All supported architectures


Description

Mozilla developers fixed several bugs, including an issue with modifying XPCNativeWrappers (CVE-2007-3738), a problem with event handlers executing elements outside of the document (CVE-2007-3737), and a cross-site scripting (XSS) vulnerability (CVE-2007-3736). They also fixed a problem with promiscuous IFRAME access (CVE-2007-3089) and an XULRunner URL spoofing issue with the wyciwyg:// URI and HTTP 302 redirects (CVE-2007-3656). Denials of Service involving corrupted memory were fixed in the browser engine (CVE-2007-3734) and the JavaScript engine (CVE-2007-3735). Finally, another XSS vulnerability caused by a regression in the CVE-2007-3089 patch was fixed (CVE-2007-3844).

Impact

A remote attacker could entice a user to view a specially crafted web page that will trigger one of the vulnerabilities, possibly leading to the execution of arbitrary code or a Denial of Service. It is also possible for an attacker to perform cross-site scripting attacks, which could result in the exposure of sensitive information such as login credentials.

Workaround

There is no known workaround at this time.

Resolution

All Mozilla Firefox users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-client/mozilla-firefox-2.0.0.6"
All Mozilla Firefox binary users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-client/mozilla-firefox-bin-2.0.0.6"
All Mozilla Thunderbird users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=mail-client/mozilla-thunderbird-2.0.0.6"
All Mozilla Thunderbird binary users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=mail-client/mozilla-thunderbird-bin-2.0.0.6"
All SeaMonkey users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-client/seamonkey-1.1.4"
All SeaMonkey binary users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-client/seamonkey-bin-1.1.4"
All XULRunner users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=net-libs/xulrunner-1.8.1.6"


References

CVE-2007-3089
CVE-2007-3656
CVE-2007-3734
CVE-2007-3735
CVE-2007-3736
CVE-2007-3737
CVE-2007-3738
CVE-2007-3844
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum