Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gcc 2.95 -> gcc 3.1 -> gcc 2.95
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
srepmub
n00b
n00b


Joined: 20 May 2002
Posts: 10

PostPosted: Sat Jun 22, 2002 12:30 am    Post subject: gcc 2.95 -> gcc 3.1 -> gcc 2.95 Reply with quote

hi!

I thought I'd try emerging gcc 3.1 as I had read it would be possible to gradually cross over to a fully gcc 3.1 compiled system. needless to say, I messed up my system.. so I went back to gcc 2.95 again. everything now emerges fine again except for things that need Qt.. I would especially like to be able to run KDE again, but none of the KDE packages seem to make it through their ./configure stage: 'need qt-mt support. please enable thread support' while Qt seems to be installed just fine (with thread support, I haven't touched anything..) I think I have recompiled all the packages that I emerged with gcc 3.1 again with gcc 2.95 (including Qt) but still no luck. if someone has an idea of how I might be able to fix this, I would love to hear it :-) I promise not to emerge gcc 3.1 or gnome 2 again until I have an idea what I'm doing..
Back to top
View user's profile Send private message
yagami
Apprentice
Apprentice


Joined: 12 May 2002
Posts: 222
Location: Leiria, Portugal

PostPosted: Sat Jun 22, 2002 11:15 am    Post subject: Reply with quote

try uninstalling qt first , and then installing it with gcc 2.95

qt and kde must be compiled with the same compiler , its very important
Back to top
View user's profile Send private message
srepmub
n00b
n00b


Joined: 20 May 2002
Posts: 10

PostPosted: Sat Jun 22, 2002 6:53 pm    Post subject: done that Reply with quote

thanks for the reply! but I've already tried that about 10 times.. I don't know what to try next
Back to top
View user's profile Send private message
Pigeon
Guru
Guru


Joined: 21 Jun 2002
Posts: 307

PostPosted: Sun Jun 23, 2002 9:14 pm    Post subject: Reply with quote

Shot in the dark, but try:

Code:
export USE="-thread"
emerge x11-libs/qt


then emerge the other qt based apps.
Back to top
View user's profile Send private message
srepmub
n00b
n00b


Joined: 20 May 2002
Posts: 10

PostPosted: Sun Jun 23, 2002 10:38 pm    Post subject: Reply with quote

thanks I'll try that! I actually reinstalled gentoo on another partition yesterday, because I wanted a non-xfs system and a 'stable' system so that I can mess up the other. (I know, there are probably ways of converting a file system ;)) one question though: don't I really want thread support??
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum