Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
SOLVED: DDRAW_Create Couldn't load WineD3D - OpenGL ....
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
c6comp
n00b
n00b


Joined: 25 Jul 2007
Posts: 7
Location: Houston, TX

PostPosted: Wed Jul 25, 2007 7:56 pm    Post subject: SOLVED: DDRAW_Create Couldn't load WineD3D - OpenGL .... Reply with quote

Hi,

First of all, i am running the nVIdia driver version 100.14.11 on a GeForce 6200, i am using Gentoo 2007.0 amd64. I successfuly installed GTA SA in wine, then installed direct x 9, but when i launch the game, it says that i require a DX9 graphics card, which wine supports. The error message in the terminal is:

Code:
_____@______ ~/.wine/drive_c/Program Files/Rockstar Games/GTA San Andreas $ wine gta_sa.exe
ALSA lib conf.c:3939:(snd_config_expand) Unknown parameters 0
ALSA lib control.c:910:(snd_ctl_open_noupdate) Invalid CTL default:0
fixme:wave:ALSA_AddCaptureDevice Add support for DSCapture
ALSA lib conf.c:3939:(snd_config_expand) Unknown parameters 1
ALSA lib control.c:910:(snd_ctl_open_noupdate) Invalid CTL default:1
fixme:wave:ALSA_AddCaptureDevice Add support for DSCapture
fixme:mixer:ALSA_MixerInit No master control found, disabling mixer
fixme:system:SystemParametersInfoW Unimplemented action: 8193 (SPI_SETFOREGROUNDLOCKTIMEOUT)
err:ddraw:DDRAW_Create Couldn't load WineD3D - OpenGL libs not present?


I don't have a clue as to why this doesnt work. I have tried it on other distros (Slackware, Debian) and it worked fine. Any help would be appreciated.

Thanks

~Jonh~


Last edited by c6comp on Thu Aug 02, 2007 3:36 pm; edited 1 time in total
Back to top
View user's profile Send private message
mattsteven
Apprentice
Apprentice


Joined: 27 Oct 2003
Posts: 240
Location: Your Planet

PostPosted: Wed Jul 25, 2007 8:00 pm    Post subject: Reply with quote

Check
Code:
eselect opengl list
as you may need to change to the nvidia opengl, the ebuild won't do it for you.

You'll have to set it also
Code:
eselect opengl set [number of nvidia gl here]


Also check that opengl set in your USE flags for wine.
_________________
Matthew Steven
Linux-only desktop since 1998
Graying hair since 2006
Back to top
View user's profile Send private message
c6comp
n00b
n00b


Joined: 25 Jul 2007
Posts: 7
Location: Houston, TX

PostPosted: Wed Jul 25, 2007 8:11 pm    Post subject: Reply with quote

mattsteven wrote:
Check
Code:
eselect opengl list
as you may need to change to the nvidia opengl, the ebuild won't do it for you.

You'll have to set it also
Code:
eselect opengl set [number of nvidia gl here]


Also check that opengl set in your USE flags for wine.


I ran the first command you gave me, and it gave me this:
Code:
Available OpenGL implementations:
  [1]   ati
  [2]   nvidia *
  [3]   xorg-x11

So, i assume that everything right, right?

And, how do i check that opengl is set in my USE flags for wine (im not that good with wine...)?

Thanks
Back to top
View user's profile Send private message
mattsteven
Apprentice
Apprentice


Joined: 27 Oct 2003
Posts: 240
Location: Your Planet

PostPosted: Wed Jul 25, 2007 8:33 pm    Post subject: Reply with quote

Easiest would just be
Code:
emerge wine -pv

_________________
Matthew Steven
Linux-only desktop since 1998
Graying hair since 2006
Back to top
View user's profile Send private message
c6comp
n00b
n00b


Joined: 25 Jul 2007
Posts: 7
Location: Houston, TX

PostPosted: Wed Jul 25, 2007 9:31 pm    Post subject: Reply with quote

mattsteven wrote:
Easiest would just be
Code:
emerge wine -pv


Code:

localhost omer # emerge wine -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] app-emulation/wine-0.9.41 [0.9.40] USE="X alsa arts cups dbus glut hal jack jpeg ldap ncurses scanner xml -debug -esd* -gif* -lcms -nas -opengl* -oss*" 11,834 kB [?=>1]

Total: 1 package (1 upgrade), Size of downloads: 11,834 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/portage/local/layman/sabayon
 [?] indicates that the source repository could not be determined


??? What do id do now? :oops:
Back to top
View user's profile Send private message
c6comp
n00b
n00b


Joined: 25 Jul 2007
Posts: 7
Location: Houston, TX

PostPosted: Thu Jul 26, 2007 1:36 am    Post subject: Reply with quote

Anyone? I think that i need the opengl 32 bit binaries? Come on, i know somebody knows... please :cry:
Back to top
View user's profile Send private message
Tonglebeak
Guru
Guru


Joined: 23 Mar 2006
Posts: 362

PostPosted: Thu Jul 26, 2007 2:41 am    Post subject: Reply with quote

You need to enable the opengl use flag for wine.
Back to top
View user's profile Send private message
iopi
n00b
n00b


Joined: 13 Mar 2005
Posts: 68

PostPosted: Thu Jul 26, 2007 5:31 am    Post subject: Reply with quote

I'm pretty sure he has opengl enabled (there is a star by opengl)

Code:

[ebuild     U ] app-emulation/wine-0.9.41 [0.9.40] USE="X alsa arts cups dbus glut hal jack jpeg ldap ncurses scanner xml -debug -esd* -gif* -lcms -nas -opengl* -oss*" 11,834 kB [?=>1]



this is probably a pretty stupid question, but you are using a nvidia card right

reason I ask is I noticed ati in your list

Code:

Available OpenGL implementations:
  [1]   ati
  [2]   nvidia *
  [3]   xorg-x11
Back to top
View user's profile Send private message
killertux
Tux's lil' helper
Tux's lil' helper


Joined: 11 Dec 2003
Posts: 119

PostPosted: Thu Jul 26, 2007 6:10 am    Post subject: Reply with quote

To be SURE system need to have opengl32.dll.so and wined3d.dll.so if you do not have those Windows apps using DirectDraw, OpenGL and Direct3D will not work.
Back to top
View user's profile Send private message
Sarenka
n00b
n00b


Joined: 30 Sep 2006
Posts: 25

PostPosted: Tue Jul 31, 2007 5:35 pm    Post subject: Reply with quote

I have similar problem. I`m using ATI X850XT with ati-driver:
Code:

# fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI RADEON X850 XT
OpenGL version string: 2.0.6473 (8.37.6)


My wine:
Code:

# emerge -pv wine
[ebuild   R   ] app-emulation/wine-0.9.41  USE="X alsa cups -dbus -esd -hal jack -jpeg -lcms -ldap -nas ncurses opengl -oss -scanner -xml" 0 kB


Opengl impl. is selected:
Code:

#  eselect opengl list
Available OpenGL implementations:
  [1]   ati *
  [2]   xorg-x11



When I try to run Counter Strike thru Steam. , i receive this error on screen:
Code:

Error initializing gl driver, check that the file 'opengl32.dll' exists.

and in console:
Code:

err:ole:CoGetClassObject class {9a5ea990-3034-4d6f-9128-01f3c61022bc} not registered
err:ole:CoGetClassObject no class object {9a5ea990-3034-4d6f-9128-01f3c61022bc} could be created for context 0x1
err:module:import_dll Library wined3d.dll (which is needed by L"c:\\windows\\system32\\d3d9.dll") not found
err:ddraw:DDRAW_Create Couldn't load WineD3D - OpenGL libs not present?

I had the same error with Wine from CVS - no wined3d.dll.so - it's just not being created during compile.

Ofcourse, adding run parameters to the game -dx8, -gl, -sw (DirectX 8, OpenGL and software rendering) makes no difference.

EDIT:
I've checked ./configure for Wine CVS:
Code:

configure: WARNING: No OpenGL library found on this system.
Wine will be build without OpenGL or Direct3D support.

Now I'm confused...
_________________
Don't kill me for my bad english...
At least - not immidietly...
Please....
Back to top
View user's profile Send private message
roderick
l33t
l33t


Joined: 11 Jul 2005
Posts: 908
Location: St. John's, NL CANADA

PostPosted: Tue Jul 31, 2007 5:55 pm    Post subject: Reply with quote

Let's get back to basics...

Can you run glxgears? What FPS do you get?

If you do a 'glxinfo | grep -i direct' do you see Direct Rendering Yes?
_________________
If God were a pickle, I'd still say "no pickle on my burger".
http://roderick-greening.blogspot.com/
Back to top
View user's profile Send private message
Sarenka
n00b
n00b


Joined: 30 Sep 2006
Posts: 25

PostPosted: Tue Jul 31, 2007 6:44 pm    Post subject: Reply with quote

I forgot in previous post:

Code:

# glxgears
57937 frames in 5.0 seconds = 11587.328 FPS
59008 frames in 5.0 seconds = 11801.524 FPS
59753 frames in 5.0 seconds = 11950.533 FPS
60516 frames in 5.0 seconds = 12103.079 FPS
59290 frames in 5.0 seconds = 11857.972 FPS
53549 frames in 5.0 seconds = 10709.044 FPS
55800 frames in 5.0 seconds = 11160.000 FPS
59093 frames in 5.0 seconds = 11818.475 FPS
59477 frames in 5.0 seconds = 11895.346 FPS

# glxinfo|grep direct
direct rendering: Yes

_________________
Don't kill me for my bad english...
At least - not immidietly...
Please....
Back to top
View user's profile Send private message
mattsteven
Apprentice
Apprentice


Joined: 27 Oct 2003
Posts: 240
Location: Your Planet

PostPosted: Tue Jul 31, 2007 7:44 pm    Post subject: Reply with quote

Let's see

Code:
ls -l /usr/lib/win32/opengl32.dll.so


Or if you are on amd64, /usr/lib32/wine/opengl32.dll.so
_________________
Matthew Steven
Linux-only desktop since 1998
Graying hair since 2006
Back to top
View user's profile Send private message
Sarenka
n00b
n00b


Joined: 30 Sep 2006
Posts: 25

PostPosted: Tue Jul 31, 2007 7:57 pm    Post subject: Reply with quote

No - it's not there...
And, as I see, shouldn't it be 'opengl32.dll' (it's not there also)? There no .so in /us/lib/win32 on my system (it's not there also)
_________________
Don't kill me for my bad english...
At least - not immidietly...
Please....
Back to top
View user's profile Send private message
mattsteven
Apprentice
Apprentice


Joined: 27 Oct 2003
Posts: 240
Location: Your Planet

PostPosted: Wed Aug 01, 2007 2:28 pm    Post subject: Reply with quote

Merge gentoolkit if you haven't already.

Code:

euse -E opengl
emerge -uD --newuse world -pv


You should see wine appear in the list, then proceed to
Code:

emerge -uD --newuse world

_________________
Matthew Steven
Linux-only desktop since 1998
Graying hair since 2006
Back to top
View user's profile Send private message
Sarenka
n00b
n00b


Joined: 30 Sep 2006
Posts: 25

PostPosted: Wed Aug 01, 2007 4:51 pm    Post subject: Reply with quote

I can't do this (emerge world) write now (I've got some work to do - LiveCD creation to be exact), but:
Code:

# cat /etc/make.conf|grep USE
USE="vhosts X alsa arts mp3 3dnow mmx jack -gtk -gnome -ipv6 kde qt3 qt4 qt opengl mysql tetex"

And this was present during last emerge world

EDIT:
I've changed opengl implementation to xorg-x11 and the configure errors are gone - I will try to ivestigate it further.
_________________
Don't kill me for my bad english...
At least - not immidietly...
Please....
Back to top
View user's profile Send private message
Sarenka
n00b
n00b


Joined: 30 Sep 2006
Posts: 25

PostPosted: Wed Aug 01, 2007 8:14 pm    Post subject: Reply with quote

After an hour or so in Counter Strike i can share workaround for this problem.
It can be sad in 3 lines:
Code:

eselect opengl set xorg-x11
emerge wine
eselect opengl set ati

_________________
Don't kill me for my bad english...
At least - not immidietly...
Please....
Back to top
View user's profile Send private message
c6comp
n00b
n00b


Joined: 25 Jul 2007
Posts: 7
Location: Houston, TX

PostPosted: Thu Aug 02, 2007 12:39 am    Post subject: Reply with quote

Sorry that i havent answered for a while... I am trying the solution posted above...
Back to top
View user's profile Send private message
c6comp
n00b
n00b


Joined: 25 Jul 2007
Posts: 7
Location: Houston, TX

PostPosted: Thu Aug 02, 2007 3:34 pm    Post subject: Reply with quote

It works! just do the following if on nvidia:


eselect opengl set xorg-x11
then
emerge wine (Note: for me , emerge still compiled wine with the --without-opengl option, so i downloaded the source of wine, and compiled and installed my self WARNING: It is a bad idea to manually install software on gentoo!)
then
eselect opengl set nvidia


Thanks to Sarenka!!!
Back to top
View user's profile Send private message
mattsteven
Apprentice
Apprentice


Joined: 27 Oct 2003
Posts: 240
Location: Your Planet

PostPosted: Sun Aug 05, 2007 1:08 pm    Post subject: Reply with quote

It might be a good idea to file a bug about this, it is definately not the way this ebuild should work.
_________________
Matthew Steven
Linux-only desktop since 1998
Graying hair since 2006
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum