Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ERRORE: "C compiler cannot create executables"
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
rete27
Tux's lil' helper
Tux's lil' helper


Joined: 26 Feb 2007
Posts: 86

PostPosted: Tue Jun 26, 2007 7:04 pm    Post subject: ERRORE: "C compiler cannot create executables" Reply with quote

Ciao
premetto subito che ho ancora poca esperienza ma le cose cambiano...
Venendo a noi ho quando cerco di fare qualsiasi cosa con emerge o più in generale con il gcc mi appare un errore del tipo
Code:
 C compiler cannot create executables


Ho provato a vedere e di sistemare le CFLAGS come dice la wiki di gentoo ma non si risolve nulla...ho provato a fare il fix_libtool_files.sh ma nulla...

la versione di gcc installata è la 4.1.2 e del gcc-config è 1.3.16

grazie a tutti (in anticipo :wink: )
_________________
Al mondo ci sono 10 tipi di persone quelle che conoscono il sistema binario e quelle che non lo conoscono...
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Tue Jun 26, 2007 7:23 pm    Post subject: Reply with quote

puoi postare il make.conf che i fatti sono meglio delle parole ;)
Back to top
View user's profile Send private message
crisandbea
Veteran
Veteran


Joined: 03 Jul 2005
Posts: 1778
Location: BOSCO (SA) ... ma domiciliato a Bologna....

PostPosted: Tue Jun 26, 2007 7:25 pm    Post subject: Reply with quote

una ricerchina nel forum non farebbe mai male

http://forums.gentoo.org/viewtopic-t-27486-postdays-0-postorder-asc-start-150.html

ciao
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4729
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Tue Jun 26, 2007 7:35 pm    Post subject: Reply with quote

con quali CFLAGS o LDFLAGS lo hai compilato l'utima volta? Prima di postare il make.conf controlla se non hai scritto male qualche parametro.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
rete27
Tux's lil' helper
Tux's lil' helper


Joined: 26 Feb 2007
Posts: 86

PostPosted: Tue Jun 26, 2007 8:25 pm    Post subject: Reply with quote

Ic3M4n wrote:
puoi postare il make.conf che i fatti sono meglio delle parole ;)

allora
Code:

VIDEO_CARDS="radeon vesa"
INPUT_DEVICES="keyboard mouse"
LINGUAS="it en"

CHOST="i686-pc-linux-gnu"

CFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer"

CXXFLAGS="${CFLAGS}"

LDFLAGS="-Wl,-z,now,-O1,--hash-style=gnu"

PORTAGE_TMPDIR=/var/tmp

PORTDIR=/usr/portage

DISTDIR=${PORTDIR}/distfiles

PKGDIR=${PORTDIR}/packages

PORT_LOGDIR=/var/log/portage

PORTDIR_OVERLAY=/usr/local/portage

FETCHCOMMAND="/usr/bin/wget -t 5 --passive-ftp \${URI} -P \${DISTDIR}"

RESUMECOMMAND="/usr/bin/wget -c -t 5 --passive-ftp \${URI} -P \${DISTDIR}"

GENTOO_MIRRORS="ftp://mirror.switch.ch/mirror/gentoo/ http://mirror.switch.ch/ftp/mirror/gentoo/ http://ds.thn.htu.se/linux/gentoo http://ftp.du.se/pub/os/gentoo http://linuv.uv.es/mirror/gentoo/"

SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"

MAKEOPTS="-j2"

PORTAGE_NICENESS=10

AUTOCLEAN="yes"

eccolo...penso che sia configurato giusto

per quanto riguarda l' ultima compilazione come CFLAGS avevo anche -mmmx e -msse
_________________
Al mondo ci sono 10 tipi di persone quelle che conoscono il sistema binario e quelle che non lo conoscono...
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4729
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Tue Jun 26, 2007 8:48 pm    Post subject: Reply with quote

LDFLAGS purtroppo è concepito come parametro gcc e viene passato al gcc e non come parametro ld (pensavo anche io il contrario) quindi ="-Wl,-O1 -Wl,--hash-style=gnu ..." se non erro.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
rete27
Tux's lil' helper
Tux's lil' helper


Joined: 26 Feb 2007
Posts: 86

PostPosted: Tue Jun 26, 2007 9:04 pm    Post subject: Reply with quote

cambito la LDFLAGS ma l'errore riamane ed è lo stesso...
Code:
checking for C compiler default output file name... configure: error: C compiler cannot create executables

_________________
Al mondo ci sono 10 tipi di persone quelle che conoscono il sistema binario e quelle che non lo conoscono...
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Tue Jun 26, 2007 9:20 pm    Post subject: Reply with quote

commenta le LDFLAGS così vediamo se l'errore è lì dentro. Almeno ci concentriamo, ad esclusione su ogni singolo parametro.
Back to top
View user's profile Send private message
.:deadhead:.
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 2960
Location: Milano, Italy

PostPosted: Tue Jun 26, 2007 11:23 pm    Post subject: Reply with quote

hai un ricordo preciso di quando sia stata l'ultima volta che ti si sia compilato qualcosa senza problemi?

ti suggerirei cmq pure io di commentare LDFLAG almeno al momento per risolvere la faccenda....
_________________
Proudly member of the Gentoo Documentation Project: the Italian Conspiracy ! ;)
Back to top
View user's profile Send private message
rete27
Tux's lil' helper
Tux's lil' helper


Joined: 26 Feb 2007
Posts: 86

PostPosted: Wed Jun 27, 2007 6:27 am    Post subject: Reply with quote

coommentendo la LDFLAGS il compilatore lavora senza dare noie infatti
Quote:

checking for C compiler default output file name... a.out
checking whether the C compiler works... yes


ora penso che il problema sia solo di configurazione delle flag del ld giusto ?
_________________
Al mondo ci sono 10 tipi di persone quelle che conoscono il sistema binario e quelle che non lo conoscono...
Back to top
View user's profile Send private message
.:deadhead:.
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 2960
Location: Milano, Italy

PostPosted: Wed Jun 27, 2007 7:52 am    Post subject: Reply with quote

rete27 wrote:
ora penso che il problema sia solo di configurazione delle flag del ld giusto ?

Già... La cosa migliore sarebbe ora che tu ricompilassi tutti i pacchetti del system, così da garantirti un ambiente di compilazione sano... gli altri pacchetti poi verranno compilati via via che saranno aggiornati, ma almeno avrai la certezza d partir da solide basi...
_________________
Proudly member of the Gentoo Documentation Project: the Italian Conspiracy ! ;)
Back to top
View user's profile Send private message
rete27
Tux's lil' helper
Tux's lil' helper


Joined: 26 Feb 2007
Posts: 86

PostPosted: Wed Jun 27, 2007 8:37 am    Post subject: Reply with quote

.:deadhead:. wrote:
Già... La cosa migliore sarebbe ora che tu ricompilassi tutti i pacchetti del system, così da garantirti un ambiente di compilazione sano... gli altri pacchetti poi verranno compilati via via che saranno aggiornati, ma almeno avrai la certezza d partir da solide basi...


ricompilo il tutto lasciando commentato LDFALGS ? non sraebbe meglio fare dei tentativi per cercare di impostare dei paremetri ?
_________________
Al mondo ci sono 10 tipi di persone quelle che conoscono il sistema binario e quelle che non lo conoscono...
Back to top
View user's profile Send private message
crisandbea
Veteran
Veteran


Joined: 03 Jul 2005
Posts: 1778
Location: BOSCO (SA) ... ma domiciliato a Bologna....

PostPosted: Wed Jun 27, 2007 8:44 am    Post subject: Reply with quote

rete27 wrote:
.:deadhead:. wrote:
Già... La cosa migliore sarebbe ora che tu ricompilassi tutti i pacchetti del system, così da garantirti un ambiente di compilazione sano... gli altri pacchetti poi verranno compilati via via che saranno aggiornati, ma almeno avrai la certezza d partir da solide basi...


ricompilo il tutto lasciando commentato LDFALGS ? non sraebbe meglio fare dei tentativi per cercare di impostare dei paremetri ?


hai già guardato qui


ciao
Back to top
View user's profile Send private message
.:chrome:.
Advocate
Advocate


Joined: 19 Feb 2005
Posts: 4588
Location: Brescia, Italy

PostPosted: Wed Jun 27, 2007 9:54 am    Post subject: Reply with quote

risolto il mistero.
quella macchina usava l'hash-style GNU, ma in un aggiornamento del sistema è stato fatto accidentalmente un downgrade di binutils alla versione 2.17, quando attualmente deve essere usata almeno la versione 2.17.50.0.12 per poter usare l'hash-style

corretto e sistemato
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4729
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Wed Jun 27, 2007 3:10 pm    Post subject: Reply with quote

ora me ne sono accorto pure io che il sistema mi ha fatto il downgrade dalla 2.17 (che non ho certo installato ~86) alla 2.16 che è l'unica stabile. Qualcuno ha maggiori info?
perchè cmake non compila più...
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
rete27
Tux's lil' helper
Tux's lil' helper


Joined: 26 Feb 2007
Posts: 86

PostPosted: Wed Jun 27, 2007 5:37 pm    Post subject: Reply with quote

se ti va di fidarti di un noob emergi la binutils 2.17.50.0.12 e poi come LDFLAGS (grazie a .:chrome:.)
Code:

LDFLAGS="-Wl,-O1 -Wl,--enable-new-dtags -Wl,--sort-common -Wl,--hash-style=gnu -s"


ora a me funziona tutto bene...
_________________
Al mondo ci sono 10 tipi di persone quelle che conoscono il sistema binario e quelle che non lo conoscono...
Back to top
View user's profile Send private message
.:chrome:.
Advocate
Advocate


Joined: 19 Feb 2005
Posts: 4588
Location: Brescia, Italy

PostPosted: Wed Jun 27, 2007 5:42 pm    Post subject: Reply with quote

djinnZ wrote:
ora me ne sono accorto pure io che il sistema mi ha fatto il downgrade dalla 2.17 (che non ho certo installato ~86) alla 2.16 che è l'unica stabile. Qualcuno ha maggiori info?
perchè cmake non compila più...

perché con quella versione di binutils, il valore "-Wl, --hash-style=gnu" non è più riconosciuto come un parametro valido per il linker, quindi la fase di compilazione fallisce.

il downgrade è stato fatto perché è cambiato il formato di package.keywords, come descritto nel post del 14 giugno sul blog di Marius Mauch
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4729
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Wed Jun 27, 2007 6:17 pm    Post subject: Reply with quote

@rete27 non è perchè sei noob (esser nuovo sul forum non implica essere nuovo a linux) ma sono su hardened quindi prendo con una certa preoccupazione questi "incidenti".

@.:chrome:.

in che senso perchè è cambiato il package.keywords? Non riesco a capire il nesso, o è un mezzo bug?!

Cambiare binutils non è uno scherzo con l'hardening e l'ottimizzazione che uso.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
.:chrome:.
Advocate
Advocate


Joined: 19 Feb 2005
Posts: 4588
Location: Brescia, Italy

PostPosted: Wed Jun 27, 2007 8:35 pm    Post subject: Reply with quote

djinnZ wrote:
in che senso perchè è cambiato il package.keywords? Non riesco a capire il nesso, o è un mezzo bug?!

è cambiato il formato per includere i pacchetti con "missing" keyword, come spiegato in quel blog
Back to top
View user's profile Send private message
drizztbsd
Retired Dev
Retired Dev


Joined: 21 Nov 2004
Posts: 278
Location: Cesano Maderno

PostPosted: Thu Jun 28, 2007 2:00 pm    Post subject: Reply with quote

rete27 wrote:
se ti va di fidarti di un noob emergi la binutils 2.17.50.0.12 e poi come LDFLAGS (grazie a .:chrome:.)
Code:

LDFLAGS="-Wl,-O1 -Wl,--enable-new-dtags -Wl,--sort-common -Wl,--hash-style=gnu -s"


ora a me funziona tutto bene...


:cry:

  • --enable-new-dtags c'è di default da una cifra di binutils quindi è inutile settarlo (e basta rippare le LDFLAGS da quel thread inutile)
  • -s è DANNOSO, non usatelo per nessun motivo
  • --sort-common non è stabile, alcuni pacchetti non vanno.

Io consiglio le solite
Code:
LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed"

_________________
Gentoo/Alt lead
Gentoo/*BSD and Gentoo/FreeBSD deputy lead
Paludis contributor
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4729
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Thu Jun 28, 2007 4:17 pm    Post subject: Reply with quote

sar� il caldo bestiale che mi rende pi� idiota del solito ma continuo a non capire il nesso tra rimozione del "-*" ed il downgrade delle binutils stabili a 2.16.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
rete27
Tux's lil' helper
Tux's lil' helper


Joined: 26 Feb 2007
Posts: 86

PostPosted: Thu Jun 28, 2007 6:17 pm    Post subject: Reply with quote

@djinnZ

l'attula riga in package.keywords per le binutils è
Code:

=sys-devel/binutils-2.17.50.0.12 -*


prova a sistemare le LDFLAG come ho postato e poi sistema come sopre il package.keywords e prova a vedere... a mio avviso dovrebbe funzionare tutto correttamente... :wink:
_________________
Al mondo ci sono 10 tipi di persone quelle che conoscono il sistema binario e quelle che non lo conoscono...
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4729
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Thu Jun 28, 2007 6:51 pm    Post subject: Reply with quote

Non ci siamo capiti ancora. Ho installato il sistema stabile e solo pochissimi pacchetti (ntfs3g, beryl e qualche programma di utilità in praticaq) sono ~x86. Eppure mi ritrovo binutils 2.17 (non 2.17.xxx 2.17 e basta) installato e non riesco a capire perchè, evidentemente, è stato prima marcato stabile e poi rimarcato instabile su hardened.
Od uno straccio di ragione per considerare instabili le binutils >2.17.50 o quale delle successive è più abbordabile visto che cmake (per il momento) con le 2.16 non vuol saperne di compilare.
Lo so che è un pacchetto slottato e ne posso avere più versioni ma dato che sono deficiente ed ogni volta che faccio uno switch di compilatore o che sia mi scordo sistematicamente di rimettere le cose a posto vorrei garantirmi dalla mia distrazione.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
.:chrome:.
Advocate
Advocate


Joined: 19 Feb 2005
Posts: 4588
Location: Brescia, Italy

PostPosted: Thu Jun 28, 2007 7:52 pm    Post subject: Reply with quote

la 2.17 è la versione stabile: http://packages.gentoo.org/packages/?category=sys-devel;name=binutils
per usare --hash-style=gnu devi avere almeno la 2.17.50.0.12, che è in keyword "missing"
Back to top
View user's profile Send private message
drizztbsd
Retired Dev
Retired Dev


Joined: 21 Nov 2004
Posts: 278
Location: Cesano Maderno

PostPosted: Fri Jun 29, 2007 12:12 pm    Post subject: Reply with quote

rete27 wrote:
@djinnZ

l'attula riga in package.keywords per le binutils è
Code:

=sys-devel/binutils-2.17.50.0.12 -*


prova a sistemare le LDFLAG come ho postato e poi sistema come sopre il package.keywords e prova a vedere... a mio avviso dovrebbe funzionare tutto correttamente... :wink:


Code:
=sys-devel/binutils-2.17.50* **
in package.keywords
_________________
Gentoo/Alt lead
Gentoo/*BSD and Gentoo/FreeBSD deputy lead
Paludis contributor
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum