Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Compiz Fusion [HOWTO]
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 11, 12, 13, 14  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
cinek810
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jul 2007
Posts: 115

PostPosted: Wed Nov 07, 2007 3:49 pm    Post subject: Reply with quote

@cuchumino: have you done:
Code:

gpasswd -a user video
?

How can I make compiz my default window manager?
I'm using KDE3.5 and kdm.
Back to top
View user's profile Send private message
manwe_
Guru
Guru


Joined: 01 Feb 2006
Posts: 563
Location: Kraków/Cracow, Poland

PostPosted: Thu Nov 08, 2007 5:39 am    Post subject: Reply with quote

[Post removed. Here I've described problem with memory leak under newest nvidia drivers 100.14.19|23. One of nVidia's developers anonunced that they fixed the problem, and next release will be free from this bug.]

Last edited by manwe_ on Mon Nov 12, 2007 1:39 pm; edited 1 time in total
Back to top
View user's profile Send private message
ChrisJumper
Veteran
Veteran


Joined: 12 Mar 2005
Posts: 1826
Location: Germany

PostPosted: Thu Nov 08, 2007 11:41 pm    Post subject: Reply with quote

FMulder wrote:

* Searching for installed applications...
* No GLX_EXT_texture_from_pixmap with direct rendering context
... present with indirect rendering, exporting: LIBGL_ALWAYS_INDIRECT=1
* Using the GTK Interface
* Starting Compiz
Traceback (most recent call last):
File "/usr/bin/fusion-icon", line 58, in ?
choose_interface(try_first=options.interface)
File "usr/lib/python2.5/site-packages/FusionIcon/interface.py", line 89, in choose_interface
File "usr/lib/python2.5/site-packages/FusionIcon/interface.py", line 35, in import_interface
File "usr/lib/python2.5/site-packages/FusionIcon/interface_gtk/__init__.py", line 3, in <module>
File "usr/lib/python2.5/site-packages/FusionIcon/interface_gtk/main.py", line 213, in <module>
File "usr/lib/python2.5/site-packages/FusionIcon/start.py", line 34, in init
File "usr/lib/python2.5/site-packages/FusionIcon/util.py", line 171, in start
File "usr/lib/python2.5/site-packages/FusionIcon/execute.py", line 41, in run
File "/usr/lib/python2.5/subprocess.py", line 443, in call
return Popen(*args, **kwargs).wait()
File "/usr/lib/python2.5/subprocess.py", line 593, in __init__
errread, errwrite)
File "/usr/lib/python2.5/subprocess.py", line 1079, in _execute_child
raise child_exception
OSError: [Errno 2] No such file or directory[/code]

SOLVED!!! For some strange reason when I did an "emerge --depclean" after a general upgrade my system deleted sys-process/psmisc that is not listed in the system package, and is not required as a dependency by any package :? I re-emerged that and now it works


Thank you very much! After a falling back to a Backup, i had this strange issue. This solved it here too!
Back to top
View user's profile Send private message
nationdemon
n00b
n00b


Joined: 15 Nov 2006
Posts: 30
Location: Dresden

PostPosted: Tue Nov 13, 2007 12:15 pm    Post subject: Reply with quote

Yesterday I recognized that theres no more beryl. Quiet late I know but I've had no time for eye candy in a while and haven't used it all the time for performance reasons. Nevermind...

I removed beryl and all the stuff, installed compiz-fusion following this instruction... Once finished I used fusion-icon (yes the one from the unstable part of the instruction) and it worked like a charm. I played a round a little with ccsm and after a while I've had to reboot the computer (non - related kernelchanges).
Back in KDE I started compiz-fusion again by typing fusion-icon and after a while of waiting I've got shell 1 (strg+alt+F1 ;) ) back with a disconnection message from the xserver. So I tried again and it happenz all the time. After a while I saw that it was opening up maybe dialogs or something with an incredible speed. I got loads of those unrecognizable nonsized windows. The taskbar (two monitorsystem on 2560x1024) filled up with symbols rapidly and then x-server crashes.

Sometimes I've been able to hit the strg + c to stop fusion-icon sometimes not. I thought it might be fusion-icon so I removed anything related to compiz-fusion whiped out all configs and scripts and so on. Reinstalled compiz (following the XGL, NVidia and compiz-fusion howto). Than I used compiz --replace ccp --sm-disable. But I always ended up back on shell 1.

so here is the Backtrace using one of those hints (env LIBGL_ALWAYS_INDIRECT=1 compiz --replace cc)
Code:

Backtrace:
0: X(xf86SigHandler+0x74) [0x4b4e34]
1: /lib/libc.so.6 [0x2b76b8e81430]
2: X [0x59cd31]
3: X(DamageDamageRegion+0x15) [0x5a21b5]
4: X(compSetRedirectBorderClip+0x81) [0x5022e1]
5: X [0x544735]
6: X(miValidateTree+0x2d9) [0x5453e9]
7: /usr/lib64/xorg/modules/drivers//nvidia_drv.so [0x2b76bae31a75]

Fatal server error:
Caught signal 11.  Server aborting


and here without

Code:
Backtrace:
0: X(xf86SigHandler+0x74) [0x4b4e34]
1: /lib/libc.so.6 [0x2afbd4f0e430]
2: /usr/lib64/xorg/modules/drivers//nvidia_drv.so [0x2afbd6ec3f45]

Fatal server error:
Caught signal 11.  Server aborting


I've triple checked my xorg.conf (beryl always works as a charm with that one)
Same to the logfile. I'll posted it if needed maybe someone is able to figure out whats wrong without posting it or someone other had meet the problem before.

I've reinstalled XGL, nvidia drivers, opengl is set to nvidia and glxinfo reports nvidia as server glx vendor for all GLX versions. glxgears shows roundabout 4k fps / second, so I assume that GL is running. xdpyinfo reports composite I am in video group to...

I've got window decoration its the same as used in kde (baghira) tried with plastic too same result. An open window wobbles once as I've seen it quiet often starting beryl. I've switched to a standard decoration in emerald-theme-manager. I've no idea.


ps.: I'm sorry for my worse english
_________________
tolkienix: find / -size gt 0 | awk {system(printf("mount --bind %s /darkness", $*))}
Back to top
View user's profile Send private message
nationdemon
n00b
n00b


Joined: 15 Nov 2006
Posts: 30
Location: Dresden

PostPosted: Tue Nov 13, 2007 2:26 pm    Post subject: Reply with quote

To find out what happens I walked back step by step and ended up checking my .bash_history. I've told you in the earlier post that I've rebootet because of a kernel change. That was the final trap. I discovered that I've started fusion-icon as root. So I started the whole KDE as root today and compiz-fusion works well. I left started kde with my own user and ended up crashing again. Annoyed, disturbed and slightly demotivated I killed my whole .kde3.5 directory (goodbye to all settings etc.) and started over. Need a laugh? It works. Right now I'm using compiz looks amazing as ever (I like those flying windows very much) its so much faster and less consuming than beryl (awesome) and those stupid little windowthingys I guessed them to be dialogs are history. I've no idea what, when, why, but anythings fine by now.

So thanks to all whom are sitting there try to solve my riddle (and were outrun by myself ;) ) and at least thank you for not killing me for this maybe stupid question...
_________________
tolkienix: find / -size gt 0 | awk {system(printf("mount --bind %s /darkness", $*))}
Back to top
View user's profile Send private message
sim-obx
n00b
n00b


Joined: 18 Nov 2007
Posts: 2

PostPosted: Mon Nov 26, 2007 7:40 pm    Post subject: compiz (cube) - Warn: Failed to load slide: freedesktopevery Reply with quote

i use compiz vs nvidia mx 440
everything work's perfect,BUT i every time after reboot i must enter
Code:
modprobe nvidia
(i write /etc/modules.autoload.d/kernel-2.6 - nvidia)
what we do?

then
Code:
compiz-start

he sad:
Code:

localhost ~ # compiz-start
NVIDA detected
Using GTK decorator
compiz (cube) - Warn: Failed to load slide: freedesktop


i won't install from overlays.

Can you help me? :D
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 419
Location: Nederland

PostPosted: Mon Nov 26, 2007 8:41 pm    Post subject: Reply with quote

If I remember well,
Code:
compiz (cube) - Warn: Failed to load slide: freedesktop
means that you are trying to load a photo as the skydome of your cube, you can ignore this error, it is not a problem and is not related to the modprobe and compiz-start issue that you seems to have

compiz-start is a program, you need to start it while loading your desktop. you can refer to this page for howto autostart a program :
http://gentoo-wiki.com/HOWTO_Autostart_Programs

to autoload your nvidia at boot time, there is a file :
/etc/modules.autoload.d/kernel-2.x (depend of your kernel version)

just add nvidia into it
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
incubator
Guru
Guru


Joined: 05 Jun 2003
Posts: 584
Location: Belgium

PostPosted: Thu Nov 29, 2007 9:11 am    Post subject: Reply with quote

I followed the Compiz_fusion howto on the gentoo wiki but when restarting X all I got was windows with no borders despite applying the fix the wiki suggested....

When starting either compiz settings manager or emerald setttings manager I didnt find any way how to switch theme either.
Adding the compiz fusion start script thats been mentioned here before into /etc/env.d/99kde-end (I use kde 3.5) ensures that it does get started so thats not it, its just plain buggy.
(and I don't have any error log to post because manualy starting it won't work, it says there is already an X running and after that I get the gtk-error (GObject) failed thing, also mentioned in the wiki...

Seems to me like there is still a lot of work to be done.
_________________
Programming today is a race between Software Engineers striving to build bigger and better idiot-proof Programs, and the Universe trying to produce bigger and better idiots.
So far, the Universe is winning!
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 419
Location: Nederland

PostPosted: Thu Nov 29, 2007 10:41 am    Post subject: Reply with quote

I am not an expert, far from it, but I noticed that the errors about X already running can usually be fixed by using the --replace options in the command line

I had a border problem for a long time, on amd64, due to a fix for flash plugin that was set in env.d, a grep of all files in env.d showed the fix
Code:
grep "XLIB_SKIP_ARGB_VISUALS" /etc/env.d/*


the below url was my saver :
http://gentoo-wiki.com/HOWTO_compiz-fusion#No_window_borders
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
incubator
Guru
Guru


Joined: 05 Jun 2003
Posts: 584
Location: Belgium

PostPosted: Thu Nov 29, 2007 12:42 pm    Post subject: Reply with quote

I know, as stated, I tried both things and neither helped.
That wiki was the one I followed
_________________
Programming today is a race between Software Engineers striving to build bigger and better idiot-proof Programs, and the Universe trying to produce bigger and better idiots.
So far, the Universe is winning!
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 419
Location: Nederland

PostPosted: Thu Nov 29, 2007 6:50 pm    Post subject: Reply with quote

incubator,

I would like to help you but looking at the last 3 pages of this topic, it seems that this is your first post on this subject

could you give more info ? what system ? amd64 or x86 ? what video card ?
what version of mesa ?
and more important, are you sure that your DRI is working ?
Code:

glxinfo | grep rendering
glxinfo | grep OpenGL


I am not a specialist but I have been fighting with compiz-fusion for some month now on amd64 and an intel based laptop, so I might have seen your situation before (did I mention that I have it working now on both system ?)
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
incubator
Guru
Guru


Joined: 05 Jun 2003
Posts: 584
Location: Belgium

PostPosted: Thu Nov 29, 2007 8:32 pm    Post subject: Reply with quote

Code:

$ glxinfo | grep rendering
direct rendering: Yes

$ glxinfo | grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 6800/AGP/SSE2/3DNOW!
OpenGL version string: 2.1.1 NVIDIA 100.14.19
OpenGL extensions:

# emerge --info
Portage 2.1.3.19 (default-linux/x86/2007.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.19-ck2-r5 i686)
=================================================================
System uname: 2.6.19-ck2-r5 i686 AMD Athlon(tm) 64 Processor 3000+
Timestamp of tree: Wed, 28 Nov 2007 16:46:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-mtune=i686 -march=i686 -m3dnow -msse2 -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-mtune=i686 -march=i686 -m3dnow -msse2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ ftp://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/"
LANG="nl_BE@euro"
LC_ALL="nl_BE@euro"
LDFLAGS="-Wl,-O1 -Wl,--enable-new-dtags -Wl,--sort-common -s"
LINGUAS="nl"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow X Xaw3d a52 aac aalib akode alsa aotuv apm asf audiofile avi bash-completion bcmath berkdb bidi bitmap-fonts browserplugin bzip2 bzlib c++ caps cdb cdparanoia cdr cpdflib crypt ctype cups curl curlwrappers cvs dba dbase dbus dbx dga dhcp dio directfb divx dpms dri dts dvb dvd dvdnav dvdr dvdread dxr3 edl encode erandom exif faad fame fb fbcon ffmpeg firefox flac fluidsynth font-server foomaticdb fpx ftp gd ggi gif gimp gimpprint glep glibc-omitfp glitz glut gnutls graphviz gs gtk gtk2 hal howl iconv imagemagick imap imlib immqt-bc jack jack-tmpfs javascript jbig jce jcs jp2 jpeg jpeg2k kde kerberos krb4 lcms lesstif libcaca live lzo lzw lzw-tiff mad midi mikmod mime ming mjpeg mmx mng modelock modplug mp3 mpeg mpeg4 mplayer msn musepack mysql noamazon nojython nptl nptlonly nsplugin nvidia ogg openal opengl oss pam pcre pdf pic png portaudio posix ppds qt3 quicktime real realmedia rtc scanner sdl slp sndfile sockets speex sql srt sse sse2 ssl svg svga tetex tga tiff truetype truetype-fonts unicode usb utempter v4l v4l2 vcd vidix vorbis win32codecs wmf wmp x264 x86 xcomposite xine xml xorg xpm xsl xv xvid yv12" ALSA_CARDS="bt87x ens1371" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="nl" USERLAND="GNU" VIDEO_CARDS="nvidia vesa fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

media-libs/mesa-6.5.2-r1


after executing compiz --replace ccp&
I always get the error that a window manager is already running , all my window borders dissappear and I lose most of my navigation functionality untill I restart kwin

if I execute emerald --replace after that nothing happens

Also, I installed mandriva on a different comp to see if compiz + emerald would work there, didnt try the commands there but just like here there is ansolutely no indication on how to switch to a different emerald theme...
_________________
Programming today is a race between Software Engineers striving to build bigger and better idiot-proof Programs, and the Universe trying to produce bigger and better idiots.
So far, the Universe is winning!
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 419
Location: Nederland

PostPosted: Thu Nov 29, 2007 11:15 pm    Post subject: Reply with quote

first an easy one, to switch themes, you need to run emerald-theme-manager
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 419
Location: Nederland

PostPosted: Thu Nov 29, 2007 11:23 pm    Post subject: Reply with quote

can you try this as a starting script :

Code:
# compiz-start script
#
# hacky autodetection of neccessary options for XGL/AIGLX/NVIDIA
#
# Hanno Boeck, http://www.hboeck.de/
#
# Licensed under the same conditions as compiz itself (MIT or GPL)

if [ ! -x /usr/bin/glxinfo ]; then
        echo "glxinfo not found, please install mesa-progs."
        exit -1
fi

GLX_WITH_DIRECT=`glxinfo|grep -c GLX_EXT_texture_from_pixmap`
GLX_WITH_INDIRECT=`LIBGL_ALWAYS_INDIRECT=1 glxinfo|grep -c GLX_EXT_texture_from_pixmap`
GLX_RENDER=`glxinfo|grep -c "OpenGL renderer string: Mesa GLX Indirect"`


COMPIZ_OPTIONS="--replace"

if [ $GLX_WITH_DIRECT -eq 3 ]; then
        if [ $GLX_RENDER -eq 0 ]; then
                echo NVIDA detected
                export __GL_YIELD="NOTHING"
        else
                echo XGL detected
        fi
elif [ $GLX_WITH_INDIRECT -eq 3 ]; then
        echo AIGLX detected
        export LIBGL_ALWAYS_INDIRECT=1
fi

compiz --replace ccp --sm-disable &
emerald --replace &



the 2 last lines are the important ones :
Code:

compiz --replace ccp --sm-disable &
emerald --replace &


I use basically the same than you (amd64 + mesa and nvidia drivers are the same)
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
incubator
Guru
Guru


Joined: 05 Jun 2003
Posts: 584
Location: Belgium

PostPosted: Fri Nov 30, 2007 8:39 am    Post subject: Reply with quote

on my intel machine I got again the same borders (but thats with an ATI card) and this emerald theme manager is that same user unfriendly app that has no "apply" button to apply the selected theme because whenever I click, select or double click on a theme, nothing happens.

Since the autostarted script did nothing here (even though its set in the /etc/env.d/99kde-env) I started it manually again and besides the usua "window manager is running" error I no get hte error it cant find libGL.so O_o (and yes, mesa + ati drivers are installed)

Also, how does KDE know not to use his own themes/window decoration?
_________________
Programming today is a race between Software Engineers striving to build bigger and better idiot-proof Programs, and the Universe trying to produce bigger and better idiots.
So far, the Universe is winning!
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 419
Location: Nederland

PostPosted: Fri Nov 30, 2007 9:07 am    Post subject: Reply with quote

Quote:
Also, how does KDE know not to use his own themes/window decoration?


this is not fully kde anymore, when you type the 'compiz --replace' 'emerald --replace', you kick out kwin

in ccsm (the compiz configuration system manager) you need to check that the 'window decoration' plugin is active. in it you can select the windows decorator, I have emerald --replace in the 'command' line

the emerald them manager does not have any apply button because as soon as you select a theme, it use it, so if you see no change, it is because you are not using emerald, try to open a console and type again emerald --replace

it is possible that you are nor using ccsm, but gconf as the plugin manager, you can check the last lines of /usr/bin/compiz-start, you will see what is used

what I do is to start ccsm then activate or deactivate the zoom plugin and see if it works. ccsm is like emerald, you do not need to apply

yo can also activate/deactivate the window decoration plugin and see the result

as a last note, I never use the autostart of /etc/env.d/99kde-env, it has always failed for me, I use fusion-icon (the compiz manager) or I start it manually in a terminal. I have perfect result with the manual start (I actually write this post on my laptop with compiz-fusion running)
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
incubator
Guru
Guru


Joined: 05 Jun 2003
Posts: 584
Location: Belgium

PostPosted: Fri Nov 30, 2007 3:10 pm    Post subject: Reply with quote

Thank you for this very usfull inforamtion :)
Indeed it seems compiz-start has "gconf" right next to the $COMPIZ_OPTIONS
I acquired fusion-icon but it seems on my laptop with ATI it wont work due to the following error:

* Detected Session: kde
* Searching for installed applications...
* No GLX_EXT_texture_from_pixmap with direct rendering context
... nor with indirect rendering, this isn't going to work!
Traceback (most recent call last):
File "./fusion-icon", line 57, in ?
from FusionIcon.interface import choose_interface
File "/home/merlidi/fusion-icon/FusionIcon/interface.py", line 23, in ?
import start
File "/home/merlidi/fusion-icon/FusionIcon/start.py", line 64, in ?
env.set()
File "/home/merlidi/fusion-icon/FusionIcon/environment.py", line 140, in set
if not self.Xgl and self.glx_vendor == 'NVIDIA Corporation':
AttributeError: Environment instance has no attribute 'glx_vendor'

As for the gconf thing, I checked on my desktop with the nvidia card, the KDE configuration manager was selected , fusion-icon starts but still absolutely nothing happens when selecting any theme.
When manually starting fusion-icon I also get the same as usual:

* Setting window manager to Compiz
... executing: compiz --replace --sm-disable --ignore-desktop-hints ccp
compiz (core) - Error: Another window manager is already running on screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

and this is the end result:
http://users.skynet.be/incubator/fusion.png

maybe just a long shot but could this have to do because I enabled transparancy (composite) in KDE ?
_________________
Programming today is a race between Software Engineers striving to build bigger and better idiot-proof Programs, and the Universe trying to produce bigger and better idiots.
So far, the Universe is winning!
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 419
Location: Nederland

PostPosted: Fri Nov 30, 2007 7:19 pm    Post subject: Reply with quote

the only thing I can see is that you are trying to use kde-windows-decorator and this has failed since a while

if I type 'kwin --replace' then 'compiz --replace ccp --sm-disable &' 'emerald --replace &', I will have the same error than you

I really have to use the starting script that I include 2 post ago, obviously, there is some details in the script before the 2 last line, that set the system for compiz according to your HW

that give you a line to investigate, try to remove the part about kde-window decorator, you can see that it is not in my script, it is still in yours (I believe, I might be wrong)
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
incubator
Guru
Guru


Joined: 05 Jun 2003
Posts: 584
Location: Belgium

PostPosted: Fri Nov 30, 2007 8:26 pm    Post subject: Reply with quote

yes, I corrected the compiz-start script (I first thought you wanted me to use that script in my autostart)
However still no borders, stilll no window management, nothing.
In fact its so buggy I lose all focus control and can't type into an xterm, the taskbar is not redrawn when a program is closed, and still the emerald themes are not applied.

I have been through this entire thread, added several options in my xorg.conf that most others have, I use compiz-0.6.0 , from ~x86 not from the overlays

I don't get the kde-window-decorator issue anymore but in the end this is truly driving me nuts....
_________________
Programming today is a race between Software Engineers striving to build bigger and better idiot-proof Programs, and the Universe trying to produce bigger and better idiots.
So far, the Universe is winning!
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 419
Location: Nederland

PostPosted: Fri Nov 30, 2007 8:41 pm    Post subject: Reply with quote

I use the folowing version
Code:

#eix -Ic compiz
dev-python/compizconfig-python (0.6.0.1[1]@11/28/2007): Compizconfig Python Bindings (git)
x11-libs/compiz-bcop (0.6.0[1]@10/21/2007): Compiz Option code Generator (git)
x11-libs/compizconfig-backend-kconfig (0.6.0[1]@10/21/2007): Compizconfig Kconfig Backend (git)
x11-libs/libcompizconfig (0.6.0[1]@10/21/2007): Compiz Configuration System (git)
x11-plugins/compiz-fusion-plugins-extra (0.6.0[1]@10/21/2007): Compiz Fusion Window Decorator Extra Plugins (git)
x11-plugins/compiz-fusion-plugins-main (0.6.0[1]@10/21/2007): Compiz Fusion Window Decorator Plugins (git)
x11-plugins/compiz-fusion-plugins-unsupported (0.6.0[1]@11/23/2007): Compiz Fusion Window Decorator Unsupported Plugins (git)
x11-wm/compiz (0.6.2-r1[1]@11/28/2007): 3D composite- and windowmanager
x11-wm/compiz-fusion (0.6.0[1]@10/21/2007): Compiz Fusion (meta)
x11-apps/ccsm (0.6.0[1]@10/21/2007): Compizconfig Settings Manager (git)
x11-themes/emerald-themes (0.5.2[1]@10/21/2007): Emerald Window Decorator Themes (git)
x11-wm/emerald (0.5.2[1]@10/21/2007): Emerald Window Decorator (git)
x11-apps/fusion-icon [1] (9999@10/21/2007): Compiz Fusion Tray Icon and Manager (git)

[1] "xeffects" /usr/portage/local/layman/xeffects


can you check that you have the same as me ?
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
incubator
Guru
Guru


Joined: 05 Jun 2003
Posts: 584
Location: Belgium

PostPosted: Fri Nov 30, 2007 8:55 pm    Post subject: Reply with quote

Code:

[D] dev-python/compizconfig-python (0.6.0.1@30-11-07 -> ~0.6.0.1): libcompizconfig python bindings
[D] x11-libs/compiz-bcop (0.6.0@30-11-07 -> ~0.6.0): Compiz option code generator
[D] x11-libs/compizconfig-backend-gconf (0.6.0@30-11-07 -> ~0.6.0): libcompizconfig gconf backend
[D] x11-libs/compizconfig-backend-kconfig (0.6.0@30-11-07 -> ~0.6.0 {arts debug elibc_FreeBSD xinerama}): libcompizconfig kde config backend
[D] x11-libs/libcompizconfig (0.6.0@30-11-07 -> ~0.6.0): Compiz configuration library
[D] x11-plugins/compiz-fusion-plugins-extra (0.6.0@30-11-07 -> ~0.6.0): Compiz Fusion extra plugins
[D] x11-plugins/compiz-fusion-plugins-main (0.6.0@30-11-07 -> ~0.6.0 {jpeg}): Compiz Fusion main plugins
[D] x11-plugins/compiz-fusion-plugins-unsupported (0.6.0@30-11-07 -> ~0.6.0): Compiz Fusion unsupported plugins
[D] x11-wm/compiz (0.6.2-r1@30-11-07 -> ~0.5.0 ~0.5.2 ~0.6.2 ~0.6.2-r1 {dbus debug gnome kde svg}): 3D composite- and windowmanager
[D] x11-wm/compiz-fusion (0.6.0@30-11-07 -> ~0.6.0 {gnome kde}): Compiz Fusion meta package
[D] x11-themes/emerald-themes (0.5.2@30-11-07 -> [M]~0.1.3!m [M]~0.1.4!m [M]~0.2.1!m ~0.5.2): Emerald window decorator themes
[D] x11-wm/emerald (0.5.2@30-11-07 -> [M]~0.1.3 [M]~0.1.4 [M]~0.2.1!m ~0.5.2 {debug}): Emerald window decorator, part of Compiz Fusion



is mine
_________________
Programming today is a race between Software Engineers striving to build bigger and better idiot-proof Programs, and the Universe trying to produce bigger and better idiots.
So far, the Universe is winning!
Back to top
View user's profile Send private message
MOROZ_FX
n00b
n00b


Joined: 25 Sep 2006
Posts: 13

PostPosted: Sat Dec 01, 2007 12:59 am    Post subject: Reply with quote

I 'am having very strange situation with emerald

if i run
Code:
compiz --replace ccp &
emerald --replace &


under su - everything is fine

if i run
Code:
compiz --replace ccp &
emerald --replace &


under common user - compiz probably starts (i see some windows effects) but emerald fails (i have no window decoration)


if i run
Code:
compiz --replace ccp &

under su

and
Code:
emerald --replace &

under user everything is ok

AND if i run
Code:
compiz --replace ccp &

under user

and
Code:
emerald --replace &

under su everything is ok

what does this may be?
Back to top
View user's profile Send private message
incubator
Guru
Guru


Joined: 05 Jun 2003
Posts: 584
Location: Belgium

PostPosted: Sat Dec 01, 2007 10:25 am    Post subject: Reply with quote

dude, I can virtually hug you :D
running those commands as root made it work :DD
_________________
Programming today is a race between Software Engineers striving to build bigger and better idiot-proof Programs, and the Universe trying to produce bigger and better idiots.
So far, the Universe is winning!
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5720
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat Dec 01, 2007 10:47 am    Post subject: Reply with quote

incubator wrote:
dude, I can virtually hug you :D
running those commands as root made it work :DD


DON'T EVER RUN APPS MEANT TO RUN AS USER AS ROOT :!: :idea:

instead fire up
Code:
ccsm
& set up everything needed

you might also want to try
Code:
gtk-window-decorator
(as alternate decoration)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.3.0-r2
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 419
Location: Nederland

PostPosted: Sat Dec 01, 2007 10:51 am    Post subject: Reply with quote

incubator,

I am happy you can enjoy the pleasure of compiz-fusion, I believe it is a great tool, try the tabbing of window, very nice
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 11, 12, 13, 14  Next
Page 12 of 14

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum