Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
how to properly install a big5 font?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Languages
View previous topic :: View next topic  
Author Message
j-kidd
Apprentice
Apprentice


Joined: 20 Feb 2003
Posts: 212

PostPosted: Sat May 17, 2003 11:15 am    Post subject: how to properly install a big5 font? Reply with quote

Let use mingliu.ttf from windows as the example... may I know what is the correct steps to install it? (for QT, GTK, etc..)

Currently, I can use the font just fine in QT applications, but fail to read any chinese character in GTK (xmms, ed2k gtk, lmule :(), Java (limewire, ed2k java :(), and WINE applications (emule plus, winmx :().

I am using xfree 4.3
Thanks!
Back to top
View user's profile Send private message
liquidx
Retired Dev
Retired Dev


Joined: 21 Aug 2002
Posts: 56
Location: London, UK

PostPosted: Mon May 26, 2003 1:32 pm    Post subject: Reply with quote

you can try the following packages for chinese fonts:

* zh-kcfonts
* arphicfonts
* twmoefonts

i am drafting a howto on chinese support in gentoo, you might want to take a quick look at it, however it is far from complete right now

http://cvs.gentoo.org/~liquidx/chinese.html
Back to top
View user's profile Send private message
liquidx
Retired Dev
Retired Dev


Joined: 21 Aug 2002
Posts: 56
Location: London, UK

PostPosted: Mon May 26, 2003 2:03 pm    Post subject: Reply with quote

oh and also, you might want to check out www.gentoo.org.tw and my www.linuxsir.org for some chinese related forums.

as far as i know, to view chinese in gnome/gtk, you need to set your LANG to a chinese character set in your .profile, or open the applications in that language: eg.

LANG="zh_TW.Big5" gedit
Back to top
View user's profile Send private message
j-kidd
Apprentice
Apprentice


Joined: 20 Feb 2003
Posts: 212

PostPosted: Mon May 26, 2003 7:32 pm    Post subject: Reply with quote

Thanks, setting LANG solved the problem :) (I set LANG to english and LC_CTYPE to big5 as I don't want the interface to be in chinese)

Another question... when putting these few lines in .xinitrc, X will freeze whenever I move or resize a QT application
Code:
#added lines
export LANG=en_US
export LC_CTYPE=zh_TW.Big5
xcin &
export XMODIFIER="@im=xcin"

#original
startkde


Do you know what is the problem? If I put those 4 lines in /usr/local/bin/big5 and then start application with "big5 appname", everything is ok. But I would like to be able to read/write chinese universally
Back to top
View user's profile Send private message
StuBear
Apprentice
Apprentice


Joined: 26 Feb 2003
Posts: 157
Location: Melbourne,AUSTRALIA

PostPosted: Tue May 27, 2003 12:35 am    Post subject: Reply with quote

Not sure whether it applies here or not, but for Japanese support to work correctly for me with gnome and qt apps I need to change LC_CTYPE to LC_ALL, otherwise the app hanges or segfaults.

Hope this is helpfull
Back to top
View user's profile Send private message
j-kidd
Apprentice
Apprentice


Joined: 20 Feb 2003
Posts: 212

PostPosted: Tue May 27, 2003 3:23 pm    Post subject: Reply with quote

Thanks for the suggestion. Apparently this is an almost one year old bug in kde :o
http://lists.kde.org/?l=kwin&w=2&r=1&s=xcin&q=b
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Languages All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum