Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[HOWTO] 64bit Gentoo auf Strato Server
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Deutsche Dokumentation
View previous topic :: View next topic  
Author Message
hendrik_x30
n00b
n00b


Joined: 12 Apr 2004
Posts: 15

PostPosted: Wed Mar 01, 2006 10:09 am    Post subject: [HOWTO] 64bit Gentoo auf Strato Server Reply with quote

HOWTO – Wie bekomme ich ein reines 64bit Gentoo auf einen Strato High-End Server:


So leid es mit auch tut, um nen 64bit Gentoo auf den Server zu backen müsst ihr als erstes mal Suse Pro 64bit drauf haben.

Sobald das passiert ist solltet ihr euch erst mal viel Zeit nehmen, ne Kanne Kaffee und mindestens 2 Schachteln Zigaretten.

Ich habe ein Software Raid1 genommen, da dieses ja automatisch mit der Suse Installation erstellt wird.

Wichtigste Komponenten für die Gentoo Installation sind eine Funktionierende Serial Console und ein Gentoo Install image für einen AMD64 wobei der Link reicht.

Als erstes loggt ihr euch per SSH auf euren Server ein und schaltet die erste Swap Partition aus:
Code:
swapoff /dev/hda2


Diese wird benötigt um das Iso Image als MiniGentoo zu benutzen um ein vollwertiges Gentoo zu installieren.

Als nächstes mit fdisk den Patitionstyp für /dev/hda2 auf 83 ändern und die Partitionstabelle schreiben.

Dann noch schnell mit
Code:
mke2fs -j /dev/hda2
die Partition mit ext3 formatieren.

Die vorhandene Boot Partition würde ich so übernehmen, da wir diese auch noch benötigen um unser Mini Gentoo zu starten, also nicht löschen.
Die restliche Partition könnt ihr nach belieben aufteilen. Aber nicht die /dev/hda2
Aber denkt dran wir wollen ein Software Raid 1 betreiben, sprich die 2te Platte sollte genauso Partitioniert sein, wobei aber erst mal /dev/hdc als Swap Partition verwendet wird.

Legt euch nun in /mnt/ ein Verzeichniss an: z.b rescue
Nun brauchen wir die Iso mit dem AMD64 minimal System aber wget gibbet leider nicht standardmäßig unter Suse 64.
Also yast starten software installieren. mit ALT-S nach wget suchen und wget installieren und wieder raus aus yast.
Dann nach /mnt wechseln und mit wget die passende iso runterladen, sollte bei der Bandbreite recht schnell gehen.
nun noch einen zweiten Ordner unter /mnt anlegen, am besten cdiso oder wie ihr wollt.

Das Iso-Image wird dann mit
Code:
mount isoname.iso -r -t iso9660 -o loop /mnt/cdiso
in das Dateisystem eingehängt.
Jetzt müssen wir noch /dev/hda2 mounten und zwar mit
Code:
mount /dev/hda2 /mnt/rescue
cp /mnt/cdiso/* /mnt/rescue
cp /mnt/cdiso/isolinux/* /mnt/rescue


Damit haben wir das komplette MiniGentoo nun auf Platte.

Jetzt solltet ihr noch /dev/md0 nach /boot mounten da wir noch grub anpassen müssen.

Code:
mount /dev/md0 /boot

vim /boot/grub/menu.lst
i


ganz am ende folgendes eintragen:

Code:
title   Gentoo Rescue System
root    (hd0,1)
kernel  /gentoo root=/dev/ram0 rw ramdisk=48000 console=tty0 console=ttyS0,57600 init=/linuxrc looptype=squashfs loop=/livecd.squashfs udev nodevfs dokeymap cdroot
initrd  /gentoo.igz


Code:
:wq


und erst mal neustarten. Jetzt brauchen wir die Serial Console, da wir nun Gentoo als Bootoption starten wollen.

Und tada nun seid ihr in eurem Mini Gentoo.

Als erstes mal
Code:
/etc/init.d/net.eth0 restart
ausführen da anscheinend beim starten nicht vernünftig die IP zugewiesen wird.
Mit
Code:
passwd
noch das root passwort ändern und
Code:
/etc/init.d/sshd start
ausführen, da wir nicht alles auf der Serial Console machen wollen.
Jetzt solltet ihr euch ganz normal per SSH auf euren Server connecten können.

Nun zur Raid1 Erstellung.
als erstes mal modprobe md machen da wir dieses Modul für unser Raid brauchen.

Code:
cd /dev/
MAKEDEV md


nun solltet ihr euch schon gedanken über eure partitionierung gemacht haben.
Ich habe z.B. die boot partition so gelassen welche nachher wieder /dev/md0 wird.
gefolgt von /dev/hda2 welche im moment noch das rescue system beherbergt.
hda3 ist bei mir 60GB gross und für /var vorgesehen, ebenso wie hdc3 ( wegen Raid1) diese werden nachher /dev/md1
hdc2 hab ich so gelassen, wird die Swap partition.
Für hda4 und hdc4 habe ich den rest der platte genommen und wird /dev/md2

Jetzt legt ihr euch eine Datei an /dev/raidtab und füllt diese mit folgenden werten:

Code:
# /boot (RAID 1)
raiddev                 /dev/md0
raid-level              1
nr-raid-disks           2
chunk-size              32
persistent-superblock   1
device                  /dev/hda1
raid-disk               0
device                  /dev/hdc1
raid-disk               1

# /var (RAID 1)
raiddev                 /dev/md1
raid-level              1
nr-raid-disks           2
chunk-size              32
persistent-superblock   1
device                  /dev/hda3
raid-disk               0
device                  /dev/hdc3
raid-disk               1

# / (RAID 1)
raiddev                 /dev/md2
raid-level              1
nr-raid-disks           2
chunk-size              32
persistent-superblock   1
device                  /dev/hda4
raid-disk               0
device                  /dev/hdc4
raid-disk               1

nachdem dies passiert ist erstellt ihr mit
Code:
mkraid /dev/md*
das Raid1.

Jetzt hilft nur warten, da erst mal das Raid1 synchronisiert wird.
Mit cat /proc/mdstat könnt ihr nachschauen wie lange es noch dauert.

Nach dem erfolgreichen synchronisieren was ca. 1h dauert könnt ihr auf euren Raid Devices die Filesystems erzeugen.

Code:
mke2fs /dev/md0
mke2fs -j /dev/md1
mke2fs -j /dev/md2


soweit so gut.



Jetzt gehts mit dem richtigen Gentoo installieren los.
Code:
swapon /dev/hdc2
mount /dev/md2 /mnt/gentoo
mkdir /mnt/gentoo/boot
mkdir /mnt/gentoo/var
mount /dev/md0 /mnt/gentoo/boot
mount /dev/md1 /mnt/gentoo/var


Ab hier könnt ihr nun der Install Anleitung auf Gentoo.org folgen, nehmt aber auch die für AMD64 und nicht x86 sonst wars alles umsonst.
Und achtet bitte nachher beim Kernel Kompilieren darauf das ihr RAID Unterstützung mit drin habt.
Und nicht vergessen die Serial Console wieder einzubauen, sonst kommt ihr nicht mehr auf euren Server falls ihr SSH nicht mit installiert habt.

Wichtig:
KERNEL RAID Unterstützung
SERIAL CONSOLE


Links:
http://www.gentoo.org/doc/en/handbook/2006.0/handbook-amd64.xml
http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/releases/amd64/current/


Viel Erfolg beim Installieren und viel Spass mit eurem 64bit Gentoo

Gruß
Hendrik


Last edited by hendrik_x30 on Sun Jul 20, 2008 7:24 pm; edited 1 time in total
Back to top
View user's profile Send private message
Antimon
n00b
n00b


Joined: 17 Mar 2003
Posts: 41

PostPosted: Sat Jul 29, 2006 4:13 pm    Post subject: Reply with quote

Vielen Dank für das super Tutorial!

Eine paar kleine Anmerkung möchte ich noch machen:

- Bei mir hiess das Image "image.squashfs" statt "livecd.squashfs", deswegen hat der erste Reboot nicht funktioniert. Nach einer Anpassung gings dann.

- Statt /dev/raidtab meinst du vermutlich /etc/raidtab

- Da schon ein Raid angelegt war und Filesysteme auf der Platte existierten musste das Anlegen des Raids erzwungen werden

Aber sonst super Anleitung, ohne die hätt ich die Installation nicht geschafft!
Back to top
View user's profile Send private message
thedude0001
Arch/Herd Tester
Arch/Herd Tester


Joined: 16 Jan 2005
Posts: 69

PostPosted: Sat Aug 19, 2006 3:09 am    Post subject: Reply with quote

Ich bin Anfang des Jahres beim Installieren von Gentoo auf einem Strato-Server durch ähnliche Reifen gesprungen (allerdings war mein SuSE nur auf der ertsen Platte installiert, ich konnte daher Gentoo relativ problemlos auf die zweite installieren). Als sich jetzt abzeichnete daß ich das Ganze für einen neuen Server wieder machen darf habe ich mal eine Anfrage bei Strato gestartet wie es denn mit einem 64bit Rescue-System aussieht. Das Ganze ist zwar jetzt schon fast zwei Monate am Laufen, aber auf eine Nachfrage hat man mir versichert daß man an der Umsetzung arbeite, man könne nur keinen genauen Termin nennen...

(Letztlich ist ein Rescue-System auch nach der Installation u.U. interessant...)
_________________
Das Schlimme auf dieser Welt ist
daß die Dummen so selbstsicher sind
und die Gescheiten so voller Zweifel.
Back to top
View user's profile Send private message
BlueEngel
n00b
n00b


Joined: 01 Jun 2004
Posts: 8

PostPosted: Sat Sep 02, 2006 6:19 pm    Post subject: Reply with quote

Hallo...

Erst mal Danke für diese Anleitung.
Habe nur folgendes Problem, habe bei mir auf dem Strato Server Gentoo über die Serielle Konsole von Strato Gentoo Installiert also auch dort den Raid 1 Verbund erstellt, und dann Gentoo drauf. Nun wollte ich Grub Installieren bekomme aber ne Fehlermeldung.

Meldung:
h1019578 / # grub-install /dev/sda
Probing devices to guess BIOS drives. This may take a long time.
/dev/md0 does not have any corresponding BIOS drive.


md0 ist bei mit /dev/sda1 & /dev/sdb1 also /boot
md1 ist bei mir /dev/sda3 & /dev/sdb3 also /

was muß ich noch machen ? Vor allem wie schaffe ich es das er anstatt die fstab nun die raidtab nimmt.
Oder muß ich da noch ne Software Installieren außer Kernel Raid Aktivieren ?

Danke
Back to top
View user's profile Send private message
blubbi
Guru
Guru


Joined: 27 Apr 2003
Posts: 545
Location: Halle (Saale), Germany

PostPosted: Tue Sep 12, 2006 12:26 am    Post subject: Reply with quote

Hi, ich hab grad heut meinen Strato Server installiert.

Danke für das HowTo!

Wenn ihr die kerneloption docache beim booten mit übergebt habt ihr die Festplatten frei zur Verfügung.

Aber achtung, wenn was schief geht "SAME PRESIDURE...."

Noch eine böse Falle das install-amd64-minimal-2006.1.iso release bootet nicht sauber.
unbedingt das install-amd64-minimal-2006.0.iso nehmen.

Wer eine Idee hat woran es liegt...

Hier die ausgabe vom 2006.1:
Quote:

Booting 'Gentoo Rescue System '

root (hd0,1)
Filesystem type is ext2fs, partition type 0x83
kernel /gentoo root=/dev/ram0 rw ramdisk=48000 console=tty0 console=ttyS0,57600
init=/linuxrc looptype=squashfs loop=/image.squashfs udev nodevfs dokeymap cdr
oot docache
[Linux-bzImage, setup=0x1c00, size=0x1b4857]
initrd /gentoo.igz
[Linux-initrd @ 0x37b7c000, 0x47322b bytes]

Bootdata ok (command line is root=/dev/ram0 rw ramdisk=48000 console=tty0 console=ttyS0,57600 init=/linuxrc looptype=squashfs loop=/image.squashfs udev nodevfs dokeymap cdroot docache)
Linux version 2.6.17-gentoo-r7 (root@poseidon) (gcc version 4.1.1 (Gentoo 4.1.1)) #1 SMP Tue Aug 29 01:41:38 UTC 2006
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009f800 (usable)
BIOS-e820: 000000000009f800 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000003fee0000 (usable)
BIOS-e820: 000000003fee0000 - 000000003fee3000 (ACPI NVS)
BIOS-e820: 000000003fee3000 - 000000003fef0000 (ACPI data)
BIOS-e820: 000000003fef0000 - 000000003ff00000 (reserved)
BIOS-e820: 00000000e0000000 - 00000000f0000000 (reserved)
BIOS-e820: 00000000fec00000 - 0000000100000000 (reserved)
DMI 2.3 present.
Nvidia board detected. Ignoring ACPI timer override.
ACPI: PM-Timer IO Port: 0x1008
ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
Processor #0 15:7 APIC version 16
ACPI: LAPIC (acpi_id[0x01] lapic_id[0x01] disabled)
ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
ACPI: IOAPIC (id[0x02] address[0xfec00000] gsi_base[0])
IOAPIC[0]: apic_id 2, version 17, address 0xfec00000, GSI 0-23
ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
ACPI: INT_SRC_OVR (bus 0 bus_irq 14 global_irq 14 high edge)
ACPI: INT_SRC_OVR (bus 0 bus_irq 15 global_irq 15 high edge)
Setting APIC routing to flat
Using ACPI (MADT) for SMP configuration information
Allocating PCI resources starting at 40000000 (gap: 3ff00000:a0100000)
Checking aperture...
CPU 0: aperture @ 0 size 32 MB
No AGP bridge found
Built 1 zonelists
Kernel command line: root=/dev/ram0 rw ramdisk=48000 console=tty0 console=ttyS0,57600 init=/linuxrc looptype=squashfs loop=/image.squashfs udev nodevfs dokeymap cdroot docache
Initializing CPU#0
PID hash table entries: 4096 (order: 12, 32768 bytes)
time.c: Using 3.579545 MHz WALL PM GTOD PIT/TSC timer.
time.c: Detected 1004.642 MHz processor.
Speakup v-2.00 CVS: Mon May 1 09:46:33 EDT 2006 : initialized
Console: colour VGA+ 80x25
Dentry cache hash table entries: 131072 (order: 8, 1048576 bytes)
Inode-cache hash table entries: 65536 (order: 7, 524288 bytes)
Memory: 1021928k/1047424k available (2561k kernel code, 24528k reserved, 802k data, 180k init)
Calibrating delay using timer specific routine.. 2010.06 BogoMIPS (lpj=1005031)
Mount-cache hash table entries: 256
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 1024K (64 bytes/line)
Using local APIC timer interrupts.
result 12558042
Detected 12.558 MHz APIC timer.
Brought up 1 CPUs
testing NMI watchdog ... OK.
migration_cost=0
checking if image is initramfs... it is
Freeing initrd memory: 4556k freed
NET: Registered protocol family 16
ACPI: bus type pci registered
PCI: Using MMCONFIG at e0000000
PCI: No mmconfig possible on device 0:18
ACPI: Subsystem revision 20060127
ACPI: Interpreter enabled
ACPI: Using IOAPIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (0000:00)
PCI: Transparent bridge - 0000:00:09.0
ACPI: PCI Interrupt Link [LNK1] (IRQs 3 5 7 9 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNK2] (IRQs 3 5 7 9 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNK3] (IRQs 3 5 7 9 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNK4] (IRQs 3 *5 7 9 10 11 12 14 15)
ACPI: PCI Interrupt Link [LNK5] (IRQs 3 5 7 9 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LUBA] (IRQs 3 5 7 9 10 *11 12 14 15)
ACPI: PCI Interrupt Link [LUBB] (IRQs 3 5 7 9 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LMAC] (IRQs 3 5 7 9 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LACI] (IRQs 3 5 7 9 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LMCI] (IRQs 3 5 *7 9 10 11 12 14 15)
ACPI: PCI Interrupt Link [LSMB] (IRQs 3 5 7 9 *10 11 12 14 15)
ACPI: PCI Interrupt Link [LUB2] (IRQs *3 5 7 9 10 11 12 14 15)
ACPI: PCI Interrupt Link [LIDE] (IRQs 3 5 7 9 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LSID] (IRQs 3 5 7 9 *10 11 12 14 15)
ACPI: PCI Interrupt Link [LFID] (IRQs 3 5 7 9 10 *11 12 14 15)
ACPI: PCI Interrupt Link [LPCA] (IRQs 3 5 7 9 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [APC1] (IRQs 16) *0, disabled.
ACPI: PCI Interrupt Link [APC2] (IRQs 17) *0, disabled.
ACPI: PCI Interrupt Link [APC3] (IRQs 18) *0, disabled.
ACPI: PCI Interrupt Link [APC4] (IRQs 19) *0, disabled.
ACPI: PCI Interrupt Link [APC5] (IRQs *16), disabled.
ACPI: PCI Interrupt Link [APCF] (IRQs 20 21 22 23) *0, disabled.
ACPI: PCI Interrupt Link [APCG] (IRQs 20 21 22 23) *0, disabled.
ACPI: PCI Interrupt Link [APCH] (IRQs 20 21 22 23) *0, disabled.
ACPI: PCI Interrupt Link [APCJ] (IRQs 20 21 22 23) *0, disabled.
ACPI: PCI Interrupt Link [APCK] (IRQs 20 21 22 23) *0, disabled.
ACPI: PCI Interrupt Link [APCS] (IRQs 20 21 22 23) *0, disabled.
ACPI: PCI Interrupt Link [APCL] (IRQs 20 21 22 23) *0, disabled.
ACPI: PCI Interrupt Link [APCZ] (IRQs 20 21 22 23) *0, disabled.
ACPI: PCI Interrupt Link [APSI] (IRQs 20 21 22 23) *0, disabled.
ACPI: PCI Interrupt Link [APSJ] (IRQs 20 21 22 23) *0, disabled.
ACPI: PCI Interrupt Link [APCP] (IRQs 20 21 22 23) *0, disabled.
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI init
pnp: PnP ACPI: found 10 devices
SCSI subsystem initialized
PCI: Using ACPI for IRQ routing
PCI: If a device doesn't work, try "pci=routeirq". If it helps, post a report
PCI-DMA: Disabling IOMMU.
pnp: 00:01: ioport range 0x1000-0x107f could not be reserved
pnp: 00:01: ioport range 0x1080-0x10ff has been reserved
pnp: 00:01: ioport range 0x1400-0x147f has been reserved
pnp: 00:01: ioport range 0x1480-0x14ff could not be reserved
pnp: 00:01: ioport range 0x1800-0x187f has been reserved
pnp: 00:01: ioport range 0x1880-0x18ff has been reserved
PCI: Bridge: 0000:00:09.0
IO window: b000-bfff
MEM window: fc000000-fdffffff
PREFETCH window: fea00000-feafffff
PCI: Bridge: 0000:00:0b.0
IO window: a000-afff
MEM window: fe900000-fe9fffff
PREFETCH window: fe800000-fe8fffff
PCI: Bridge: 0000:00:0c.0
IO window: 9000-9fff
MEM window: fe700000-fe7fffff
PREFETCH window: fe600000-fe6fffff
PCI: Bridge: 0000:00:0d.0
IO window: 8000-8fff
MEM window: fe500000-fe5fffff
PREFETCH window: fe400000-fe4fffff
PCI: Bridge: 0000:00:0e.0
IO window: 7000-7fff
MEM window: fe300000-fe3fffff
PREFETCH window: fe200000-fe2fffff
NET: Registered protocol family 2
IP route cache hash table entries: 32768 (order: 6, 262144 bytes)
TCP established hash table entries: 131072 (order: 9, 2097152 bytes)
TCP bind hash table entries: 65536 (order: 8, 1048576 bytes)
TCP: Hash tables configured (established 131072 bind 65536)
TCP reno registered
IA32 emulation $Id: sys_ia32.c,v 1.32 2002/03/24 13:02:28 ak Exp $
squashfs: version 3.0 (2006/03/15) Phillip Lougher
SGI XFS with ACLs, security attributes, realtime, large block/inode numbers, no debug enabled
SGI XFS Quota Management subsystem
Initializing Cryptographic API
io scheduler noop registered
io scheduler deadline registered (default)
pcie_portdrv_probe->Dev[005d:10de] has invalid IRQ. Check vendor BIOS
assign_interrupt_mode Found MSI capability
pcie_portdrv_probe->Dev[005d:10de] has invalid IRQ. Check vendor BIOS
assign_interrupt_mode Found MSI capability
pcie_portdrv_probe->Dev[005d:10de] has invalid IRQ. Check vendor BIOS
assign_interrupt_mode Found MSI capability
pcie_portdrv_probe->Dev[005d:10de] has invalid IRQ. Check vendor BIOS
assign_interrupt_mode Found MSI capability
Real Time Clock Driver v1.12ac
initialized device: /dev/synth, node ( MAJOR 10, MINOR 25 )
Linux agpgart interface v0.101 (c) Dave Jones
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
00:07: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
PNP: No PS/2 controller found. Probing ports directly.
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
mice: PS/2 mouse device common for all mice
RAMDISK driver initialized: 16 RAM disks of 48000K size 1024 blocksize
loop: loaded (max 8 devices)
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
NFORCE-CK804: IDE controller at PCI slot 0000:00:06.0
NFORCE-CK804: chipset revision 242
NFORCE-CK804: not 100% native mode: will probe irqs later
NFORCE-CK804: 0000:00:06.0 (rev f2) UDMA133 controller
NFORCE-CK804: neither IDE port enabled (BIOS)
md: md driver 0.90.3 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: bitmap version 4.39
TCP bic registered
NET: Registered protocol family 1
NET: Registered protocol family 17
Freeing unused kernel memory: 180k freed
>> Loading modules
:: Scanning for ehci-hcd...usbcore, ehci-hcd loaded.
:: Scanning for hid...hid loaded.
:: Scanning for usb-storage...usb-storage loaded.
:: Scanning for uhci-hcd...uhci-hcd loaded.
:: Scanning for ohci-hcd...ohci-hcd loaded.
:: Scanning for sl811-hcd...sl811-hcd loaded.
:: Scanning for ieee1394...ieee1394 loaded.
:: Scanning for ohci1394...ohci1394 loaded.
:: Scanning for sbp2...sbp2 loaded.
:: Scanning for sata_promise...libata, sata_promise loaded.
:: Scanning for sata_sil...sata_sil loaded.
:: Scanning for sata_sil24...sata_sil24 loaded.
:: Scanning for sata_svw...sata_svw loaded.
:: Scanning for sata_via...sata_via loaded.
:: Scanning for sata_nv...sata_nv loaded.
:: Scanning for sata_sx4...sata_sx4 loaded.
:: Scanning for sata_sis...sata_sis loaded.
:: Scanning for sata_uli...sata_uli loaded.
:: Scanning for sata_vsc...sata_vsc loaded.
:: Scanning for sata_qstor...sata_qstor loaded.
:: Scanning for ahci...ahci loaded.
:: Scanning for ata_piix...ata_piix loaded.
:: Scanning for sata_mv...sata_mv loaded.
:: Scanning for pdc_adma...pdc_adma loaded.
:: Scanning for dm-mod...dm-mod loaded.
:: Scanning for dm-mirror...dm-mirror loaded.
:: Scanning for jfs...jfs loaded.
:: Scanning for nfs...sunrpc, lockd, nfs loaded.
>> Activating mdev
>> Making tmpfs for /newroot
>> Attempting to mount CD:- /dev/sda
>> Attempting to mount CD:- /dev/sda1
>> Attempting to mount CD:- /dev/sda2
>> Attempting to mount CD:- /dev/sda3
>> Attempting to mount CD:- /dev/sdb
>> Attempting to mount CD:- /dev/sdb1
>> Attempting to mount CD:- /dev/sdb2
>> Attempting to mount CD:- /dev/sdb3
>> No bootable medium found. Waiting for new devices.
..
>> Attempting to mount CD:- /dev/sda
>> Attempting to mount CD:- /dev/sda1
>> Attempting to mount CD:- /dev/sda2
>> Attempting to mount CD:- /dev/sda3
>> Attempting to mount CD:- /dev/sdb
>> Attempting to mount CD:- /dev/sdb1
>> Attempting to mount CD:- /dev/sdb2
>> Attempting to mount CD:- /dev/sdb3
>> Attempting to mount CD:- /dev/sda
>> Attempting to mount CD:- /dev/sda1
>> Attempting to mount CD:- /dev/sda2
>> Attempting to mount CD:- /dev/sda3
>> Attempting to mount CD:- /dev/sdb
>> Attempting to mount CD:- /dev/sdb1
>> Attempting to mount CD:- /dev/sdb2
>> Attempting to mount CD:- /dev/sdb3
!! Could not find CD to boot, something else needed!
>> Loading keymaps
Please select a keymap from the following list by typing in the appropriate
name or number. Hit Enter for the default "us/41" US English keymap.

1 azerty 7 cf 13 es 19 il 25 mk 31 ru 37 trf
2 be 8 croat 14 et 20 is 26 nl 32 se 38 trq
3 bg 9 cz 15 fi 21 it 27 no 33 sg 39 ua
4 br-a 10 de 16 fr 22 jp 28 pl 34 sk-y 40 uk
5 br-l 11 dk 17 gr 23 la 29 pt 35 sk-z 41 us
6 by 12 dvorak 18 hu 24 lt 30 ro 36 slovene 42 wangbe

<< Load keymap (Enter for default):
>> Keeping default keymap
>> Determining root device...
!! The root block device is unspecified or not detected.
Please specify a device to boot, or "shell" for a shell...
boot() ::


grüße
blubbi
Back to top
View user's profile Send private message
thedude0001
Arch/Herd Tester
Arch/Herd Tester


Joined: 16 Jan 2005
Posts: 69

PostPosted: Wed Sep 13, 2006 12:51 am    Post subject: Reply with quote

Wenn du genau nach der Anleitung oben vorgegangen bist dürfte es eigentlich auch mit der 2006.0 nicht funktionieren da das image auf der livecd einen anderen namen hat. entscheidend ist der Eintrag "loop=/livecd.squashfs" in der grub.conf. Auf der 2006.1-CD heißt das Image anders (auf der 2006.0 übrigens auch, da heißt es "image.squashfs"), guck einfach mal auf die CD, ist die große Datei um die 30MB oder so...
_________________
Das Schlimme auf dieser Welt ist
daß die Dummen so selbstsicher sind
und die Gescheiten so voller Zweifel.
Back to top
View user's profile Send private message
blubbi
Guru
Guru


Joined: 27 Apr 2003
Posts: 545
Location: Halle (Saale), Germany

PostPosted: Wed Sep 13, 2006 2:38 am    Post subject: Reply with quote

das ist mir bewußt!

Es geht trozdem nicht mit der 2006.1

ich habe es auch mit der 64Bit version noch nicht geschafft auf ein raid zu installieren.

Ich hab nun das raid zerrissen hab auf sda ein 32Bit gentoo das läßt sich ohne Probleme installieren.

Dann habe ich auf sdb ein 64Bit Gentoo installiert das ich mit dem grub von sda boote.

Frag nicht warum ich kann es dir nicht sagen alles andere hat nicht funktioniert. Ich kann nicht mehr dazu sagen...
Sobald ich es rausgefunden habe was da los ist poste ich es.

Das Problem ist wenn ich ein lauffähiges 64Bit system hab un den botloader nach sda und sdb schreibe (wegen raid) dann bootet die kiste nicht. Obige konfiguration ist die einzige situation in der die Kiste bisher gebootet hat..

weiteres Folgt...

grüße
blubbi
Back to top
View user's profile Send private message
Quadaptor
n00b
n00b


Joined: 02 May 2006
Posts: 9
Location: Frankfurt/Main

PostPosted: Mon Oct 09, 2006 9:38 pm    Post subject: Reply with quote

Hallo zusammen,
ich habe mir mal die Mühe gemacht, ein weiteres HowTo für die Installation eines 64Bit Hardened Gentoos für Strato Server zusammenzuschreiben. Die Ziele scheinen in unterschiedliche Richtungen zu gehen und könnte daher für manch einen doch interessant sein. Nachfolgend der Link:

:arrow: http://de.gentoo-wiki.com/Installation_von_Gentoo_AMD64_auf_Strato_Root_Server
Back to top
View user's profile Send private message
Henks
n00b
n00b


Joined: 10 Jan 2005
Posts: 21

PostPosted: Fri Oct 27, 2006 11:57 am    Post subject: Reply with quote

Hallo zusammen,

der Link zum viki scheint bei mir moemtan nicht zu landen. Sorry wenn das schon mal irgendwo anders erwähnt wurde, aber vielleicht kann mir einer von Euch weiterhelfen.

Prinzipiell funktioniert die serielle Console bei mir, aber mit einem meiner meinung nach hässlichen Unterscheid zu den Sunfires mit denen ich professionell arbeite. Wenn ich das ssh-Fenster zum Console-Fenser schließe bin ich anschließend wieder am login.

Gibt es eine Möglichkeit das so einzurichten das die serielle console-session geöffnet bleibt, auch wenn ich die ssh-Verbindung zum Consoleserver schließe (so wie die Console bei SunFire Servern).

Vielen Dank im Vorraus ;)

/cheer

Henks
Back to top
View user's profile Send private message
smove
n00b
n00b


Joined: 03 Jul 2005
Posts: 51
Location: Germany

PostPosted: Tue Nov 07, 2006 9:33 pm    Post subject: Reply with quote

Kann man nach einer Installation mit dem 2006.0-Image ohne Probleme auf 2006.1 umstellen, sodass der Server bei Reboot-Bedarf dennoch gescheit bootet?
Back to top
View user's profile Send private message
blubbi
Guru
Guru


Joined: 27 Apr 2003
Posts: 545
Location: Halle (Saale), Germany

PostPosted: Tue Nov 07, 2006 9:53 pm    Post subject: Reply with quote

was ist das denn für eine Frage.... wer gentoo auf nem 64Bit Server installiert sollte sich zumindest etwas mit gentoo auskennen.

[ironie]
Nein, es war bei gentoo noch nie möglich von einem release zum anderen ein update durchzuführen!
Wie schön wäre es wenn man nur ein "emerge -uDNva world" eingeben müsste um auf dem neustem Stand zu sein.
[/ironie]

Wenn du die Installation durchführst und ein emerge sync machst, ist dein System ein "2006.1"... wobei ICH bei gentoo eh nicht von releases sprechen würde... denn das wird ja nicht so gehandhabt wie bei SuSE oder ähnlichen distris.
Kann nur sein das du die make.profile neu linken musst... aber das wäre dann auch schon dsa kompliziertest.

Grüße
blubbi
Back to top
View user's profile Send private message
smove
n00b
n00b


Joined: 03 Jul 2005
Posts: 51
Location: Germany

PostPosted: Sat Nov 11, 2006 6:44 pm    Post subject: Reply with quote

Ich scheine das Image mit der eigentlichen Installation verwechselt zu haben.
Es ging ja um das 2006.1er Image was nicht richtig bootet. o0

Wie Gentoo funktioniert ist mir vollkommen klar, ergo kannst du dir deine Kommentare klemmen.
Und von Releases würde ich bei Gentoo auch nicht direkt sprechen, das ist wohl wahr.
Back to top
View user's profile Send private message
aZZe
l33t
l33t


Joined: 20 Feb 2003
Posts: 955
Location: Dinslaken, Germany

PostPosted: Tue Mar 06, 2007 10:46 am    Post subject: Reply with quote

Hat strato mitlerweile keine 64Bit Rescue-Console? Ist die immer noch 32Bit?
_________________
ASUS 4A785TD-V EVO with AMD Phenom(tm) II X4 965
4GB RAM DDR3-1333
ATI Radeon HD4870
Back to top
View user's profile Send private message
blubbi
Guru
Guru


Joined: 27 Apr 2003
Posts: 545
Location: Halle (Saale), Germany

PostPosted: Tue Mar 06, 2007 3:57 pm    Post subject: Reply with quote

IMHO nein.... ist ziemlich peinlich das ganze...

Wenn man zumindest in das bootrom kommen würde und sich seine eigene netboot image anlegen koennte wäre das fein! Einfach auf einen anderen Rechner ein Image legen und das bootrom dahin zeigen lassen.
Dann hätte man sein ganz persöhnliches Rescuesystem :-)

By the way, der Support ist immer noch mehr als dürftig... und die Wartezeiten in der recht teuren Warteschlange sind auch recht lang....
Back to top
View user's profile Send private message
aZZe
l33t
l33t


Joined: 20 Feb 2003
Posts: 955
Location: Dinslaken, Germany

PostPosted: Thu Mar 08, 2007 9:19 am    Post subject: Reply with quote

Oh jaa das kann ich nur bestätigen! Habe da gerade mal angerufen weil die Deppen meine neue Kontoverbindung nicht richtig übernommen haben. Die Möglichkeit das im Kundencenter zu machen hat man irgendwie seit 1 ¹/2 Monaten nicht mehr. "Technisches Problem"....echt zum kotzen. Kennt einer von euch einen Anbieter, der ein 64Bit rescue system schon mit anbietet?
_________________
ASUS 4A785TD-V EVO with AMD Phenom(tm) II X4 965
4GB RAM DDR3-1333
ATI Radeon HD4870
Back to top
View user's profile Send private message
b3cks
Veteran
Veteran


Joined: 23 Mar 2004
Posts: 1481
Location: Bremen (GER)

PostPosted: Thu Mar 08, 2007 9:42 am    Post subject: Reply with quote

aZZe wrote:
Kennt einer von euch einen Anbieter, der ein 64Bit rescue system schon mit anbietet?

:arrow: Hetzner
Kann ich persönlich nur empfehlen.
_________________
I am /root and if you see me laughing you better have a backup.
Back to top
View user's profile Send private message
aZZe
l33t
l33t


Joined: 20 Feb 2003
Posts: 955
Location: Dinslaken, Germany

PostPosted: Thu Mar 08, 2007 5:15 pm    Post subject: Reply with quote

Aha! Hetzner hat sowas? Hab auch schon immer ein Auge auf Hetzner geworfen. Das einzige ist nur bei Hetzner gibts erstmal keine Konsole, wie bei strato und 1&1. Sicherlich kann man bei Hetzner den ganzen Kram dazu konfigurieren eRIC express etc. nur lässt sich Hetzner das auch gut bezahlen. Positiv ist das die Mindestvertragslaufzeit von 1 Monat. Wie lange dauert denn der Reboot ins Rescue System bei Hetzner? Bei strato hat sowas immer nur 2min gedauert.
_________________
ASUS 4A785TD-V EVO with AMD Phenom(tm) II X4 965
4GB RAM DDR3-1333
ATI Radeon HD4870
Back to top
View user's profile Send private message
b3cks
Veteran
Veteran


Joined: 23 Mar 2004
Posts: 1481
Location: Bremen (GER)

PostPosted: Thu Mar 08, 2007 5:55 pm    Post subject: Reply with quote

aZZe wrote:
Wie lange dauert denn der Reboot ins Rescue System bei Hetzner? Bei strato hat sowas immer nur 2min gedauert.

Wenn auf dem Server nicht so viel Traffic wäre, würde ich das jetzt testen, aber länger als 1-2 Minuten dauert das auch hier nicht.
_________________
I am /root and if you see me laughing you better have a backup.
Back to top
View user's profile Send private message
gabelhonz
Apprentice
Apprentice


Joined: 30 Aug 2004
Posts: 222
Location: 10010100111110011

PostPosted: Fri Jun 15, 2007 2:13 pm    Post subject: Reply with quote

hendrik_x30 wrote:
So leid es mit auch tut, um nen 64bit Gentoo auf den Server zu backen müsst ihr als erstes mal Suse Pro 64bit drauf haben.

Ich kann auch aus einem 32 Bit Environment die 64Bit livecd auf meine Partition kopieren und booten. Ist doch egal von wo aus, solange ich kein chroot ausführe. Das heißt ich kann auch erstmal das Rescue System Booten und von dort aus meine 64Bit mini partiton erstellen.

gruß
_________________
Wenn Chuck Norris ins Wasser fällt, wird Chuck Norris nicht nass. Wasser wird Chuck Norris.
Back to top
View user's profile Send private message
blubbi
Guru
Guru


Joined: 27 Apr 2003
Posts: 545
Location: Halle (Saale), Germany

PostPosted: Fri Jun 15, 2007 2:22 pm    Post subject: Reply with quote

Ich versteh das hin und her auch nicht.... die sollen ein 64Bit Rescue system anbieten.... das ist alles was man braucht.
Auch wenn man ein 32Bit system hat kann man aus nem 64Bit System in ein 32Bit System chrooten.

Also weg mit dem 32Bit Rescuekram und her mit 64Bit.

Grüße
blubbi
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Deutsche Dokumentation All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum