Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Email System For The Home Network - Version 2.1
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 23, 24, 25, 26, 27  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
jack_mort
Apprentice
Apprentice


Joined: 30 Jan 2003
Posts: 166

PostPosted: Mon Mar 28, 2005 2:18 pm    Post subject: Reply with quote

Well, I don't have ANY error, in ANY log. Everything seems OK...

Edit : it works ! Strange... I just stopped the daemon, regenerated a new ssl key, and now it's OK ! :P
Back to top
View user's profile Send private message
jack_mort
Apprentice
Apprentice


Joined: 30 Jan 2003
Posts: 166

PostPosted: Tue Mar 29, 2005 6:27 pm    Post subject: Reply with quote

Just another couple of questions : is there a way to make the Sent/Trash/etc folders not showing as Inbox subfolders (within Thunderbird) when using IMAP ? And is using pop3 access with spamassassin useful, or does it only makes sense with IMAP ?
Back to top
View user's profile Send private message
bubbas
n00b
n00b


Joined: 29 Dec 2003
Posts: 36
Location: Germany

PostPosted: Sat May 07, 2005 4:05 pm    Post subject: Reply with quote

So there it is an all new bogotrainer version. Many new features and better than ever :lol:

Support-Thread

Please for questions and suggestions use the new Thread!

cu

bubbas
Back to top
View user's profile Send private message
odborg
Tux's lil' helper
Tux's lil' helper


Joined: 12 Apr 2002
Posts: 89
Location: Aalborg, Denmark

PostPosted: Mon May 09, 2005 1:10 pm    Post subject: Reply with quote

i wish to relay some domains how do i go about this?

example
i and a friend both have a user with the same name on our servers (two seperate domains)
i wish to be able to work as an relay for his server (sort of mx backup) so that if his machine is not online people can stilll send mail to him.

If I receive a mail to user@mydomain.com it will be delvivered to the inbox of 'user' on my machine.
If I receive a mail to user@hisdomain.com it will be delivered to the inbox of 'user' on his machine.
It would be perfect i i could also relay user@thirddomain.com to someothername@yahoo.com

I would like to have general solution, not through procmail for each user.

Any ideas where I should go looking?
Back to top
View user's profile Send private message
Sanjiyan
n00b
n00b


Joined: 29 Mar 2004
Posts: 39

PostPosted: Sun May 29, 2005 2:41 pm    Post subject: Reply with quote

I seem to have found a problem with sending email via this HOWTO:

I can send emails from my email clients just fine, but when I try to send email via the Squrriel Mail webmail software, my ISP bounces back with the following error message:

(Attached it the entire message, including headers)

Received: from pop3.blueyonder.co.uk [195.188.53.61]
by localhost with POP3 (fetchmail-6.2.5)
for xxxx@localhost (single-drop); Sun, 29 May 2005 14:50:15 +0100 (BST)
Received: from smtp-in2.blueyonder.co.uk ([172.23.146.13]) by cluster3 with Microsoft SMTPSVC(5.0.2195.6713); Sun, 29 May 2005 14:48:34 +0100
MIME-Version: 1.0
Content-Type: multipart/report;
report-type=delivery-status;
boundary="----_=_NextPart_001_01C56455.1B9A87FE"
X-MimeOLE: Produced By Microsoft Exchange V6.0.6603.0
Received: from eback03.blueyonder.co.uk ([195.188.53.214]) by smtp-in2.blueyonder.co.uk with Microsoft SMTPSVC(5.0.2195.6713); Sun, 29 May 2005 14:48:34 +0100
Received: from [172.23.164.205] (helo=anti-virus02-08) by eback03.blueyonder.co.uk with smtp (Exim 4.32) id 1DcO8r-0005Yf-2S for xxxxx@blueyonder.co.uk; Sun, 29 May 2005 14:47:49 +0100
Received: from [195.188.213.7] (helo=smtp-out4.blueyonder.co.uk) by exim8.blueyonder.co.uk with esmtp (Exim 4.41) id 1DcO84-0006Y8-Jg for xxxx@blueyonder.co.uk; Sun, 29 May 2005 14:47:00 +0100
X-DSNContext: 7ce717b1 - 1184 - 00000002 - 00000000
X-Envelope-To: xxxx@blueyonder.co.uk
Return-Path:
X-OriginalArrivalTime: 29 May 2005 13:48:34.0670 (UTC) FILETIME=[1B8620E0:01C56455]
content-class: urn:content-classes:dsn
Subject: Undeliverable:sdfsf
Date: Sun, 29 May 2005 14:48:34 +0100
Message-ID: <YQtv4dXwu000c954e@smtp-out4.blueyonder.co.uk>
X-MS-Has-Attach: yes
X-MS-TNEF-Correlator:
Thread-Topic: sdfsf
Thread-Index: AcVkVRuYI2H4MFWzSFynf3iarJHmzwAAAAB8
From: "System Administrator" <postmaster@blueyonder.co.uk>
To: <xxx@blueyonder.co.uk>

Your message

To: xxxx@blueyonder.co.uk
Subject: sdfsf
Sent: Sun, 29 May 2005 14:50:07 +0100

did not reach the following recipient(s):

xxxxx@blueyonder.co.uk on Sun, 29 May 2005 14:48:33 +0100
The message contains a content type that is not supported
<smtp-out4.blueyonder.co.uk #5.6.1 smtp;554 5.6.1 Body type not
supported by Remote Host>



Any ideas?
Back to top
View user's profile Send private message
linux_girl
Apprentice
Apprentice


Joined: 12 Sep 2003
Posts: 283

PostPosted: Sat Jun 11, 2005 3:13 pm    Post subject: Reply with quote

i d like to see a printable version of this howto :D

[EDIT:] being french i am wondering does False-Negatives is the folder where i should move spam that wasnt catched by bogo ?[/EDIT]
[EDIT 2]
i ve set gotmail to retrive all hotmail's email not only new & i set it to delet. but it didnt delet already read mails. so evry 10 minuts he was adding duplicats to mailbox
workaround move all of ~/.maildir/IN-hotmail/cur/* to /tmp/mails then add this rules in top of ~/.procmailrc:

Code:

:0 Whc:msgid.lock
|formail -D 8192 msgid.cache
:0 a:
.duplicates/


then
Code:

cd /tmp/mails
for i in * ;do procmail <$i && rm $i;done


this will put all duplicats mail to ~/.maildir/.duplicats u could also move them to /dev/null if u want
_________________
:D :D


Last edited by linux_girl on Sun Jun 19, 2005 1:39 am; edited 3 times in total
Back to top
View user's profile Send private message
LLSLIM
n00b
n00b


Joined: 20 Feb 2004
Posts: 4
Location: Ohio, USA

PostPosted: Sat Jun 18, 2005 10:45 pm    Post subject: Re: Email System For The Home Network - Version 2.1 Reply with quote

I have a quick edit to the guide's section 3.4 on relaying mesages through our ISP SMTP Server, which is important to ensure against messages being classified as spam. This was a head scratcher for a couple of days for me, but like the whole Gentoo experience made me become familar with certain packages like postfix. I feel the section needs to take in account that the MX records for the ISP may not be set as intended to guard against spam, and other things unbenounced to the home user using the SMTP server to relay messages. Here is just my suggestions on what to add to the section.

Diclaimer: Didn't know much about the postfix, cyrus sasl, courier imap mail set up until last Sunday (6 days prior to this message) when I discovered this guide. So this may be known to season vets, but I feel it should be touched upon in the guide for noobs like myself. So any corrections are very much welcome.

To demostrate the problems of the current message relay configuration section of this guide, I will use a real-world and active smtp server for a common ISP. The example ISP is the SBC GLOBAL DSL service provide in the United Sates which the web services are managed by well known YAHOO!. Then followed by a simple How-to on using Postfix as an SMTP Authorization client to relay messages through a YAHOO! Server.

The example server adress: smtp.sbcglobal.yahoo.com (SBC SMTP)

Again in the original section with the example server added...
beowulf wrote:


3.4 Making Postfix a Relay to our ISP:

As was mentioned in section 1.1, we can use Postfix to be an email relay and send any mail to our ISP's SMTP server before it hits the Internet. Please keep in mind, that this step is NOT needed if you intend to use Postfix as a full-blown MTA. This step is optional and should NOT be used if you have an MX record.

Email Client->Cyrus-SASL->Postfix->Cyrus-SASL->ISP SMTP Server->Internet

This is easily accomplished as well. Although it's not really needed, it may be needed with some ISP's or some network setups so I've included for anyone who may need it.

First you must create a file that holds our ISP's SMTP Server authentication information. The format is rather simple "[server] [user]:[pass]". Here's what one could look like if we used the information in chart 2.2 under the SMTP heading:
Code:

root@server # vi /etc/postfix/saslpass

#original guide format
#smtp.isp.com          beo739:rsmtp-pass

#added example line for sbcglobal in original format
smtp.sbcglobal.yahoo.com       our_sbcglobal_username@sbcglobal.net:our-sbc-password





The original /etc/postfix/main.cf look like this:


Code:

root@server # vi /etc/postfix/main.cf

# the name of our SMTP server of our ISP for relaying messages in original guide format
#relayhost = smtp.isp.com

# sbcglobal server in original guide format
relayhost=smtp.sbcglobal.yahoo.com


I ran into trouble when trying to send mail to my ISP due to a feature of postfix as described in the documentation of the relayhost option. Where postfix automatically tries to look up and connect to the machine in the domain name MX record (DNS MX) of the supplied "smtp.isp.com" address, and NOT directly to the "smtp.isp.com" machine unless it is enclosed by square brackets in both our /etc/postfix/main.cf and our /etc/postfix/saslpass files to disable MX record lookup by postfix.

Like the original version of the section said, if you run a local Domain Name server and have your domain MX record set to "smtp.isp.com", then you should skip this section. Most likely if the home network is small a name server with MX record would be overkill, instead local domain name resolution is a carefully crafted array of host files. That's what my home network resolution is at the moment.

Also if the ISP SMTP server's DNS MX record points to the same machine as supplied relayhost variable (i.e. both are "smtp.isp.com"), then puting square brackets in around "smtp.isp.com" are optional and unneccessary, but they won't break the postfix configuration either way. Some major mail service providers like YAHOO! have a dummy server called "nomail" as the MX records for their SMTP servers that collects anything not legal. SMTP authorization to the "nomail" server just times out. To check for a SMTP server's DNS MX record use the 'dig' command line tool from the bind-tools ebuild package (emerge bind-tools).

An example dig for the MX record for the SBC STMP server looks like the following:

Code:

root@server # dig smtp.sbcglobal.yahoo.com mx

; <<>> DiG 9.2.5 <<>> smtp.sbcglobal.yahoo.com mx
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 29362
;; flags: qr rd; QUERY: 1, ANSWER: 3, AUTHORITY: 5, ADDITIONAL: 6

;; QUESTION SECTION:
;smtp.sbcglobal.yahoo.com.      IN      MX

;; ANSWER SECTION:
smtp.sbcglobal.yahoo.com. 653   IN      CNAME   smtp-sbc.mail.yahoo.com.
smtp-sbc.mail.yahoo.com. 108    IN      CNAME   smtp-sbc-v1.mail.vip.sc5.yahoo.com.
smtp-sbc-v1.mail.vip.sc5.yahoo.com. 1800 IN MX  1 nomail.yahoo.com.




For those not familar with DNS terminology and/or lookup scheme, here is a quick synopsis of the above ANSWER SETION resulting from the 'dig' command. You see smtp.sbcglobal.yahoo.com is just a CNAME or alias for the real name of the SMTP server which is smtp-sbc-v1.mail.vip.sc5.yahoo.com (ports vary). The SMTP server has a MX record that points to nomail.yahoo.com. Therefore the "nomail" server address gets passed to postfix and not the actual SMTP server address such as smtp.sbcglobal.yahoo.com that is needed as the relay host.

This results in the message being put in the postfix delayed message queue and the following log messages:

Code:

Jun 15 12:46:37 [postfix/qmgr] 7EF221057F1: from=<local_user@intra.net>, size=3556, nrcpt=1 (queue active)
Jun 15 12:47:07 [postfix/smtp] connect to nomail.yahoo.com[216.145.48.35]: Connection timed out (port 25)
Jun 15 12:47:07 [postfix/smtp] 7EF221057F1: to=<outside_user@gmail.com>, relay=none, delay=30, status=deferred (connect to nomail.yahoo.com[216.145.48.35]: Connection timed out)


To correct the problem we'll put square brackets around the server name that we want to relay messages. The solution works for server CNAME or aliases as well.

Relevant changes to the files using the guide's terminology, and the real life SBC example. They should look like the following segments:

Code:

root@server # vi /etc/postfix/main.cf

# the name of our SMTP server of our ISP for relaying messages.
#relayhost = [smtp.isp.com]

# sbcglobal server
relayhost=[smtp.sbcglobal.yahoo.com]


Code:

root@server # vi /etc/postfix/saslpass

# the name of our SMTP server of our ISP for relaying messages.
#[smtp.isp.com]     beo739:rstmp-pass

#sbcglobal server
[smtp.sbcglobal.yahoo.com]       our_sbcglobal_username@sbcglobal.net:our-sbc-password


Then from here on, follow the guide like normal. starting from this point...

beowulf wrote:

After you've completed that, let's protect the file and hash it so postfix can work with it. We do this with the following commands:
Code:

root@server # /bin/chown root:root /etc/postfix/saslpass
root@server # /bin/chmod 600 /etc/postfix/saslpass
root@server # /usr/sbin/postmap hash:/etc/postfix/saslpass



Hope this helps and is clear. To reiterate the addition of brackets can't hurt exsisting working installs, but it does cause a few headaches without them. Just my 2 cents.

peace and regards,
-Slim.
Back to top
View user's profile Send private message
VoiDeR
Tux's lil' helper
Tux's lil' helper


Joined: 11 Dec 2003
Posts: 122

PostPosted: Wed Jul 13, 2005 3:24 pm    Post subject: Reply with quote

I have almost everything working here except i cant relay my mail to my isp. If i send an email to say fubar@hotmail.com it trys to connect to hotmail directly. I can send to local users and recieve mail just fine. I can login to the imap and view my mail that way. I just cant send out. Here is all the config files that i had to edit in the send section of the guide

Code:

#/etc/postfix/main.cf

myhostname = localhost
mydomain = localdomain
inet_interfaces = $myhostname, localhost
queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/lib/postfix
mail_owner = postfix
myorigin = $myhostname
mydestination = $myhostname, localhost.$mydomain
unknown_local_recipient_reject_code = 450
mynetworks_style = subnet
mynetworks = 127.0.0.0/8 192.168.1.1/24
mailbox_command = /usr/bin/procmail
debug_peer_level = 2
debugger_command =
         PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
         xxgdb $daemon_directory/$process_name $process_id & sleep 5
sendmail_path = /usr/sbin/sendmail
newaliases_path = /usr/bin/newaliases
mailq_path = /usr/bin/mailq
setgid_group = postdrop
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/postfix-2.0.16-r1/sample
readme_directory = /usr/share/doc/postfix-2.0.16-r1/readme
default_destination_concurrency_limit = 2
alias_database = hash:/etc/mail/aliases
local_destination_concurrency_limit = 2
alias_maps = hash:/etc/mail/aliases
home_mailbox = .maildir/

smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_local_domain =
broken_sasl_auth_clients = yes
smtpd_client_restrictions = permit_sasl_authenticated, reject

#smtpd_use_tls=yes
#smtpd_tls_auth_only = yes
#smtpd_tls_key_file = /etc/ssl/postfix/server.key
#smtpd_tls_cert_file = /etc/ssl/postfix/server.crt
#smtpd_tls_CAfile = /etc/ssl/postfix/server.pem
#smtpd_tls_loglevel = 3
#smtpd_tls_received_header = yes
#smtpd_tls_session_cache_timeout = 3600s
#tls_random_source = dev:/dev/urandom

smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/saslpass
smtp_sasl_security_options = noanonymous


Code:


#/etc/sasl2/smtpd.conf

# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/files/smtp.sasl,v 1.2 2004/07/18 03:26:56 dragonheart Exp $
pwcheck_method:saslauthd
mech_list: plain login

#/usr/lib/sasl2/smtpd.conf

pwcheck_method:saslauthd
mech_list: plain login

# /etc/conf.d/saslauthd
# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/files/saslauthd-2.1.20.conf,v 1.1 2004/10/31 06:13:48 langthang Exp $
SASL_AUTHMECH=shadow

SASL_RIMAP_HOSTNAME=""
SASL_TIME_OF_DAY_LOGIN_RESTRICTIONS=yes

SASLAUTHD_OPTS="-a ${SASL_AUTHMECH}"

#/etc/postfix/saslpass
# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/files/smtp.pass,v 1.2 2004/07/18 03:26:56 dragonheart Exp $
#
# remotehost user:password
smtp.suscom.net xxxxxxxxx:xxxxxxxxx


Im not sure what to do from here. Ive searched but still havent came up with a solution.

VoiDeR
Back to top
View user's profile Send private message
c_riis
n00b
n00b


Joined: 22 May 2004
Posts: 9
Location: Denmark, Copenhagen

PostPosted: Sat Jul 30, 2005 2:55 pm    Post subject: Reply with quote

Hi, first id like to say thanks for this howto !!!

Im have just been through it and i ran into a problem and a few things i dont understand.

When, on my laptop, im trying to get the mail from the server, which looks like it gets mail from my ISP, Kmail says "the connection to SERVER is broken... and in my servers logfiles the imapd thinks it needs sql... How do i make this work ?

Kmail can get the info when i press "Check what the servers support" ind the Security-tab. So some sort of connection is working..

Code:

pbk1111@kosmo ~/bin $ /usr/bin/fetchmail -vvv -a -m "/usr/bin/procmail -d %T"
fetchmail: 6.2.5.2 querying gmail (protocol POP3) at Sat Jul 30 16:01:43 2005: poll started
fetchmail: Issuer Organization: Thawte Consulting cc
fetchmail: Issuer CommonName: Thawte Server CA
fetchmail: Server CommonName: pop.gmail.com
fetchmail: gmail key fingerprint: F2:BE:86:E4:E2:51:76:AA:B6:00:91:7B:97:A4:E6:F3
fetchmail: Warning: server certificate verification: unable to get local issuer certificate
fetchmail: Issuer Organization: Thawte Consulting cc
fetchmail: Issuer CommonName: Thawte Server CA
fetchmail: Server CommonName: pop.gmail.com
fetchmail: Warning: server certificate verification: certificate not trusted
fetchmail: Issuer Organization: Thawte Consulting cc
fetchmail: Issuer CommonName: Thawte Server CA
fetchmail: Server CommonName: pop.gmail.com
fetchmail: Warning: server certificate verification: unable to verify the first certificate
fetchmail: POP3< +OK Gpop 35pf2846136wra ready.
fetchmail: POP3> CAPA
fetchmail: POP3< +OK Capability list follows
fetchmail: POP3< USER
fetchmail: POP3< RESP-CODES
fetchmail: POP3< EXPIRE 0
fetchmail: POP3< LOGIN-DELAY 300
fetchmail: POP3< X-GOOGLE-VERHOEVEN
fetchmail: POP3< .
fetchmail: POP3> USER TEST@gmail.com
fetchmail: POP3< +OK send PASS
fetchmail: POP3> PASS *
fetchmail: POP3< +OK Welcome.
fetchmail: POP3> STAT
fetchmail: POP3< +OK 1 463
1 message for TEST@gmail.com at gmail (463 octets).
fetchmail: POP3> LIST 1
fetchmail: POP3< +OK 1 463
fetchmail: POP3> RETR 1
fetchmail: POP3< +OK message follows
reading message TEST@gmail.com@gmail-pop.l.google.com:1 of 1 (463 octets)
#* flushed
fetchmail: POP3> DELE 1
fetchmail: POP3< +OK marked for deletion
fetchmail: POP3> QUIT
fetchmail: POP3< +OK Farewell.
fetchmail: 6.2.5.2 querying gmail (protocol POP3) at Sat Jul 30 16:01:48 2005: poll completed
fetchmail: normal termination, status 0


Code:

kosmo ~ # tail -f  /var/log/messages
Jul 30 16:24:22 kosmo imapd: authentication error: Input/output error
Jul 30 16:25:49 kosmo imapd: Connection, ip=[::ffff:192.168.1.2]
Jul 30 16:26:30 kosmo authdaemond: failed to connect to mysql server (server=mysql.example.com, userid=admin): Unknown MySQL Server Host 'mysql.example.com' (1)
Jul 30 16:26:30 kosmo imapd: LOGIN FAILED, user=pbk1111, ip=[::ffff:192.168.1.2]
Jul 30 16:26:30 kosmo imapd: authentication error: Input/output error
Jul 30 16:27:47 kosmo imapd: Connection, ip=[::ffff:192.168.1.2]
Jul 30 16:27:47 kosmo imapd: Disconnected, ip=[::ffff:192.168.1.2], time=0
Jul 30 16:27:47 kosmo imapd-ssl: Connection, ip=[::ffff:192.168.1.2]
Jul 30 16:27:47 kosmo imapd-ssl: Unexpected SSL connection shutdown.
Jul 30 16:27:47 kosmo imapd-ssl: Disconnected, ip=[::ffff:192.168.1.2], time=0, starttls=1


As i read from this howto, on my laptop, i need to supply the login and password for the user om ny server, [postmaster] in one of the configfiles.., right ? Im a bit confused i must say...

Must the sending and receiving part of the Kmail configuration include the same login/password ?

Another thing i dont understand is what the "/etc/mail/aliases" does ? why alias root to some other user (or is it the other way around?) i cant see the purpose.

Would it be possible to leave out the procmail part ?

The part about PAM, how do i check that i have pam running ? as i understand its for authentificating users... and i suppose i got it, and it works... but how to check it ?




Any idea would be appreciated!!

- Christian from Denmark :-)
Back to top
View user's profile Send private message
robfish
Tux's lil' helper
Tux's lil' helper


Joined: 25 Nov 2002
Posts: 137
Location: New Zealand

PostPosted: Tue Aug 09, 2005 9:43 pm    Post subject: Reply with quote

I used the guide about a year ago to successfully set up a mail server on a Gentoo server.

I can use Kontact (Kmail) successfully on my desktop Gentoo machine but I am having trouble sending from a Windows XP machine.

With Outlook and Outlook Express I can read mail fine but when trying to send I get a message...

"The server you are connecting to is using a security certificate that could not be verified.
The signature of the certificate could not be verified"

With Thunderbird I get.....

"Could not establish an encrypted connection because certificate presented by 192.168.10.11 is invalid or corrupted. Error Code -8182"

What do I do to sort out this problem?
_________________
RobFish
Back to top
View user's profile Send private message
al
Guru
Guru


Joined: 26 Dec 2002
Posts: 304
Location: Scotland

PostPosted: Sun Aug 28, 2005 10:43 am    Post subject: Reply with quote

First i would like to say thanks for this fantastic tutorial!:D

I have been following the wiki here: http://gentoo-wiki.com/HOWTO_Email_System_for_the_Home_Network

Everything appears to be working fine on my server end.
If i ssh into my server and load Mutt i can send and receive mail from the internet.

If i load Sylpheed on my workstation (inside the same lan) i can receive mail from the server but when i try and send i get an error 554 Relay Access Denied.
Code:
[11:35:53] ESMTP> AUTH LOGIN
[11:35:53] ESMTP< 334 VXNlcm5hbWU6
[11:35:53] ESMTP> [USERID]
[11:35:53] ESMTP< 334 UGFzc3dvcmQ6
[11:35:53] ESMTP> [PASSWORD]
[11:35:53] ESMTP< 235 Authentication successful
[11:35:53] ESMTP> MAIL FROM:<alunt2003@alunt2003@homelinux.org> SIZE=347
[11:35:53] SMTP< 250 Ok
[11:35:53] SMTP> RCPT TO:<alunt2003@yahoo.com>
[11:35:53] SMTP< 554 <alunt2003@yahoo.com>: Relay access denied
** error occurred on SMTP session
** Error occurred while sending the message.


On the server i get a long tail of woe in my /var/log/message.
My log file snippet is here: http://thomson.podzone.org/files/messages

Can anyone help?

Thanks :?

EDIT: I should probably mention that i have set it up as a full blown smtp server. I am not routing through my existing yahoo email.


Last edited by al on Wed Sep 14, 2005 8:32 pm; edited 1 time in total
Back to top
View user's profile Send private message
al
Guru
Guru


Joined: 26 Dec 2002
Posts: 304
Location: Scotland

PostPosted: Sun Aug 28, 2005 4:08 pm    Post subject: Reply with quote

Okay been messing around with it again.

I changed the following line in my /etc/postfix/main.cf

Code:
mynetworks = 192.168.0.1/255, 127.0.0.1
to
mynetworks = 192.168.0.1/24, 127.0.0.0/8


and now i can send from my client box but in my log on my server i see this:

Code:
Aug 28 16:45:41 alunt2003 postfix/smtp[23460]: 1C55D208F8E: to=<edited@btinternet.com>, relay=mx1.bt.mail.yahoo.com[195.50.106.135], delay=0, status=sent (250 ok dirdel)


I thought i was the email provider so why does it say bt.mail.yahoo.com? Is that because my broadband is with bt/yahoo?
I do have a Yahoo mail account but i'm pretty sure i didn't use it in the config.

I'm horribly confused :?
Back to top
View user's profile Send private message
appetitus
Apprentice
Apprentice


Joined: 28 Sep 2003
Posts: 209

PostPosted: Tue Sep 20, 2005 6:03 am    Post subject: Re: Email System For The Home Network - Version 2.1 Reply with quote

LLSLIM wrote:
I ran into trouble when trying to send mail to my ISP due to a feature of postfix as described in the documentation of the relayhost option. Where postfix automatically tries to look up and connect to the machine in the domain name MX record (DNS MX) of the supplied "smtp.isp.com" address, and NOT directly to the "smtp.isp.com" machine unless it is enclosed by square brackets in both our /etc/postfix/main.cf and our /etc/postfix/saslpass files to disable MX record lookup by postfix.


THANKS! That problem was driving me crazy. :D :D
_________________
Being a Gentoo user means living in a house inhabited by a family of crazed carpenters. When you wake up, the house is different. Maybe there is a new turret, or some walls have moved, or perhaps someone has removed the floor under your bed.
Back to top
View user's profile Send private message
sander2
n00b
n00b


Joined: 21 Dec 2003
Posts: 21

PostPosted: Wed Sep 28, 2005 2:38 am    Post subject: Reply with quote

hi!

i read almost the whole thread but couldn't get the thunderbird -> sasl -> postfix thing working.

can someone please help me/us?

please see this thread: http://forums.gentoo.org/viewtopic-t-331546.html

thank you!
Back to top
View user's profile Send private message
carpman
Advocate
Advocate


Joined: 20 Jun 2002
Posts: 2202
Location: London - UK

PostPosted: Fri Sep 30, 2005 6:43 pm    Post subject: Reply with quote

hello, need bit of advice on webapp-config.

Have home server behind smoothwall box, have setup LAMP with vhost flag, have got main apache server in /var/www/localhost but have setup a virtual server using IP alias which points to /home/user/public_html which i use as public server.

This user is also the one used for this guide, thing is how and where do i install squirrelmail?

Following this guide the squirrelmail section does not work as squirrelmail is now a webapp-config ebuild.

cheers
_________________
Work Station - 64bit
Gigabyte GA X48-DQ6 Core2duo E8400
8GB GSkill DDR2-1066
SATA Areca 1210 Raid
BFG OC2 8800 GTS 640mb
--------------------------------
Notebook
Samsung Q45 7100 4gb
Back to top
View user's profile Send private message
bdemore
n00b
n00b


Joined: 22 Oct 2002
Posts: 67

PostPosted: Mon Oct 03, 2005 10:48 pm    Post subject: Apache PHP Squirrelmail Configuration How To? Reply with quote

The excellent guide states in regard to setting up Squirrelmail "I will assume you have a working Apache and PHP setup". Unfortunately, I don't. I used to have an excellent guide and I think it was a how-to document under Desktop Configuration. I can't find it anymore. Anyway, if someone could point me in the right direction with regard to the Apache config. files that need to be modified in order to get Squirrelmail working on this setup I'd be very grateful, thanks.
Back to top
View user's profile Send private message
jbiggs77
n00b
n00b


Joined: 13 Sep 2003
Posts: 38

PostPosted: Tue Oct 11, 2005 1:15 pm    Post subject: Reply with quote

Been working on getting this system working for a week or so now. At first, retrieving emails with fetchmail was working great and I could view them with mutt locally but I couldn't get courier-imap working. Came to find out it was an issue with DNS.

Now imap is working and I can view all the emails fetchmail had placed in my maildir but I can not fetch any more emails. Fetchmail seems to be working but I am receiving "Returned to sender" emails in my inbox. How can I check to make sure fetchmail is working correctly? How can I see if it is handing off the emails to Postfix, etc., all the way down the line?

Edit: It seems that when fetchmail hands the emails off to Postfix, Postfix then tries to deliver the mails to me by relaying them through my ISP's smtp server to address mylogin@localhost.mydomain. Why is it doing this and why is it sending them to that address?

Edit 2: OK, so the problem was that I was just calling fetchmail and not telling it implicitly to deliver to procmail, which I have done. I am still having problems with procmail not creating my folders though. It did create one of the folders about a week ago when I started on this but it is not listed inside the courierimapsubscribed file.
Back to top
View user's profile Send private message
ChojinDSL
l33t
l33t


Joined: 07 Jul 2003
Posts: 784

PostPosted: Thu Oct 20, 2005 3:01 pm    Post subject: Reply with quote

I originally had a perfect working email server. But the mobo got fried, so I reinstalled on a new pc with a different cpu.

anyways, I just hooked up my server's original harddrive to the new machine and just recompiled everything for the new cpu. So there might be some legacy configs lying around. Its not a sparkly clean new install from scratch.

I've followed the guide, but for some reason I cant connect to my server via imap.

My log file spits this out whenever I try to connect. And sylpheed-claws gives me an error of course as well.
Code:
Oct 20 16:49:10 [imapd] Connection, ip=[::ffff:192.168.2.100]
Oct 20 16:49:10 [imapd] LOGIN FAILED, user=chojin, ip=[::ffff:192.168.2.100]
Oct 20 16:49:10 [imapd] authentication error: Input/output error
Oct 20 16:49:10 [authdaemond] failed to connect to mysql server (server=mysql.example.com, userid=admin): Unknown MySQL Server Host 'mysql.example.com' (1)


Now Im a little confused. While I do use mysql for my mythtv setup. I made sure to emerge all the mentioned programs with a USE="-mysql". So that they were built without the need for mysql.

Furthermore, I noticed that when I emerged courier-imap, at the end there was a message warning me that authdaemond was no longer provided and that courier-authlib or something like that was used. Do I still need authdaemond? Which packages provides that?

*****EDIT***********

I managed to fix it. I just went into all of the relevant configs for courier-imap and courier in /etc/ and made sure that there were no references to mysql. I had also forgotten to restart courier-authlib. So it was probably still using an unedited config file.
Anyways, now it works again.
Back to top
View user's profile Send private message
mxa055
n00b
n00b


Joined: 09 Oct 2005
Posts: 38

PostPosted: Mon Oct 24, 2005 1:32 pm    Post subject: Reply with quote

Hi there,

I am getting this error when trying to start courier-imap-ssl


Code:

/etc/init.d/courier-imapd-ssl start
 * Starting courier-authlib: authdaemond ...                              [ ok ] * Starting courier-imapd over SSL ...
bind: Address already in use
ll_daemon_start: Resource temporarily unavailable                         [ !! ]



Some people already mentioned that they have solved this issue but don't point to the solution.

Any help?

Regards,
Michael
Back to top
View user's profile Send private message
mxa055
n00b
n00b


Joined: 09 Oct 2005
Posts: 38

PostPosted: Tue Oct 25, 2005 9:56 am    Post subject: Reply with quote

mxa055 wrote:
Hi there,

I am getting this error when trying to start courier-imap-ssl


Code:

/etc/init.d/courier-imapd-ssl start
 * Starting courier-authlib: authdaemond ...                              [ ok ] * Starting courier-imapd over SSL ...
bind: Address already in use
ll_daemon_start: Resource temporarily unavailable                         [ !! ]



Some people already mentioned that they have solved this issue but don't point to the solution.

Any help?

Regards,
Michael


A restart fixed the problem! :roll:
Back to top
View user's profile Send private message
AMSch
Apprentice
Apprentice


Joined: 29 Mar 2004
Posts: 179
Location: Austria

PostPosted: Thu Jan 26, 2006 9:01 am    Post subject: Reply with quote

I get the following error when I try to fetch mail from my 2 pop accounts:

Code:

procmail: Missing recipient
sh: line 1: andreas: command not found
fetchmail: MDA returned nonzero status 127


Code:

#!/bin/bash
/usr/bin/fetchmail -a -s -m "/usr/bin/procmail -d
%T"


"andreas" is the mail user - can anybody help please?
Back to top
View user's profile Send private message
AMSch
Apprentice
Apprentice


Joined: 29 Mar 2004
Posts: 179
Location: Austria

PostPosted: Thu Jan 26, 2006 10:26 am    Post subject: Reply with quote

Messages are recieved from my pop servers, but they arent deleted and recieved again the next time the script runs -> I had over 1000 mail in my inbox but only 5 different mails :-(
Back to top
View user's profile Send private message
AMSch
Apprentice
Apprentice


Joined: 29 Mar 2004
Posts: 179
Location: Austria

PostPosted: Thu Jan 26, 2006 12:18 pm    Post subject: Reply with quote

Solved it - error was in script - had newline after "-d"
Back to top
View user's profile Send private message
miscdebris
n00b
n00b


Joined: 30 Mar 2005
Posts: 68

PostPosted: Sat Feb 11, 2006 11:59 pm    Post subject: Some Issues Reply with quote

Fetchmail is working perfectly, however, it returns status 1 whenever it can't find any email, and that causes frcon to send an email to my root account. anything we can do to stop this?

One of my sub[/list]folders keeps deleting the email contained within it.

I have kmail set to use imap to store the groupware information, but, and while it's not losing the information, it fails to process it. My contacts won't display, my schedule is blank, though it should be full, no tasks even though I have many, etc.

Anyone have any ideas on these?
Back to top
View user's profile Send private message
Rwilson
Tux's lil' helper
Tux's lil' helper


Joined: 14 Feb 2004
Posts: 78

PostPosted: Sat Feb 18, 2006 3:46 am    Post subject: Reply with quote

I'm in the process of using this Howto to setup my own little email server and have come upon a hitch. I have two email accounts, one with gmail and one with yahoo. I use each one for different things, so I need to be able to send emails through each host based on which account the email is from. Do I need to do any special configuration to handle this?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 23, 24, 25, 26, 27  Next
Page 24 of 27

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum