Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200706-06 ] Mozilla products: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1567

PostPosted: Tue Jun 19, 2007 9:26 pm    Post subject: [ GLSA 200706-06 ] Mozilla products: Multiple vulnerabilitie Reply with quote

Gentoo Linux Security Advisory

Title: Mozilla products: Multiple vulnerabilities (GLSA 200706-06)
Severity: normal
Exploitable: remote
Date: June 19, 2007
Bug(s): #180436
ID: 200706-06

Synopsis

Multiple vulnerabilities have been reported in Mozilla Firefox, Thunderbird, SeaMonkey and XULRunner, some of which may allow user-assisted arbitrary remote code execution.

Background

Mozilla Firefox is an open-source web browser from the Mozilla Project, and Mozilla Thunderbird an email client. The SeaMonkey project is a community effort to deliver production-quality releases of code derived from the application formerly known as the 'Mozilla Application Suite'. XULRunner is a Mozilla runtime package that can be used to bootstrap XUL+XPCOM applications like Firefox and Thunderbird.

Affected Packages

Package: www-client/mozilla-firefox
Vulnerable: < 2.0.0.4
Unaffected: >= 2.0.0.4
Architectures: All supported architectures

Package: www-client/mozilla-firefox-bin
Vulnerable: < 2.0.0.4
Unaffected: >= 2.0.0.4
Architectures: All supported architectures

Package: mail-client/mozilla-thunderbird
Vulnerable: < 2.0.0.4
Unaffected: >= 2.0.0.4
Unaffected: >= 1.5.0.12 < 1.5.0.13
Architectures: All supported architectures

Package: mail-client/mozilla-thunderbird-bin
Vulnerable: < 2.0.0.4
Unaffected: >= 2.0.0.4
Unaffected: >= 1.5.0.12 < 1.5.0.13
Architectures: All supported architectures

Package: www-client/seamonkey
Vulnerable: < 1.1.2
Unaffected: >= 1.1.2
Architectures: All supported architectures

Package: www-client/seamonkey-bin
Vulnerable: < 1.1.2
Unaffected: >= 1.1.2
Architectures: All supported architectures

Package: net-libs/xulrunner
Vulnerable: < 1.8.1.4
Unaffected: >= 1.8.1.4
Architectures: All supported architectures


Description

Mozilla developers fixed several bugs involving memory corruption through various vectors (CVE-2007-2867, CVE-2007-2868). Additionally, several errors leading to crash, memory exhaustion or CPU consumption were fixed (CVE-2007-1362, CVE-2007-2869). Finally, errors related to the APOP protocol (CVE-2007-1558), XSS prevention (CVE-2007-2870) and spoofing prevention (CVE-2007-2871) were fixed.

Impact

A remote attacker could entice a user to view a specially crafted web page that will trigger one of the vulnerabilities, possibly leading to the execution of arbitrary code or a Denial of Service. It is also possible for an attacker to spoof the address bar or other browser elements, obtain sensitive APOP information, or perform cross-site scripting attacks, leading to the exposure of sensitive information, like user credentials.

Workaround

There is no known workaround at this time.

Resolution

All Mozilla Firefox users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-client/mozilla-firefox-2.0.0.4"
All Mozilla Firefox binary users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-client/mozilla-firefox-bin-2.0.0.4"
All Mozilla Thunderbird users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=mail-client/mozilla-thunderbird-2.0.0.4"
All Mozilla Thunderbird binary users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=mail-client/mozilla-thunderbird-bin-2.0.0.4"
All SeaMonkey users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-client/seamonkey-1.1.2"
All SeaMonkey binary users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-client/seamonkey-bin-1.1.2"
All XULRunner users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=net-libs/xulrunner-1.8.1.4"


References

CVE-2007-1362
CVE-2007-1558
CVE-2007-2867
CVE-2007-2868
CVE-2007-2869
CVE-2007-2870
CVE-2007-2871
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum