Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] gnome-volume-manager mounting Windows partition
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
trolley
Apprentice
Apprentice


Joined: 12 Jun 2002
Posts: 292
Location: Canada

PostPosted: Mon Jun 18, 2007 12:34 am    Post subject: [solved] gnome-volume-manager mounting Windows partition Reply with quote

gnome-volume-manager is mounting my windows partition, but I don't want it to. How can I tell it which partitions to ignore?

Last edited by trolley on Tue Jun 19, 2007 12:04 am; edited 1 time in total
Back to top
View user's profile Send private message
Impalatore-polacco
Apprentice
Apprentice


Joined: 15 Apr 2007
Posts: 203
Location: Campogalliano - bell'ITALIA

PostPosted: Mon Jun 18, 2007 12:39 am    Post subject: Reply with quote

Take a look in the /etc/fstab, if there is your windows partition delete it, and linux don't automount it
_________________
Ci stanno osservando, ci sono i pipistrelli....ne hai presa troppa bello, ne hai presa troppa
Back to top
View user's profile Send private message
trolley
Apprentice
Apprentice


Joined: 12 Jun 2002
Posts: 292
Location: Canada

PostPosted: Mon Jun 18, 2007 1:32 am    Post subject: Reply with quote

Impalatore-polacco wrote:
Take a look in the /etc/fstab, if there is your windows partition delete it, and linux don't automount it


They're not in there:

Code:

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/sda2               /boot           ext3            noauto,noatime  1 2
/dev/sda4               /               ext3            noatime         0 1
/dev/sda3               none            swap            sw              0 0
#/dev/cdrom1            /mnt/cdrom      auto            ro              0 0
#/dev/dvd               /mnt/dvd        auto            ro              0 0
#/dev/fd0               /mnt/floppy     auto            noauto          0 0
/dev/sda1               /mnt/media      ntfs            umask=0222      0 0

# glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
# POSIX shared memory (shm_open, shm_unlink).
# (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
#  use almost no memory if not populated with files)
shm                     /dev/shm        tmpfs           nodev,nosuid,noexec     0 0
tmpfs                   /dev/shm        tmpfs           nodev,nosuid,noexec     0 0


My Windows partitions that are being mounted that I don't want to be are /dev/hda1 and /dev/hda5.
Back to top
View user's profile Send private message
Impalatore-polacco
Apprentice
Apprentice


Joined: 15 Apr 2007
Posts: 203
Location: Campogalliano - bell'ITALIA

PostPosted: Mon Jun 18, 2007 1:47 am    Post subject: Reply with quote

In the fstab put
Quote:
#
at the beginnig of the line
Code:
/dev/sda1               /mnt/media      ntfs            umask=0222      0 0
you should have this fstab
Code:
# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/sda2               /boot           ext3            noauto,noatime  1 2
/dev/sda4               /               ext3            noatime         0 1
/dev/sda3               none            swap            sw              0 0
#/dev/cdrom1            /mnt/cdrom      auto            ro              0 0
#/dev/dvd               /mnt/dvd        auto            ro              0 0
#/dev/fd0               /mnt/floppy     auto            noauto          0 0
#/dev/sda1               /mnt/media      ntfs            umask=0222      0 0

# glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
# POSIX shared memory (shm_open, shm_unlink).
# (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
#  use almost no memory if not populated with files)
shm                     /dev/shm        tmpfs           nodev,nosuid,noexec     0 0
tmpfs                   /dev/shm        tmpfs           nodev,nosuid,noexec     0 0
and the windows partition shouldn't automount
_________________
Ci stanno osservando, ci sono i pipistrelli....ne hai presa troppa bello, ne hai presa troppa
Back to top
View user's profile Send private message
trolley
Apprentice
Apprentice


Joined: 12 Jun 2002
Posts: 292
Location: Canada

PostPosted: Mon Jun 18, 2007 1:53 am    Post subject: Reply with quote

I actually do want that one mounted. I should have explained my partition layout better. I have 3 NTFS partitions:

Code:

/dev/hda1: Windows
/dev/hda5: Storage
/dev/sda1: Media


I want the Media partition (my music, etc.) mounted, but I don't want the other 2 mounted. The other 2 have just started mounting automatically since I installed gnome-volume-manager to do automounting for my CD and DVD drives.
Back to top
View user's profile Send private message
Impalatore-polacco
Apprentice
Apprentice


Joined: 15 Apr 2007
Posts: 203
Location: Campogalliano - bell'ITALIA

PostPosted: Mon Jun 18, 2007 3:01 am    Post subject: Reply with quote

...mmmm I only have a suggestion to try. Maybe it helps by hiding the ntfs partition; I think you can do this with fdisk or with gparted. (unmount the partition before you try to hide it)
_________________
Ci stanno osservando, ci sono i pipistrelli....ne hai presa troppa bello, ne hai presa troppa
Back to top
View user's profile Send private message
jabol
Apprentice
Apprentice


Joined: 05 Oct 2005
Posts: 269

PostPosted: Mon Jun 18, 2007 6:10 am    Post subject: Reply with quote

Same problem here. All my partitions get mounted as I log into Gnome. I'm not asked which should, nor can I change it. Even those which don't actually have mountpoints on the disk (those are than automatically created)! I believe partition hiding isn't really a good way for getting this right. It's a bit like a dirty hack (which I can accept for one time use, but not as long term workaround).
I believe I will need to search gnome-config throughtoutly...
Back to top
View user's profile Send private message
trolley
Apprentice
Apprentice


Joined: 12 Jun 2002
Posts: 292
Location: Canada

PostPosted: Mon Jun 18, 2007 11:55 am    Post subject: Reply with quote

I'm going to try adding entries for them in fstab with the noauto option to see if that does it. I'll post my results.
Back to top
View user's profile Send private message
Impalatore-polacco
Apprentice
Apprentice


Joined: 15 Apr 2007
Posts: 203
Location: Campogalliano - bell'ITALIA

PostPosted: Mon Jun 18, 2007 5:48 pm    Post subject: Reply with quote

You can try to hide the partition from a live linux distro...I think this is the last idea I have for the moment :?
_________________
Ci stanno osservando, ci sono i pipistrelli....ne hai presa troppa bello, ne hai presa troppa
Back to top
View user's profile Send private message
trolley
Apprentice
Apprentice


Joined: 12 Jun 2002
Posts: 292
Location: Canada

PostPosted: Tue Jun 19, 2007 12:03 am    Post subject: Reply with quote

Adding them to fstab with noauto fixed it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum