Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Hur får man bort svensk installation?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
Luddetiger
n00b
n00b


Joined: 11 Nov 2005
Posts: 25

PostPosted: Sun Jun 17, 2007 6:09 pm    Post subject: Hur får man bort svensk installation? Reply with quote

Jag har på något sett fått in massor av program på svenska.
Typ:

ln: skapar symbolisk länk

Och i de programmen fungerar in UTF-8 så bra. Men egentligen vill jag bara bli av med det. Vill ha svenska tecken men inget mer.

Hur får man till det? Allt på engelska med stöd för åäö.
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4834
Location: Gothenburg, Sweden

PostPosted: Mon Jun 18, 2007 7:34 pm    Post subject: Reply with quote

Vad har du för locale-inställningar? Vilken output ger
Code:
locale
Den enda inställningen som är viktig för att få stöd för svenskt tangentbord är LC_CTYPE som bör vara sv_SE eller sv_SE.UTF-8, övriga kan ha inställningen "C".
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Luddetiger
n00b
n00b


Joined: 11 Nov 2005
Posts: 25

PostPosted: Mon Jun 18, 2007 7:37 pm    Post subject: Reply with quote

# locale
LANG=sv_SE.UTF-8
LC_CTYPE="sv_SE.UTF-8"
LC_NUMERIC="sv_SE.UTF-8"
LC_TIME="sv_SE.UTF-8"
LC_COLLATE="sv_SE.UTF-8"
LC_MONETARY="sv_SE.UTF-8"
LC_MESSAGES="sv_SE.UTF-8"
LC_PAPER="sv_SE.UTF-8"
LC_NAME="sv_SE.UTF-8"
LC_ADDRESS="sv_SE.UTF-8"
LC_TELEPHONE="sv_SE.UTF-8"
LC_MEASUREMENT="sv_SE.UTF-8"
LC_IDENTIFICATION="sv_SE.UTF-8"
LC_ALL=

Så där hade jag ju lite mer.

Hittar inte var alla dessa är satta. i /etc/env.d/02locale har jag bara LANG="sv_SE.UTF-8

Men jag måste lösa detta. Alla min program är helt skadade... :-( fdisk och sånt ser hel skumma ut. VIll inte ha sakerna på svenska
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4834
Location: Gothenburg, Sweden

PostPosted: Tue Jun 19, 2007 6:01 am    Post subject: Reply with quote

Eftersom du inte själv ställt in något för LC_* ärver de från LANG. Notera att LC_* har citattecken medan LANG inte har det. Ställ helt enkelt in allt utom LC_CTYPE till en_US.UTF-8 eller en_GB.UTF-8 om du föredrar brittisk engelska.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Luddetiger
n00b
n00b


Joined: 11 Nov 2005
Posts: 25

PostPosted: Tue Jun 19, 2007 2:01 pm    Post subject: Reply with quote

lade nu till så det står så här:

LANG=en_GB.UTF-8
LC_CTYPE="sv_SE.UTF-8"
LC_TIME="sv_SE.UTF-8"
LC_MONETARY="sv_SE.UTF-8"
LC_TELEPHONE="sv_SE.UTF-8"
LC_MEASUREMENT="sv_SE.UTF-8"


När jag kör locale så får jag detta som output:
LANG=en_GB.UTF-8
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=


Programmen verkara förstå direkt. Men nu fungera inte åäö :-(
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4834
Location: Gothenburg, Sweden

PostPosted: Tue Jun 19, 2007 4:49 pm    Post subject: Reply with quote

Skumt, om du har till exempel
/etc/env.d/02locale:
LANG="en_GB.UTF-8"
LC_CTYPE="sv_SE.UTF-8"

skall du få
Code:
LANG=en_GB.UTF-8
LC_CTYPE=sv_SE.UTF-8
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=

som output från locale givet att du kört env-update som root och source /etc/profile i den terminal du använder. Du kan experimentera med att köra till exempel
Code:
LC_CTYPE="sv_SE.UTF-8" xterm

och sedan köra locale i den xtermen.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Luddetiger
n00b
n00b


Joined: 11 Nov 2005
Posts: 25

PostPosted: Tue Jun 19, 2007 5:22 pm    Post subject: Reply with quote

Där hade vi problemet ;-)

Jag körde ju inte env-update och det.
Jag testade source /etc/env.d/02locale

Nu får jag output:
Code:

LANG=en_GB.UTF-8
LC_CTYPE=sv_SE.UTF-8
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=


Så det verkar ju rätt. Men vissa program kör ändå med svenska. Kan man köra något för att kompilera om dem med detta som utgång istället?
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4834
Location: Gothenburg, Sweden

PostPosted: Tue Jun 19, 2007 5:48 pm    Post subject: Reply with quote

Det beror delvis på vad du har för LINGUAS-inställning. Vidare behåller gnome och kde de inställningar du hade när du loggade på.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Luddetiger
n00b
n00b


Joined: 11 Nov 2005
Posts: 25

PostPosted: Tue Jun 19, 2007 5:50 pm    Post subject: Reply with quote

Och det kollar jag hur?
Kör datorn som server så jag kör inte gnome o sånt. Det är mer typ program cfdisk och sånt som har kvar språket.
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4834
Location: Gothenburg, Sweden

PostPosted: Tue Jun 19, 2007 6:15 pm    Post subject: Reply with quote

LINGUAS finns med i outputen från emerge --info men har du inte ställt in något själv så skall det inte vara något problem med det. Program som startas från en terminal får de inställningar som terminalen har. Om du inte kört source /etc/profile i alla terminaler kan det vara problemet. Det är för övrigt LC_MESSAGES som ger cfdisk på svenska.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Luddetiger
n00b
n00b


Joined: 11 Nov 2005
Posts: 25

PostPosted: Thu Jun 21, 2007 3:48 pm    Post subject: Reply with quote

Det löste sig när jag startade om consolen. Satt med screen session som hade sakerna antagligen sparade.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum