Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[e17] J'arrive pas à installer la 0.17, on me propose 0.16.8
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
raynox
Apprentice
Apprentice


Joined: 06 May 2005
Posts: 190
Location: Lille, Tourcoing

PostPosted: Wed Jul 11, 2007 8:20 pm    Post subject: [e17] J'arrive pas à installer la 0.17, on me propose 0.16. Reply with quote

Salut,

Je souhaiterai installer e17 mais il m'installe enlightenment-0.16.8.6 surement que la version 0.17 n'est pas en stable mais comment l'ajouter?

Je suis en 64bits

Merci

PS : j'ai suivi ça http://fr.gentoo-wiki.com/HOWTO_Enlightenment_DR17 (et d'autres)
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Wed Jul 11, 2007 8:32 pm    Post subject: Reply with quote

Rajoute ** à chaque ligne des paquets que tu démasque pour e17.

Par exemple x11-wm/enlightenment -* **
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
raynox
Apprentice
Apprentice


Joined: 06 May 2005
Posts: 190
Location: Lille, Tourcoing

PostPosted: Wed Jul 11, 2007 8:37 pm    Post subject: Reply with quote

oki merci, j'essaye ca des que je peux car la j'installe firefox
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3136

PostPosted: Wed Jul 11, 2007 8:39 pm    Post subject: Reply with quote

'alute

juste pour info, tu peux également utiliser l'overlay enlightenment pour l'install :wink:
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3559
Location: Belgium

PostPosted: Wed Jul 11, 2007 8:59 pm    Post subject: Re: [e17] J'arrive pas à installer la 0.17, on me propose 0 Reply with quote

raynox wrote:
j'ai suivi ça http://fr.gentoo-wiki.com/HOWTO_Enlightenment_DR17 (et d'autres)

Je ne l'ai jamais installé mais à première vue il semblerait que le tuto aurait besoin d'être révisé.
En effet :
- l'arbre portage "officiel" ne contient pas de version >0.16.8.8, même masquée;
- Dans l'overlay "enlightenment", l'ebuild est appellé e-9999.ebuild et non enlightenment-trucmuche.ebuild !
Cela explique pourquoi tu obtiens toujours la version 0.16.* ...

(@titoucha : désolé mais j'ai bien peur que, justement, ton exemple ne soit pas pertinent ! ;) )
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3755
Location: Lyon, France

PostPosted: Wed Jul 11, 2007 9:05 pm    Post subject: Reply with quote

Suit ça : http://overlays.gentoo.org/dev/vapier/wiki/enlightenment ;)
_________________
Google+ | Twitter
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3136

PostPosted: Wed Jul 11, 2007 9:07 pm    Post subject: Reply with quote

arf ! mdr :P
suite au sync de layman, j'ai "perdu" 3 overlays
Code:
[ebuild  N    ] x11-wm/e-0.16.999.037  USE="doc nls pam" 31,109 kB [2]

_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Wed Jul 11, 2007 9:29 pm    Post subject: Re: [e17] J'arrive pas à installer la 0.17, on me propose 0 Reply with quote

ghoti wrote:

(@titoucha : désolé mais j'ai bien peur que, justement, ton exemple ne soit pas pertinent ! ;) )


Il existe une version enlightenment **0.16.9999 dans l'arbre je suppose que c'est une version cvs de la 17 enfin cette numérotation est étrange.
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
raynox
Apprentice
Apprentice


Joined: 06 May 2005
Posts: 190
Location: Lille, Tourcoing

PostPosted: Wed Jul 11, 2007 10:13 pm    Post subject: Reply with quote

la 16.9999 a mon avis c'est celle juste avant la 17? Sinon plus rien a comprendre dans la numérotation des versions

Je vais essayer le lien de geekounet, j'etais tombé sur à peu pres le meme tuto ici : http://gentoo-wiki.com/HOWTO_e17

Bon je vais continuer, merci
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3559
Location: Belgium

PostPosted: Thu Jul 12, 2007 12:37 am    Post subject: Re: [e17] J'arrive pas à installer la 0.17, on me propose 0 Reply with quote

titoucha wrote:
l existe une version enlightenment **0.16.9999 dans l'arbre je suppose que c'est une version cvs de la 17 enfin cette numérotation est étrange.

Arf oui, tu as raison : elle m'avait échappée celle-là ! :oops:
Back to top
View user's profile Send private message
raynox
Apprentice
Apprentice


Joined: 06 May 2005
Posts: 190
Location: Lille, Tourcoing

PostPosted: Thu Jul 12, 2007 12:00 pm    Post subject: Reply with quote

Salut,

Bon maintenant c'est ok mais lorsque j'installe le paquet il me dit qu'il faut le USE avec "png" donc comme je le met pas dans le make.conf j'ai donc decidé de le mettre dans le package.use comme cela :

Code:

x11-wm/e png


C'est bon? car il me demande encore le USE avec png
Back to top
View user's profile Send private message
yoyo
Bodhisattva
Bodhisattva


Joined: 04 Mar 2003
Posts: 4273
Location: Lyon - France

PostPosted: Thu Jul 12, 2007 12:14 pm    Post subject: Reply with quote

Le USEflag "png", il le demande, mais sur quel paquet ? Je ne suis pas certain que x11/e est un USEflag "png" ...

Pourquoi ne pas le mettre dans ton make.conf ?? A priori, s'il est placé sur un paquet tu auras les libs installés. Dès lors, pourquoi ne pas en profiter ?

Enjoy !
_________________
La connaissance s'accroît quand on la partage.
JCB
Back to top
View user's profile Send private message
raynox
Apprentice
Apprentice


Joined: 06 May 2005
Posts: 190
Location: Lille, Tourcoing

PostPosted: Thu Jul 12, 2007 12:16 pm    Post subject: Reply with quote

Ouais ben je vais l'ajouter au make, sinon j'ai trouvé c'est dans /etc/portage/package.keywords

Sinon c'est bien e-9999 qui demande le paquet, j'ai ajouté le "png" au make.conf et il me demande encore :cry:
Merci :)

Edit: ah non c'est evas, bon je le recompile et je reteste, oups
Back to top
View user's profile Send private message
raynox
Apprentice
Apprentice


Joined: 06 May 2005
Posts: 190
Location: Lille, Tourcoing

PostPosted: Thu Jul 12, 2007 1:05 pm    Post subject: Reply with quote

Bon je les installe j'ai toujours une interface toute détruite sans image bon, je vais mettre gnome c'est plus simple
Back to top
View user's profile Send private message
raynox
Apprentice
Apprentice


Joined: 06 May 2005
Posts: 190
Location: Lille, Tourcoing

PostPosted: Thu Jul 12, 2007 1:14 pm    Post subject: Reply with quote

En fait, il l'installe mais dans /etc/X11/Sessions/ y a pas de e17 ou enlightenment donc celui que j'execute c'était celui de la 0.16.8.

Je les desinstalle j'ai reinstalle la 17 et j'ai rien dans /etc/X11/Sessions/.
C'est barbant
Back to top
View user's profile Send private message
math_roc
n00b
n00b


Joined: 07 Jan 2006
Posts: 65

PostPosted: Thu Jul 12, 2007 1:14 pm    Post subject: Reply with quote

ce n'est pas e qui a beoin du flags png, c evas ou imlib2 (me souviens plus).
par contre c'est au moment ou e est emergé qu'il se rend compte qu'il manquai le use 'png', du coup, c'est à ce moment qu'il le dit.

donc, une fois que tu as mis png dans make.conf, tente un
emerge world -uDN
et ensuite
emerge e -uDN
Back to top
View user's profile Send private message
raynox
Apprentice
Apprentice


Joined: 06 May 2005
Posts: 190
Location: Lille, Tourcoing

PostPosted: Thu Jul 12, 2007 1:25 pm    Post subject: Reply with quote

Bon ok je fais un world alors et apres je reste, bon je pense pas que c'est ce probleme car je les recompilé et apres il m'a compile e17 mais j'ai des executables mais rien pour executer au lancement du startx
Back to top
View user's profile Send private message
raynox
Apprentice
Apprentice


Joined: 06 May 2005
Posts: 190
Location: Lille, Tourcoing

PostPosted: Thu Jul 12, 2007 1:53 pm    Post subject: Reply with quote

Dans /etc/X11/Sessions/ j'ai toujours pas d'executable pour e17.... :(
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3559
Location: Belgium

PostPosted: Thu Jul 12, 2007 3:05 pm    Post subject: Reply with quote

(ça ne sert à rien de faire plusieurs posts consécutifs : tu peux toujours éditer ton dernier post ! ;))

Bon, je viens de faire une tentative rapide "méthode geekounet", snapshot périodique, avec un x32 et chez moi ça plante sur x11-libs/evas-0.9.9.037.
Pas trop envie d'investiguer plus loin (les CVS, faut être motivé et avoir le temps pour les maîtriser ...) mais tu es sûr que toutes tes compils se sont bien déroulées ?

Pour ce qui est du png, je plussoye les autres : c'est un truc universel (comme le gif - OuiBonJeSors ;) ) et il faut donc l'activer globalement dans le make.conf !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum