Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gentoo Alpha kernel compilation erros
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
Mario1776
n00b
n00b


Joined: 07 Jun 2007
Posts: 1

PostPosted: Sat Jun 09, 2007 11:44 am    Post subject: Gentoo Alpha kernel compilation erros Reply with quote

I am trying to install gentoo on an Enorex Alpha computer. I have been following the directions listed here. I have gotten to Chapter 7: Configuring the Kernel, and I am to the point of trying to compile the kernel. When I enter 'make && make modules_install' these errors are displayed. What is the problem and how can I resolve it? Thanks for any help you can give.
Back to top
View user's profile Send private message
Lupin_the_3rd
Apprentice
Apprentice


Joined: 03 Apr 2005
Posts: 168

PostPosted: Mon Jun 11, 2007 1:27 pm    Post subject: Reply with quote

That's the exact same compiler error I get building the 'gmp' package on my alpha EV56, here:

http://forums.gentoo.org/viewtopic-t-542194.html

I'm very interested to see what the resolution to this is.
_________________
Compaq XP1000 Alpha EV67 667Mhz w/ 2GB ECC
32bit PCI: ATI Radeon 9100 (DRI works!)
32bit PCI: Generic Firewire 400 card
64bit PCI: BCM5703 Gig-E (Compaq NC7771)
64bit PCI: Sil3124 SATA w/ mdadm RAID1 (pair of WD VelociRaptors)
Back to top
View user's profile Send private message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2397

PostPosted: Sat Jul 21, 2007 12:16 pm    Post subject: Reply with quote

not all kernel versions work on the alpha. i had this problem many times.
if you are not a kernel hacker, just try different versions until you find one that works.
not a real solution, i know... but it's the truth.
Back to top
View user's profile Send private message
Lupin_the_3rd
Apprentice
Apprentice


Joined: 03 Apr 2005
Posts: 168

PostPosted: Sat Jul 21, 2007 10:45 pm    Post subject: Reply with quote

alex.blackbit wrote:
not all kernel versions work on the alpha. i had this problem many times.
if you are not a kernel hacker, just try different versions until you find one that works.
not a real solution, i know... but it's the truth.


Thanks, but not a kernel issue here. As I mentioned above, I get the *identical* compiler errors on the gmp package, while my kernel builds and runs perfectly.
_________________
Compaq XP1000 Alpha EV67 667Mhz w/ 2GB ECC
32bit PCI: ATI Radeon 9100 (DRI works!)
32bit PCI: Generic Firewire 400 card
64bit PCI: BCM5703 Gig-E (Compaq NC7771)
64bit PCI: Sil3124 SATA w/ mdadm RAID1 (pair of WD VelociRaptors)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum