Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200705-23 ] Sun JDK/JRE: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1540

PostPosted: Thu May 31, 2007 6:26 pm    Post subject: [ GLSA 200705-23 ] Sun JDK/JRE: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: Sun JDK/JRE: Multiple vulnerabilities (GLSA 200705-23)
Severity: normal
Exploitable: remote
Date: May 31, 2007
Updated: May 28, 2009
Bug(s): #176675, #178851
ID: 200705-23

Synopsis


Multiple vulnerabilities have been identified in Sun Java Development Kit
(JDK) and Java Runtime Environment (JRE).


Background


The Sun Java Development Kit (JDK) and the Sun Java Runtime Environment
(JRE) provide the Sun Java platform.


Affected Packages

Package: dev-java/sun-jdk
Vulnerable: < 1.5.0.11
Unaffected: >= 1.5.0.11
Unaffected: >= 1.4.2.14 < 1.4.2.15
Unaffected: >= 1.4.2.15 < 1.4.2.16
Unaffected: >= 1.4.2.19 < 1.4.2.20
Architectures: All supported architectures

Package: dev-java/sun-jre-bin
Vulnerable: < 1.6.0.01
Unaffected: >= 1.6.0.01
Unaffected: >= 1.5.0.16 < 1.5.0.17
Unaffected: >= 1.5.0.15 < 1.5.0.16
Unaffected: >= 1.5.0.12 < 1.5.0.13
Unaffected: >= 1.5.0.11 < 1.5.0.12
Unaffected: >= 1.4.2.18 < 1.4.2.19
Unaffected: >= 1.4.2.17 < 1.4.2.18
Unaffected: >= 1.4.2.15 < 1.4.2.16
Unaffected: >= 1.4.2.14 < 1.4.2.15
Unaffected: >= 1.4.2.19 < 1.4.2.20
Unaffected: >= 1.5.0.17 < 1.5.0.18
Unaffected: >= 1.5.0.18 < 1.5.0.19
Architectures: All supported architectures


Description


An unspecified vulnerability involving an "incorrect use of system
classes" was reported by the Fujitsu security team. Additionally, Chris
Evans from the Google Security Team reported an integer overflow
resulting in a buffer overflow in the ICC parser used with JPG or BMP
files, and an incorrect open() call to /dev/tty when processing certain
BMP files.


Impact


A remote attacker could entice a user to run a specially crafted Java
class or applet that will trigger one of the vulnerabilities. This
could lead to the execution of arbitrary code outside of the Java
sandbox and of the Java security restrictions, or crash the Java
application or the browser.


Workaround


There is no known workaround at this time.


Resolution


All Sun Java Development Kit users should upgrade to the latest
version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose "dev-java/sun-jdk"

All Sun Java Runtime Environment users should upgrade to the latest
version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose "dev-java/sun-jre-bin"


References

CVE-2007-2435
CVE-2007-2788
CVE-2007-2789


Last edited by GLSA on Wed Jul 30, 2014 4:24 am; edited 6 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum