Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge xorg-x11 blocked by "media-libs/mesa-6.5.1-r1 failed"
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
kjones
n00b
n00b


Joined: 03 May 2007
Posts: 26

PostPosted: Sun May 27, 2007 5:27 pm    Post subject: emerge xorg-x11 blocked by "media-libs/mesa-6.5.1-r1 fa Reply with quote

I am working a sparc64:

2.6.20-gentoo-r5 #4 SMP Tue May 22 20:27:03 zic sparc64 sun4u TI UltraSparc I (SpitFire) GNU/Linux

I want X11.

# emerge --sync <====works fine
# emerge portage <====works also
# emerge xorg-x11 <===fails with "media-libs/mesa-6.5.1-r1 failed" message.

There are other postings on this subject, but no solution that I could relate to.

http://www.nabble.com/emerge-xorg-xll--fails-out-at-media-libs-mesa-6.5-r3-t1879194.html
and
http://forums.gentoo.org/viewtopic-t-558044-highlight-mesa.html

To save time here is my complete stdout error message minus some very repetitive stuff...

--------------start snip---------
kjones-sun2 bin # emerge xorg-x11
Calculating dependencies... done!
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 27) media-libs/mesa-6.5.1-r1 to /
* MesaLib-6.5.1.tar.bz2 RMD160 ;-) ... [ ok ]
* MesaLib-6.5.1.tar.bz2 SHA1 ;-) ... [ ok ]
* MesaLib-6.5.1.tar.bz2 SHA256 ;-) ... [ ok ]
* MesaLib-6.5.1.tar.bz2 size ;-) ... [ ok ]
* checking ebuild checksums ;-) ... [ ok ]
* checking auxfile checksums ;-) ... [ ok ]
* checking miscfile checksums ;-) ... [ ok ]
* checking MesaLib-6.5.1.tar.bz2 ;-) ... [ ok ]
* QA Notice: USE Flag 'amd64-fbsd' not in IUSE for media-libs/mesa-6.5.1-r1
* QA Notice: USE Flag 'kernel_FreeBSD' not in IUSE for media-libs/mesa-6.5.1-r1
>>> Unpacking source...
>>> Unpacking MesaLib-6.5.1.tar.bz2 to /var/tmp/portage/media-libs/mesa-6.5.1-r1/work
* Applying 6.5.1-freebsd-dri.patch ... [ ok ]
* Removing DO_DEBUG defs in dri drivers...
* Sparc assembly code is not working; deactivating
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/media-libs/mesa-6.5.1-r1/work/Mesa-6.5.1 ...
(cd configs && rm -f current && ln -s linux-dri current)
make default
make[1]: Entering directory `/var/tmp/portage/media-libs/mesa-6.5.1-r1/work/Mesa-6.5.1'
make[2]: Entering directory `/var/tmp/portage/media-libs/mesa-6.5.1-r1/work/Mesa-6.5.1/src'
Making sources for linux-dri
mkdir ../lib
make[3]: Entering directory `/var/tmp/portage/media-libs/mesa-6.5.1-r1/work/Mesa-6.5.1/src/glx/x11'
Makefile:95: depend: No such file or directory
touch depend
makedepend -fdepend -I. -I../../../include -I../../../include/GL/internal -I../../../src/mesa/main -I../../../src/mesa/glapi -I../../../src/mesa/drivers/dri/common `pkg-config --cflags libdrm` glcontextmodes.c clientattrib.c compsize.c eval.c glxcmds.c glxext.c glxextensions.c indirect.c indirect_init.c indirect_size.c indirect_window_pos.c indirect_transpose_matrix.c indirect_vertex_array.c indirect_vertex_program.c pixel.c pixelstore.c render2.c renderpix.c single2.c singlepix.c vertarr.c xfont.c glx_pbuffer.c glx_query.c glx_texture_compression.c dri_glx.c XF86dri.c \
../../../src/mesa/main/dispatch.c ../../../src/mesa/glapi/glapi.c ../../../src/mesa/glapi/glthread.c
makedepend: warning: glcontextmodes.c (reading /usr/include/bits/types.h, line 31): cannot find include file "stddef.h"
not in ./stddef.h
not in ../../../include/stddef.h
not in ../../../include/GL/internal/stddef.h
not in ../../../src/mesa/main/stddef.h
not in ../../../src/mesa/glapi/stddef.h
not in ../../../src/mesa/drivers/dri/common/stddef.h
not in /usr/include/drm/stddef.h
not in /usr/include/stddef.h
.
. etc for fifteen or so repeats.
.
makedepend: warning: clientattrib.c (reading /usr/include/libio.h, line 53): cannot find include file "stdarg.h"
not in ./stdarg.h
not in ../../../include/stdarg.h
not in ../../../include/GL/internal/stdarg.h
not in ../../../src/mesa/main/stdarg.h
not in ../../../src/mesa/glapi/stdarg.h
not in ../../../src/mesa/drivers/dri/common/stdarg.h
not in /usr/include/drm/stdarg.h
not in /usr/include/stdarg.h
makedepend: warning: clientattrib.c (reading glxclient.h, line 59): cannot find include file "GL/glxproto.h"
not in GL/glxproto.h
not in GL/glxproto.h
not in ./GL/glxproto.h
not in ../../../include/GL/glxproto.h
not in ../../../include/GL/internal/GL/glxproto.h
not in ../../../src/mesa/main/GL/glxproto.h
not in ../../../src/mesa/glapi/GL/glxproto.h
not in ../../../src/mesa/drivers/dri/common/GL/glxproto.h
not in /usr/include/drm/GL/glxproto.h
not in /usr/include/GL/glxproto.h
makedepend: warning: glxcmds.c (reading /usr/include/limits.h, line 124): cannot find include file "limits.h"
makedepend: warning: glxcmds.c (reading ../../../src/mesa/main/glheader.h, line 72): cannot find include file "float.h"
not in ./float.h
not in ../../../include/float.h
not in ../../../include/GL/internal/float.h
not in ../../../src/mesa/main/float.h
not in ../../../src/mesa/glapi/float.h
not in ../../../src/mesa/drivers/dri/common/float.h
not in /usr/include/drm/float.h
not in /usr/include/float.h
makedepend: warning: glxcmds.c (reading ../../../src/mesa/main/glheader.h, line 73): cannot find include file "stdarg.h"
not in ./stdarg.h
not in ../../../include/stdarg.h
not in ../../../include/GL/internal/stdarg.h
not in ../../../src/mesa/main/stdarg.h
not in ../../../src/mesa/glapi/stdarg.h
not in ../../../src/mesa/drivers/dri/common/stdarg.h
not in /usr/include/drm/stdarg.h
not in /usr/include/stdarg.h
makedepend: warning: indirect.c, line 33: cannot find include file "GL/glxproto.h"
not in ./GL/glxproto.h
not in ../../../include/GL/glxproto.h
not in ../../../include/GL/internal/GL/glxproto.h
not in ../../../src/mesa/main/GL/glxproto.h
not in ../../../src/mesa/glapi/GL/glxproto.h
not in ../../../src/mesa/drivers/dri/common/GL/glxproto.h
not in /usr/include/drm/GL/glxproto.h
not in /usr/include/GL/glxproto.h
makedepend: warning: indirect_vertex_array.c, line 32: cannot find include file "GL/glxproto.h"
not in ./GL/glxproto.h
not in ../../../include/GL/glxproto.h
not in ../../../include/GL/internal/GL/glxproto.h
not in ../../../src/mesa/main/GL/glxproto.h
not in ../../../src/mesa/glapi/GL/glxproto.h
not in ../../../src/mesa/drivers/dri/common/GL/glxproto.h
not in /usr/include/drm/GL/glxproto.h
not in /usr/include/GL/glxproto.h
makedepend: warning: indirect_vertex_array.c (reading indirect_va_private.h, line 39): cannot find include file "GL/glxproto.h"
not in ./GL/glxproto.h
not in ../../../include/GL/glxproto.h
not in ../../../include/GL/internal/GL/glxproto.h
not in ../../../src/mesa/main/GL/glxproto.h
not in ../../../src/mesa/glapi/GL/glxproto.h
not in ../../../src/mesa/drivers/dri/common/GL/glxproto.h
not in /usr/include/drm/GL/glxproto.h
not in /usr/include/GL/glxproto.h
makedepend: warning: indirect_vertex_program.c, line 31: cannot find include file "GL/glxproto.h"
not in ./GL/glxproto.h
not in ../../../include/GL/glxproto.h
not in ../../../include/GL/internal/GL/glxproto.h
not in ../../../src/mesa/main/GL/glxproto.h
not in ../../../src/mesa/glapi/GL/glxproto.h
not in ../../../src/mesa/drivers/dri/common/GL/glxproto.h
not in /usr/include/drm/GL/glxproto.h
not in /usr/include/GL/glxproto.h
make[3]: Leaving directory `/var/tmp/portage/media-libs/mesa-6.5.1-r1/work/Mesa-6.5.1/src/glx/x11'
make[3]: Entering directory `/var/tmp/portage/media-libs/mesa-6.5.1-r1/work/Mesa-6.5.1/src/glx/x11'
sparc-unknown-linux-gnu-gcc -c -I. -I../../../include -I../../../include/GL/internal -I../../../src/mesa/main -I../../../src/mesa/glapi -I../../../src/mesa/drivers/dri/common `pkg-config --cflags libdrm` -O2 -mcpu=ultrasparc -pipe -fno-strict-aliasing -fPIC -DGLX_USE_TLS -D_POSIX_SOURCE -D_POSIX_C_SOURCE=199309L -D_SVID_SOURCE -D_BSD_SOURCE -D_GNU_SOURCE -DPTHREADS -DUSE_EXTERNAL_DXTN_LIB=1 -DIN_DRI_DRIVER -DGLX_DIRECT_RENDERING -DHAVE_ALIAS -DHAVE_POSIX_MEMALIGN -DXF86VIDMODE -D_REENTRANT -UIN_DRI_DRIVER -DDEFAULT_DRIVER_DIR=\"/usr/lib/dri\" glcontextmodes.c -o glcontextmodes.o
sparc-unknown-linux-gnu-gcc -c -I. -I../../../include -I../../../include/GL/internal -I../../../src/mesa/main -I../../../src/mesa/glapi -I../../../src/mesa/drivers/dri/common `pkg-config --cflags libdrm` -O2 -mcpu=ultrasparc -pipe -fno-strict-aliasing -fPIC -DGLX_USE_TLS -D_POSIX_SOURCE -D_POSIX_C_SOURCE=199309L -D_SVID_SOURCE -D_BSD_SOURCE -D_GNU_SOURCE -DPTHREADS -DUSE_EXTERNAL_DXTN_LIB=1 -DIN_DRI_DRIVER -DGLX_DIRECT_RENDERING -DHAVE_ALIAS -DHAVE_POSIX_MEMALIGN -DXF86VIDMODE -D_REENTRANT -UIN_DRI_DRIVER -DDEFAULT_DRIVER_DIR=\"/usr/lib/dri\" clientattrib.c -o clientattrib.o
In file included from clientattrib.c:38:
glxclient.h:59:25: GL/glxproto.h: No such file or directory
In file included from clientattrib.c:38:
glxclient.h:257: error: syntax error before "GLXContextTag"
glxclient.h:257: warning: no semicolon at end of struct or union
glxclient.h:401: error: syntax error before '}' token
clientattrib.c: In function `do_enable_disable':
clientattrib.c:48: error: dereferencing pointer to incomplete type
clientattrib.c:56: error: dereferencing pointer to incomplete type
clientattrib.c:56: error: dereferencing pointer to incomplete type
clientattrib.c: In function `__indirect_glPushClientAttrib':
clientattrib.c:75: error: dereferencing pointer to incomplete type
clientattrib.c:76: error: dereferencing pointer to incomplete type
clientattrib.c:78: error: dereferencing pointer to incomplete type
clientattrib.c:84: error: dereferencing pointer to incomplete type
clientattrib.c:93: error: dereferencing pointer to incomplete type
clientattrib.c:93: error: dereferencing pointer to incomplete type
clientattrib.c: In function `__indirect_glPopClientAttrib':
clientattrib.c:101: error: dereferencing pointer to incomplete type
clientattrib.c:102: error: dereferencing pointer to incomplete type
clientattrib.c:105: error: dereferencing pointer to incomplete type
clientattrib.c:110: error: dereferencing pointer to incomplete type
clientattrib.c:122: error: dereferencing pointer to incomplete type
clientattrib.c:122: error: dereferencing pointer to incomplete type
clientattrib.c: In function `__glFreeAttributeState':
clientattrib.c:131: error: dereferencing pointer to incomplete type
clientattrib.c:132: error: dereferencing pointer to incomplete type
make[3]: *** [clientattrib.o] Error 1
make[3]: Leaving directory `/var/tmp/portage/media-libs/mesa-6.5.1-r1/work/Mesa-6.5.1/src/glx/x11'
make[2]: *** [subdirs] Error 1
make[2]: Leaving directory `/var/tmp/portage/media-libs/mesa-6.5.1-r1/work/Mesa-6.5.1/src'
make[1]: *** [default] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-libs/mesa-6.5.1-r1/work/Mesa-6.5.1'
make: *** [linux-dri] Error 2

!!! ERROR: media-libs/mesa-6.5.1-r1 failed.
Call stack:
ebuild.sh, line 1615: Called dyn_compile
ebuild.sh, line 972: Called qa_call 'src_compile'
ebuild.sh, line 44: Called src_compile
mesa-6.5.1-r1.ebuild, line 215: Called die

!!! Build failed
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/media-libs/mesa-6.5.1-r1/temp/build.log'.

---------------end snip--------------

I am a newbe for gentoo. My other sparc runs Aurora with great success. I chose gentoo in order to learn more about the linux structure. This has not been easy. :-(

Ken
Back to top
View user's profile Send private message
gust4voz
Retired Dev
Retired Dev


Joined: 09 Sep 2003
Posts: 373
Location: Buenos Aires, Argentina

PostPosted: Mon May 28, 2007 12:59 pm    Post subject: Reply with quote

eselect opengl set xorg-x11 and try again.
I thought this was fixed some time ago but it seems to resurface from time to time...
_________________
Gustavo Zacarias
Gentoo/SPARC monkey
Back to top
View user's profile Send private message
kjones
n00b
n00b


Joined: 03 May 2007
Posts: 26

PostPosted: Mon May 28, 2007 4:27 pm    Post subject: eselect opengl set xorg-x11 -- did not work:-( Reply with quote

I tried your suggestion. It appears that opengl is missing.
Here is what happened.
-------------snip-----------

kjones-sun2 bin # eselect opengl set xorg-x11
!!! Error: Can't load module opengl
Killed
kjones-sun2 bin #
kjones-sun2 bin # locate opengl | grep x11
/usr/lib/opengl/xorg-x11
/usr/lib/opengl/xorg-x11/include
/usr/lib/opengl/xorg-x11/include/glxtokens.h
/usr/lib/opengl/xorg-x11/include/glxmd.h
/usr/lib/opengl/xorg-x11/include/glxproto.h
kjones-sun2 bin #
kjones-sun2 bin # eselect help | grep opengl
kjones-sun2 bin #
----------end snip---------------

Ken
Back to top
View user's profile Send private message
kjones
n00b
n00b


Joined: 03 May 2007
Posts: 26

PostPosted: Tue May 29, 2007 2:15 pm    Post subject: emerge opengl does not work Reply with quote

If I do:
-----------snip---------
# emerge opengl
Calculating dependencies... done!
>>> Verifying ebuild Manifests...
>>> Emerging (1 of 2) media-libs/mesa-6.5.1-r1 to /
----------end snip------------

Which, of course, fails. This feels like between a rock and a hard place.

Ken
Back to top
View user's profile Send private message
gust4voz
Retired Dev
Retired Dev


Joined: 09 Sep 2003
Posts: 373
Location: Buenos Aires, Argentina

PostPosted: Tue May 29, 2007 4:35 pm    Post subject: Reply with quote

You just need eselect-opengl, not opengl itself (which mesa makes part of).
_________________
Gustavo Zacarias
Gentoo/SPARC monkey
Back to top
View user's profile Send private message
kjones
n00b
n00b


Joined: 03 May 2007
Posts: 26

PostPosted: Tue May 29, 2007 8:42 pm    Post subject: eselect opengl does not work for me. Reply with quote

I appologize Gustavo Zacarias. I do not understand how to get eselect opengl.
I tried the command line you offered. It did not not work for me :-(

See below.

---------snip--------------
kjones-sun2 bin # eselect opengl set xorg-x11
!!! Error: Can't load module opengl
Killed
kjones-sun2 bin #
--------end snip--------------
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4727
Location: Angra do Heroísmo (PT)

PostPosted: Tue May 29, 2007 8:48 pm    Post subject: Reply with quote

Hi.

Have you tried emerging eselect-opengl? By the way, you don't have the opengl use flag, do you?
_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
kjones
n00b
n00b


Joined: 03 May 2007
Posts: 26

PostPosted: Wed May 30, 2007 2:54 am    Post subject: I am getting loster and loster Reply with quote

I think I do not have a USE flag on opengl. I did the following "grep" command. It came up empty.
----------start snip----------
kjones-sun2 etc # ls -l /usr/portage/profiles/default-linux/sparc/sparc64/2006.1
total 20
drwxr-xr-x 2 root root 4096 Apr 30 17:35 2.4
-rw-r--r-- 1 root root 582 Feb 12 17:06 make.defaults
-rw-r--r-- 1 root root 353 Apr 20 21:06 package.mask
-rw-r--r-- 1 root root 522 Jan 18 13:06 packages
-rw-r--r-- 1 root root 3 Apr 11 2006 parent
kjones-sun2 etc # grep opengl *.*
kjones-sun2 etc #
----------end snip------------

In use.default is the following line. Is this bad?
------------snip----------------
opengl virtual/opengl
---------end snip-------------

I did emerge eselect-opengl successfully but the following emerge xorg-x11 still failed on "!!! ERROR: media-libs/mesa-6.5.1-r1 failed"

Do I need to compile again? What specifically might I need to do to .config?

Ken
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4727
Location: Angra do Heroísmo (PT)

PostPosted: Wed May 30, 2007 2:56 am    Post subject: Reply with quote

Post the exact error message. To check if you have the opengl useflag, do the following:
Code:
# emerge --info | grep opengl
# grep opengl /etc/portage/package.use

_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
kjones
n00b
n00b


Joined: 03 May 2007
Posts: 26

PostPosted: Wed May 30, 2007 2:09 pm    Post subject: Exact error message plus grep's for USE flag Reply with quote

Following is the exact error message. It follows a bunch of warnings. Here is where the word error starts appearing.

--------snip--------------
make[3]: Entering directory `/var/tmp/portage/media-libs/mesa-6.5.1-r1/work/Mesa-6.5.1/src/glx/x11'
sparc-unknown-linux-gnu-gcc -c -I. -I../../../include -I../../../include/GL/internal -I../../../src/mesa/main -I../../../src/mesa/glapi -I../../../src/mesa/drivers/dri/common `pkg-config --cflags libdrm` -O2 -mcpu=ultrasparc -pipe -fno-strict-aliasing -fPIC -DGLX_USE_TLS -D_POSIX_SOURCE -D_POSIX_C_SOURCE=199309L -D_SVID_SOURCE -D_BSD_SOURCE -D_GNU_SOURCE -DPTHREADS -DUSE_EXTERNAL_DXTN_LIB=1 -DIN_DRI_DRIVER -DGLX_DIRECT_RENDERING -DHAVE_ALIAS -DHAVE_POSIX_MEMALIGN -DXF86VIDMODE -D_REENTRANT -UIN_DRI_DRIVER -DDEFAULT_DRIVER_DIR=\"/usr/lib/dri\" glcontextmodes.c -o glcontextmodes.o
sparc-unknown-linux-gnu-gcc -c -I. -I../../../include -I../../../include/GL/internal -I../../../src/mesa/main -I../../../src/mesa/glapi -I../../../src/mesa/drivers/dri/common `pkg-config --cflags libdrm` -O2 -mcpu=ultrasparc -pipe -fno-strict-aliasing -fPIC -DGLX_USE_TLS -D_POSIX_SOURCE -D_POSIX_C_SOURCE=199309L -D_SVID_SOURCE -D_BSD_SOURCE -D_GNU_SOURCE -DPTHREADS -DUSE_EXTERNAL_DXTN_LIB=1 -DIN_DRI_DRIVER -DGLX_DIRECT_RENDERING -DHAVE_ALIAS -DHAVE_POSIX_MEMALIGN -DXF86VIDMODE -D_REENTRANT -UIN_DRI_DRIVER -DDEFAULT_DRIVER_DIR=\"/usr/lib/dri\" clientattrib.c -o clientattrib.o
In file included from clientattrib.c:38:
glxclient.h:59:25: GL/glxproto.h: No such file or directory
In file included from clientattrib.c:38:
glxclient.h:257: error: syntax error before "GLXContextTag"
glxclient.h:257: warning: no semicolon at end of struct or union
glxclient.h:401: error: syntax error before '}' token
clientattrib.c: In function `do_enable_disable':
clientattrib.c:48: error: dereferencing pointer to incomplete type
clientattrib.c:56: error: dereferencing pointer to incomplete type
clientattrib.c:56: error: dereferencing pointer to incomplete type
clientattrib.c: In function `__indirect_glPushClientAttrib':
clientattrib.c:75: error: dereferencing pointer to incomplete type
clientattrib.c:76: error: dereferencing pointer to incomplete type
clientattrib.c:78: error: dereferencing pointer to incomplete type
clientattrib.c:84: error: dereferencing pointer to incomplete type
clientattrib.c:93: error: dereferencing pointer to incomplete type
clientattrib.c:93: error: dereferencing pointer to incomplete type
clientattrib.c: In function `__indirect_glPopClientAttrib':
clientattrib.c:101: error: dereferencing pointer to incomplete type
clientattrib.c:102: error: dereferencing pointer to incomplete type
clientattrib.c:105: error: dereferencing pointer to incomplete type
clientattrib.c:110: error: dereferencing pointer to incomplete type
clientattrib.c:122: error: dereferencing pointer to incomplete type
clientattrib.c:122: error: dereferencing pointer to incomplete type
clientattrib.c: In function `__glFreeAttributeState':
clientattrib.c:131: error: dereferencing pointer to incomplete type
clientattrib.c:132: error: dereferencing pointer to incomplete type
make[3]: *** [clientattrib.o] Error 1
make[3]: Leaving directory `/var/tmp/portage/media-libs/mesa-6.5.1-r1/work/Mesa-6.5.1/src/glx/x11'
make[2]: *** [subdirs] Error 1
make[2]: Leaving directory `/var/tmp/portage/media-libs/mesa-6.5.1-r1/work/Mesa-6.5.1/src'
make[1]: *** [default] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-libs/mesa-6.5.1-r1/work/Mesa-6.5.1'
make: *** [linux-dri] Error 2

!!! ERROR: media-libs/mesa-6.5.1-r1 failed.
Call stack:
ebuild.sh, line 1615: Called dyn_compile
ebuild.sh, line 972: Called qa_call 'src_compile'
ebuild.sh, line 44: Called src_compile
mesa-6.5.1-r1.ebuild, line 215: Called die

!!! Build failed
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/media-libs/mesa-6.5.1-r1/temp/build.log'.

kjones-sun2 bin #

-----------end snip-------------------

Yes, the USE flag is set for opengl. Is that bad?

--------------snip---------------
USE="X apache2 arts berkdb bitmap-fonts cli cracklib crypt cups dri eds emboss encode esd fbcon foomaticdb fortran gcc64 gdbm gif gnome gstreamer gtk gtk2 iconv imlib isdnlog jpeg kde libwww mad midi mikmod motif mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp oss pam pcre perl png pppd python qt3 readline reflection sdl session sparc spell spl ssl tcpd truetype truetype-fonts type1-fonts vorbis xml xorg xv zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="dummy fbdev glint mach64 mga r128 radeon savage sisusb sunbw2 suncg14 suncg3 suncg6 sunffb sunleo tdfx v4l voodoo"

--------------end snip---------

Below is "grep" for opengl on package.use and others in that directory. There is no "opengl" in package.use

-------------snip------------
kjones-sun2 bin # cd /usr/portage/profiles/base
kjones-sun2 base # ls
ChangeLog package.use package.use.mask.example profile.bashrc use.force virtuals make.defaults package.use.mask packages use.defaults use.mask
kjones-sun2 base # grep opengl package.use
kjones-sun2 base # grep opengl use.defaults
opengl virtual/opengl
kjones-sun2 base # grep opengl *.*
use.defaults:opengl virtual/opengl
kjones-sun2 base #
--------end snip-----------

I do not understand what is going on. Please suggest a document or set of documents that I can study.

Ken
Back to top
View user's profile Send private message
ribx
Apprentice
Apprentice


Joined: 20 Nov 2003
Posts: 212
Location: germany

PostPosted: Thu May 31, 2007 9:31 am    Post subject: Reply with quote

check this:

http://forums.gentoo.org/viewtopic-t-557168-highlight-include+stddef.html
_________________
The adopt an unanswered post initiative
Back to top
View user's profile Send private message
ribx
Apprentice
Apprentice


Joined: 20 Nov 2003
Posts: 212
Location: germany

PostPosted: Thu May 31, 2007 10:08 am    Post subject: Reply with quote

i have the same problem than you had in the beginning, but no solution yet.

the solution from the post above also didnt fixed my problem.

regards

[EDIT]
i think i had a different problem which was fixed by http://forums.gentoo.org/viewtopic-p-3870933.html#3870933
[/EDIT]
_________________
The adopt an unanswered post initiative
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4727
Location: Angra do Heroísmo (PT)

PostPosted: Thu May 31, 2007 5:13 pm    Post subject: Re: Exact error message plus grep's for USE flag Reply with quote

kjones wrote:
Following is the exact error message. It follows a bunch of warnings. Here is where the word error starts appearing.
Code:
glxclient.h:59:25: GL/glxproto.h: No such file or directory

You haven't set the opengl implementation. Run eselect opengl show to check the current selection.
kjones wrote:

Yes, the USE flag is set for opengl. Is that bad?

No, that's good on this case.
kjones wrote:

Code:
VIDEO_CARDS="dummy fbdev glint mach64 mga r128 radeon savage sisusb sunbw2 suncg14 suncg3 suncg6 sunffb sunleo tdfx v4l voodoo"


You should add to your /etc/make.conf a VIDEO_CARDS definition. Otherwise xorg will try to compile all drivers.
_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
kjones
n00b
n00b


Joined: 03 May 2007
Posts: 26

PostPosted: Fri Jun 01, 2007 11:27 pm    Post subject: I almost understand, but.... Reply with quote

You suggested that I run the following. Nothing useful happens. How do I figure out where my problem lies?

-----------snip-------------
kjones-sun2 etc # eselect opengl show
!!! Error: Can't load module opengl
Killed
kjones-sun2 etc #
----------end snip--------

Another thing. Is there a command that tells me what video card is in my sparc ULTRA? If I dismantle it will I be able to figure out the appropriate driver? How about I add the following to /etc/make.conf. I have selected the SUN drivers I recognize. Will this help somewhat?

---------snip-------------
VIDEO_CARDS="sunbw2 suncg14 suncg3 suncg6 sunffb sunleo tdfx"
---------end snip--------

Ken
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4727
Location: Angra do Heroísmo (PT)

PostPosted: Sat Jun 02, 2007 11:32 am    Post subject: Re: I almost understand, but.... Reply with quote

kjones wrote:

Code:
kjones-sun2 etc # eselect opengl show
!!! Error: Can't load module opengl
Killed
kjones-sun2 etc #


You still don't have eselect-opengl on your system. Please post the output of emerge -pv eselect-opengl.
kjones wrote:

Another thing. Is there a command that tells me what video card is in my sparc ULTRA? If I dismantle it will I be able to figure out the appropriate driver? How about I add the following to /etc/make.conf. I have selected the SUN drivers I recognize. Will this help somewhat?
Code:
VIDEO_CARDS="sunbw2 suncg14 suncg3 suncg6 sunffb sunleo tdfx"


Yes, it should help.
_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
kjones
n00b
n00b


Joined: 03 May 2007
Posts: 26

PostPosted: Sat Jun 02, 2007 1:59 pm    Post subject: Reply with quote

Jorge,
Yes, opengl seems unavailable. I am lost now and can do little but follow your suggestions. :(

----------------snip--------------
kjones-sun2 ~ # emerge -pv eselect-opengl

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] app-admin/eselect-opengl-1.0.5 0 kB
Total: 1 package (1 reinstall), Size of downloads: 0 kB
kjones-sun2 ~ # eselect opengl show
!!! Error: Can't load module opengl
Killed
-------------end snip---------------

If it helps, http://forums.gentoo.org/viewtopic-t-557168-highlight-include+stddef.html
seems to have the same initial failure from trying to build mesa. But that thread succeeds doing "emerge x11-drm". This does not work for me.

---------------snip-----------------
kjones-sun2 include # emerge x11-drm
Calculating dependencies |
!!! All ebuilds that could satisfy "x11-drm" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-base/x11-drm-20070314 (masked by: missing keyword)
- x11-base/x11-drm-20060608-r1 (masked by: missing keyword)
- x11-base/x11-drm-20051223 (masked by: missing keyword)
- x11-base/x11-drm-20060608 (masked by: missing keyword)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
-------------end snip-------------

Thank you again for your patience.

Ken
Back to top
View user's profile Send private message
kjones
n00b
n00b


Joined: 03 May 2007
Posts: 26

PostPosted: Sat Jun 02, 2007 3:14 pm    Post subject: Reaching for straws -- sigh. Reply with quote

Jorge:

I noticed that the .ebuild files effecting x11-drm have in their $HEADER: comment reference to x86, not SUN architecture. Is this just a coincidence?

-----------snip----------

kjones-sun2 x11-drm # pwd
/usr/portage/x11-base/x11-drm

kjones-sun2 x11-drm # ls
ChangeLog files x11-drm-20051223.ebuild x11-drm-20060608.ebuild
Manifest metadata.xml x11-drm-20060608-r1.ebuild x11-drm-20070314.ebuild

kjones-sun2 x11-drm # grep Header: *.ebuild
x11-drm-20051223.ebuild:# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20051223.ebuild,v 1.12 2006/09/07 04:47:34 battousai Exp $
x11-drm-20060608-r1.ebuild:# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20060608-r1.ebuild,v 1.6 2007/03/14 18:18:53 battousai Exp $
x11-drm-20060608.ebuild:# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20060608.ebuild,v 1.12 2007/03/14 18:18:53 battousai Exp $
x11-drm-20070314.ebuild:# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20070314.ebuild,v 1.2 2007/03/14 18:18:53 battousai Exp $
kjones-sun2 x11-drm #
--------------end snip----------------

The problem is that the VIDEO CARDS don't look familiar:

----------------snip---------
IUSE_VIDEO_CARDS="
video_cards_i810
video_cards_mach64
video_cards_mga
video_cards_nv
video_cards_r128
video_cards_radeon
video_cards_savage
video_cards_sis
video_cards_sunffb
video_cards_tdfx
video_cards_via"
IUSE="${IUSE_VIDEO_CARDS} kernel_FreeBSD kernel_linux"
------------end snip---------------

"hwbrowser" on my other ULTRA sparc1 says that it has a "Sun Turbo GX" with a Server:Sun driver. Maybe my whole problem lies in not specifying the correct video card driver and then manipulating the KEYWORDS. (about which I know next to nothing)

Ken
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4727
Location: Angra do Heroísmo (PT)

PostPosted: Sun Jun 03, 2007 4:12 am    Post subject: Reply with quote

kjones wrote:
Jorge,
Yes, opengl seems unavailable. I am lost now and can do little but follow your suggestions. :(
Code:
kjones-sun2 ~ # emerge -pv eselect-opengl
...
[ebuild   R   ] app-admin/eselect-opengl-1.0.5  0 kB

hmm, you have eselect-opengl installed. Run dispatch-conf to update your config files.
kjones wrote:

Code:
kjones-sun2 include # emerge x11-drm
Calculating dependencies |
!!! All ebuilds that could satisfy "x11-drm" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-base/x11-drm-20070314 (masked by: missing keyword)
- x11-base/x11-drm-20060608-r1 (masked by: missing keyword)
- x11-base/x11-drm-20051223 (masked by: missing keyword)
- x11-base/x11-drm-20060608 (masked by: missing keyword)

I never tried to build X on SPARC as I have no interest in having it on my server. I looked at the ebuilds and you're right - they haven't been keyworded for sparc. Have you tried building the drm support in the kernel?
If the previous don't help, then I won't be of much help as I can't see anything else to do. I hope gust4voz or another sparc dev can help you.
_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
gust4voz
Retired Dev
Retired Dev


Joined: 09 Sep 2003
Posts: 373
Location: Buenos Aires, Argentina

PostPosted: Mon Jun 04, 2007 12:02 pm    Post subject: Reply with quote

x11-drm is a no go on sparc, it's not required to build X with opengl properly and it doesn't work either.
And that's for hardware-accelerated gl, mesa can handle software acceleration on it's own just fine.
_________________
Gustavo Zacarias
Gentoo/SPARC monkey
Back to top
View user's profile Send private message
kjones
n00b
n00b


Joined: 03 May 2007
Posts: 26

PostPosted: Mon Jun 04, 2007 2:37 pm    Post subject: Back to the beginning. Why won't mesa build? Reply with quote

re: opengl
Quote:
that's for hardware-accelerated gl, mesa can handle software acceleration on it's own just fine.


Still mesa does not build. It complains about bad code in glxclient.h and clientattrib.c.
At the beginning of this thread I posted the complete stdout message which resulted from attempting to 'emerge xorg-x11'. /mesa-6.5.1-r1 seems to be broken.

I have a problem that is blocking progress. How do I figure out what it is?

By the way. Congratulations on this FORUM design. The technical features make it very easy to use.

Ken
Back to top
View user's profile Send private message
kjones
n00b
n00b


Joined: 03 May 2007
Posts: 26

PostPosted: Sun Jun 10, 2007 2:33 am    Post subject: mesa blocked by libdrm-2.2 (~sparc keyword) Reply with quote

I am trying to get xorg-x11 to run on my sparc64. It seems to require mesa which requires libdrm which is blocked by ~sparc keyword. What do I do??

k
Quote:
jones-sun2 mesa # emerge --pretend /usr/portage/media-libs/mesa/mesa-6.5.2-r1.ebuild
emerging by path implies --oneshot... adding --oneshot to options.

*** emerging by path is broken and may not always work!!!


These are the packages that would be merged, in order:

Calculating dependencies /
*** You are emerging a masked package. It is MUCH better to use
*** /etc/portage/package.* to accomplish this. See portage(5) man
*** page for details.
>>> Waiting 10 seconds before starting...
>>> (Control-C to abort)...
Continuing... in: 10 9 8 7 6 5 4 3 2 1
\
!!! All ebuilds that could satisfy ">=x11-libs/libdrm-2.2" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-libs/libdrm-2.3.0 (masked by: ~sparc keyword)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "media-libs/mesa-6.5.2-r1" [ebuild])

kjones-sun2 mesa #
Back to top
View user's profile Send private message
corsair
Retired Dev
Retired Dev


Joined: 06 Oct 2003
Posts: 451
Location: Aachen, Germany

PostPosted: Sun Jun 10, 2007 7:42 am    Post subject: Re: mesa blocked by libdrm-2.2 (~sparc keyword) Reply with quote

kjones wrote:
I am trying to get xorg-x11 to run on my sparc64. It seems to require mesa which requires libdrm which is blocked by ~sparc keyword. What do I do??


sorry, you are doing it wrong! first, please don't use emerge /usr/portage/cat/package/package-version.ebuild. It's broken as you should have read in the output. To emerge xorg-x11 you have to do emerge xorg-x11 (or if you only want latest stable mesa then do emerge mesa). It's that simple :wink: . The problem is, that you are trying to emerge a package (mesa-6.5.2-r1), which is itself marked ~sparc (i.e. unstable packages are marked with ~sparc instead of sparc). So it can require other ~sparc packages. And so it does. Please take a look at the second and third chapter of the Gentoo handbook. (here) There everything you want to know is explained in a very understandable way - better than what I would write now :roll:

Best regards,

-corsair
Back to top
View user's profile Send private message
kjones
n00b
n00b


Joined: 03 May 2007
Posts: 26

PostPosted: Mon Jun 11, 2007 1:05 am    Post subject: I think I need to reconfigure the xorg-x11 package Reply with quote

corsair:

This whole thing started because "emerge xorg-x11" did not work. It gets hung on mesa.
(See the beginning of the first post in this thread.)

My job, as I understand it now, is to learn enough about the portage system to either update to a gentoo package that has a working mesa or change my package so that it calls a (sparc) marked [not a ~sparc marked] version of mesa.

Is this interpretation correct? Assuming whatever was wrong when I first did it is now fixed, should emerge --sync do the whole thing?

I have a number of mesa ebuilds available. How did they get here and why does emerge pick the one it picks?

Quote:
/usr/portage/media-libs/mesa/mesa-6.5.3.ebuild
/usr/portage/media-libs/mesa/mesa-6.5.2.ebuild
/usr/portage/media-libs/mesa/mesa-6.5.1-r1.ebuild
/usr/portage/media-libs/mesa/mesa-6.5-r3.ebuild
/usr/portage/media-libs/mesa/mesa-6.5.2-r1.ebuild


Ken
Back to top
View user's profile Send private message
Ferris
Retired Dev
Retired Dev


Joined: 13 Jan 2003
Posts: 426
Location: N. Virginia (USA)

PostPosted: Mon Jun 11, 2007 11:49 am    Post subject: Reply with quote

What do you get from 'emerge -pv mesa'? Just 'emerge mesa' should work fine. Unless you are playing with /etc/portage/package.keywords file, just 'emerge mesa' should pick the correct version and build. Now, you are showing that for some reason you have never merged glxproto --- make sure you have USE=glx in your /etc/make.conf as well, please.
Back to top
View user's profile Send private message
kjones
n00b
n00b


Joined: 03 May 2007
Posts: 26

PostPosted: Mon Jun 11, 2007 8:50 pm    Post subject: emerge mesa does not work...neither does glxproto Reply with quote

Ferris,
It seems to me that I must blow away my portage files and start again. How do I do that?
Ken
Quote:

kjones-sun2 ~ # emerge glxproto
Calculating dependencies /
emerge: there are no ebuilds to satisfy "glxproto".

kjones-sun2 ~ # emerge -pv mesa
These are the packages that would be merged, in order:
Calculating dependencies... done!
[ebuild N ] media-libs/mesa-6.5.1-r1 USE="motif nptl -debug -doc (-hardened)" VIDEO_CARDS="sunffb tdfx (-i810) -mach64 -mga -none -r128 -radeon (-s3virge) -savage (-sis) (-trident) (-via)" 0 kB

Total: 1 package (1 new), Size of downloads: 0 kB

kjones-sun2 ~ #more /etc/make.conf
CFLAGS="-O2 -mcpu=ultrasparc -pipe"
CHOST="sparc-unknown-linux-gnu"
CXXFLAGS="-O2 -mcpu=ultrasparc -pipe"
CONFIG_PROTECT="-*"
VIDEO_CARDS="sunbw2 suncg14 suncg3 suncg6 sunffb sunleo tdfx"
USE="glx"
kjones-sun2 ~ #
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum