Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X.org Lockups (part III)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, ... 10, 11, 12  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
rastersize
n00b
n00b


Joined: 04 Jan 2006
Posts: 7
Location: Sweden

PostPosted: Sat Aug 18, 2007 11:49 am    Post subject: Re: X eats 100% CPU after running screensaver for a long per Reply with quote

VinzC wrote:
Hi.

Don't know if it's the right place for posting but here I am. I've run through the big upgrade expat+KDE 3.5.5 -> KDE 3.5.7. Now I'm facing strange lockups of X, i.e. it eats 100% CPU after a certain amount of time running the screensaver. The more I leave my machine inactive (with the screen saver running) the longer X consumes CPU but only *after* I unlock the screen.

I've been able to unlock the screen a couple of times since the last time it ate up CPU like this, maybe four or five times but I always noticed CPU activity was still high for a noticeable period of time - a few seconds, maybe 10-20 seconds. And when it locks up I can still switch to a text console and kill -9 X, which is my only option. Strangely enough I can see activity in Superkaramba applets (Aero-IO panel) and the clock in kicker ticking but I can't interact with the desktop.

The first time I saw X lock up I tried zapping it with Ctrl-Alt-BkSpace but then I couldn't even switch to a text console. I've had to SSH into the machine and kill X manually. Running /etc/init.d/xdm stop doesn't work either in such a case.

Does anyone have an idea on that really annoying problem?


As mentioned in this thread you can disable RenderAccel in xorg.conf. Which will "fix" the symptom, not the cause :(
I'm running Xorg and KDE with this and everything works as usual except two things (so far at least): rxvt-unicode lags (:P) and I can't use gl2 in Mplayer (had to go down to just gl).

Btw. You guys should be happy, when my box does (or should I say did) this I couldn't even SSH, or for that matter ping it.
_________________
[AMD AM2 X2 3800+] [ASUS M2N-SLI Delux] [Corsair 6400C5 2*1GB] [2*250 GB SATAII + 160 GB PATA]
jiart.org
Swede
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4688
Location: Theux (Belgium)

PostPosted: Sat Aug 18, 2007 2:40 pm    Post subject: Reply with quote

Thanks rastersize.

But I don't understand why I should disable RenderAccel *now* :?: I've run my system with xorg-7.2 since May and KDE 3.5.5 since - wow - a long time that the graphics system is locking. It's only now that I've run into a large number of updates, including expat, KDE, nvidia-drivers plus some more that I don't remember.

Do you think rolling back to nvidia-drivers-99xx would actually fix the problem?
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
rastersize
n00b
n00b


Joined: 04 Jan 2006
Posts: 7
Location: Sweden

PostPosted: Sat Aug 18, 2007 3:45 pm    Post subject: Reply with quote

Yea, rolling back to older nvidia-drivers (pre 100.x.y) should probably stop the bug from occurring. At least I hope/think so.
I tried it yesterday but then xorg began complaining about something and I didn't have time to fix it at the moment so here I am at 100.14.11. Will probably try again some time soon. So if you try it, please tell if it's a success or if it's just as bad as running 100.*
_________________
[AMD AM2 X2 3800+] [ASUS M2N-SLI Delux] [Corsair 6400C5 2*1GB] [2*250 GB SATAII + 160 GB PATA]
jiart.org
Swede
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4688
Location: Theux (Belgium)

PostPosted: Sat Aug 18, 2007 10:08 pm    Post subject: Reply with quote

I rolled back to nvidia-drivers-1.0.9755-r1 but the problem didn't disappear :( . I'm trying now rolling back to gentoo-sources-2.6.21-r4... (Yup, that also changed with the massive update after which troubles came...)

EDIT: [strike]Troubles came after I upgraded 2.6.21-gentoo-r4 to 2.6.22-gentoo-r2.[/strike]

EDIT: Erm... no, I was running 2.6.21-gentoo-r4 all the time 8O . Damn it! What happened to my box?!
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
rastersize
n00b
n00b


Joined: 04 Jan 2006
Posts: 7
Location: Sweden

PostPosted: Sun Aug 19, 2007 2:26 pm    Post subject: Reply with quote

Damn! Really thought/hoped that would work :/

Don't think rolling back to kernel 2.6.21 will help at all as I were running 2.6.19 the first time I encountered the problem (and I had not experienced any problems of that kind with that kernel before upgrading to latest nvidia-drivers).

By the way, my system froze again today (with RenderAccel off). Because of this I think kdm might have something to do with this as I logged in via kdm. When I had rebooted, I logged in via tty instead and the system is now running without any freezes, so I have disabled xdm/kdm from starting at boot (runlevel default) and always logs in via tty and executes startx.

Later, I will try to enable RenderAccel and try to login via tty to see if X will work or freeze.

Edit: I almost wish I had an AMD/ATi graphics card now :P
_________________
[AMD AM2 X2 3800+] [ASUS M2N-SLI Delux] [Corsair 6400C5 2*1GB] [2*250 GB SATAII + 160 GB PATA]
jiart.org
Swede
Back to top
View user's profile Send private message
Ainulindalë
n00b
n00b


Joined: 23 Sep 2004
Posts: 8
Location: Paris, France.

PostPosted: Sun Aug 19, 2007 3:44 pm    Post subject: Reply with quote

rastersize wrote:

Edit: I almost wish I had an AMD/ATi graphics card now :P


I have an AMD64 and an ATI 9200. And I have the same problem. So don't wish bad things :-).
And by the way, re-emerging without the opengl USE flag and disabling all that is related to graphic acceleration in xorg.conf seems to do the trick : my system seems stable.
_________________
Oooook !
Back to top
View user's profile Send private message
rastersize
n00b
n00b


Joined: 04 Jan 2006
Posts: 7
Location: Sweden

PostPosted: Sun Aug 19, 2007 9:58 pm    Post subject: Reply with quote

Ainulindalë wrote:
rastersize wrote:

Edit: I almost wish I had an AMD/ATi graphics card now :P


I have an AMD64 and an ATI 9200. And I have the same problem. So don't wish bad things :-).
And by the way, re-emerging without the opengl USE flag and disabling all that is related to graphic acceleration in xorg.conf seems to do the trick : my system seems stable.


Hmm, so it's affecting both nvidia and ATI users. So, which xorg versions are you guys running? Does the error only occur in KDE or is other desktop environments also effected? And so on.

Currently my system is running the following:
Gentoo sources 2.6.22-r2
KDE 3.5.7
xorg-x11 7.1
nvidia-drivers 100.11.09 (card: nv7300LE)

I upgraded to nvidia-drivers-100.11.14 from 100.11.09 and xorg-x11-7.2 from 7.1 yesterday and since my last post I have discovered that having RenderAccel set to on or off doesn't matter anymore for me and starting X from tty doesn't make the bug go away. Even after downgrading to the previous versions which worked yesterday the system freezes. This have become really annoying now, gah I can't use me workstation anymore!

Can't some clever guy/girl tell me what is wrong and what to do to fix it, please :)
_________________
[AMD AM2 X2 3800+] [ASUS M2N-SLI Delux] [Corsair 6400C5 2*1GB] [2*250 GB SATAII + 160 GB PATA]
jiart.org
Swede
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4688
Location: Theux (Belgium)

PostPosted: Sun Aug 19, 2007 10:48 pm    Post subject: Reply with quote

I've run tests under pure X (xdm/xsession) and the problem doesn't arise. I mean X doesn't consume 100% CPU after a while when an OpenGL screen saver (such as has BlockTube) run for a long period of time. When the screen saver ends the CPU goes to a normal activity, i.e. 1-10%.

I'm going to make further tests with XFCE4, which I've already installed. I'm leaving the screen saver for a whole day long. But I'm confident in that the problem is most probably due to migrating KDE from 3.5.5 to 3.5.7 - in my case at least.

After that I'll see if the problem also occurs with a brand new KDE profile.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
Mark_van_Dark
n00b
n00b


Joined: 20 Aug 2007
Posts: 5

PostPosted: Mon Aug 20, 2007 12:01 pm    Post subject: Reply with quote

I have the same problem with the cpu.

I can work for hours but suddenly the cpu usage for /usr/bin/X raises to 100% or more. I have this problem since i have upgrade from kde 3.5.5 to 3.5.7.

I have an intel graphics card so the ATI and NVIDIA bug doesn't work for me.

I have already killed superkaramba because some users had the problem when running superkaramba.

Please have someone a solution it is really annouying to kill X and restart your programs.
Back to top
View user's profile Send private message
rastersize
n00b
n00b


Joined: 04 Jan 2006
Posts: 7
Location: Sweden

PostPosted: Mon Aug 20, 2007 12:48 pm    Post subject: Reply with quote

VinzC wrote:
I've run tests under pure X (xdm/xsession) and the problem doesn't arise. I mean X doesn't consume 100% CPU after a while when an OpenGL screen saver (such as has BlockTube) run for a long period of time. When the screen saver ends the CPU goes to a normal activity, i.e. 1-10%.

I'm going to make further tests with XFCE4, which I've already installed. I'm leaving the screen saver for a whole day long. But I'm confident in that the problem is most probably due to migrating KDE from 3.5.5 to 3.5.7 - in my case at least.

After that I'll see if the problem also occurs with a brand new KDE profile.


Greate, I can live with XFCE4 (if it works that is) until KDE4RC1 is available (which hopefully doesn't freeze like this).

(By the way, I don't need to have the screensaver running for this bug to kick in.)
_________________
[AMD AM2 X2 3800+] [ASUS M2N-SLI Delux] [Corsair 6400C5 2*1GB] [2*250 GB SATAII + 160 GB PATA]
jiart.org
Swede
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4688
Location: Theux (Belgium)

PostPosted: Mon Aug 20, 2007 2:10 pm    Post subject: Reply with quote

VinzC wrote:
I've run tests under pure X (xdm/xsession) and the problem doesn't arise. I mean X doesn't consume 100% CPU after a while when an OpenGL screen saver (such as has BlockTube) run for a long period of time. When the screen saver ends the CPU goes to a normal activity, i.e. 1-10%.

I'm going to make further tests with XFCE4, which I've already installed. I'm leaving the screen saver for a whole day long. But I'm confident in that the problem is most probably due to migrating KDE from 3.5.5 to 3.5.7 - in my case at least.

After that I'll see if the problem also occurs with a brand new KDE profile.

rastersize wrote:
Greate, I can live with XFCE4 (if it works that is) until KDE4RC1 is available (which hopefully doesn't freeze like this).

(By the way, I don't need to have the screensaver running for this bug to kick in.)

Note I'm also considering - still in my case - testing compositing within XFCE and OpenGL. If I can get compositing work together with OpenGL applications like screensavers then I consider I won the battle and the real problem lies within KDE. I'll check that in 2-3 of hours when I get home.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
billydv
l33t
l33t


Joined: 22 Dec 2006
Posts: 876
Location: Mount Vernon, NY

PostPosted: Mon Aug 20, 2007 5:28 pm    Post subject: Reply with quote

VinzC, I have noticed the same thing and have been going crazy with this for weeks, I get it to stop freezing, change something else and get the freezes again, what I do seem to see is that the screensavers seem to have some kind of bad interaction with either the nvidia-drivers or the composite window manager ( beryl or compiz ),
One thing you can try if you can live without the screensavers is set it to blank screen when you are in the KDE configure your desktop, I am noticing that this seems to stop alot of this although I am still testing this theory. Also, be sure that you dont have xorg.conf problems, gentoo puts numerous items in their standard xorg.conf that had caused problems for me, be sure to try X -configure and afterwards redo you xorg.cong and be sure there are no wrong module loads or messed up font directories, check your xorg.log and be sure there are no errors or warnings, then reemerge nvidia-drivers to be sure they are correct.

Second thing you can try, if you cant live without screensavers is (this is only if you run beryl or compiz) to have kdesktop_lock kill you window manager when it activates. This can be done by renaming /usr/kde/3.5/bin kdesktop_lock to kdesktop_lock1, create this file in its place

#!/bin/sh
#This kills beryl when you start your screensaver
killall beryl && kdesktop_lock1



Save it as kdesktop_lock and be sure to make it executable by all

Now when you configure your screensaver make sure to set it to blank screen only and require password to stop within 10-15 seconds to be sure that beryl is killed quickly when you are in screensaver mode, then in beryl manager be sure to set fallback window manager to kwin or whatever you want so that it will put it to normal upon killing beryl. If you use compiz substitute compiz or compiz.real for beryl in the script, to know which you need to stop just run top while compiz is running and it will tell you the name of the process
_________________
Billy DeVincentis
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4688
Location: Theux (Belgium)

PostPosted: Mon Aug 20, 2007 10:06 pm    Post subject: Reply with quote

Thanks for your hints billydv.

Here is an update to what I wrote earlier: I've run XFCE4 with compositing enabled and OpenGL screensavers - not that I can't live without them but I'm sure at least the video chain is put under stress :-) - and no lockup occured. I'm going to have the test run the whole night long but I'm now almost sure (say, 99.99%) neither the video drivers nor X is concerned. CPU usage is absolutely normal and never went to 100% when I gained control after I unlocked the screen.

This IMHO tends to prove there's a problem either with KDE 3.5.7 itself or with my configuration files. With KDE 3.5.7 the problem occurred systematically in the morning after the screen saver (OpenGL) had run all night long. Note after one or two of hours the CPU went to 100% but only for a short while. That didn't happen with XFCE even after a few hours running OpenGL stuff with compositing enabled.

I'll try tomorrow running a blank KDE profile to see if KDE causes the "bug" or if it's just in the config files.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
billydv
l33t
l33t


Joined: 22 Dec 2006
Posts: 876
Location: Mount Vernon, NY

PostPosted: Mon Aug 20, 2007 10:34 pm    Post subject: Reply with quote

My problem is that I cant live without kde which is why this has driven me so crazy
_________________
Billy DeVincentis
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4688
Location: Theux (Belgium)

PostPosted: Tue Aug 21, 2007 8:47 am    Post subject: Reply with quote

billydv wrote:
My problem is that I cant live without kde which is why this has driven me so crazy

Have you tried whiping out your .kde directory or with a blank user account? (Since it's what I'm going to try next and you are a little ahead from me ;-) )

EDIT: Also note KDE is just another window manager plus a set of tools (more or less). You might as well - as a temporary fix - use XFCE, enable KDE services and run KDE applications from XFCE.

EDIT: At a first glance, a blank KDE profile looks Ok even with compositing (transparency, shades and effects) enabled. However I let the GL screensaver run too short to be able to see the difference. I'll let it run for the night and I'll post my comments tomorrow.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
billydv
l33t
l33t


Joined: 22 Dec 2006
Posts: 876
Location: Mount Vernon, NY

PostPosted: Tue Aug 21, 2007 7:19 pm    Post subject: Reply with quote

Just to let you know, kde with a new user profile did the very same thing, something else to note, on an amd64 debian install, I had everything running perfect until I changed processors from a 939 xp3400 to an fx57, then I started getting freezes on that too.
_________________
Billy DeVincentis
Back to top
View user's profile Send private message
billydv
l33t
l33t


Joined: 22 Dec 2006
Posts: 876
Location: Mount Vernon, NY

PostPosted: Tue Aug 21, 2007 7:52 pm    Post subject: Reply with quote

BTW, same mostly stable system X86, on a socket A mboard by abit works rock solid, never a freeze or lockup for a very long time, I never really have to reboot or anything, so I question if its not the chipset driver or something?
_________________
Billy DeVincentis
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4688
Location: Theux (Belgium)

PostPosted: Tue Aug 21, 2007 9:45 pm    Post subject: Reply with quote

billydv wrote:
BTW, same mostly stable system X86, on a socket A mboard by abit works rock solid, never a freeze or lockup for a very long time, I never really have to reboot or anything, so I question if its not the chipset driver or something?

I don't suspect hardware problems for if it were the case you would have random crashes, freezes or reboots in random circumstances for example. Since the problem occurs only in the same circumstances maybe the driver is the cause. IMHO the problem is software rather than hardware.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
Mark_van_Dark
n00b
n00b


Joined: 20 Aug 2007
Posts: 5

PostPosted: Wed Aug 22, 2007 5:19 am    Post subject: Reply with quote

I think my problems are gone. Since yesterday i didn't get a xorg lockup or 100% cpu usage by X.

I did the following:

1.) Added my intel graphics drivers to the kernel (previously used non DRI and the xorg i810 drivers)
2.) Reboot
3.) Went to the console (CTRL+ALT+1)
4.) Shutdown X (/etc/init.d/xdm stop) and removed the xorg.conf
5.) Run X -configure
6.) Check settings and changed necessary things like modules and fonts
7.) Added DRI support to xorg.conf
8.) Started X (/etc/init.d/xdm start)

Since then my KDE works without freezing or locking ups.
Back to top
View user's profile Send private message
Ainulindalë
n00b
n00b


Joined: 23 Sep 2004
Posts: 8
Location: Paris, France.

PostPosted: Wed Aug 22, 2007 5:58 am    Post subject: Reply with quote

VinzC wrote:
Thanks for your hints billydv.

Here is an update to what I wrote earlier: I've run XFCE4 with compositing enabled and OpenGL screensavers -[...]
This IMHO tends to prove there's a problem either with KDE 3.5.7 itself or with my configuration files.


As I said before, I'm using XFCE4, on an AMD64/ATI Radeon 9200, and I experienced this problem for two or three weeks (in fact it started with my migration towards kernel 2.6.22 or some update at this time perhaps ?), that's why I don't think it's KDE related or qt related.
For my part, running XFCE with composite/DRI gives me freezes on simple actions such as using XFCE menu (but it's unpredictable).

The only thing I did which helped me to narrow (a bit) the problem was to modify/remove options on xorg.conf one at a time, even modifying AGP speed, to eventually remove all options related to GL/DRI. I can't be sure that the fact that I recompiled world without the "opengl" flag helped, but right now my system works.

And by the way, for my part, the system was freezing even when I wasn't using it or coming back on an open session : I was able to monitor the CPU usage from work, and it was the same thing : might have something to do with power management ?
_________________
Oooook !
Back to top
View user's profile Send private message
billydv
l33t
l33t


Joined: 22 Dec 2006
Posts: 876
Location: Mount Vernon, NY

PostPosted: Wed Aug 22, 2007 12:19 pm    Post subject: Reply with quote

Mark , I thought when using the nvidia driver you should have dri and glcore disabled, what other modules did you disable?
_________________
Billy DeVincentis
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4688
Location: Theux (Belgium)

PostPosted: Wed Aug 22, 2007 3:02 pm    Post subject: Reply with quote

VinzC wrote:
Thanks for your hints billydv.

Here is an update to what I wrote earlier: I've run XFCE4 with compositing enabled and OpenGL screensavers -[...]
This IMHO tends to prove there's a problem either with KDE 3.5.7 itself or with my configuration files.


Ainulindalë wrote:
As I said before, I'm using XFCE4, on an AMD64/ATI Radeon 9200, and I experienced this problem for two or three weeks (in fact it started with my migration towards kernel 2.6.22 or some update at this time perhaps ?), that's why I don't think it's KDE related or qt related.
For my part, running XFCE with composite/DRI gives me freezes on simple actions such as using XFCE menu (but it's unpredictable).

The only thing I did which helped me to narrow (a bit) the problem was to modify/remove options on xorg.conf one at a time, even modifying AGP speed, to eventually remove all options related to GL/DRI. I can't be sure that the fact that I recompiled world without the "opengl" flag helped, but right now my system works.

And by the way, for my part, the system was freezing even when I wasn't using it or coming back on an open session : I was able to monitor the CPU usage from work, and it was the same thing : might have something to do with power management ?

Is it also possible that both your and my problems be different? Indeed I've run KDE alone a whole night and the CPU usage was normal, not 100%. I made no change to my xorg.conf file. Now I'm on the way to check all of my KDE session config files to see which one is responsible for "locking" X (note I don't have any freeze or so since a) I can switch to a console and killall -9 X and b) I can see applets like superkaramba and kicker refresh their display.)
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
Joaquin24
Tux's lil' helper
Tux's lil' helper


Joined: 01 Jun 2006
Posts: 95
Location: 3L3CTR0nic, 7uX-0-L4nD

PostPosted: Thu Aug 23, 2007 3:55 am    Post subject: Reply with quote

hi, I ve been cheating a bit with niceness, and the sysctl.conf..

there is a a tiny deamon called verynice than assigns nice according to Ram, etc..


emerge verynice.. the situation did improve, I know this has been discussed before but whatever, setting the X to nice -4 gave me results of, let's say (aprox) 90% less crashes, almost none..

BTW, vnice deamon is intended for that, here's part of the conf
Code:

# Also we do this for "xanim" and "realplay"
goodexe "compiz"
goodexe "X"
goodexe "gmplayer"
goodexe "mplayer
# reduce your probability of turning out coasters from your CD drive
goodexe "cdrecord"
goodexe "k3b"

# Making the X server a "good" program is usually a good idea too
#   -- X is essentially a multimedia app. These next few lines will
#   work even if root is declared an "immune" user and X is run as root,
#   because "goodexe"'s specified in verynice.conf are exceptions to
#   the "immuneuser" rule
# (these are appropriate for RedHat Linux, with XFree 3.x -- the appropriate
# file might be different on your system. To find the proper name, do a PS
# to find the X pid, then ls -l /proc/{pid}/exe
goodexe "/etc/X11/X"
goodexe "/usr/X11R6/bin/XF86_SVGA"
goodexe "/usr/X11R6/bin/XF86_Mono"
goodexe "/usr/X11R6/bin/XF86_VGA16"
goodexe "/usr/X11R6/bin/XF86_S3"
goodexe "/usr/X11R6/bin/XF86_Mach32"
goodexe "/usr/X11R6/bin/XF86_Mach64"
goodexe "/usr/X11R6/bin/XF86_Mach8"
goodexe "/usr/X11R6/bin/XF86_8514"
goodexe "/usr/X11R6/bin/XF86_P9000"
goodexe "/usr/X11R6/bin/XF86_AGX"
goodexe "/usr/X11R6/bin/XF86_W32"
# These are for XFree86 4.0, but haven't been tested
goodexe "/usr/X11R6/bin/XFree86"
goodexe "/usr/X11R6/bin/X"

# Sample additional parameters, specifying the built in defaults
goodexe     -4
#notnice    -4
#batchjob   18
#runaway    20
#kill       22
#badkarmarate .0167



 


hey ?!!? gnome gone crazy, WTF?? it' s using only 5 MB with Openoffice also ? see here http://img212.imageshack.us/my.php?image=pantallazods7.png

whatever at least it won't be jamming bytes between my video card and Xorg. :D :D

why 's everyone so obssesed with RenderAccel? . afaik is only a tweak that works on some specifics cards... just saying :? there are lots of tweaks, i. e . Option "DamageEvents" "true" (provides better performace for compiz/beryl)
Back to top
View user's profile Send private message
Mark_van_Dark
n00b
n00b


Joined: 20 Aug 2007
Posts: 5

PostPosted: Thu Aug 23, 2007 8:03 am    Post subject: Reply with quote

@billydv
I don't have a nvidia card i have an intel 945G integrated graphics card. i only disabled glcore the rest still are the original modules of the X -configure.

@VinzC
That's the same problem i had. I could be logged in into kde for the whole day and nothing happens (as long as i didn't do anything). But when i tried to start k3b or only wanted to open the kde menu my whole system locked up and cpu was at 100%. But i also could watch my superkaramba updating it's display. I also could work in the kde-console but i couldn't start a program or do anything else (by the way the console was open so i think it doesn't need a lot of cpu)

The interesting part was that when i tried to enter the console (CTRL+ALT+1) i got a lot of strange symbols and icons like there was the rest of a buffer. i could "repair" it by restarting the consolefonts. So i thought the problem was with my graphics configuration because the console of linux doesn't have to something with kde or any other displaymanager.
Back to top
View user's profile Send private message
maartenlambrecht
n00b
n00b


Joined: 28 Jun 2007
Posts: 52
Location: Dentergem (Belgium)

PostPosted: Thu Aug 23, 2007 8:21 am    Post subject: Reply with quote

Quote:
6.) Check settings and changed necessary things like modules and fonts

Does this have anything to do with the error I get?
Code:
FreeFontPath: FPE "/usr/share/fonts/misc/" refcount is 2, should be 1

What did you change?
I can't solve this problem. I hope somebody can...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2, 3, ... 10, 11, 12  Next
Page 2 of 12

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum