Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kgcc64 emerge fails on SGI ip30 w/ livecd-rc6
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
e-ipi
Apprentice
Apprentice


Joined: 23 Aug 2005
Posts: 192

PostPosted: Tue May 29, 2007 2:19 am    Post subject: kgcc64 emerge fails on SGI ip30 w/ livecd-rc6 Reply with quote

Hello,

I've been trying to get linux re-installed on my Octane. I've been using livecd-rc6 and following the handbook. Things seem to work fine until i try to emerge kgcc64. Are there any known issues with the ebuild?

Thanks!
Back to top
View user's profile Send private message
Redhatter
Retired Dev
Retired Dev


Joined: 20 Sep 2003
Posts: 548
Location: Brisbane, QLD, Australia

PostPosted: Tue May 29, 2007 7:24 am    Post subject: Reply with quote

Hmm, a few people have commented about kgcc64... I'm in the process of reloading my O2 (although I just re-used my old kernel).

But since a few seem to be having difficulties, I'll have a look at installing it. (I normally cross-compile from another machine.)

Could you elaborate on the errors you get?
_________________
Stuart Longland (a.k.a Redhatter, VK4MSL)
I haven't lost my mind - it's backed up on a tape somewhere...

Gentoo/MIPS Cobalt developer, Mozilla herd member.
Back to top
View user's profile Send private message
tillin9
n00b
n00b


Joined: 27 May 2007
Posts: 2
Location: Middletown, CT

PostPosted: Tue May 29, 2007 3:57 pm    Post subject: Reply with quote

I think I may have the same problem. I'm using RC6 and the MIPS handbook to attempt an install on my O2. I put the errors on the LiveCD thread, http://forums.gentoo.org/viewtopic-t-242518-start-25.html but I also tried to get kgcc64 as my initial problem surfaced on a kernel compile with a script with 64 in the name, and it was in the handbook, so I thought maybe it was needed. The error I got was similar to the ones when trying to recompile portage, though obviously the lines were different. Thanks in advance for any suggestions.
Back to top
View user's profile Send private message
e-ipi
Apprentice
Apprentice


Joined: 23 Aug 2005
Posts: 192

PostPosted: Tue May 29, 2007 5:53 pm    Post subject: Reply with quote

Sorry, my Octane isn't with me now,
so i can't say what the error is.

For what it's worth, i tried emerging
kgcc64 on my ppc laptop. I'm not sure if it's
supposed to work, but i tried emerging
kgcc64 on my ppc32 laptop. That
didn't work, either.
Back to top
View user's profile Send private message
Redhatter
Retired Dev
Retired Dev


Joined: 20 Sep 2003
Posts: 548
Location: Brisbane, QLD, Australia

PostPosted: Wed May 30, 2007 1:17 am    Post subject: Reply with quote

Well, kgcc64 is a merging of several toolchains; there used to be a separate 64-bit kernel compiler for mips64, sparc64, ppc64, hppa, s390 and AMD64.

I'd say this is a bug for the toolchain herd if its broken on other arches too.
_________________
Stuart Longland (a.k.a Redhatter, VK4MSL)
I haven't lost my mind - it's backed up on a tape somewhere...

Gentoo/MIPS Cobalt developer, Mozilla herd member.
Back to top
View user's profile Send private message
tillin9
n00b
n00b


Joined: 27 May 2007
Posts: 2
Location: Middletown, CT

PostPosted: Wed May 30, 2007 2:55 am    Post subject: Reply with quote

Sorry, I now think my issue was different. My /etc/make.conf was improperly set for the O2.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum