Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[PALUDIS] Support thread (current v. 0.24.6) - Part 3
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... , 13, 14, 15  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
dleverton
Guru
Guru


Joined: 28 Aug 2006
Posts: 517

PostPosted: Tue Oct 09, 2007 3:27 pm    Post subject: Re: Stuck at " * Regenerating environment..." Reply with quote

tecknojunky wrote:
dleverton wrote:
tecknojunky wrote:
File is here. (800 kbits upload speed)

What does /etc/env.d/60prelink look like?
Code:
# cat /etc/env.d/60prelink
PRELINK_PATH_MASK="/lib/modules:/usr/lib/locale:/usr/lib/wine:/usr/lib/valgrind:*.la:*.png:*.py:*.pl:*.pm:*.sh:*.xml:*.xslt:*.a:*.js"
PRELINK_PATH=""
Hope it helps

No funny invisible characters in there?
Back to top
View user's profile Send private message
tecknojunky
Veteran
Veteran


Joined: 19 Oct 2002
Posts: 1937
Location: Montréal

PostPosted: Wed Oct 10, 2007 2:12 am    Post subject: Re: Stuck at " * Regenerating environment..." Reply with quote

dleverton wrote:
tecknojunky wrote:
dleverton wrote:
tecknojunky wrote:
File is here. (800 kbits upload speed)

What does /etc/env.d/60prelink look like?
Code:
# cat /etc/env.d/60prelink
PRELINK_PATH_MASK="/lib/modules:/usr/lib/locale:/usr/lib/wine:/usr/lib/valgrind:*.la:*.png:*.py:*.pl:*.pm:*.sh:*.xml:*.xslt:*.a:*.js"
PRELINK_PATH=""
Hope it helps

No funny invisible characters in there?
Unfortunatly. :(
_________________
(7 of 9) Installing star-trek/species-8.4.7.2::talax.
Back to top
View user's profile Send private message
dleverton
Guru
Guru


Joined: 28 Aug 2006
Posts: 517

PostPosted: Wed Oct 10, 2007 9:43 am    Post subject: Re: Stuck at " * Regenerating environment..." Reply with quote

tecknojunky wrote:
Unfortunatly. :(

Hmm. The first place in the strace output I can see that it goes wrong is
Code:
27728 open("/lib/modules:/usr/lib/locale:/usr/lib/wine:/usr/lib/", O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY) = -1 ENOENT (No such file or directory)
but I have no idea why it would try to treat that as a file. Maybe try reinstalling prelink, to make sure you have a fresh copy of the /etc/env.d file.
Back to top
View user's profile Send private message
TheNewOsiris
Tux's lil' helper
Tux's lil' helper


Joined: 18 Dec 2006
Posts: 91

PostPosted: Sat Oct 13, 2007 2:16 am    Post subject: can't install barnyard. Reply with quote

I can't seem to install barnyard. This is the output I recieve:

Code:
These packages will be installed:

* net-analyzer/barnyard-0.2.0-r2 {:0} [N] mysql postgres sguil
* net-analyzer/sancp-1.6.1-r2 {:0} [N] sguil
* dev-lang/ocaml-3.09.3-r1 {:0} [N] X gdbm -latex ncurses -tk
* dev-ml/findlib-1.1.2_p1 {:0} [N] -doc -tk
* dev-ml/pcre-ocaml-5.12.1 {:0} [N] -examples
* net-analyzer/sguil-sensor-0.6.1 {:0} [N]

Total: 6 packages (6 new)

(1 of 6) Installing net-analyzer/barnyard-0.2.0-r2::gentoo

>>> Running ebuild phase fetch as paludisbuild:paludisbuild...
>>> Starting builtin_fetch
>>> Already have barnyard-0.2.0.tar.gz
>>> Already have barnyard-0.2.0-patches.tar.bz2
 * Checking MD5 for barnyard-0.2.0-patches.tar.bz2 ...                   [ ok ]
 * Checking RMD160 for barnyard-0.2.0-patches.tar.bz2 ...                [ ok ]
 * Checking SHA256 for barnyard-0.2.0-patches.tar.bz2 ...                [ ok ]
 * Checking MD5 for barnyard-0.2.0.tar.gz ...                            [ ok ]
 * Checking RMD160 for barnyard-0.2.0.tar.gz ...                         [ ok ]
 * Checking SHA256 for barnyard-0.2.0.tar.gz ...                         [ ok ]
>>> Done builtin_fetch
>>> Completed ebuild phase fetch
paludis@1192240743: [WARNING] In program paludis --log-level qa --dl-deps-default discard --install =net-analyzer/barnyard-0.2.0-r2::gentoo =net-analyzer/sancp-1.6.1-r2::gentoo =dev-lang/ocaml-3.09.3-r1::gentoo =dev-ml/findlib-1.1.2_p1::gentoo =dev-ml/pcre-ocaml-5.12.1::gentoo =net-analyzer/sguil-sensor-0.6.1::gentoo --add-to-world-spec ( net-analyzer/sguil-client net-analyzer/sguil-server net-analyzer/sguil-sensor ):
  ... When performing install action from command line:
  ... When executing install task:
  ... When installing 'net-analyzer/barnyard-0.2.0-r2':
  ... When checking permissions on '/var/tmp/paludis' for userpriv:
  ... Directory '/var/tmp/paludis' owned by group 'root', not 'paludisbuild', cannot enable userpriv
>>> Running ebuild phase prepare as root:root...
>>> Starting builtin_prepare
>>> Done builtin_prepare
>>> Completed ebuild phase prepare
>>> Running ebuild phases init saveenv as root:root...
>>> Starting builtin_init
>>> Done builtin_init
>>> Starting builtin_saveenv
>>> Done builtin_saveenv
>>> Completed ebuild phases init saveenv
>>> Running ebuild phases loadenv setup saveenv as root:root...
>>> Starting builtin_loadenv
>>> Done builtin_loadenv
>>> Starting pkg_setup
>>> Done pkg_setup
>>> Starting builtin_saveenv
>>> Done builtin_saveenv
>>> Completed ebuild phases loadenv setup saveenv
>>> Running ebuild phases loadenv unpack compile test saveenv as root:root...
>>> Starting builtin_loadenv
>>> Done builtin_loadenv
>>> Starting src_unpack
>>> Unpacking barnyard-0.2.0.tar.gz to /var/tmp/paludis/net-analyzer/barnyard-0.2.0-r2/work
tar zxf /usr/portage/distfiles/barnyard-0.2.0.tar.gz --no-same-owner
>>> Unpacking barnyard-0.2.0-patches.tar.bz2 to /var/tmp/paludis/net-analyzer/barnyard-0.2.0-r2/work
tar jxf /usr/portage/distfiles/barnyard-0.2.0-patches.tar.bz2 --no-same-owner
 * Applying 0.2.0-sguil_files.patch ...                                  [ ok ]
 * Applying 0.2.0-configure-in.patch ...                                 [ ok ]
 * Applying 0.2.0-op_plugbase.c.patch ...                                [ ok ]
 * Recreating configure ...
autoheader-2.61: WARNING: Using auxiliary files such as `acconfig.h', `config.h.bot'
autoheader-2.61: WARNING: and `config.h.top', to define templates for `config.h.in'
autoheader-2.61: WARNING: is deprecated and discouraged.
autoheader-2.61:
autoheader-2.61: WARNING: Using the third argument of `AC_DEFINE' and
autoheader-2.61: WARNING: `AC_DEFINE_UNQUOTED' allows one to define a template without
autoheader-2.61: WARNING: `acconfig.h':
autoheader-2.61:
autoheader-2.61: WARNING:   AC_DEFINE([NEED_FUNC_MAIN], 1,
autoheader-2.61:                [Define if a function `main' is needed.])
autoheader-2.61:
autoheader-2.61: WARNING: More sophisticated templates can also be produced, see the
autoheader-2.61: WARNING: documentation.
>>> Done src_unpack
>>> Starting src_compile
econf: updating /var/tmp/paludis/net-analyzer/barnyard-0.2.0-r2/work/barnyard-0.2.0/config.guess with /usr/share/gnuconfig/config.guess
econf: updating /var/tmp/paludis/net-analyzer/barnyard-0.2.0-r2/work/barnyard-0.2.0/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --enable-tcl --sysconfdir=/etc/snort --enable-postgres --enable-mysql --build=i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets $(MAKE)... yes
checking for working aclocal-1.4... found
checking for working autoconf... found
checking for working automake-1.4... found
checking for working autoheader... found
checking for working makeinfo... found
checking for i686-pc-linux-gnu-gcc... no
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for gcc option to accept ANSI C... none needed
checking for i686-pc-linux-gnu-ranlib... no
checking for ranlib... ranlib
checking for i686-pc-linux-gnu-gcc... gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking whether byte ordering is bigendian... no
checking for strings.h... (cached) yes
checking for string.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for unistd.h... (cached) yes
checking sys/sockio.h usability... no
checking sys/sockio.h presence... no
checking for sys/sockio.h... no
checking paths.h usability... yes
checking paths.h presence... yes
checking for paths.h... yes
checking for socket in -lsocket... no
checking whether printf must be declared... no
checking whether fprintf must be declared... no
checking whether syslog must be declared... no
checking whether puts must be declared... no
checking whether fputs must be declared... no
checking whether fputc must be declared... no
checking whether fopen must be declared... no
checking whether fclose must be declared... no
checking whether fwrite must be declared... no
checking whether fflush must be declared... no
checking whether getopt must be declared... no
checking whether bzero must be declared... no
checking whether bcopy must be declared... no
checking whether memset must be declared... no
checking whether strtol must be declared... no
checking whether strcasecmp must be declared... no
checking whether strncasecmp must be declared... no
checking whether strerror must be declared... no
checking whether perror must be declared... no
checking whether socket must be declared... no
checking whether sendto must be declared... no
checking whether vsnprintf must be declared... no
checking whether snprintf must be declared... no
checking whether strtoul must be declared... no
checking for snprintf... yes
checking for strlcpy... no
checking for strlcat... no
checking for strerror... yes
checking /usr/include/mysql/mysql.h usability... yes
checking /usr/include/mysql/mysql.h presence... yes
checking for /usr/include/mysql/mysql.h... yes
checking for mysql_real_connect in -lmysqlclient... yes
checking for tclsh8.4... tclsh8.4
checking for the tcl version number... 8.4, patchlevel .13
checking /usr/include/postgresql/libpq-4/libpq-fe.h usability... yes
checking /usr/include/postgresql/libpq-4/libpq-fe.h presence... yes
checking for /usr/include/postgresql/libpq-4/libpq-fe.h... yes
checking for PQsetdbLogin in -lpq... no


**********************************************
  ERROR: unable to find postgresql library
  checked in the following places
        /usr/lib
**********************************************

make -j2
make: *** No targets specified and no makefile found.  Stop.

!!! ERROR in net-analyzer/barnyard-0.2.0-r2:
!!! In src_compile at line 3061
!!! compile problem

!!! Call stack:
!!!    * src_compile (/var/tmp/paludis/net-analyzer/barnyard-0.2.0-r2/temp/loadsaveenv:3061)
!!!    * ebuild_f_compile (/usr/libexec/paludis/src_compile.bash:51)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:363)
!!!    * main (/usr/libexec/paludis/ebuild.bash:381)

die trap: exiting with error.

Install error:
  * In program paludis --log-level qa --dl-deps-default discard --install =net-analyzer/barnyard-0.2.0-r2::gentoo =net-analyzer/sancp-1.6.1-r2::gentoo =dev-lang/ocaml-3.09.3-r1::gentoo =dev-ml/findlib-1.1.2_p1::gentoo =dev-ml/pcre-ocaml-5.12.1::gentoo =net-analyzer/sguil-sensor-0.6.1::gentoo --add-to-world-spec ( net-analyzer/sguil-client net-analyzer/sguil-server net-analyzer/sguil-sensor ):
  * When performing install action from command line:
  * When executing install task:
  * When installing 'net-analyzer/barnyard-0.2.0-r2':
  * Install error: Install failed for 'net-analyzer/barnyard-0.2.0-r2::gentoo'


Resume command: paludis --log-level qa --dl-deps-default discard --install '=net-analyzer/barnyard-0.2.0-r2::gentoo' '=net-analyzer/sancp-1.6.1-r2::gentoo' '=dev-lang/ocaml-3.09.3-r1::gentoo' '=dev-ml/findlib-1.1.2_p1::gentoo' '=dev-ml/pcre-ocaml-5.12.1::gentoo' '=net-analyzer/sguil-sensor-0.6.1::gentoo' --add-to-world-spec '( net-analyzer/sguil-client net-analyzer/sguil-server net-analyzer/sguil-sensor )'
Back to top
View user's profile Send private message
pussi
l33t
l33t


Joined: 08 May 2004
Posts: 727
Location: Finland

PostPosted: Sat Oct 13, 2007 2:31 am    Post subject: Reply with quote

did you try reinstalling postgresql?
Back to top
View user's profile Send private message
TheNewOsiris
Tux's lil' helper
Tux's lil' helper


Joined: 18 Dec 2006
Posts: 91

PostPosted: Sat Oct 13, 2007 3:24 am    Post subject: Reply with quote

yes, I have reinstalled postgresql and its dependencies.
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3057
Location: Redmond, WA

PostPosted: Sat Oct 13, 2007 7:29 am    Post subject: Reply with quote

http://bugs.gentoo.org/show_bug.cgi?id=124921
Back to top
View user's profile Send private message
TheNewOsiris
Tux's lil' helper
Tux's lil' helper


Joined: 18 Dec 2006
Posts: 91

PostPosted: Sat Oct 13, 2007 12:29 pm    Post subject: Reply with quote

so there is no solution?
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3057
Location: Redmond, WA

PostPosted: Sat Oct 13, 2007 3:17 pm    Post subject: Reply with quote

Pretty much.
Back to top
View user's profile Send private message
peterbye
n00b
n00b


Joined: 28 Apr 2004
Posts: 19
Location: UK

PostPosted: Fri Oct 19, 2007 12:16 pm    Post subject: package.provided type question Reply with quote

I know that Paludis has no equivalent of package.provided and the reason for that.
Can someone tell me how to deal with xorg-server wanting to install the nvidia-drivers ebuild please?
I have the nvidia drivers direct from nVidia, not from the ebuild.
In package_mask.conf I have:
Code:
x11-drivers/nvidia-drivers

In use.conf I have the line:
Code:
*/* VIDEO_CARDS: -* nvidia vesa fbdev

which I presume is what's making xorg-server want to install the nvidia-drivers ebuild.

When I try to build xorg-server I get
Code:
  * When adding PackageDepSpec 'x11-base/xorg-server':
  * When adding package 'x11-base/xorg-server-1.3.0.0::gentoo':
  * When adding post dependencies as post dependencies:
  * When adding PackageDepSpec 'x11-drivers/nvidia-drivers':
  * All versions of 'x11-drivers/nvidia-drivers' are masked. Candidates are:
    * x11-drivers/nvidia-drivers-1.0.7185::gentoo: Masked by user_mask
       etc


so how can I tell it that I have nvidia drivers already and I don't want the ebuild installed?
I'm more than a little concerned that taking nvidia out of the VIDEO_CARDS line will have side effects!
Thanks
Back to top
View user's profile Send private message
Penguin of Wonder
Apprentice
Apprentice


Joined: 17 Jan 2006
Posts: 280
Location: West Virginia

PostPosted: Fri Oct 19, 2007 12:46 pm    Post subject: Reply with quote

Removing nvidia from your VIDEO card section won't change anything. All it is for is telling Paludis which drivers to include. Just take it out, you'll be fine.
_________________
My Linux Blog

AMD64 3700+
2G DDR 3200 Ram
320G HDD
Back to top
View user's profile Send private message
zxy
Veteran
Veteran


Joined: 06 Jan 2006
Posts: 1160
Location: in bed in front of the computer

PostPosted: Fri Oct 19, 2007 1:18 pm    Post subject: Reply with quote

@peterbye : or you can put a fake ebuild for nvidia-drivers in your local repository
_________________
Nature does not hurry, yet everything is accomplished.
Lao Tzu
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3057
Location: Redmond, WA

PostPosted: Fri Oct 19, 2007 3:21 pm    Post subject: Reply with quote

What's the advantage of installing nvidia drivers outside of a package manager?
Back to top
View user's profile Send private message
Penguin of Wonder
Apprentice
Apprentice


Joined: 17 Jan 2006
Posts: 280
Location: West Virginia

PostPosted: Fri Oct 19, 2007 3:30 pm    Post subject: Reply with quote

slycordinator, I assume you probably a) already know, and b) were directing that at peterbye, but just in case, the answer is none. :wink:
_________________
My Linux Blog

AMD64 3700+
2G DDR 3200 Ram
320G HDD
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3057
Location: Redmond, WA

PostPosted: Fri Oct 19, 2007 3:36 pm    Post subject: Reply with quote

I was essentially trying to ask why in the hell he wants to do this.
Back to top
View user's profile Send private message
n3Cre0
Tux's lil' helper
Tux's lil' helper


Joined: 16 Jan 2007
Posts: 129

PostPosted: Fri Oct 19, 2007 8:21 pm    Post subject: Reply with quote

Hi,

I quickly hacked up an ebuild (v0.9.1) of aircrack-ng to use the svn repo instead of the official releases, but I get this error, when it tries to install:
Quote:
>>> Starting src_install
make -j2 prefix=/usr docdir=/usr/share/doc/aircrack-ng-9999 mandir=/usr/share/man/man1 destdir=/var/tmp/paludis/net-wireless/aircrack-ng-9999/image/ install doc
make -C src install
make[1]: Entering directory `/var/tmp/paludis/net-wireless/aircrack-ng-9999/work/aircrackng/src'
make -C osdep
install -d /usr/share/doc/aircrack-ng-9999
install -m 644 ChangeLog INSTALLING README LICENSE AUTHORS VERSION /usr/share/doc/aircrack-ng-9999
ACCESS DENIED open_wr: /usr/share/doc/aircrack-ng-9999/ChangeLog
install: cannot create regular file `/usr/share/doc/aircrack-ng-9999/ChangeLog': Permission denied
ACCESS DENIED open_wr: /usr/share/doc/aircrack-ng-9999/INSTALLING
install: cannot create regular file `/usr/share/doc/aircrack-ng-9999/INSTALLING': Permission denied
ACCESS DENIED open_wr: /usr/share/doc/aircrack-ng-9999/README
install: cannot create regular file `/usr/share/doc/aircrack-ng-9999/README': Permission denied
ACCESS DENIED open_wr: /usr/share/doc/aircrack-ng-9999/LICENSE
install: cannot create regular file `/usr/share/doc/aircrack-ng-9999/LICENSE': Permission denied
ACCESS DENIED open_wr: /usr/share/doc/aircrack-ng-9999/AUTHORS
install: cannot create regular file `/usr/share/doc/aircrack-ng-9999/AUTHORS': Permission denied
ACCESS DENIED open_wr: /usr/share/doc/aircrack-ng-9999/VERSION
install: cannot create regular file `/usr/share/doc/aircrack-ng-9999/VERSION': Permission denied
make: *** [doc] Error 1
make: *** Waiting for unfinished jobs....
make[2]: Entering directory `/var/tmp/paludis/net-wireless/aircrack-ng-9999/work/aircrackng/src/osdep'
Building for Linux
make[3]: Entering directory `/var/tmp/paludis/net-wireless/aircrack-ng-9999/work/aircrackng/src/osdep'
make[3]: `.os.Linux' is up to date.
make[3]: Leaving directory `/var/tmp/paludis/net-wireless/aircrack-ng-9999/work/aircrackng/src/osdep'
make[2]: Leaving directory `/var/tmp/paludis/net-wireless/aircrack-ng-9999/work/aircrackng/src/osdep'
make -C osdep install
make[2]: Entering directory `/var/tmp/paludis/net-wireless/aircrack-ng-9999/work/aircrackng/src/osdep'
Building for Linux
make[3]: Entering directory `/var/tmp/paludis/net-wireless/aircrack-ng-9999/work/aircrackng/src/osdep'
make[3]: `.os.Linux' is up to date.
make[3]: Leaving directory `/var/tmp/paludis/net-wireless/aircrack-ng-9999/work/aircrackng/src/osdep'
make[2]: Leaving directory `/var/tmp/paludis/net-wireless/aircrack-ng-9999/work/aircrackng/src/osdep'
install -d /usr/bin
install -m 755 aircrack-ng airdecap-ng packetforge-ng ivstools kstats buddy-ng makeivs-ng /usr/bin
ACCESS DENIED unlink: /usr/bin/aircrack-ng
install: cannot remove `/usr/bin/aircrack-ng': Permission denied
ACCESS DENIED unlink: /usr/bin/airdecap-ng
install: cannot remove `/usr/bin/airdecap-ng': Permission denied
ACCESS DENIED unlink: /usr/bin/packetforge-ng
install: cannot remove `/usr/bin/packetforge-ng': Permission denied
ACCESS DENIED unlink: /usr/bin/ivstools
install: cannot remove `/usr/bin/ivstools': Permission denied
ACCESS DENIED unlink: /usr/bin/kstats
install: cannot remove `/usr/bin/kstats': Permission denied
ACCESS DENIED open_wr: /usr/bin/buddy-ng
install: cannot create regular file `/usr/bin/buddy-ng': Permission denied
ACCESS DENIED open_wr: /usr/bin/makeivs-ng
install: cannot create regular file `/usr/bin/makeivs-ng': Permission denied
make[1]: *** [install] Error 1
make[1]: Leaving directory `/var/tmp/paludis/net-wireless/aircrack-ng-9999/work/aircrackng/src'
make: *** [install] Error 2

!!! ERROR in net-wireless/aircrack-ng-9999:
!!! In src_install at line 3151
!!! emake install failed

!!! Call stack:
!!! * src_install (/var/tmp/paludis/net-wireless/aircrack-ng-9999/temp/loadsaveenv:3151)
!!! * ebuild_f_install (/usr/libexec/paludis/src_install.bash:48)
!!! * ebuild_main (/usr/libexec/paludis/ebuild.bash:363)
!!! * main (/usr/libexec/paludis/ebuild.bash:381)

die trap: exiting with error.
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-27143.log"

open_wr: /usr/share/doc/aircrack-ng-9999/ChangeLog
open_wr: /usr/share/doc/aircrack-ng-9999/INSTALLING
open_wr: /usr/share/doc/aircrack-ng-9999/README
open_wr: /usr/share/doc/aircrack-ng-9999/LICENSE
open_wr: /usr/share/doc/aircrack-ng-9999/AUTHORS
open_wr: /usr/share/doc/aircrack-ng-9999/VERSION
unlink: /usr/bin/aircrack-ng
unlink: /usr/bin/airdecap-ng
unlink: /usr/bin/packetforge-ng
unlink: /usr/bin/ivstools
unlink: /usr/bin/kstats
open_wr: /usr/bin/buddy-ng
open_wr: /usr/bin/makeivs-ng
--------------------------------------------------------------------------------


elog> Summary of messages from net-wireless/aircrack-ng-9999:

elog> * subversion update start -->
elog> * repository: http://trac.aircrack-ng.org/svn/branch/1.0-dev
elog> * working copy: /usr/portage/distfiles/svn-src/aircrack-ng/1.0-dev

Install error:
* In program paludis --safe-resume -i aircrack-ng:
* When performing install action from command line:
* When executing install task:
* When installing 'net-wireless/aircrack-ng-9999':
* Install error: Install failed for 'net-wireless/aircrack-ng-9999::local-portage'


Resume command: paludis --log-level qa --dl-deps-default discard --install '=net-wireless/aircrack-ng-9999::local-portage' --add-to-world-spec '( net-wireless/aircrack-ng )'


But when I go to /var/tmp/paludis/net-wireless/aircrack-ng-9999/work/aircrackng/src/ and just enter 'make install' (it compiled everything already) it installs everything fine

The ebuild:
Quote:

# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

inherit toolchain-funcs subversion

ESVN_REPO_URI="http://trac.aircrack-ng.org/svn/branch/1.0-dev"

S="${WORKDIR}/${PN/-/}"

DESCRIPTION="WLAN tools for breaking 802.11 WEP/WPA keys"
HOMEPAGE="http://www.aircrack-ng.org"
SRC_URI=""

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 arm ~ppc x86 ~x86-fbsd"
IUSE="wifi"

DEPEND="wifi? ( net-libs/libpcap )"

src_compile() {
emake || die "emake failed"
}

src_install() {
local target
use wifi && target="install" || target="install_userland"
emake \
prefix=/usr \
docdir="/usr/share/doc/${PF}" \
mandir="/usr/share/man/man1" \
destdir="${D}" \
${target} \
doc \
|| die "emake install failed"
}

src_test() {
#./makeivs wep.ivs 11111111111111111111111111 || die 'generating ivs file failed'
#./aircrack-ng wep.ivs || die 'cracking WEP key failed'

# Upstream uses signal in order to quit,
# So protect busybox with process group leader.
"$(tc-getCC)" -o process-group-leader "${FILESDIR}/process-group-leader.c"
./process-group-leader ./aircrack-ng -w test/password.lst test/wpa.cap || die 'cracking WPA key failed'
}


ciaranm (on IRC) told me to edit the ebuild to correspond with the makefile. But I have no clue. So here is the Makefile
Quote:
ROOT = .
include $(ROOT)/common.mak

SCRIPTS = airmon-ng airdriver-ng patchchk
DOCFILES = ChangeLog INSTALLING README LICENSE AUTHORS VERSION


default: all

all:
$(MAKE) -C src $(@)
$(MAKE) -C test $(@)

aircrack-ng-opt-prof_gen: all
mkdir -p prof
$(MAKE) -C src $(@)

aircrack-ng-opt-prof_use:
$(MAKE) -C src $(@)

install:
$(MAKE) -C src $(@)
$(MAKE) -C test $(@)
install -m 755 $(SCRIPTS) $(DESTDIR)$(sbindir)
install -d $(DESTDIR)$(mandir)
install -m 644 ./manpages/* $(DESTDIR)$(mandir)

uninstall:
$(MAKE) -C src $(@)
$(MAKE) -C test $(@)
-rm -f $(DESTDIR)$(sbindir)/airmon-ng
-rm -f $(DESTDIR)$(sbindir)/airdriver-ng
-rm -f $(DESTDIR)$(sbindir)/patchchk
-rm -f $(DESTDIR)$(mandir)/aircrack-ng.1
-rm -f $(DESTDIR)$(mandir)/airdecap-ng.1
-rm -f $(DESTDIR)$(mandir)/airdriver-ng.1
-rm -f $(DESTDIR)$(mandir)/aireplay-ng.1
-rm -f $(DESTDIR)$(mandir)/airmon-ng.1
-rm -f $(DESTDIR)$(mandir)/airodump-ng.1
-rm -f $(DESTDIR)$(mandir)/airolib-ng.1
-rm -f $(DESTDIR)$(mandir)/airsev-ng.1
-rm -f $(DESTDIR)$(mandir)/airtun-ng.1
-rm -f $(DESTDIR)$(mandir)/buddy-ng.1
-rm -f $(DESTDIR)$(mandir)/easside-ng.1
-rm -f $(DESTDIR)$(mandir)/ivstools.1
-rm -f $(DESTDIR)$(mandir)/kstats.1
-rm -f $(DESTDIR)$(mandir)/makeivs-ng.1
-rm -f $(DESTDIR)$(mandir)/packetforge-ng.1
-rm -f $(DESTDIR)$(mandir)/wesside-ng.1
-rm -fr $(DESTDIR)$(docdir)

strip:
$(MAKE) -C src $(@)
$(MAKE) -C test $(@)

doc:
install -d $(DESTDIR)$(docdir)
install -m 644 $(DOCFILES) $(DESTDIR)$(docdir)

clean:
$(MAKE) -C src $(@)
$(MAKE) -C test $(@)

distclean: clean


Can anyone PLEASE help with this? Thank you
_________________
OS: Linux 2.6.26 i686 Gentoo v2.0.0 Sound: HDA Intel
CPU: Intel(R) Pentium(R) M processor 1.73GHz (GenuineIntel)
Disk: 95.23GB Video: ATI Radeon Mobility X700 XL with Catalyst 8.08 RAM: 1011MB
Back to top
View user's profile Send private message
Penguin of Wonder
Apprentice
Apprentice


Joined: 17 Jan 2006
Posts: 280
Location: West Virginia

PostPosted: Fri Oct 19, 2007 8:30 pm    Post subject: Reply with quote

Didn't Ciaram tell you that you need to add the DESTDIR(s) to the ebuild? Or do you not how to do that?
_________________
My Linux Blog

AMD64 3700+
2G DDR 3200 Ram
320G HDD
Back to top
View user's profile Send private message
n3Cre0
Tux's lil' helper
Tux's lil' helper


Joined: 16 Jan 2007
Posts: 129

PostPosted: Fri Oct 19, 2007 9:27 pm    Post subject: Reply with quote

No, I don't. But if someone would explain how I would know for the future.
_________________
OS: Linux 2.6.26 i686 Gentoo v2.0.0 Sound: HDA Intel
CPU: Intel(R) Pentium(R) M processor 1.73GHz (GenuineIntel)
Disk: 95.23GB Video: ATI Radeon Mobility X700 XL with Catalyst 8.08 RAM: 1011MB
Back to top
View user's profile Send private message
beso_1717
Apprentice
Apprentice


Joined: 19 Jul 2007
Posts: 263

PostPosted: Mon Oct 22, 2007 1:33 pm    Post subject: Reply with quote

i have a problem with the default settings options. i cannot configure paludis to read them. where do i have to put the export PALUDIS_OPTIONS="--options" thing?
Back to top
View user's profile Send private message
Penguin of Wonder
Apprentice
Apprentice


Joined: 17 Jan 2006
Posts: 280
Location: West Virginia

PostPosted: Mon Oct 22, 2007 2:02 pm    Post subject: Reply with quote

In your bashrc file, but not the one in /etc/paludis. The other one.
_________________
My Linux Blog

AMD64 3700+
2G DDR 3200 Ram
320G HDD
Back to top
View user's profile Send private message
beso_1717
Apprentice
Apprentice


Joined: 19 Jul 2007
Posts: 263

PostPosted: Mon Oct 22, 2007 3:28 pm    Post subject: Reply with quote

what other bashrc?!
Back to top
View user's profile Send private message
Penguin of Wonder
Apprentice
Apprentice


Joined: 17 Jan 2006
Posts: 280
Location: West Virginia

PostPosted: Mon Oct 22, 2007 3:58 pm    Post subject: Reply with quote

The one in your ~/ directory. The one that modifies everything you do in the terminal.
_________________
My Linux Blog

AMD64 3700+
2G DDR 3200 Ram
320G HDD
Back to top
View user's profile Send private message
beso_1717
Apprentice
Apprentice


Joined: 19 Jul 2007
Posts: 263

PostPosted: Mon Oct 22, 2007 5:49 pm    Post subject: Reply with quote

that doesn't work!!!! there's no way to put the export PALUDIS_OPTIONS in ~/.bashrc and make paludis get 'em.... there's no real guide about using that. i've done some browsing around but i wasn't able to find nothing useful. it's pretty annoying to always type the options manually...
Back to top
View user's profile Send private message
Penguin of Wonder
Apprentice
Apprentice


Joined: 17 Jan 2006
Posts: 280
Location: West Virginia

PostPosted: Mon Oct 22, 2007 6:03 pm    Post subject: Reply with quote

beso_1717 wrote:
that doesn't work!!!! there's no way to put the export PALUDIS_OPTIONS in ~/.bashrc and make paludis get 'em.... there's no real guide about using that. i've done some browsing around but i wasn't able to find nothing useful. it's pretty annoying to always type the options manually...


Actually it does work.

alias paludis='paludis --crazy-default-option'

Next time read.
_________________
My Linux Blog

AMD64 3700+
2G DDR 3200 Ram
320G HDD
Back to top
View user's profile Send private message
tecknojunky
Veteran
Veteran


Joined: 19 Oct 2002
Posts: 1937
Location: Montréal

PostPosted: Wed Oct 24, 2007 3:23 pm    Post subject: Reply with quote

I was wondering... can you use the ebuild command on paludis base builds?

For example, I had OpenOffice prevented to be installed by the collision-protect script. OO takes 36-40 hours to build on my system and doing "ebuild /usr/portage/app-office/openoffice/openoffice-2.3.0.ebuild qmerge" would have been quite neat, but I'm unsure if it would be compatible with Paludis file tracking system.
_________________
(7 of 9) Installing star-trek/species-8.4.7.2::talax.
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... , 13, 14, 15  Next
Page 14 of 15

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum