Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Typo in fstab configuration in guide? *SOLVED*
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
piratetitan
n00b
n00b


Joined: 12 May 2007
Posts: 7

PostPosted: Sat May 12, 2007 6:21 pm    Post subject: Typo in fstab configuration in guide? *SOLVED* Reply with quote

Alright, so I was installing Gentoo agian since I messed it up the first time by following different guides, and strictly followed the Cell-Overlay guide and used a graphical livecd. I got through it all easily, and rebooted my PS3. Then Gentoo booted up and I started to get this:

Code:

Mounting Local Filesystems...
mount: wrong fs type, bad option, bad superblock on none, missing codepage


Well, after a while of messing around with Gentoo I had no idea what to do, so I manually started to mount each filesystem one by one, and when I got to the spu filesystem I got the error. In the guide the fstab has this:

Code:

none    /spu    spufs   default    0 0


I assumed that this is what it should be:

Code:

none    /spu    spufs   defaults    0 0


Then I rebooted and everything mounted fine.

Just wanted to make sure that you guys knew (pretty sure you already did). Just delete this if its already been reported. 8)


Last edited by piratetitan on Sun May 13, 2007 9:04 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32302
Location: 56N 3W

PostPosted: Sat May 12, 2007 6:41 pm    Post subject: Reply with quote

piratetitan,

Please check bugs.gentoo.org and report it there if its new. The devs don't always read the forums but they do take notice of bug reports
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
rangerpb
Developer
Developer


Joined: 19 Jan 2005
Posts: 147

PostPosted: Sun May 13, 2007 2:04 am    Post subject: Re: Typo in fstab configuration in guide? Reply with quote

piratetitan wrote:
Alright, so I was installing Gentoo agian since I messed it up the first time by following different guides, and strictly followed the Cell-Overlay guide and used a graphical livecd. I got through it all easily, and rebooted my PS3. Then Gentoo booted up and I started to get this:

Code:

Mounting Local Filesystems...
mount: wrong fs type, bad option, bad superblock on none, missing codepage


Well, after a while of messing around with Gentoo I had no idea what to do, so I manually started to mount each filesystem one by one, and when I got to the spu filesystem I got the error. In the guide the fstab has this:

Code:

none    /spu    spufs   default    0 0


I assumed that this is what it should be:

Code:

none    /spu    spufs   defaults    0 0


Then I rebooted and everything mounted fine.

Just wanted to make sure that you guys knew (pretty sure you already did). Just delete this if its already been reported. 8)


Which guide and which stage?
_________________
-->
rangerpb
<--
Back to top
View user's profile Send private message
piratetitan
n00b
n00b


Joined: 12 May 2007
Posts: 7

PostPosted: Sun May 13, 2007 2:49 am    Post subject: Hmm? Reply with quote

I used this guide: http://overlays.gentoo.org/proj/cell/wiki/InstallGentooOnPS3
and I used stage4 tarbell which I downloaded and a graphical live cd.

This really isn't a bug (since it isn't the system's fault or anything), just a typo in this part of the guide:

The option for the spu part of the fstab should be defaults instead of default.

(I can't remember what the orignal fstab from the installation was, as I just copied and pasted the guide's fstab and hence encountered the problem).

Code:
Given the prior disk partitioning scheme, you need to make sure /etc/fstab reflects the proper device naming. Here is an fstab entry with that assumption in mind:
 /etc/fstab: static file system information.
#
# noatime turns off atimes for increased performance (atimes normally aren't
# needed; notail increases performance of ReiserFS (at the expense of storage
# efficiency).  It's safe to drop the noatime options if you want and to
# switch between notail / tail freely.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#
# See the manpage fstab(5) for more information.
#

# <fs>                  <mountpoint>    <type>          <opts>          <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/sda1               /               ext3            noatime         0 1
/dev/sda2               none            swap            sw              0 0
/dev/sr0                /mnt/cdrom      iso9660         noauto,ro       0 0
#/dev/fd0               /mnt/floppy     auto            noauto          0 0

# NOTE: The next line is critical for boot!
proc                    /proc           proc            defaults        0 0

# glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
# POSIX shared memory (shm_open, shm_unlink).
# (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
#  use almost no memory if not populated with files)
shm                     /dev/shm        tmpfs           nodev,nosuid,noexec     0 0
none    /spu    spufs   default    0 0


I just posted this here to save someone else the trouble of trying to figure out what the problem is, since I'm new to linux and it took me quite a while to figure out what was wrong.
Back to top
View user's profile Send private message
rangerpb
Developer
Developer


Joined: 19 Jan 2005
Posts: 147

PostPosted: Sun May 13, 2007 12:22 pm    Post subject: Thanks Reply with quote

Cool, I will fix the guide. Thanks for the feedback. Can you add SOLVED to the topic?
_________________
-->
rangerpb
<--
Back to top
View user's profile Send private message
piratetitan
n00b
n00b


Joined: 12 May 2007
Posts: 7

PostPosted: Sun May 13, 2007 9:05 pm    Post subject: No Worries Reply with quote

No prob, and thanks.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum