Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kan ej få grup att villa boota eller fa bra grafisk bild
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
KinkyGolab
n00b
n00b


Joined: 22 May 2006
Posts: 11

PostPosted: Sat Apr 14, 2007 12:40 pm    Post subject: kan ej få grup att villa boota eller fa bra grafisk bild Reply with quote

hej nu har jag konfat instalaltionen på min gentoo 64bits har startat om den, men när grub kommer fram altså där jagväljer vilken jag vill boota upp så är bilden helt sjuk den är randig och prikig typ som grafik kortet är trasigt, men det är den ej (händer bara i grub)


om jag väljer en i boot menyn så får jag medelande



kan nån se vad jag har gjort fel i min grub

# Which listing to boot as default. 0 is the first, 1 the second etc.
default 0
# How many seconds to wait before the default listing is booted.
timeout 30
# Nice, fat splash-image to spice things up :)
# Comment out if you don't have a graphics card installed
splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title=Gentoo Linux 2.6.20-gentoo-r5
# Partition where the kernel image (or operating system) is located
root (hd0,2)
kernel /boot/kernel-2.6.20-gentoo-r5 root=/dev/sda3

title=Gentoo Linux 2.6.20-gentoo-r5 (rescue)
# Partition where the kernel image (or operating system) is located
root (hd0,0)
kernel /boot/kernel-2.6.20-gentoo-r5 root=/dev/sda3 init=/bin/bb

# The next four lines are only if you dualboot with a Windows system.
# In this case, Windows is hosted on /dev/hda6.
#title=Windows XP
#rootnoverify (hd0,5)
#makeactive
#chainloader +1


min / liger på sda3
boot liger på sda2
swap liger på sda1

min kernel heter /boot/kernel-2.6.20-gentoo-r5

efter jag har confat grub.conf så kör jag

grep -v rootfs /proc/mounts > /etc/mtab

sen

grub-install --no-floppy /dev/sda

då får jag mess
Installation finished. No error reported.
This is the contents of the device map /boot/grub/device.map.
Check if this is correct or not. If any of the lines is incorrect,
fix it and re-run the script `grub-install'.

sen bootar jag om systemet väljer en i grub menyn sen får jag medelande
Booting "gentoo Linux 2.6.20-gentoo-r5"
root (hd0,0)
filesystem typ unkncown, partion typ 0x83
kernel /boot/kernel-2.6.20-gentoo-r5 root=Dev/sda3


Error 17:Cannot mount selected partion

Press any key to continue...


ser nån nåt fel jag gör?, jag saknar lilo :,-((( mycket änklare tycker jag

alvarligt moste jag säga jag gillar mera lilo, men det funkar ej på 64bits ochdet är för jävligt :-/


PS: jag inakteverade splashimage=(hd0,0)/boot/grub/splash.xpm.gz då blev bilden bra altså gammla hederliga boot menyn, men får endå upp kan ej boota
_________________
// Sorry About My Spelling Im Dyslectic //
Back to top
View user's profile Send private message
KinkyGolab
n00b
n00b


Joined: 22 May 2006
Posts: 11

PostPosted: Sat Apr 14, 2007 2:26 pm    Post subject: Reply with quote

ingen som kan hjälpa mig? :(
_________________
// Sorry About My Spelling Im Dyslectic //
Back to top
View user's profile Send private message
Ehnvis
Guru
Guru


Joined: 13 Jun 2006
Posts: 305
Location: /dev/random

PostPosted: Sun Apr 15, 2007 6:44 am    Post subject: Reply with quote

Eftersom du har /boot på /dev/sda2 så borde root(hd0,2) vara root(hd0,1) istället.
Ändra för både din normala boot och din rescue boot. Detta borde fungera, om inte
så hojta igen.
_________________
HP NC 4010, Pentium-M 725 1.6GHz w/ 1Gb RAM, 60Gb Hitachi Travelstar.
Running Gentoo-2.6.21-r4 (again as 2.6.22 kernels hogs CPU), all but SD reader works fine.
Back to top
View user's profile Send private message
KinkyGolab
n00b
n00b


Joined: 22 May 2006
Posts: 11

PostPosted: Sun Apr 15, 2007 6:02 pm    Post subject: Reply with quote

tack så mycket nu fönkar det :). nu har jag en ny fråga, jag har börjat installera packet nu. jag har merkt att dom har börjat med nåt nytt sen jag körde gentoo sist när jag kör ex emerge -p mplayer så kommer massa flagor upp vete fan va det heter men dom typ visa gröna visa röda
menar domma

[ebuild N ] media-video/mplayer-1.0_rc2_pre20070321-r4 USE="X gtk iconv ipv6 mmx samba sse sse2 unicode -3dnow -3dnowext -a52 -aac -aalib -alsa (-altivec) -amr -arts -bidi -bindist -bl -cddb -cdparanoia -cpudetection -custom-cflags -debug -dga -directfb -doc -dts -dv -dvb -dvd -dvdnav -dvdread -enca -encode -esd -fbcon -ftp -ggi -gif -ivtv -jack -joystick -jpeg -libcaca -lirc -live -livecd -lzo -mad -md5sum -mmxext -mp2 -mp3 -musepack -nas -openal -opengl -oss -png -pnm -quicktime -radio -rar (-real) -rtc -sdl -speex -srt (-svga) -tga -theora -tivo -truetype -v4l -v4l2 (-vidix) -vorbis (-win32codecs) -x264 -xanim -xinerama -xv -xvid -xvmc -zoran" VIDEO_CARDS="mga s3virge tdfx vesa"

jag vet ju va dom är till ex läga till stöt i proget eller ta veck, nu är det så jag undrar det som den visar är det såna grejer den har lakt dit skelv när den installerar eller är det sånt den rekomenderar?

vad betyder fergerna?






Ehnvis wrote:
Eftersom du har /boot på /dev/sda2 så borde root(hd0,2) vara root(hd0,1) istället.
Ändra för både din normala boot och din rescue boot. Detta borde fungera, om inte
så hojta igen.

_________________
// Sorry About My Spelling Im Dyslectic //
Back to top
View user's profile Send private message
PanzerKanzler
Guru
Guru


Joined: 04 Dec 2005
Posts: 371
Location: Belgravia, London

PostPosted: Sun Apr 15, 2007 10:33 pm    Post subject: Reply with quote

Jag vet inte om det är samma i alla konsoler, men för mig (Konsole) betyder röda use-flaggor att de ska med, blå betyder att de inte ska med, och ljusgröna betyder att flaggan har ändrats sen sist.
_________________
If you've got nothing nice to say, you're probably not alone...
Back to top
View user's profile Send private message
Zev
n00b
n00b


Joined: 05 Nov 2006
Posts: 44

PostPosted: Mon Apr 16, 2007 8:19 am    Post subject: Reply with quote

PanzerKanzler wrote:
Jag vet inte om det är samma i alla konsoler, men för mig (Konsole) betyder röda use-flaggor att de ska med, blå betyder att de inte ska med, och ljusgröna betyder att flaggan har ändrats sen sist.


Samma här. Använder urxvt.

Quote:

# emerge -vp rxvt-unicode

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] x11-terms/rxvt-unicode-8.1 USE="perl truetype -iso14755" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum