Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem booting (self made) LiveCD[SOLVED]
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
JeliJami
Veteran
Veteran


Joined: 17 Jan 2006
Posts: 1086
Location: Belgium

PostPosted: Tue Apr 03, 2007 3:59 pm    Post subject: Reply with quote

look at this post: Problem booting (self made) LiveCD[SOLVED]

the author also had a problem with /dev/iseries/vcd*
_________________
Unanswered Post Initiative | Search | FAQ
Former username: davjel
Back to top
View user's profile Send private message
naclosagc
n00b
n00b


Joined: 26 Jan 2006
Posts: 12
Location: St Louis, MO

PostPosted: Tue Apr 03, 2007 4:10 pm    Post subject: Reply with quote

davjel wrote:
look at this post: Problem booting (self made) LiveCD[SOLVED]

the author also had a problem with /dev/iseries/vcd*


Thanks - may have found my problem - crosses fingers and toes . . .
_________________
Andy Carlson
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Tue Apr 03, 2007 5:57 pm    Post subject: Reply with quote

merged above three posts here.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
naclosagc
n00b
n00b


Joined: 26 Jan 2006
Posts: 12
Location: St Louis, MO

PostPosted: Tue Apr 03, 2007 6:43 pm    Post subject: Reply with quote

Didn't work. don't see where to go from here. the last thing I did was verify that ide was compiled in the kernel, which most of the board specific ide stuff was not. still didn't work.
_________________
Andy Carlson
Back to top
View user's profile Send private message
naclosagc
n00b
n00b


Joined: 26 Jan 2006
Posts: 12
Location: St Louis, MO

PostPosted: Tue Apr 03, 2007 7:06 pm    Post subject: Reply with quote

nixnut wrote:
merged above three posts here.


Since you merged the posts, could you take the [Solved} off - don't figure many people will look if its Solved. Thanks.
_________________
Andy Carlson
Back to top
View user's profile Send private message
nativemad
Developer
Developer


Joined: 30 Aug 2004
Posts: 839
Location: Switzerland

PostPosted: Wed Apr 04, 2007 12:17 pm    Post subject: Reply with quote

It seems that this iseries thing is really coming from genkernel....

Please remove the Line Nr. ~350 in /usr/share/genkernel/generic/initrd.scripts
The Line is:
Code:
DEVICES="$DEVICES /dev/iseries/vcd*"


Then, rebuild your initramdrive and the iso!

cheers
Back to top
View user's profile Send private message
newtonian
Guru
Guru


Joined: 19 Jan 2005
Posts: 456
Location: Hokkaido Japan

PostPosted: Mon Jan 14, 2008 4:00 pm    Post subject: Reply with quote

nativemad wrote:
It seems that this iseries thing is really coming from genkernel....

Please remove the Line Nr. ~350 in /usr/share/genkernel/generic/initrd.scripts
The Line is:
Code:
DEVICES="$DEVICES /dev/iseries/vcd*"


Then, rebuild your initramdrive and the iso!

cheers


Hi-
I followed this howto http://gentoo-wiki.com/HOWTO_build_a_LiveCD_from_scratch building my own kernel from scratch then running genkernel initrd

I'm having the same iseries issue.

Code:
>> Activating mdev
>> Making tmpfs for /newroot
>> Attempting to mount media:- /dev/hdc
>> Media found on /dev/iseries/vcd*
>> Determining root device...
>> Determining looptype ...
!! Invalid loop location: /livecd.squashfs
!! Please export LOOP with a valid location, or reboot and pass a proper loop=...
!! kernel command line!


Did as suggested in the quote:

Code:
bootstrapCD() {
        # Locate the cdrom device with our media on it.
        # CDROM DEVICES
        DEVICES="/dev/cdroms/* /dev/ide/cd/* /dev/sr*"
        # USB Keychain/Storage
        DEVICES="$DEVICES /dev/sd*"
        # IDE devices
        DEVICES="$DEVICES /dev/hd*"
        # USB using the USB Block Driver
###added comment        DEVICES="$DEVICES /dev/ubd* /dev/ubd/*"
        # iSeries devices
###added comment        DEVICES="$DEVICES /dev/iseries/vcd*"
        # The device was specified on the command line.  Shold we even be doing a
        # scan at this point?  I think not.
        [ -n "${CDROOT_DEV}" ] && DEVICES="$DEVICES ${CDROOT_DEV}"

        findcdmount $DEVICES
}


but that made vcd* turn to ubd* with the same result. My cd is loading as sr0
same as before initrd.scripts update and still giving the same
Quote:
"!! Invalid loop location: /livecd.squashfs " error.


This post http://forums.gentoo.org/viewtopic-t-550669-highlight-iseries+loop.html
shows the issue as solved by unpacking initramfs and adding a isofs module. I'd try that but I'm not sure howto unpack/pack initrmfs.

Any ideas appreciated.

Cheers,
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum