Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200703-19 ] LTSP: Authentication bypass in included LibVNCServer code
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1571

PostPosted: Mon Mar 19, 2007 12:26 am    Post subject: [ GLSA 200703-19 ] LTSP: Authentication bypass in included L Reply with quote

Gentoo Linux Security Advisory

Title: LTSP: Authentication bypass in included LibVNCServer code (GLSA 200703-19)
Severity: high
Exploitable: remote
Date: March 18, 2007
Bug(s): #142661
ID: 200703-19

Synopsis


LTSP includes a version of libVNCServer that is vulnerable to an
authentication bypass.


Background


The Linux Terminal Server Project adds thin-client support to Linux
servers.


Affected Packages

Package: net-misc/ltsp
Vulnerable: < 4.2-r1
Unaffected: >= 4.2-r1
Architectures: All supported architectures


Description


The LTSP server includes vulnerable LibVNCServer code, which fails to
properly validate protocol types effectively letting users decide what
protocol to use, such as "Type 1 - None" (GLSA-200608-05). The LTSP VNC
server will accept this security type, even if it is not offered by the
server.


Impact


An attacker could exploit this vulnerability to gain unauthorized
access with the privileges of the user running the VNC server.


Workaround


There is no known workaround at this time.


Resolution


All LTSP users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=net-misc/ltsp-4.2-r1"


References

CVE-2006-2450
GLSA 200608-05


Last edited by GLSA on Mon Jun 10, 2013 4:24 am; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum