Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200703-17 ] ulogd: Remote execution of arbitrary code
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1581

PostPosted: Sun Mar 18, 2007 10:26 pm    Post subject: [ GLSA 200703-17 ] ulogd: Remote execution of arbitrary code Reply with quote

Gentoo Linux Security Advisory

Title: ulogd: Remote execution of arbitrary code (GLSA 200703-17)
Severity: high
Exploitable: remote
Date: March 18, 2007
Bug(s): #161882
ID: 200703-17

Synopsis

ulogd contains a possible buffer overflow potentially allowing for the remote execution of arbitrary code.

Background

ulogd is a userspace daemon for netfilter related logging.

Affected Packages

Package: app-admin/ulogd
Vulnerable: < 1.23-r1
Unaffected: >= 1.23-r1
Architectures: All supported architectures


Description

SUSE reported unspecified buffer overflows in ulogd involving the calculation of string lengths.

Impact

A remote attacker could trigger a possible buffer overflow through unspecified vectors, potentially leading to the remote execution of arbitrary code with the rights of the user running the ulogd daemon, or more probably leading to the crash of the daemon.

Workaround

There is no known workaround at this time.

Resolution

All ulogd users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=app-admin/ulogd-1.23-r1"


References

CVE-2007-0460
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum