Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ALSA : can't load module. [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Frelon
Tux's lil' helper
Tux's lil' helper


Joined: 10 Oct 2004
Posts: 149
Location: France

PostPosted: Wed Mar 14, 2007 4:10 pm    Post subject: ALSA : can't load module. [SOLVED] Reply with quote

Hi,
I have an IbookG3 dual usb and got some trouble to start alsa. It used to works but since I have rebuild my system It do not :-(

I have hard compiled the drivers in the kernel (and followed the alsa guide) :

Code:

#
# I2C Hardware Bus support
#
...
...
CONFIG_I2C_POWERMAC=y
# CONFIG_I2C_MPC is not set
...
#
# Sound
#
CONFIG_SOUND=y
# CONFIG_DMASOUND_PMAC is not set

#
# Advanced Linux Sound Architecture
#
CONFIG_SND=y
CONFIG_SND_TIMER=y
CONFIG_SND_PCM=y
CONFIG_SND_SEQUENCER=y
CONFIG_SND_SEQ_DUMMY=y
CONFIG_SND_OSSEMUL=y
CONFIG_SND_MIXER_OSS=y
CONFIG_SND_PCM_OSS=y
CONFIG_SND_PCM_OSS_PLUGINS=y
CONFIG_SND_SEQUENCER_OSS=y
# CONFIG_SND_DYNAMIC_MINORS is not set
CONFIG_SND_SUPPORT_OLD_API=y
CONFIG_SND_VERBOSE_PROCFS=y                               

...
...#
# ALSA PowerMac devices
#
CONFIG_SND_POWERMAC=y
CONFIG_SND_POWERMAC_AUTO_DRC=y

#
# Apple Onboard Audio driver
#
# CONFIG_SND_AOA is not set
# CONFIG_SND_AOA_SOUNDBUS is not set


merged alsa-utils etc, and :

Code:

stanbook stan # /etc/init.d/alsasound start
 * Loading ALSA modules ...
 *   Loading: snd-card-0 ...
FATAL: Module snd_powermac not found.                                     [ ok ]
 * Restoring Mixer Levels ...
 * No mixer config in /var/lib/alsa/asound.state, you have to unmute you  [ ok ]


Any idea ??

Code:
stanbook stan # emerge -pv alsa-utils

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] media-sound/alsa-utils-1.0.14_rc2-r1  USE="midi nls" 0 kB


_________________
http://stan.openmod.org


Last edited by Frelon on Fri Mar 16, 2007 5:45 pm; edited 1 time in total
Back to top
View user's profile Send private message
JoseJX
Developer
Developer


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Wed Mar 14, 2007 5:45 pm    Post subject: Reply with quote

You have built in support, so there is no module to load. Is sound not working? Or are you just trying to get rid of the message?
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
Frelon
Tux's lil' helper
Tux's lil' helper


Joined: 10 Oct 2004
Posts: 149
Location: France

PostPosted: Wed Mar 14, 2007 5:53 pm    Post subject: Reply with quote

Quote:
You have built in support, so there is no module to load.


Yes, I do not understand why It try to load a module. I have modprobed nothing and follow the alsa-guide with the built-in approach.

Quote:
Is sound not working? Or are you just trying to get rid of the message?


No it is not :

Code:

stan@stanbook ~ $ alsamixer

alsamixer: function snd_ctl_open failed for default: No such device


Weird..
_________________
http://stan.openmod.org
Back to top
View user's profile Send private message
fb
l33t
l33t


Joined: 08 Dec 2003
Posts: 631
Location: New Zealand

PostPosted: Wed Mar 14, 2007 9:59 pm    Post subject: Reply with quote

At this point we should may be have a look at the following files:
Code:
/etc/modules.d/alsa
/etc/modules.autoload.d/kernel-2.6
Back to top
View user's profile Send private message
Frelon
Tux's lil' helper
Tux's lil' helper


Joined: 10 Oct 2004
Posts: 149
Location: France

PostPosted: Wed Mar 14, 2007 11:15 pm    Post subject: Reply with quote

Thx,

1. alsa :

Code:

stanbook modules.d # more alsa
# Alsa kernel modules' configuration file.

# ALSA portion
alias char-major-116 snd
# OSS/Free portion
alias char-major-14 soundcore

##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `modules-update' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
##  ALSA portion
## alias snd-card-0 snd-interwave
## alias snd-card-1 snd-ens1371
##  OSS/Free portion
## alias sound-slot-0 snd-card-0
## alias sound-slot-1 snd-card-1
##

# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
##  OSS/Free portion - card #2
## alias sound-service-1-0 snd-mixer-oss
## alias sound-service-1-3 snd-pcm-oss
## alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.
options snd cards_limit=1
stanbook modules.d #                                       



2. kernel-2.6 is empty.

3. modprobe.conf :

Code:

...
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss
alias snd-card-0 snd-powermac
alias sound-slot-0 snd-powermac
alias binfmt-0064 binfmt_aout
options sb io=0x220 irq=7 dma=1 dma16=5 mpu_io=0x330
options snd cards_limit=1
...

_________________
http://stan.openmod.org
Back to top
View user's profile Send private message
quatsch
Tux's lil' helper
Tux's lil' helper


Joined: 24 Apr 2005
Posts: 104
Location: New York, NY

PostPosted: Thu Mar 15, 2007 5:16 pm    Post subject: Reply with quote

do you by any chance have OSS sound support compiled into your kernel? I had a problem like yours recently on my x86 box and it seemed to be because for some reason the default config selected OSS along with ALSA. Just a thought.
Back to top
View user's profile Send private message
Frelon
Tux's lil' helper
Tux's lil' helper


Joined: 10 Oct 2004
Posts: 149
Location: France

PostPosted: Thu Mar 15, 2007 10:25 pm    Post subject: Reply with quote

Quote:

do you by any chance have OSS sound support compiled into your kernel?


Erf, no, it is not !!
_________________
http://stan.openmod.org
Back to top
View user's profile Send private message
Frelon
Tux's lil' helper
Tux's lil' helper


Joined: 10 Oct 2004
Posts: 149
Location: France

PostPosted: Fri Mar 16, 2007 5:46 pm    Post subject: Reply with quote

For the record, I have solved the problem by compiling snd-powermac as module.
_________________
http://stan.openmod.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum