Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Update 0.1.4.0_beta10 [git] --toolchain, --perl
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5 ... 9, 10, 11  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 2584
Location: The Peanut Gallery

PostPosted: Wed Sep 05, 2007 11:41 am    Post subject: Reply with quote

swimmer wrote:
Hmm - it happens to me on one (of three) system that if one package fails to compile/install the chain seemed to be borked ...
Code:
!! media-gfx/splashutils-1.5.1.1 failed to install.
! Failed so far: media-gfx/splashutils-1.5.1.1
Checking dependencies..done
** update: Dependency Error - media-video/dvdrip-0.98.8 requires [0.98.6] which is not in the install list!

It happened t ome quite often the last days on this system because splashutils does not build on it but I'm not sure whether the same happens as well on the other systems ... is this a known issue to you guys?

No it's not, thanks for reporting it swimmer; if you're on IRC, ask us in #friendly-coders but we'll put this on the list to sort out. We should get some failures from expat update ;)

Edit: do you have --verbose in your EMERGE_DEFAULT_OPTS by any chance? It looks like it's mistaking a prior version for an incoming one. There was another bug there, but I don't think that's what triggered that output.

Try this one md5sum: 564f32bb3ba84851b4a5a16d2cbda953
wget http://phpfi.com/261019?download -O /sbin/update; md5sum /sbin/update

I added a check for --verbose as well as --quiet, and it should now go up or down with -v or -q from there. (You could always do -vv or -qq but now they'll start off at -v or -q based on EMERGE_DEFAULT_OPTS in make.conf; so if it's set at --verbose and you use -q it'll go down to normal.)

HTH.
Back to top
View user's profile Send private message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 2584
Location: The Peanut Gallery

PostPosted: Thu Sep 06, 2007 2:43 am    Post subject: Reply with quote

ryz wrote:
I have found the problem. First param is set to "-uDN" and then it calls checkFlags which ads another minus '-'. Either param should just be set to uDN or checkFlags has to check that if param is not empty that it does not already has an minus in front.

Absolutely right; we did have this changed in working version (and I think I mentioned it to bunkacid on irc) but I totally forgot to put it into the beta release. My bad :S Sorry for not being awake before either ;)
Code:

elif [[ $# -eq 1 && $1 = -* && ! $1 = *[^sqvpaFSCRM-]* ]]; then
   target='world'
   param='-uDN'
   if [[ $1 = *[FSCRM]* ]]; then
      doEmerge=0
      target=[none]
   fi
   [[ $1 = *M* && $1 = *[SCR]* ]] && msg 'M covers all maintenance options'
   checkFlags "$1"

All we did was move the last two lines up to the beginning of that block. beta_2b has this change (post above.) If it tests ok, I'll put it in original post.

Edit: Thanks for the bugfixing btw, sorry for hassle. set -x is good isn't it? :D (help set and help shopt)
Back to top
View user's profile Send private message
swimmer
Veteran
Veteran


Joined: 15 Jul 2002
Posts: 1291
Location: Netherlands

PostPosted: Thu Sep 06, 2007 7:51 am    Post subject: Reply with quote

steveL wrote:
No it's not, thanks for reporting it swimmer; if you're
on IRC, ask us in #friendly-coders but we'll put this on the list to
sort out. We should get some failures from expat update ;)

Edit: do you have --verbose in your EMERGE_DEFAULT_OPTS by any chance?
It looks like it's mistaking a prior version for an incoming one. There
was another bug there, but I don't think that's what triggered that
output.

Try this one md5sum: 564f32bb3ba84851b4a5a16d2cbda953
wget http://phpfi.com/261019?download -O /sbin/update; md5sum /sbin/update

I added a check for --verbose as well as --quiet, and it should now go
up or down with -v or -q from there. (You could always do -vv or -qq but
now they'll start off at -v or -q based on EMERGE_DEFAULT_OPTS in
make.conf; so if it's set at --verbose and you use -q it'll go down to
normal.)

HTH.


Hi Steve :)

I do not use --verbose in my EMERGE_DEFAULT_OPTS ... but thanks for the fast
response and solution offered :)

I downloaded beta2b and will use it - the only problem is that I solved my
problem with splashutils and the emerge chain is now clean again ... no more
testcase :-/ Sorry about that.

Thanks again for the fast work
swimmer
Back to top
View user's profile Send private message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 2584
Location: The Peanut Gallery

PostPosted: Thu Sep 06, 2007 10:32 am    Post subject: Reply with quote

swimmer wrote:
I do not use --verbose in my EMERGE_DEFAULT_OPTS ... but thanks for the fast
response and solution offered :)

I downloaded beta2b and will use it - the only problem is that I solved my
problem with splashutils and the emerge chain is now clean again ... no more
testcase :-/ Sorry about that.

Hmm OK, that's odd then. I tried testing by setting it to fail automatically and it seemed to be ok; one problem was if one of the pkgs was blocked due to dep failing (eg device-mapper/udev) but it was giving us a message and had the package name highlighted. I'll tweak that for next beta.
Back to top
View user's profile Send private message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 2584
Location: The Peanut Gallery

PostPosted: Fri Sep 14, 2007 9:52 am    Post subject: Reply with quote

Beta 2c, minor bugfix for resume display bug. While I was there, took new resume code from development version, as it was written a while ago, and has been refined a bit as well. I really like it-- you'll only see it when there's more than 10 packages to emerge. They are sorted according to category, with the categories in order of emerge, nicely coloured. Toolchain and rebuilds are broken out of the compact listing:
Code:
dev-libs        Upgrade         expat libIDL
                New             fcgi
                Upgrade         openssl
sys-fs          Upgrade         device-mapper udev
media-sound     Upgrade         alsa-headers lame alsa-utils alsa-tools timidity++
sys-apps        Upgrade         busybox ed parted man-pages debianutils
app-arch        Upgrade         tar
media-libs      Upgrade         libpng libvorbis alsa-lib alsa-oss gstreamer openexr openal smpeg flac gst-plugins-base
sys-devel       Upgrade         gettext autoconf libtool
net-misc        Upgrade         rsync
                New             mDNSResponder
                Upgrade         curl openssh
dev-java        New             java-sdk-docs
app-admin       Upgrade         eselect-oodict
                New             apache-tools
app-text        Upgrade         multitail sgml-common
Rebuild         aspell          USE="gpm -examples% -nls"
                Upgrade         poppler gnome-doc-utils tetex
sys-kernel      New             gentoo-sources
dev-perl        Upgrade         XML-Parser
                New             XML-LibXML-Common
                Upgrade         XML-SAX
                New             XML-LibXML
                Upgrade         XML-Simple
perl-core       Upgrade         Test-Simple
virtual         New             perl-Test-Simple
gnome-base      Upgrade         gnome-mime-data libbonobo libglade gconf gnome-keyring librsvg gnome-vfs libgnome libgnomeprint libgnomeprintui libbonoboui
 libgnomeui
dev-lang        Upgrade         tcl tk mono
Rebuild         ghc             USE="doc -bash-completion% -binary -ghcbootstrap"
x11-proto       Upgrade         inputproto compositeproto
net-libs        Upgrade         libpcap libnfsidmap
app-doc         Upgrade         xorg-docs
sys-process     Upgrade         psmisc
dev-scheme      Upgrade         gambit
x11-libs        Upgrade         libX11 libXi libXtst libXcomposite libXfont startup-notification fltk cairo pango libwnck vte
app-crypt       Upgrade         mit-krb5
x11-apps        Upgrade         iceauth setxkbmap xhost xrandr xinit
app-portage     Upgrade         eix kuroo
media-gfx       New             nvidia-cg-toolkit
                Upgrade         sane-backends
www-misc        Upgrade         htdig
dev-util        Upgrade         bouml catalyst gtk-doc devhelp quilt glade git bzr bzrtools
x11-misc        Upgrade         shared-mime-info icon-naming-utils
dev-cpp         Upgrade         libxmlpp
dev-dotnet      Upgrade         libgdiplus
x11-terms       Upgrade         xterm
x11-wm          Upgrade         fluxbox
x11-themes      Upgrade         gnome-icon-theme
dev-python      Upgrade         setuptools pyorbit
                New             PyQt
                Upgrade         pycurl gnome-python
net-dns         Upgrade         libidn
media-video     Upgrade         realplayer
gnome-extra     Upgrade         zenity evolution-data-server
media-plugins
Rebuild         libvisual-plugins USE="alsa gtk jack mplayer opengl -debug -esd (-gstreamer%*)"
                Upgrade         gst-plugins-alsa gst-plugins-oss gst-plugins-xvideo gst-plugins-x
kde-base        Upgrade         kdelibs libkonq kdesu libkdenetwork libkmime kdebase-data kghostview kcminit kpersonalizer ktnef cervisia kate librss
 khotkeys kcheckpass ksmserver kwin kreadconfig ksplashml mimelib libksieve kdeaddons-docs-konq-plugins quanta kcalc kde-i18n nsplugins kmenuedit
 kcachegrind klinkstatus kimagemapeditor kommander kompare kfilereplace libkcal kicker knewsticker kfind kdepasswd kate-plugins kicker-applets
 knewsticker-scripts kdepim-kioslaves certmanager kdeprint kpdf kcontrol khelpcenter konsole kdesdk-kioslaves kdm kmail libkdepim libkpimidentities kontact
 kaddressbook knotes knode kaddressbook-plugins kdesktop kdebase-kioslaves kdebase-startkde konqueror kviewshell kdvi konq-plugins
net-irc         Upgrade         konversation
net-nds
Rebuild         openldap        USE="berkdb crypt gdbm kerberos odbc perl readline sasl ssl tcpd -debug -ipv6 -minimal -overlays -samba* (-selinux) -slp -smbkrb5passwd"
dev-php         Upgrade         roadsend-php
app-emulation   Upgrade         wine
x11-base        Upgrade         xorg-server
x11-drivers     Upgrade         xf86-input-mouse xf86-video-nv
www-servers     Upgrade         lighttpd apache
dev-haskell     New             regex-base regex-posix regex-compat filepath
                Upgrade         mtl
* 205 in total
! There are blocking packages:
[blocks B     ] <kde-base/kdesktop-3.5.6-r1 (is blocking kde-base/kdebase-kioslaves-3.5.7-r1)
[blocks B     ] <=kde-base/kmail-3.5.6-r1 (is blocking kde-base/libkdepim-3.5.7-r1)
Upgrading kde-base/kdesktop to 3.5.7 from 3.5.5-r1
Upgrading kde-base/kmail to 3.5.7-r2 from 3.5.5-r2
About to proceed (Y/n)?

It looks much nicer on screen. Yes I still need to do expat, update is going to do it all for me thanks! ;P
Back to top
View user's profile Send private message
swimmer
Veteran
Veteran


Joined: 15 Jul 2002
Posts: 1291
Location: Netherlands

PostPosted: Tue Sep 18, 2007 8:23 am    Post subject: Reply with quote

Hi SteveL,

the error/bug is back! :)

Code:
tj portage # update
** Emerging -uDN world then running revdep-rebuild
[...]
!! media-libs/alsa-lib-1.0.15_rc2 failed to install.
Packages installed so far: 5 of 6.      2 remaining
! Failed so far: media-libs/alsa-lib-1.0.15_rc2
Checking dependencies..done
** update: Dependency Error - media-sound/alsa-utils-1.0.15_rc1 requires [1.0.14] which is not in the install list!

Version=0.1.4.0_beta2c

I use the same version on 4 PC's and alsa-lib failed on every single of them but the error above only showed up on *one* of them?!?
The only difference that I can see is that I use EMERGE_DEFAULT_OPTS="--color y" on the 'erroneous' PC - I'll disable it for now and will see if that has any influence ...

And there are more strange differences: after compiling all the packages *except* alsa-lib the update process stops on 3 of 4 PC's - only on 1 (not the same with the error above btw.) asks if I want to continue with a revdep-rebuild. Strange ...

EDIT: Stupid me, on the PC's revdep-rebuild does not come in I have an alias for update: "update -D" :-/ Is emerge -aUDNR still default?

Greetz
swimmer

PS: I normally download the script on my main PC and distribute it via scp to the others - should be no difference ...


Last edited by swimmer on Tue Sep 18, 2007 9:17 am; edited 1 time in total
Back to top
View user's profile Send private message
swimmer
Veteran
Veteran


Joined: 15 Jul 2002
Posts: 1291
Location: Netherlands

PostPosted: Tue Sep 18, 2007 9:03 am    Post subject: Reply with quote

Ok - after commenting out EMERGE_DEFAULT_OPTS="--color y" the script works as presumed - it even asks if I want to continue with a revdep-rebuild ;-)

As far as I can see the script handles only "--quiet" and "--verbose" - very other option specified let's it bail out ...

HTH
swimmer
Back to top
View user's profile Send private message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 2584
Location: The Peanut Gallery

PostPosted: Tue Sep 18, 2007 2:02 pm    Post subject: Reply with quote

swimmer wrote:
the error/bug is back! :)

Oh noes! ;P Glad it got sorted; added support for --color in EMERGE_DEFAULT_OPTS.
Quote:
Is emerge -aUDNR still default?

Yeah, as long as you don't specify a target (like world/system or some package) and only use (any of) the following options: sqvpaFSR.
Quote:
I normally download the script on my main PC and distribute it via scp to the others - should be no difference ...

None at all, it's just a text file. I think bunkacid had an ebuild, but we're not too worried about that til we get this version finished. Still got to do the config file update at some point, never mind depclean, prelink, eclean blah blah blah ;)
Quote:
As far as I can see the script handles only "--quiet" and "--verbose" - very other option specified let's it bail out ...

OK I've added --color y/n (or Y/N) support (found a small bug in resume while I was looking at this, when you're resuming after the main install has happened, or there never was a main install.) This was a little bit tricky because of the interaction with NOCOLOR, but hopefully it should all be good. I won't put it on front page til tested (gotta go out now, so can't stress it atm.)
md5: e537c100060fe7603bcb0c7864ea3757 http://phpfi.com/263554
wget http://phpfi.com/263554?download -O /sbin/update
Wrt to the other options, can you specify which ones break it? It's a PITA checking them TBH.

Thanks for your troubleshooting, Swimmer, hope this one works better ;)
Back to top
View user's profile Send private message
swimmer
Veteran
Veteran


Joined: 15 Jul 2002
Posts: 1291
Location: Netherlands

PostPosted: Tue Sep 18, 2007 2:12 pm    Post subject: Reply with quote

Ok - thanks for your fast reaction!

I'll be away the next 10 days so no time to troubleshoot ;-)

Greetz
swimmer
Back to top
View user's profile Send private message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 2584
Location: The Peanut Gallery

PostPosted: Tue Sep 18, 2007 5:33 pm    Post subject: Reply with quote

swimmer wrote:
I'll be away the next 10 days so no time to troubleshoot ;-)

No worries; have a good one! :-)
Back to top
View user's profile Send private message
Pol
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2003
Posts: 111

PostPosted: Mon Sep 24, 2007 10:15 am    Post subject: Reply with quote

Hello,

I have found a small bug...

When there are no more place left on the device, the script hang ... without exiting...

I discovered it when I did a genlop -c on a update of bzip ;)
Back to top
View user's profile Send private message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 2584
Location: The Peanut Gallery

PostPosted: Tue Sep 25, 2007 2:43 pm    Post subject: Reply with quote

Pol wrote:
I have found a small bug...

When there are no more place left on the device, the script hang ... without exiting...

I discovered it when I did a genlop -c on a update of bzip ;)

Thanks for the bug report, Pol. You mean if the hard disk (with /var/tmp/portage on it) is out of room? Hmm that's not good. Does emerge exit in that situation?
Back to top
View user's profile Send private message
Pol
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2003
Posts: 111

PostPosted: Tue Sep 25, 2007 2:55 pm    Post subject: Reply with quote

steveL wrote:
Pol wrote:
I have found a small bug...

When there are no more place left on the device, the script hang ... without exiting...

I discovered it when I did a genlop -c on a update of bzip ;)

Thanks for the bug report, Pol. You mean if the hard disk (with /var/tmp/portage on it) is out of room? Hmm that's not good. Does emerge exit in that situation?


Hello,

Yes emerge exit ;)

I use tmpfs (http://gentoo-wiki.com/TIP_Speeding_up_portage_with_tmpfs) and when /var/tmp/portage is full, thing that happens sometimes... the script does nothing... it doesn't exit, emerge does.

Thx for that script btw, it's very nice!

Bye
Back to top
View user's profile Send private message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 2584
Location: The Peanut Gallery

PostPosted: Wed Sep 26, 2007 2:57 pm    Post subject: Reply with quote

Pol wrote:
steveL wrote:
Thanks for the bug report, Pol. You mean if the hard disk (with /var/tmp/portage on it) is out of room? Hmm that's not good. Does emerge exit in that situation?


Yes emerge exit ;)

OK I'll have a look at this tonight and we'll have something fixed in a couple of days, tops.
Quote:
I use tmpfs (http://gentoo-wiki.com/TIP_Speeding_up_portage_with_tmpfs) and when /var/tmp/portage is full, thing that happens sometimes... the script does nothing... it doesn't exit, emerge does.

OK, you should know that the -m option does this too. size=256 should be in /etc/update and is the default, giving you 256MB of tmpfs. You can ofc set it to whatever you like (I haven't tested it for ages, but nothing's changed with it, so I don't see why it should have stopped working :)
Quote:
Thx for that script btw, it's very nice!

You're very welcome!
Back to top
View user's profile Send private message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 2584
Location: The Peanut Gallery

PostPosted: Wed Nov 07, 2007 9:03 am    Post subject: Reply with quote

New version. Gah didn't fix the outta space thing yet, sorry. This one has major changes (it's the one we've been working on for the last couple of months while only minor fixes have been going out.) As ever, bug reports welcome :)
Back to top
View user's profile Send private message
lowtexx
n00b
n00b


Joined: 31 Jan 2006
Posts: 12

PostPosted: Wed Nov 21, 2007 7:15 pm    Post subject: Reply with quote

hi,

I found a problem in the new 0.1.4.0_beta3a version.
After an error I get the message:
Code:

!! No packages compiled successfully on this run, aborting.
/sbin/update: line 623: needMaint: command not found

needMaint seems to be defined. Is this a known problem?

cu
lowtexx
Back to top
View user's profile Send private message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 2584
Location: The Peanut Gallery

PostPosted: Wed Nov 21, 2007 8:36 pm    Post subject: Reply with quote

lowtexx wrote:
I found a problem in the new 0.1.4.0_beta3a version.
After an error I get the message:
Code:

!! No packages compiled successfully on this run, aborting.
/sbin/update: line 623: needMaint: command not found

needMaint seems to be defined. Is this a known problem?

Hi lowtexx it hasn't shown before, but it is a bug. This should have fixed it:
wget http://dev.gentooexperimental.org/~igli/src/update/update-20071121 -O /sbin/update
md5sum: 026ff7fee5953d37f4a6f5c43ea7b794
HTH.
Serves me right for messing about with aliases ;p
Back to top
View user's profile Send private message
palchen
n00b
n00b


Joined: 29 Dec 2007
Posts: 10

PostPosted: Sat Dec 29, 2007 6:48 pm    Post subject: Re: Update 0.1.4_beta3b -- expat/binhosts the way we like ' Reply with quote

I am stuck! The script stops while trying to install parted-1.8.7. I cannot emerge that version parted either but can emerge parted-1.8.8.
Would you please tell me where to change the package version as referenced by the update script?
Thanks a mill.
Back to top
View user's profile Send private message
Naib
Advocate
Advocate


Joined: 21 May 2004
Posts: 4138
Location: Removed by Neddy

PostPosted: Sat Dec 29, 2007 7:30 pm    Post subject: Re: Update 0.1.4_beta3b -- expat/binhosts the way we like ' Reply with quote

palchen wrote:
I am stuck! The script stops while trying to install parted-1.8.7. I cannot emerge that version parted either but can emerge parted-1.8.8.
Would you please tell me where to change the package version as referenced by the update script?
Thanks a mill.


if you just type emerge parted -vp what does it display
_________________
A free press is the unsleeping guardian of every other right that free men prize; it is the most dangerous foe of tyranny. Where men have the habit of liberty, the Press will continue to be the vigilant guardian of the rights of the ordinary citizen.
Back to top
View user's profile Send private message
palchen
n00b
n00b


Joined: 29 Dec 2007
Posts: 10

PostPosted: Sat Dec 29, 2007 7:50 pm    Post subject: Re: Update 0.1.4_beta3b -- expat/binhosts the way we like ' Reply with quote

Naib wrote:
palchen wrote:
I am stuck! The script stops while trying to install parted-1.8.7. I cannot emerge that version parted either but can emerge parted-1.8.8.
Would you please tell me where to change the package version as referenced by the update script?
Thanks a mill.


if you just type emerge parted -vp what does it display


This is what is displayed - thanks for the reply (I'm a noob with emerge ...)

emerge -vp parted

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] sys-apps/parted-1.8.8 USE="nls readline -debug -device-mapper (-selinux)" 0 kB

When the script hung on installing parted-1.8.7 I stopped the script and tried an emerge and it too hung while trying to download parted-1.8.7.
I figured that the repository had changed as this world update had been running for about 20hrs. I did an emerge --sync (my bad I guess).
emerge -av parted does however install 1.8.8 which the update script tries to downgrade and hangs at the download stage?
Back to top
View user's profile Send private message
Naib
Advocate
Advocate


Joined: 21 May 2004
Posts: 4138
Location: Removed by Neddy

PostPosted: Sat Dec 29, 2007 8:15 pm    Post subject: Reply with quote

ok so it sounds more like a src download issue.

"update" is at its core a wrapper around emerge (a very clever wrapper I might add ;) ) so when you type "update foo" what it eventually does is "emerge foo" (sorry steveL for reducing the script to its core).

So two interesting things here

1) there is no timeout/retries on the source (iirc there is an /etc/make.conf option)
2) portage is trying to install a version of parted that is, as far as your profile is concerned, depreciated

The only reason why an older version of a certain package is being pulled in/installed is because another application has got a setting that say "no newer versions"

What is the EXACT line you are typing when you are using update and also what is the output of emerge world -uvDp <= this might show what the real package that is giving issues is
_________________
A free press is the unsleeping guardian of every other right that free men prize; it is the most dangerous foe of tyranny. Where men have the habit of liberty, the Press will continue to be the vigilant guardian of the rights of the ordinary citizen.
Back to top
View user's profile Send private message
palchen
n00b
n00b


Joined: 29 Dec 2007
Posts: 10

PostPosted: Sat Dec 29, 2007 8:30 pm    Post subject: Reply with quote

What is the EXACT line you are typing when you are using update

simply "update"

and also what is the output of emerge world -uvDp <= this might show what the real package that is giving issues is[/quote]


emerge world -uvDp

These are the packages that would be merged, in order:

Calculating world dependencies |
!!! Multiple versions within a single package slot have been
!!! pulled into the dependency graph:

x11-base/xorg-server:0

('ebuild', '/', 'x11-base/xorg-server-1.4-r4', 'merge') pulled in by
('ebuild', '/', 'net-misc/vnc-4.1.2-r5', 'merge')

('ebuild', '/', 'x11-base/xorg-server-1.4.0.90', 'merge') pulled in by
('installed', '/', 'x11-drivers/xf86-input-elographics-1.1.0', 'nomerge')
('ebuild', '/', 'x11-drivers/ati-drivers-8.443.1-r1', 'merge')
('ebuild', '/', 'x11-drivers/xf86-input-magellan-1.1.1', 'merge')
(and 77 more)

The script has been running for about 20hrs so I guess the above comes from that.

Then all the packages are listed with the following at the bottom:
Total: 359 packages (335 upgrades, 2 downgrades, 20 new, 2 in new slots), Size of downloads: 1,629,406 kB

An "emerge -av =parted-1.8.7" also fails while trying to download while an "emerge -av parted" pulls in 1.8.8??
Back to top
View user's profile Send private message
Naib
Advocate
Advocate


Joined: 21 May 2004
Posts: 4138
Location: Removed by Neddy

PostPosted: Sat Dec 29, 2007 8:44 pm    Post subject: Reply with quote

ok type this:

update -p

need to see what update is trying to pull in AND in what order and for what reason. This is more a package dependency issue just causing problems with update/portage
_________________
A free press is the unsleeping guardian of every other right that free men prize; it is the most dangerous foe of tyranny. Where men have the habit of liberty, the Press will continue to be the vigilant guardian of the rights of the ordinary citizen.
Back to top
View user's profile Send private message
palchen
n00b
n00b


Joined: 29 Dec 2007
Posts: 10

PostPosted: Sat Dec 29, 2007 9:39 pm    Post subject: Reply with quote

[quote="Naib"]ok type this:

update -p

Not compiling www-client/mozilla-firefox-2.0.0.11
Not compiling app-office/openoffice-2.3.1
* 362 in total
** 2 Downgrades:
app-admin/equo-0.9.21 [9999-r2]
net-wireless/wpa_supplicant-0.5.8 [0.6.0-r10] USE="dbus gnutls gsm madwifi qt3 qt4 readline ssl"
wpa_supplicant-0.5.7.ebuild, wpa_supplicant-0.5.8.ebuild,
wpa_supplicant-0.6.0.ebuild:
wpa_supplicant requires libs from /usr so it's moving back. Symlinks are in
place so that baselayout still works.
Toolchain: sys-kernel/linux-headers is being upgraded
! sys-kernel/linux-headers (2.6.23) is newer than running kernel (2.6.22)
- so it will not be installed; upgrade your kernel first
@ Not compiling sys-libs/glibc-2.7-r1
@ Not compiling sys-kernel/linux-headers-2.6.23-r2
dev-libs/expat-2.0.0 does not match from (<2) - you might wish to edit /etc/warning.
# The list of packages to be emerged is saved in /root/emerge/emergeList
# Skipped: www-client/mozilla-firefox-2.0.0.11 app-office/openoffice-2.3.1
sys-kernel/linux-headers (2.6.23) is newer than running kernel (2.6.22)

This is the only difference with the previous posting. There are 362 apps, do you want me to post all of the results?

I need some sleep and will continue this tomorrow.
Making a data backup :)

Thanks for your assistance.
Back to top
View user's profile Send private message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 2584
Location: The Peanut Gallery

PostPosted: Mon Dec 31, 2007 12:11 am    Post subject: Reply with quote

palchen wrote:
An "emerge -av =parted-1.8.7" also fails while trying to download while an "emerge -av parted" pulls in 1.8.8??

If it's really just the download stage you can download the file from ftp://ftp.gnu.org/gnu/parted/parted-1.8.7.tar.bz2 [1] and save it in /usr/portage/distfiles.
1.8.7 is marked unstable on most architectures, and 1.8.8 has been out for quite some time. Your best bet to sort this out is to log onto irc.freenode.org and ask in #gentoo, or we're in #friendly-coders. This really is a tree issue (the xorg thing is one too.) As Naib, said update is simply a fancy wrapper for emerge; as you've seen the problems show when you run vanilla emerge. (Not that update never borks; it just tends to shout with two red exclamation marks when something serious happens, and real bugs usually have a stack trace.)

To really see what's pulling it in, run emerge -puDNt world but do not post it directly here; it'll be pages and pages of output, and it takes some deciphering. Use a pastebin (I'd save it for a month) and post the link here or on irc.

You'll more likely get a quicker result on IRC tbh; there are always hundreds of people in #gentoo who are willing to help, and they're always up on what's going on in the tree.

[1] http://www.gnu.org/software/parted/ has link to mirrors, btw, if you need a nearer one.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, 4, 5 ... 9, 10, 11  Next
Page 4 of 11

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum