Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Cannot emerge php, mysql configure failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
torbjornlu
n00b
n00b


Joined: 26 Feb 2007
Posts: 4

PostPosted: Mon Feb 26, 2007 10:08 am    Post subject: [solved] Cannot emerge php, mysql configure failed Reply with quote

Hi,

I've recently installed mysql and it works but when I now try to install php I get the followin error:
Code:
checking for MySQL UNIX socket location... /var/run/mysqld/mysqld.sock
checking for mysql_close in -lmysqlclient... no
checking for mysql_error in -lmysqlclient... no
configure: error: mysql configure failed. Please check config.log for more information.

!!! ERROR: dev-lang/php-5.1.6-r6 failed.
Call stack:
  ebuild.sh, line 1539:   Called dyn_compile
  ebuild.sh, line 939:   Called src_compile
  php-5.1.6-r6.ebuild, line 173:   Called src_compile_normal
  php-5.1.6-r6.ebuild, line 323:   Called php5_1-sapi_src_compile
  php5_1-sapi.eclass, line 576:   Called die


config.log did not give me any more info.

Any ideas?

Thanks
/Torbjörn


Last edited by torbjornlu on Wed Feb 28, 2007 7:31 pm; edited 1 time in total
Back to top
View user's profile Send private message
SLBMEH
Apprentice
Apprentice


Joined: 16 Aug 2003
Posts: 299
Location: Pittsburgh, PA

PostPosted: Mon Feb 26, 2007 10:21 am    Post subject: Reply with quote

what are your use flags in /etc/make.conf and your package specific use flags for mysql and php in /etc/package.use

also what profile are you using

Code:
ls -l /etc/make.profile

_________________
Steve - Semper Fi
Back to top
View user's profile Send private message
torbjornlu
n00b
n00b


Joined: 26 Feb 2007
Posts: 4

PostPosted: Mon Feb 26, 2007 10:46 am    Post subject: Reply with quote

/etc/make.conf
Code:
USE=" fastcgi perl php python ruby apache2 -X alsa -arts avi -berkdb -bitmap-fonts -cairo -cdr cd
rom cli crypt -cups -dbus -dlloader -dri dvb dvbplayer dvd -dvdr dxr3 dxr3-audio-denoise eds elib
c_glibc emacs -emboss encode esd fam ffmpeg -firefox -fortran ftp gdbm -gif gmail -gnome gpm gstr
eamer -gtk hal input_devices_evdev input_devices_keyboard input_devices_mouse -ipv6 -isdnlog jpeg
 -kde kernel_linux ldap libg++ lirc mad mikmod mp3 mpeg msql mysql ncurses net nfs nls nptl nptlo
nly ntfs ogg -opengl oss -pam pcre pdflib perl php png -ppds -pppd python -qt3 -qt4 -quicktime re
adline reflection rsh ruby sdl se_swedb sendmail session sockets spell spl -sql ssl tcpd -truetyp
e -truetype-fonts tv_check tv_pick_cgi -type1-fonts udev unicode userland_GNU v4l v4l2 vdr vorbis
 win32codecs x86 xml -xorg -xv zlib"

/etc/portage/package.use
Code:
dev-ruby/rails mysql fastcgi

profile:
Code:
lrwxrwxrwx 1 root root 48 Jan  2 21:45 /etc/make.profile -> ../usr/portage/profiles/default-linux/x86/2006.1


Hope that will clarify
Back to top
View user's profile Send private message
SLBMEH
Apprentice
Apprentice


Joined: 16 Aug 2003
Posts: 299
Location: Pittsburgh, PA

PostPosted: Mon Feb 26, 2007 11:00 am    Post subject: Reply with quote

hmm... try

Code:
emerge -uDv mysql


and then make sure it's initialized and then try to reemerge php.
_________________
Steve - Semper Fi
Back to top
View user's profile Send private message
torbjornlu
n00b
n00b


Joined: 26 Feb 2007
Posts: 4

PostPosted: Mon Feb 26, 2007 4:45 pm    Post subject: Reply with quote

I tried that, a lot was updated but then the same error appeared when emerging php.

But what do you mean with "make sure it's initialized"? I have a database up an running in mysql but do I need to do more?

Regards
Back to top
View user's profile Send private message
nixnut
Administrator
Administrator


Joined: 09 Apr 2004
Posts: 10973
Location: the dutch mountains

PostPosted: Mon Feb 26, 2007 5:40 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Networking & Security.
Not about getting gentoo installed, so moved here.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Sen
n00b
n00b


Joined: 09 Sep 2005
Posts: 10

PostPosted: Tue Feb 27, 2007 9:27 am    Post subject: Reply with quote

Try to remove msql from your use flags in the beginning mysql emerge says that the use flag msql has support for software not in portage yet.
it dit the trick for me so :)
_________________
Plug in plug out
Back to top
View user's profile Send private message
torbjornlu
n00b
n00b


Joined: 26 Feb 2007
Posts: 4

PostPosted: Wed Feb 28, 2007 7:29 pm    Post subject: [solved] Cannot emerge php, mysql configure failed Reply with quote

That did it! Thanks a lot!

So dont use both msql and mysql in your USE-variable when installing php.

/Torbjörn :D
Back to top
View user's profile Send private message
kunitoki
n00b
n00b


Joined: 05 Dec 2006
Posts: 13
Location: Venice - Italy

PostPosted: Fri Aug 10, 2007 7:49 am    Post subject: Reply with quote

i had the same problem. i think that having enabled "msql" and "mysql" when compiling PHP should produce a notice for the user.

asking for a gentoo dev to update the php ebuild...
_________________
the jucetice pit
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum