Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: qmail vpopmail courier-imap qmail-scanner (02/2007)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
skydion
n00b
n00b


Joined: 06 Oct 2006
Posts: 3

PostPosted: Thu Nov 01, 2007 10:54 am    Post subject: Smtp auth Reply with quote

How can I turn on obligatory smtp auth? I have next problem, when I connect to my smtp server over telnet session
I can send mail without auth command, I don't now how I can turn on this command?
Back to top
View user's profile Send private message
petterg
Guru
Guru


Joined: 25 Mar 2004
Posts: 460
Location: Oslo, Norway

PostPosted: Tue Nov 06, 2007 4:20 pm    Post subject: Re: Smtp auth Reply with quote

skydion wrote:
How can I turn on obligatory smtp auth? I have next problem, when I connect to my smtp server over telnet session
I can send mail without auth command, I don't now how I can turn on this command?


I don't remember, but I'm sure it's stated in the guide. Just search for "auth" in the first post of this thread, and you'll find.
Back to top
View user's profile Send private message
lmegliol
n00b
n00b


Joined: 12 Sep 2005
Posts: 68

PostPosted: Wed Dec 19, 2007 3:15 pm    Post subject: Reply with quote

Are there any updates to this HOWTO for netqmail 1.05-r8?

Attempting to edit netqmail 1.05-r8.ebuild following the instructions in step 2 is no longer obvious. The instructions say to look for "use ssl && append-flags -DTLS" and append some lines after that line. But that line is now commented out of the ebuild file, and a comment states that "-DTLS is now set by the SSL/TLS patch". Since I am just blindly following instructions to get this all working, I do not know the implications of these commented out lines. Should I continue to following the directions and insert the lines that are supposed to follow?

In any case, I have tried that using a fresh Gentoo install, and notlsbeforeauth will not show up on the "emerge -pv netqmail" command that is supposed to verify that the notlsbeforeauth is showing up.

For the record, PORTDIR_OVERLAY is correctly set and I have downloaded the patch. (Is the patch still valid for r8?)

Thanks.
Back to top
View user's profile Send private message
lmegliol
n00b
n00b


Joined: 12 Sep 2005
Posts: 68

PostPosted: Mon Dec 24, 2007 12:48 am    Post subject: Reply with quote

OK, so I decided to mask anything higher than the version of netqmail used in this thread. I've followed all of the instructions to the letter. Sending email works well. But for some unknown reason, I cannot log in to POP3 or IMAP. If I telnet into the POP3 port, I connect to the server. When I give it the username and password, I get an error. If I have my mail client try it, also an error. I turned off iptables to be sure that there are no network problems.

I ran the following to test whether vpopmail has the correct password and is querying correctly:

Code:

printf "lmegliol@domain.com\0XXXXXXXX\0blah\0" | vchkpw `which id` 3<&0


(Obviously I used a real password.)

And the output of that command confirms that it is working correctly. I've even reinstalled the entire OS, starting from scratch twice now, hoping that there is something that I have just done wrong. But after all three installations, I end up with the same problem. Logging into POP3 and IMAP does not work.

My only thought now is that I only masked netqmail and not any of the other packages. There may be something in one of the other packages that is causing the problem. I will try to mask the others and hope for the best.

In the meantime, does anyone have any insights as to what the problem might be?
Back to top
View user's profile Send private message
Erik Olofsson
n00b
n00b


Joined: 31 Dec 2007
Posts: 2

PostPosted: Mon Dec 31, 2007 9:20 am    Post subject: QMS log analyzer Reply with quote

I started getting errors in the qms-log_cron script today:
date: invalid date `2007-11-31'

This can be fixed by changing the relevant lines in 'qms-log_cron' to:
Code:

# Parse the current date
#datestr=`date`
#dom=`date --date="${datestr}" +%d`
#monthnum=`date --date="${datestr}" +%m`
#year=`date --date="${datestr}" +%Y`

#[ "${monthnum}" == "01" ] && monthnum="13" && let "year=${year}-1"
#let "monthnum=${monthnum}-1"
datestr=`date --date="-1 month" +"%a, %d %b %Y"`
Back to top
View user's profile Send private message
maiku
Guru
Guru


Joined: 24 Mar 2004
Posts: 500
Location: Long Island, NY

PostPosted: Fri Feb 01, 2008 1:31 am    Post subject: Reply with quote

With this configuration, would one be able to set spamassassin rules on a per-user basis? For example, let's say one user wants to whitelist all messages from a domain or wans his spam score to be different from everybody else's?
_________________
- Mike A. Leonetti
Back to top
View user's profile Send private message
vult
n00b
n00b


Joined: 13 May 2006
Posts: 24
Location: Poland -> Łódź

PostPosted: Mon Feb 04, 2008 2:38 pm    Post subject: maybe a bit OT Reply with quote

Hello,

sorry for OT but I know you are somehow connected to qmail and maybe you can help.

The question is how to ban some certain IP when they try to f.e. break to an account bruteforcing the password. Log says that IP is trying to send email f.e. 20 times per second. Can I block somehow this tries?

Thanks in advance, and sorry again for OT.
_________________
-v-
Back to top
View user's profile Send private message
stiret
n00b
n00b


Joined: 22 Dec 2003
Posts: 6

PostPosted: Wed May 21, 2008 2:32 pm    Post subject: rcptchk Reply with quote

Hello again,

I know it's been over a year since I posted on this, but I've just returned from Iraq and I would like to get rcptchk working if possible.

ns1 chkuser_pg # ./vpopchk.sh notavaliduser notmydomain.com ; echo $?
notavaliduser - notmydomain.com
111
ns1 chkuser_pg # ./vpopchk.sh notavaliduser mydomain.com ; echo $?
notavaliduser - mydomain.com
40
ns1 chkuser_pg # ./vpopchk.sh validuser mydomain.com ; echo $?
validuser - mydomain.com
0
ns1 chkuser_pg # ./vpopchk.sh validalias mydomain.com ; echo $?
validalias - mydomain.com
4

Thanks,

Scott
Back to top
View user's profile Send private message
petterg
Guru
Guru


Joined: 25 Mar 2004
Posts: 460
Location: Oslo, Norway

PostPosted: Mon Jul 07, 2008 8:47 am    Post subject: Reply with quote

I'm doing a new server install at the moment, and writing an updated guide while doing it. I don't have much time these days, so it's moving slow.


Some late reply to your questions:
stiret: Isn't the rcptchk running ok? Remember errorlevels is used to signal status. It's not like errorlevel != 0 equals error

vult
I have a loganalyser running on my servers that detects bad password entries in the logfiles. When an IP has provided more than 3 bad passwords within 5 minutes it creates a rule in iptables to block that ip. It works with ssh, smtp, pop, imap and apache.
The idea was good. The problem is that iptables get too many rules and makes the whole system slow. I have no good ideas of how to implement a cleanup for iptables. Rules must be deleted after a while...
The other thing I'd like an implementation for is bounced spam - spammers using an adress on my domain as sender when they send out spam. Hence my server get thousands of bounced spammails, within a short periode of time. All of them from different ip's. This kneels spamassassin and qmail starts to let mail through unchecked.

If anyone would like to work on this stuff, I'll be happy to assist.

maiku
Yes, spamassassin supports individual userrules. Read the spamassassin manual. However, I don't know of any userfriendly interface to administrate this. It should be posible to make as a plugin to squirrelmail or qmailadmin. Actually I'd like most user settings available from squirrelmail... wonder if anyone has created plugins for such?
Back to top
View user's profile Send private message
Erik Olofsson
n00b
n00b


Joined: 31 Dec 2007
Posts: 2

PostPosted: Mon Jul 28, 2008 9:49 pm    Post subject: qmail and vpopmail dying Reply with quote

The latest emerge left courier-authlib not being able to authenticate against vpopmail. The vpopmail support has been removed and according to this qmail and vpopmail are dying projects:
http://www.usenet-forums.com/courier-imap/392330-courier-users-courier-authlib-vpopmail.html

I was able to get it working again by adding to /etc/portage/package.mask:
>net-libs/courier-authlib-0.58

So the question is what are my options here... Is it easy to migrate the mailboxes to another server solution? Which solution should I aim for?
Back to top
View user's profile Send private message
maiku
Guru
Guru


Joined: 24 Mar 2004
Posts: 500
Location: Long Island, NY

PostPosted: Tue Jul 29, 2008 12:22 am    Post subject: Reply with quote

Try qmail without vpopmail. It is supposed to be able to support virtual domains anyway. Try emerging webmin to manage your mailboxes and aliases.
_________________
- Mike A. Leonetti
Back to top
View user's profile Send private message
jiri.tyr
n00b
n00b


Joined: 08 Feb 2005
Posts: 26
Location: Czech Republic

PostPosted: Mon Sep 08, 2008 7:51 am    Post subject: Replace courier-authlib with dovecot Reply with quote

Try my HOW-TO:

http://forums.gentoo.org/viewtopic-t-706798-highlight-vpopmail+dovecot.html
Back to top
View user's profile Send private message
vklimovs
n00b
n00b


Joined: 15 Dec 2005
Posts: 20

PostPosted: Sun May 31, 2009 3:57 pm    Post subject: Reply with quote

It is possible to use latest versions of courier-authlib, if vpopmail is (was) using MySQL:
http://en.gentoo-wiki.com/wiki/Courier-authlib_with_MySQL
Back to top
View user's profile Send private message
rockier
n00b
n00b


Joined: 01 Jan 2005
Posts: 19

PostPosted: Fri Sep 25, 2009 12:23 am    Post subject: Reply with quote

I created a new machine and when I installed netqmail everything looked ok but I could not recieve e-mail thru the pop3d.
I followed the steps in this tread. Thanks for the great help on this tread.

What I have found is the courier-authlib is not installing the libauthvchkpw files.

What I have done is copied them from another install and everything started working.

The big question is where is the files and how does one get them if they do not have another machine to get them from?

I hope this helps someone having the same problems.
Back to top
View user's profile Send private message
vklimovs
n00b
n00b


Joined: 15 Dec 2005
Posts: 20

PostPosted: Fri Sep 25, 2009 8:01 am    Post subject: Reply with quote

Quote:
The big question is where is the files and how does one get them if they do not have another machine to get them from?


The authvchkpw is not maintained anymore, hence not installed. But you don't need that. See http://en.gentoo-wiki.com/wiki/Courier-authlib_with_MySQL
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6
Page 6 of 6

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum