Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
TinyGentoo chroot problem [solved - workaround]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
konan
n00b
n00b


Joined: 13 Sep 2006
Posts: 13

PostPosted: Tue Jan 16, 2007 12:42 pm    Post subject: TinyGentoo chroot problem [solved - workaround] Reply with quote

I'm following install on http://gentoo-wiki.com/TinyGentoo, but when I do env-update it gives me error:

Code:
gentoo opt # chroot i586-gentoo-uclibc-linux /bin/bash --login
I have no name!@gentoo / $ env-update
Traceback (most recent call last):
  File "/usr/sbin/env-update", line 27, in ?
    import portage
  File "/usr/lib/portage/pym/portage.py", line 75, in ?
    from portage_data import ostype, lchown, userland, secpass, uid, wheelgid, \
  File "/usr/lib/portage/pym/portage_data.py", line 85, in ?
    if secpass < 1 and portage_gid in os.getgroups():
OSError: [Errno 38] Function not implemented
I have no name!@gentoo / $


If I try to execute emerge it gives me:
Code:
I have no name!@gentoo / $ emerge
Traceback (most recent call last):
  File "/usr/bin/emerge", line 28, in ?
    import portage
  File "/usr/lib/portage/pym/portage.py", line 75, in ?
    from portage_data import ostype, lchown, userland, secpass, uid, wheelgid, \
  File "/usr/lib/portage/pym/portage_data.py", line 85, in ?
    if secpass < 1 and portage_gid in os.getgroups():
OSError: [Errno 38] Function not implemented
I have no name!@gentoo / $


What is wrong?

I tryed to use all 3 stages, but it gives me same error.


Last edited by konan on Fri Jan 19, 2007 8:33 am; edited 1 time in total
Back to top
View user's profile Send private message
wynn
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2416
Location: UK

PostPosted: Tue Jan 16, 2007 4:24 pm    Post subject: Reply with quote

Mount /proc on i586-gentoo-uclibc-linux/proc before the chroot.

"Function not implemented" seems to be connected to a missing /proc tree.

There's no text on http://gentoo-wiki.com/TinyGentoo 8O
_________________
The avatar is jorma, a "duck" from "Elephants Dream": the film and all the production materials have been made available under a Creative Commons Attribution 2.5 License, see orange.blender.org for details.
Back to top
View user's profile Send private message
konan
n00b
n00b


Joined: 13 Sep 2006
Posts: 13

PostPosted: Tue Jan 16, 2007 10:55 pm    Post subject: Reply with quote

I did mount proc. I also mounted /dev and tryed with mounting /usr/portage and with fresh portage-snapshot from web ...
Always same error...

Any idea?


No text? i think link is ok ...
Back to top
View user's profile Send private message
tiketti
n00b
n00b


Joined: 29 Apr 2003
Posts: 32
Location: Finland

PostPosted: Wed Jan 17, 2007 3:23 pm    Post subject: Reply with quote

On what kind of enviroment you try to chroot? 32/64bit? Kernel version?

I'm using chrooted stage3-x86-uclibc-2006.1 for compiling stuff for my VIA C3 based network appliance and had no problem following the instructions of TinyGentoo.
_________________
Gentoo on x86, sparc, alpha, amd64, embedded
Back to top
View user's profile Send private message
konan
n00b
n00b


Joined: 13 Sep 2006
Posts: 13

PostPosted: Wed Jan 17, 2007 10:01 pm    Post subject: Reply with quote

32bit system
2006.1 gentoo
installed from install-x86-minimal-2006.1.iso and stage3-x86-2006.1.tar.bz2 -> I followed Gentoo Handbook
Fresh install

Code:

uname -a
Linux gentoo 2.6.18-gentoo-r6 #1 SMP Wed Jan 17 14:43:19 CET 2007 i686 Intel(R) Celeron(R) CPU 2.60GHz GenuineIntel GNU/Linux


Code:
cat /etc/make.conf
# These settings were set by the catalyst build script that automatically built this stage
# Please consult /etc/make.conf.example for a more detailed example
CFLAGS="-O2 -mtune=pentium4 -pipe"
CHOST="i386-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j2"

USE="-X -gnome -kde -gtk -gtk2 -qt3 -qt4 -alsa"

GENTOO_MIRRORS="ftp://mirrors.tera-byte.com/pub/gentoo ftp://distro.ibiblio.org/pub/linux/distributions/gentoo/ ftp://ftp.gtlib.gatech.edu/pub/gentoo "

SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"



If you need any additional info, please let me know!
Back to top
View user's profile Send private message
tiketti
n00b
n00b


Joined: 29 Apr 2003
Posts: 32
Location: Finland

PostPosted: Thu Jan 18, 2007 2:58 pm    Post subject: Reply with quote

Which stage3-file you used exactly?
_________________
Gentoo on x86, sparc, alpha, amd64, embedded
Back to top
View user's profile Send private message
konan
n00b
n00b


Joined: 13 Sep 2006
Posts: 13

PostPosted: Fri Jan 19, 2007 8:32 am    Post subject: Reply with quote

I try to compile tinygentoo on opensuse and it worked like a charm ... I make-my-wish-come-true .. :)

Ps: I used stage3-x86-uclibc-2006.1.tar.bz2 from two diferent mirrors. Really don't know hwat wrong!

Thanx for help!

Cheers
Back to top
View user's profile Send private message
bw32
n00b
n00b


Joined: 21 Nov 2006
Posts: 3

PostPosted: Mon Jan 29, 2007 2:40 am    Post subject: Reply with quote

Same problem here. Can someone help out? I don't want to complie tinygentoo stage3. is there any other way?

stage3-x86-uclibc-2006.1.tar.bz2
portage-latest.tar.bz2
Back to top
View user's profile Send private message
fireball
n00b
n00b


Joined: 31 Jan 2007
Posts: 1

PostPosted: Wed Jan 31, 2007 11:07 pm    Post subject: Reply with quote

I'm seeing this too.

Tinygentoo instructions are talking about cross compiling. Is it strictly necessary to do it that way?
Back to top
View user's profile Send private message
wynn
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2416
Location: UK

PostPosted: Thu Feb 01, 2007 8:04 pm    Post subject: Reply with quote

To try and clear things up, I have used the TinyGentoo instructions to install it (the URL in the first post has a comma tagged on to the end, that's why it gave a blank page).

The stage was stage3-x86-uclibc-2006.1.tar.bz2 and the MD5 and SHA1 checksums were OK — the signature on .DIGESTS was verified too.

Here is the first part of emerge --info for the host Gentoo
Code:
# emerge --info
Portage 2.1.1-r2 (default-linux/x86/2006.1, gcc-4.1.1, glibc-2.4-r4, 2.6.18-gentoo-r6 i686)
=================================================================
System uname: 2.6.18-gentoo-r6 i686 AMD Athlon(TM) XP 3000+
Gentoo Base System version 1.12.6
Last Sync: Thu, 01 Feb 2007 09:00:01 +0000
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: [Not Present]
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
and here is the one for the TinyGentoo installation
Code:
# emerge --info
Portage 2.1.1-r2 (uclibc/x86, gcc-4.1.1, uclibc-0.9.28.1-r0, 2.6.18-gentoo-r6 i686)
=================================================================
System uname: 2.6.18-gentoo-r6 i686 AMD Athlon(TM) XP 3000+
Gentoo Base System version 1.12.6
Last Sync: Thu, 01 Feb 2007 09:00:01 +0000
ccache version 2.4 [enabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: [Not Present]
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
dev-util/confcache:  [Not Present]
Everything up to
Code:
# ROOT=/tinygentoo USE=make-symlinks emerge -avkN baselayout-lite uclibc busybox
has worked without problems.

The TinyGentoo make.conf is
Code:
# cat /etc/make.conf
# These settings were set by the catalyst build script that automatically built this stage
# Please consult /etc/make.conf.example for a more detailed example
CFLAGS="-march=athlon-xp -Os -pipe"
CHOST="i386-gentoo-linux-uclibc"
CXXFLAGS="-Os -pipe"
LDFLAGS="-Wl,-z,relro"
FEATURES="ccache buildpkg" # To use previously built packages, use the -k option with emerge
USE="minimal"
PKGDIR="${PORTDIR}/packages/uclibc" # Store .tbz2's in their own directory
UCLIBC_CPU=K7
just leaving out the MIRRORS and SYNC lines.

After
Code:
mount --bind /usr/portage /mnt/gentoo_uclibc/usr/portage
mount --bind /dev /mnt/gentoo_uclibc/dev
mount -t proc proc /mnt/gentoo_uclibc/proc
chroot /mnt/gentoo_uclibc/ /bin/bash
env-update && source /etc/profile
it is suggested that you "mount --bind" the distfiles directory — but this is already mounted because /usr/portage is mounted. Also, on checking /dev after unpacking the stage3 tarball, it seemed full of all the things the host Gentoo system /dev had so it wasn't mounted either.

Further, the OP had
Code:
chroot i586-gentoo-uclibc-linux /bin/bash --login
instead of just "/bin/bash", also there was no "source /etc/profile" after "env-update": this might have been a cause of the trouble.

All the rest, up to
Code:
ROOT=/tinygentoo USE=make-symlinks emerge -avkN baselayout-lite uclibc busybox
worked — including the revdep-rebuild which found nothing to rebuild.

This last emerge failed because of a missing keyword and nothing seems to get round that.
_________________
The avatar is jorma, a "duck" from "Elephants Dream": the film and all the production materials have been made available under a Creative Commons Attribution 2.5 License, see orange.blender.org for details.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum