Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[XFCE4] Version 4.4
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
TrizoLakai
Apprentice
Apprentice


Joined: 09 Jun 2006
Posts: 231
Location: Nantes (FRANCE)

PostPosted: Thu Feb 01, 2007 6:53 pm    Post subject: [XFCE4] Version 4.4 Reply with quote

Pour ceux qui sont à la traine comme moi : http://linuxfr.org/2007/01/22/21946.html

On commence par un sync :
Code:
emerge --sync

ou
Code:
paludis -s



Dans votre /etc/portage/package.unmask ou /etc/paludis/package_unmask.conf
Code:
##
## XFCE 4.4
xfce-base/libxfce4util
xfce-base/libxfce4mcs
xfce-base/libxfcegui4
xfce-base/xfce4-panel
xfce-base/xfce-mcs-manager
xfce-extra/xfce4-mixer
xfce-base/xfprint
xfce-base/xfce-mcs-plugins
xfce-extra/xfce4-icon-theme
xfce-extra/mousepad
xfce-extra/exo
xfce-extra/terminal
xfce-base/orage
xfce-base/thunar
xfce-base/xfdesktop
xfce-extra/xfce4-appfinder
xfce-base/xfce-utils
xfce-base/xfwm4
x11-themes/gtk-engines-xfce
xfce-base/xfce4-session
xfce-extra/xfwm4-themes
xfce-base/xfce4
xfce-extra/xfce4-clipman
xfce-extra/xfce4-datetime
xfce-extra/xfce4-diskperf
xfce-extra/xfce4-genmon
xfce-extra/xfce4-mount
xfce-extra/xfce4-notes
xfce-extra/xfce4-quicklauncher
xfce-extra/xfce4-sensors
xfce-extra/xfce4-smartbookmark
xfce-extra/xfce4-systemload
xfce-extra/xfce4-weather
xfce-extra/xfce4-xfapplet
xfce-extra/xfce4-xkb
xfce-extra/xfce4-wavelan
xfce-extra/xfce4-dev-tools


Puis :
Paludis :
Code:
paludis -u xfce-extra/xfcalendar xfce-base/xffm xfce-extra/xfce4-iconbox xfce-extra/xfce4-trigger-launcher xfce-extra/xfce4-toys xfce-extra/xfce4-systray


Emerge :
Code:
emerge -C xfce-extra/xfcalendar xfce-base/xffm xfce-extra/xfce4-iconbox xfce-extra/xfce4-trigger-launcher xfce-extra/xfce4-toys xfce-extra/xfce4-systray



Et enfin :
Code:
paludis -i xfce4 xfce-base/xfprint  x11-themes/gtk-engines-xfce

ou
Code:
emerge xfce4 xfce-base/xfprint  x11-themes/gtk-engines-xfce



Note : la USE "minimal" est intégrée, ce qui est bien appréciable :)


Last edited by TrizoLakai on Mon Feb 05, 2007 8:27 pm; edited 1 time in total
Back to top
View user's profile Send private message
Tuxicomane
Apprentice
Apprentice


Joined: 14 Nov 2006
Posts: 290
Location: Val-de-Marne, FRANCE

PostPosted: Thu Feb 01, 2007 11:40 pm    Post subject: Reply with quote

Eh bien écoute, merci, j'avais pas vu cette nouvelle version, du coup je la teste :D
(et puis si c'est concluant, je l'utiliserais complètement, je commencais à me lasser de fluxbox )
Back to top
View user's profile Send private message
CryoGen
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1425
Location: Bamako - Mali - Afrique

PostPosted: Fri Feb 02, 2007 12:03 am    Post subject: Reply with quote

Moi je le savais depuis longtemps :P (faut dire que j'utilise la 4.4 depuis la _rc2 ;) )
XFce4.4 + Beryl/Emerald ca roXX :twisted:
_________________
- CryoGen` on #gentoofr@irc.freenode.net
- ~amd64 / KDE4
- I'm the bone of my sword...
Back to top
View user's profile Send private message
Tuxicomane
Apprentice
Apprentice


Joined: 14 Nov 2006
Posts: 290
Location: Val-de-Marne, FRANCE

PostPosted: Fri Feb 02, 2007 12:07 am    Post subject: Reply with quote

Pour Beryl, je veux pas installer de drivers propriétaires, donc c'est mort :D

Sinon il est masqué, mais bon pour l'instant j'ai même pas entrevu le bout d'un bug, c'est cool !
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5530
Location: ~Brussels - Belgique

PostPosted: Fri Feb 02, 2007 8:32 am    Post subject: Reply with quote

Ah XFCE, je viens de virer Gnome il y a 2 jours (en ayant constaté que je n'utilisais de Gnome que le menu), et j'en suis hyper content (surtout que Beryl fonctionne avec) :D

J'attendrai que la 4.4 passe en ~arch, je suis parfois patient 8)
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
lmarcini
Guru
Guru


Joined: 21 Jul 2004
Posts: 531
Location: Champagne sur Seine (France)

PostPosted: Fri Feb 02, 2007 9:16 am    Post subject: Reply with quote

XFCE est vraiment très bien : homogène, peu gourmand, simple sans être austère et réactif... Et pourtant, je suis un KDEiste convaincu :-)

Nota : j'avais utilisé intensivement la version 4.4 bêta il y a quelques mois sur une Arch Linux et c'était déjà impressionnant de stabilité et de rapidité...
_________________
umount /dev/brain
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4912

PostPosted: Fri Feb 02, 2007 9:33 am    Post subject: Reply with quote

Je la testerais bien à l'occasion cette nouvelle version.

Mais je sais pas ce qui se passe avec moi: plus ça va et plus je veux de l'épuré. Je suis passé par fvwm, xfce4, fluxbox...
Un ami m'a fait découvrir http://www.suckless.org/wiki/wmii et c'est bien sympa!

Si ça continue je vais finir en mode console only.

[edit] ben tenez, il vient de me passer ce lien, pour ceux qui aime l'épuré: http://modeemi.cs.tut.fi/~tuomov/ion/ [/edit]
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
nemo13
Veteran
Veteran


Joined: 08 Oct 2004
Posts: 1016
Location: France/Istres

PostPosted: Sun Feb 04, 2007 10:13 pm    Post subject: Re: [XFCE4] Version 4.4 Reply with quote

TrizoLakai wrote:
Pour ceux qui sont à la traine comme moi :
Dans votre /etc/portage/package.unmask ou /etc/paludis/package_unmask.conf
Code:
##
## XFCE 4.4
.....
xfce-base/xfprint
....

Emerge :
Code:
emerge -C xfce-extra/xfcalendar xfce-base/xffm xfce-extra/xfce4-iconbox xfce-extra/xfce4-trigger-launcher xfce-extra/xfce4-toys xfce-extra/xfce4-systray

Bonsoir TrizoLakai,
il faudrait rajouter xfce-base/xfprint dans la liste des paquets à unmerger car sinon il se passe un truc marrant : :?
tu n'accèdes pas au gestionnaire de paramètres et à tout ce qui touche de près à des modifications de configuration xfce.
on peux s'en "appercevoir" en lançant dans un terminal :
Code:
xfce-alsa

le message suivant apparait lorsqu'on veut modifier les options alsa :
Quote:
(xfce-mcs-manager:5163): xfce-mcs-manager-WARNING **: Module /usr/lib/xfce4/mcs-plugins/xfprint_plugin.so cannot be opened (libxfcegui4.so.3: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou répertoire de ce type)

bien évidement /usr/lib/xfce4/mcs-plugins/xfprint_plugin.so existe 8O
mais en faisant :
Code:
eix xfce-base/xfprint
c'est xfce-base/xfprint-4.2.3
d'où l'embrouille.
je n'en suis sorti par :
Code:
sudo emerge -C =xfce-base/xfprint-4.2.3
sudo emerge -C =x11-themes/gtk-engines-xfce-2.2.8
sudo emerge -avt xfce-base/xfprint

au passage rajoute aussi x11-themes/gtk-engines-xfce car :
Code:
 equery depends gtk-engines-xfce
[ Searching for packages depending on gtk-engines-xfce... ]
xfce-base/xfce4-4.4.0 (>=x11-themes/gtk-engines-xfce-2.4)
xfce-base/xfprint-4.2.3 (>=x11-themes/gtk-engines-xfce-2.2.5)

voili-voila
Merci à toi pour m'avoir donnée l'envie d'installer xfce4.4
A+
Nota : qui pourrait m'expliquer la relation entre xfprint et les divers panneaux de conf de xfce ?
Back to top
View user's profile Send private message
nonas
Guru
Guru


Joined: 17 Apr 2005
Posts: 328

PostPosted: Mon Feb 05, 2007 1:23 am    Post subject: Reply with quote

kwenspc wrote:
Je la testerais bien à l'occasion cette nouvelle version.

Mais je sais pas ce qui se passe avec moi: plus ça va et plus je veux de l'épuré. Je suis passé par fvwm, xfce4, fluxbox...
Un ami m'a fait découvrir http://www.suckless.org/wiki/wmii et c'est bien sympa!

Si ça continue je vais finir en mode console only.

[edit] ben tenez, il vient de me passer ce lien, pour ceux qui aime l'épuré: http://modeemi.cs.tut.fi/~tuomov/ion/ [/edit]
Pour de l'ultraminimaliste tu peux aussi regarder du côté de dwm (http://www.suckless.org/wiki/dwm), c'est un wmii en encore plus léger.
Y'a pas mal d'exemples dans le Monthly Screenshots actuel (http://forums.gentoo.org/viewtopic-t-536501.html)

Je retesterai XFCE à l'occasion, j'ai utilisé la 4.2 pendant longtemps mais je suis sous openbox en ce moment.
Back to top
View user's profile Send private message
TrizoLakai
Apprentice
Apprentice


Joined: 09 Jun 2006
Posts: 231
Location: Nantes (FRANCE)

PostPosted: Mon Feb 05, 2007 8:27 pm    Post subject: Reply with quote

Voila mis à jour. :)
Back to top
View user's profile Send private message
DuF
Advocate
Advocate


Joined: 09 Dec 2002
Posts: 2647
Location: Paris

PostPosted: Tue Feb 06, 2007 10:37 am    Post subject: Reply with quote

Bonjour,

Je pense que la mise à jour n'est pas complète, il faut ajouter xfprint lors de la phase "emerge --unmerge ...." ce qui nous donne :
Code:
emerge -C xfce-extra/xfcalendar xfce-base/xffm xfce-extra/xfce4-iconbox xfce-extra/xfce4-trigger-launcher xfce-extra/xfce4-toys xfce-extra/xfce4-systray xfce-base/xfprint


Et je pense qu'il n'est pas utile d'ajouter xfprint lors de l'emerge de fin car il semble être en dépendance, ce qui donne :
Code:
emerge xfce4 x11-themes/gtk-engines-xfce


Cdt
Back to top
View user's profile Send private message
nemo13
Veteran
Veteran


Joined: 08 Oct 2004
Posts: 1016
Location: France/Istres

PostPosted: Tue Feb 06, 2007 2:26 pm    Post subject: Reply with quote

DuF wrote:
Bonjour,

Je pense que la mise à jour n'est pas complète, il faut ajouter xfprint lors de la phase "emerge --unmerge ...." ce qui nous donne :
Code:
emerge -C xfce-extra/xfcalendar xfce-base/xffm xfce-extra/xfce4-iconbox xfce-extra/xfce4-trigger-launcher xfce-extra/xfce4-toys xfce-extra/xfce4-systray xfce-base/xfprint


Et je pense qu'il n'est pas utile d'ajouter xfprint lors de l'emerge de fin car il semble être en dépendance, ce qui donne :
Code:
emerge xfce4 x11-themes/gtk-engines-xfce


Cdt
bonjour,
pour l'emerge -C j'aurai rajouté gtk-engines-xfce ce qui donnerait :
Code:
emerge -C xfce-extra/xfcalendar xfce-base/xffm xfce-extra/xfce4-iconbox xfce-extra/xfce4-trigger-launcher xfce-extra/xfce4-toys xfce-extra/xfce4-systray xfce-base/xfprint x11-themes/gtk-engines-xfce

Pour la dépendance xprint envers xfce j'ai pas regardé l'ebuild donc je n'ai pas d'avis.
A+
Back to top
View user's profile Send private message
TrizoLakai
Apprentice
Apprentice


Joined: 09 Jun 2006
Posts: 231
Location: Nantes (FRANCE)

PostPosted: Tue Feb 06, 2007 4:14 pm    Post subject: Reply with quote

Attends il y a un truc que je ne comprend pas.
Moi paludis -u xfce4 m'a désinstallé tout ce qui avait rapport avec xfce4 me semble t-il.

C'est pas de même avec emerge ? :?:
Back to top
View user's profile Send private message
Bapt
Veteran
Veteran


Joined: 14 Apr 2003
Posts: 1152
Location: Paris

PostPosted: Tue Feb 06, 2007 6:40 pm    Post subject: Reply with quote

TrizoLakai wrote:
C'est pas de même avec emerge ? :?:

Chut !!! il ne faut pas le dire trop fort il parait que c'est un gros troll ...
Back to top
View user's profile Send private message
nemo13
Veteran
Veteran


Joined: 08 Oct 2004
Posts: 1016
Location: France/Istres

PostPosted: Tue Feb 06, 2007 9:25 pm    Post subject: Reply with quote

Bapt wrote:
TrizoLakai wrote:
C'est pas de même avec emerge ? :?:

Chut !!! il ne faut pas le dire trop fort il parait que c'est un gros troll ...

je n'ai pas encore chopper le palus alors :?
il semblerait donc que ce ne soit pas tout à fait pareil
A+
Back to top
View user's profile Send private message
Vi66cent
n00b
n00b


Joined: 05 Aug 2006
Posts: 15
Location: Liege [Belgium]

PostPosted: Tue Feb 13, 2007 5:37 pm    Post subject: Reply with quote

Savez-vous quand cette version d'xfce passera en stable dans portage ?

Merci :)
Back to top
View user's profile Send private message
DuF
Advocate
Advocate


Joined: 09 Dec 2002
Posts: 2647
Location: Paris

PostPosted: Tue Feb 13, 2007 10:39 pm    Post subject: Reply with quote

Aucune idée, mais perso j'ai pas attendu et j'ai mis le tout en ~x86 et ça vaut le coup, surtout que c'est bien stable. La progression par rapport à la version précédente est intérêssante et surtout la transparence native à partir du moment que composite est activé. D'ailleurs, pour ceux qui le souhaitent, ne pas oublier d'ajouter le USE flag "xcomposite"...
Back to top
View user's profile Send private message
Vi66cent
n00b
n00b


Joined: 05 Aug 2006
Posts: 15
Location: Liege [Belgium]

PostPosted: Fri Feb 16, 2007 1:08 am    Post subject: Reply with quote

Hum...petit problème pour emerger xfce4.4, certain packet bloque d'autre...vous avez ce problème ?

Code:
# emerge -av xfce4 xfce-base/xfprint  x11-themes/gtk-engines-xfce

These are the packages that would be merged, in order:

Calculating dependencies... done!
[blocks B     ] <xfce-base/xfce4-panel-4.4 (is blocking xfce-base/libxfcegui4-4.4.0)
[blocks B     ] <xfce-base/xfce-utils-4.4 (is blocking xfce-base/xfce4-panel-4.4.0)
[blocks B     ] xfce-extra/xfce4-taskbar (is blocking xfce-base/libxfce4util-4.4.0-r1)
[blocks B     ] >=xfce-base/xfce4-panel-4.3 (is blocking xfce-extra/xfce4-minicmd-0.3.0-r1, xfce-extra/xfce4-battery-0.3.0-r1, xfce-extra/xfce4-cpugraph-0.2.2-r2, xfce-extra/xfce4-clipman-0.4.1-r2, xfce-extra/xfce4-showdesktop-0.4.0-r2)
[blocks B     ] xfce-extra/xfce4-showdesktop (is blocking xfce-base/libxfce4util-4.4.0-r1)
[blocks B     ] xfce-extra/xfce4-minicmd (is blocking xfce-base/libxfce4util-4.4.0-r1)
[blocks B     ] xfce-extra/xfce4-windowlist (is blocking xfce-base/libxfce4util-4.4.0-r1)
[ebuild     U ] xfce-base/libxfce4util-4.4.0-r1 [4.2.3.2] USE="-debug% -doc" 0 kB
[ebuild  N    ] gnome-extra/libgsf-1.14.2  USE="python -bzip2 -debug -doc -gnome -static" 0 kB
[ebuild  N    ] dev-libs/libcroco-0.6.1  USE="-debug" 0 kB
[ebuild     U ] x11-themes/gtk-engines-xfce-2.4.0 [2.2.8-r1] USE="(-static%)" 240 kB
[ebuild  N    ] app-text/recode-3.6-r2  USE="nls" 1,711 kB
[ebuild  N    ] x11-themes/hicolor-icon-theme-0.10  33 kB
[ebuild  N    ] gnome-base/librsvg-2.16.1  USE="zlib -debug -doc -gnome" 414 kB
[ebuild     U ] xfce-base/libxfce4mcs-4.4.0 [4.2.3] USE="-debug% -doc% -startup-notification%" 0 kB
[ebuild  N    ] games-misc/fortune-mod-1.99.1-r2  USE="-offensive" 1,770 kB
[ebuild     U ] xfce-extra/xfce4-icon-theme-4.4.0 [4.2.3] 1,756 kB
[ebuild     U ] xfce-base/xfce-utils-4.4.0-r2 [4.2.3] USE="-dbus% -debug% (-gtkhtml%)" 547 kB
[ebuild     U ] xfce-base/xfce4-panel-4.4.0 [4.2.3] USE="-debug% -doc% -startup-notification%" 800 kB
[ebuild     U ] xfce-base/libxfcegui4-4.4.0 [4.2.3] USE="-debug% -doc% -startup-notification%" 0 kB
[ebuild  N    ] xfce-base/orage-4.4.0  USE="-debug" 1,634 kB
[ebuild     U ] xfce-base/xfce-mcs-manager-4.4.0 [4.2.3] USE="-debug%" 0 kB
[ebuild     U ] xfce-base/xfwm4-4.4.0 [4.2.3.2] USE="xcomposite%* -debug% -startup-notification%" 1,636 kB
[ebuild     U ] xfce-base/xfprint-4.4.0 [4.2.3] USE="-debug% -doc%" 854 kB
[ebuild     U ] xfce-extra/xfce4-appfinder-4.4.0 [4.2.3] USE="-debug%" 362 kB
[ebuild     U ] xfce-extra/mousepad-0.2.12 [0.2.2-r1] USE="-debug%" 321 kB
[ebuild     U ] xfce-base/xfce-mcs-plugins-4.4.0 [4.2.3] USE="-debug%" 0 kB
[ebuild     U ] xfce-extra/xfwm4-themes-4.4.0 [4.2.3] 485 kB
[ebuild     U ] xfce-base/xfce4-session-4.4.0 [4.2.3] USE="-dbus% -debug% -gnome%" 1,298 kB
[ebuild     U ] xfce-extra/xfce4-mixer-4.4.0-r1 [4.2.3] USE="alsa -debug%" 457 kB
[ebuild  N    ] xfce-extra/exo-0.3.2  USE="python -debug -doc -hal -libnotify" 0 kB
[ebuild  N    ] xfce-base/thunar-0.8.0-r2  USE="pcre -dbus -debug -doc -exif -gnome -hal -plugins -startup-notification" 0 kB
[ebuild     U ] xfce-extra/terminal-0.2.6-r1 [0.2.4] USE="-dbus -debug -doc -startup-notification%" 1,545 kB
[ebuild     U ] xfce-base/xfdesktop-4.4.0-r3 [4.2.3] USE="-dbus% -debug% -doc% -minimal%" 3,077 kB
[ebuild     U ] xfce-base/xfce4-4.4.0 [4.2.3.2] USE="alsa%* cups%* -minimal% -oss% (-svg%)" 0 kB

Total: 28 packages (19 upgrades, 9 new, 7 blocks), Size of downloads: 18,933 kB

!!! Error: The above package list contains packages which cannot be installed
!!!        at the same time on the same system.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
Back to top
View user's profile Send private message
_droop_
l33t
l33t


Joined: 30 May 2004
Posts: 957

PostPosted: Fri Feb 16, 2007 7:56 am    Post subject: Reply with quote

Salut,

Supprimes les paquets qui te bloque, mets à jour ta gentoo et fais les installations dont tu as envie :

Code:
emerge -aC <xfce-base/xfce4-panel-4.4 <xfce-base/xfce-utils-4.4 xfce-extra/xfce4-taskbar >=xfce-base/xfce4-panel-4.3 xfce-extra/xfce4-showdesktop xfce-extra/xfce4-minicmd xfce-extra/xfce4-windowlist
emerge -aDuv world
emerge -av xfce4 xfce-base/xfprint  x11-themes/gtk-engines-xfce


Ca devrait aller comme çà.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum