Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
livecd won't boot on HP 9000/800/2000-44 (L-Class)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
firesox
Tux's lil' helper
Tux's lil' helper


Joined: 24 Nov 2005
Posts: 132

PostPosted: Fri Jan 26, 2007 1:15 pm    Post subject: livecd won't boot on HP 9000/800/2000-44 (L-Class) Reply with quote

Hi there,

while booting the hppa version of the gentoo livecd 2006.1 I get this:

Code:
 Reactivating console.
 Type Ctrl-B to access Guardian Service Processor Commands

Gentoo Linux; http://www.gentoo.org/
 Copyright 1999-2006 Gentoo Foundation; Distributed under the GPLv2

Press I to enter interactive boot mode

 * Mounting proc at /proc ...                                             [ ok ]
 * Mounting sysfs at /sys ...                                             [ ok ]
 * Mounting /dev for udev ...                                             [ ok ]
 * Seeding /dev with needed nodes .../sbin/functions.sh: line 678:  3327 Segmentation fault      ( import_addon "${addon}-start.sh" )
 * Mounting devpts at /dev/pts ...                                        [ ok ]
/etc/init.d/modules: command substitution: line 48: unexpected EOF while looking for matching `''
/etc/init.d/modules: command substitution: line 50: syntax error: unexpected end of file
 * Setting up dm-crypt mappings ...                                       [ ok ]
 * Mounting local filesystems ...                                         [ ok ]
 * Activating (possible) swap ...                                         [ ok ]
 * Setting up dm-crypt mappings ...                                       [ ok ]
/sbin/rc: line 385:  3407 Segmentation fault      ( local retval=; local service="$1"; local myservice="$1"; source "/etc/init.d/${service}"; retval=$?; in
    eerror "Failed to source /etc/init.d/${service}"; return "${retval}";
fi; local conf="$(add_suffix /etc/conf.d/${service})"; [[ -e ${conf} ]] && source "${conf}"; conf="$(add_suffix /etc/rc.conf)"; [[ -e ${conf} ]] && source)

 * One or more critical startup scripts failed to start!
 * Please correct this, and reboot ...                                                                                                                     


If I explicitly boot with 0/vmlinux32 it segfaults while processing the initrd. As I've seen in the hardware database, my machine was tested successfully on a serial console (which I have). Any hint?
Back to top
View user's profile Send private message
HPRichard
Tux's lil' helper
Tux's lil' helper


Joined: 02 Feb 2005
Posts: 94
Location: KA, Germany

PostPosted: Mon Jan 29, 2007 4:23 pm    Post subject: Reply with quote

My first thought is a defective livecd (error during downloading or burning). Did you check the md5sum of he downloaded iso image and of the burned CD-ROM?
The second thought is defective hardware (bad CPU, Cache, RAM for example), you could try to remove any unnecessary hardware from the machine an leave just one CPU, a minimum amount of RAM and the CD-ROM drive as well as the needed basic circuitry like the serial port and check if it works then.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum