Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[PALUDIS] Support thread (current v. 0.22.2) - Part 2
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 18, 19, 20  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
jorges
Tux's lil' helper
Tux's lil' helper


Joined: 31 Oct 2005
Posts: 114
Location: Barcelona, Spain

PostPosted: Mon Apr 16, 2007 8:48 am    Post subject: Re: Do I have to manually create symlinks for update-eix ? Reply with quote

zxy wrote:
jorges

do you use eselect use flag, too?
OK, now I see. One have to install the hooks first and then enable them via eselect, right? Thanks zxy.
Back to top
View user's profile Send private message
zxy
Veteran
Veteran


Joined: 06 Jan 2006
Posts: 1160
Location: in bed in front of the computer

PostPosted: Mon Apr 16, 2007 8:52 am    Post subject: Reply with quote

jorges

The logic behind install functions looks like this:

If you had it disabled before then it stays disabled, but if you had it enabled before install, then it stays enabled.
_________________
Nature does not hurry, yet everything is accomplished.
Lao Tzu
Back to top
View user's profile Send private message
dleverton
Guru
Guru


Joined: 28 Aug 2006
Posts: 517

PostPosted: Mon Apr 16, 2007 11:24 am    Post subject: Reply with quote

STEDevil wrote:
Is it really required to also change /usr/portage and /var/cashe/paludis to the same? Seems to work fine for me with root root 755 both on dirs and files which I assume is system default.

As long as the unprivileged account can read the necessary files from the tree, you should be OK.

EDIT: This also applies to the cache.
Back to top
View user's profile Send private message
sneakerski
Apprentice
Apprentice


Joined: 14 Oct 2003
Posts: 168

PostPosted: Wed Apr 18, 2007 2:11 am    Post subject: Reply with quote

Hello everybody. I'm trying to install an overlay with paludis, and I can't figure it out. In portage, you can just get the overlay's folder in whatever method you want, and then add the directory to PORTDIR_OVERLAYS and expect it to work.

Here's what I've done with paludis. Please correct me (and tell me WHY) where I've made mistakes or steps I've missed. I've tried reading around but to little avail.

I've got a folder named /usr/local/overlays/xeffects
In it, there is a profiles/ folder with the repo_name file in it with a single line, no whitespace name ("xeffects")

I've also made the file /etc/paludis/repositories/xeffects.conf
Here are it's contents:
Code:

location = ${ROOT}/usr/local/overlays/xeffects/
sync = svn://svn.gentoo-xeffects.org/xeffects
profiles = ${ROOT}/usr/portage/profiles/default-linux/amd64/2006.1
distdir = /usr/portage/distfiles
format = ebuild
names_cache = ${location}/.cache/names
write_cache = /var/cache/paludis/metadata


I've created the /usr/portage/overlays/xeffects/.cache/names directory.

Now, here're the errors I receive when trying to install something from the overlay.
Code:

 ... When loading virtual packages for repository 'xeffects'
  ... When loading category names for xeffects:
  ... No categories file for repository at '/usr/local/overlays/xeffects', faking it

Building dependency list.../usr/libexec/paludis/ebuild.bash: line 254: /usr/local/overlays/xeffects/sys-libs/glibc/glibc-2.5-r1.ebuild: Permission denied

!!! ERROR in sys-libs/glibc-2.5-r1:
!!! In ebuild_load_ebuild at line 254
!!! Error sourcing ebuild '/usr/local/overlays/xeffects/sys-libs/glibc/glibc-2.5-r1.ebuild'

!!! Call stack:
!!!    * ebuild_load_ebuild (/usr/libexec/paludis/ebuild.bash:254)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:339)
!!!    * main (/usr/libexec/paludis/ebuild.bash:372)

die trap: exiting with error.
paludis@1176846634: [WARNING] In program paludis -ip glibc:
  ... When performing install action from command line:
  ... When executing install task:
  ... When adding PackageDepSpec 'sys-libs/glibc':
  ... When checking mask reasons for 'sys-libs/glibc-2.5-r1::xeffects'
  ... When fetching metadata for 'sys-libs/glibc-2.5-r1':
  ... When generating version metadata for 'sys-libs/glibc-2.5-r1':
  ... Caught exception 'Name '' is not a valid slot name' (paludis::SlotNameError) when generating cache for 'sys-libs/glibc-2.5-r1::xeffects'
paludis@1176846634: [WARNING] (same context) Could not generate cache for 'sys-libs/glibc-2.5-r1::xeffects'
paludis@1176846634: [WARNING] No usable metadata for 'sys-libs/glibc-2.5-r1' in 'xeffects'

So, it seems like my two problems are that Paludis doesn't have permissions to the folder. I've changed the permissions of the folder to the same permissions /usr/portage has, but this didn't work. I'm stumped. (i chowned -R portage.portage the xeffects folder and then chmodded -R g+rw xeffects.)
Also, it's missing the metadata. How do I make the metadata? I tried cd'ing to the glibc directory and running ebuild glibc-2.5-r1.ebuild digest, which didn't work.

Thanks for any help!
_________________
Athlon 64 X2 @ 2ghz on an Asus nForce 4 w/ 1gig
Radeon X850 using OSS Radeon drivers
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5720
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Apr 18, 2007 6:45 am    Post subject: Reply with quote

http://forums.gentoo.org/viewtopic-p-4009298.html#4009298

read this post & follow the answers, then it should work
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.3.0-r2
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
jorges
Tux's lil' helper
Tux's lil' helper


Joined: 31 Oct 2005
Posts: 114
Location: Barcelona, Spain

PostPosted: Fri Apr 20, 2007 4:17 am    Post subject: keywords and slots Reply with quote

Hi,
I noticed something strange today when updating world. I have sun-jdk 1.5 and 1.6 installed and keyworded ~amd64 in /etc/paludis/keywords.conf, but when updating I get:
Code:
$ paludis -ip world
Building target list...
Building dependency list
These packages will be installed:

* dev-java/sun-jdk-1.6.0-r2::gentoo {:1.6} [U 1.6.0-r1] X alsa -doc -examples -jce (-nsplugin) <world>

Total: 1 package (1 upgrade)

General sets:

* world:           Packages that have been explicitly installed

So paludis is ignoring sun-jdk-1.5. Does the keyword apply to highest slot? Maybe it's because one of the slots is in world and the other not (BTW, how do I check this?)? Any ideas? If I wanted the 1.5 slot to be ~, what do I do?
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5720
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Apr 20, 2007 12:33 pm    Post subject: Reply with quote

are you still having this multislot-problem with gcc?

I'm trying to install a new amd64-system with paludis & gcc-3.3.6 paradoxically doesn't want to emerge without the multislot use-flag, with the multislot-useflag paludis pulls it in during every install :evil:

any advice? besides --dl-upgrade as-needed, which is no option during world-update (since lots of packages are being omitted)

thanks :)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.3.0-r2
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
zxy
Veteran
Veteran


Joined: 06 Jan 2006
Posts: 1160
Location: in bed in front of the computer

PostPosted: Fri Apr 20, 2007 12:36 pm    Post subject: Reply with quote

Code:
paludis ..... --dl-downgrade error


to see what package pulls it in
_________________
Nature does not hurry, yet everything is accomplished.
Lao Tzu
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5720
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Apr 20, 2007 12:58 pm    Post subject: Reply with quote

zxy wrote:
Code:
paludis ..... --dl-downgrade error


to see what package pulls it in

thanks :) ,

do I have to uninstall gcc-3.3.6 for that?
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.3.0-r2
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
zxy
Veteran
Veteran


Joined: 06 Jan 2006
Posts: 1160
Location: in bed in front of the computer

PostPosted: Fri Apr 20, 2007 1:06 pm    Post subject: Reply with quote

i don't know about gcc, but for kde and all other stuff i just reinstalled the packages (bottom of the listed ones that make an error with "dl-downgrade error") that were pulling in lower version of qt for example. Then qt wouldn't want to downgrade any more.
Should be the same with the packages that want gcc.

(Afaik qemu still needs gcc 3.*, but not sure.)
_________________
Nature does not hurry, yet everything is accomplished.
Lao Tzu
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5720
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat Apr 21, 2007 8:45 am    Post subject: Reply with quote

alright, unfortunately paludis didn't stop as expected, after another emerge, this behavior was gone, strange ...

... last time I encountered this, it took 3 times to emerge the same things to make it go away ...

I'm having a problem on amd64 btw:

paludis doesn't want to install amd64 nvidia-drivers:
when installing it only checks the *-Linux-x86* file, then tries to build the x86_64 driver with the x86 package!

"relocatable linking with relocations from format elf32-i386 to format elf64-x86-64 is not supported"

any idea ?

thanks in advance
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.3.0-r2
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
zxy
Veteran
Veteran


Joined: 06 Jan 2006
Posts: 1160
Location: in bed in front of the computer

PostPosted: Sat Apr 21, 2007 8:52 am    Post subject: Reply with quote

kernelOfTruth:

If you find bugs post them here:
http://paludis.pioto.org/trac/

and if you checked the FAQ page and didn't get the answer, then #paludis on IRC would be the place to ask too.
_________________
Nature does not hurry, yet everything is accomplished.
Lao Tzu
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5720
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sun Apr 22, 2007 9:22 am    Post subject: Reply with quote

zxy wrote:
kernelOfTruth:

If you find bugs post them here:
http://paludis.pioto.org/trac/

and if you checked the FAQ page and didn't get the answer, then #paludis on IRC would be the place to ask too.


I think the bug with gcc should have already been mentioned ...

I "fixed" it, I had used wrong use-flags when migrating from amd64 to x86 & borked my system somehow, installing it new right now, I'll install paludis later & report back if any problems occur

thanks
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.3.0-r2
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
Pse
Apprentice
Apprentice


Joined: 01 Mar 2005
Posts: 188
Location: by the plate river

PostPosted: Mon Apr 23, 2007 10:50 pm    Post subject: Reply with quote

I have recently switched over to Paludis and I was wondering what would be the right way to deal with binary packages. I've read somewhere that this functionality hasn't been implemented yet. Is it safe to use 'quickpkg'? Should I use 'emerge' to merge them, or should I stick to Paludis and cook up a 'fake' ebuild for the time being?
Thanks =)
Back to top
View user's profile Send private message
Simius
Apprentice
Apprentice


Joined: 26 Oct 2002
Posts: 219
Location: Budapest, Hungary

PostPosted: Sat Apr 28, 2007 12:39 pm    Post subject: Monodoc won't install with Paludis Reply with quote

My best guess is it's a directory issue. I wonder if the last path in the /usr/bin/gacutil call shouldn't be simply /usr/lib64 instead. After all, that's where libc.so is, and mono apparently can't find libc.so...

Code:

/usr/bin/gacutil /i monodoc.dll /f /package monodoc /gacdir /usr/lib64 /root /var/tmp/paludis/dev-util/monodoc-1.2.3/image//usr/lib64

Unhandled Exception: System.DllNotFoundException: libc
  at (wrapper managed-to-native) Mono.Tools.Driver:symlink (string,string)
  at Mono.Tools.Driver.Install (Boolean check_refs, System.String name, System.String package, System.String gacdir, System.String link_gacdir, System.String libdir, System.String link_libdir) [0x00000]
  at Mono.Tools.Driver.Main (System.String[] args) [0x00000]
make[2]: *** [install-data-local] Error 1
make[2]: Leaving directory `/var/tmp/paludis/dev-util/monodoc-1.2.3/work/monodoc-1.2.3/engine'
make[1]: *** [install-am] Error 2
make[1]: Leaving directory `/var/tmp/paludis/dev-util/monodoc-1.2.3/work/monodoc-1.2.3/engine'
make: *** [install-recursive] Error 1

!!! ERROR in dev-util/monodoc-1.2.3:
!!! In src_install at line 1818
!!! (no message provided)

!!! Call stack:
!!!    * src_install (/var/tmp/paludis/dev-util/monodoc-1.2.3/temp/loadsaveenv:1818)
!!!    * ebuild_f_install (/usr/libexec/paludis/src_install.bash:48)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:354)
!!!    * main (/usr/libexec/paludis/ebuild.bash:372)

die trap: exiting with error.

Install error:
  * In program paludis --install monodevelop:
  * When performing install action from command line:
  * When executing install task:
  * When installing 'dev-util/monodoc-1.2.3':
  * Install error: Install failed for 'dev-util/monodoc-1.2.3::gentoo'


Resume command: paludis --log-level qa --dl-deps-default discard --install '=dev-util/monodoc-1.2.3::gentoo' '=dev-dotnet/gtk-sharp-2.10.0::gentoo' '=dev-dotnet/gnomevfs-sharp-2.16.0::gentoo' '=dev-dotnet/art-sharp-2.16.0::gentoo' '=dev-dotnet/gnome-sharp-2.16.0::gentoo' '=dev-dotnet/gtksourceview-sharp-0.10-r1::gentoo' '=dev-dotnet/gecko-sharp-0.11-r1::gentoo' '=dev-dotnet/glade-sharp-2.10.0::gentoo' '=dev-dotnet/gconf-sharp-2.16.0::gentoo' '=net-libs/libsoup-2.2.99::gentoo' '=gnome-extra/gtkhtml-3.12.2::gentoo' '=dev-dotnet/gtkhtml-sharp-2.16.0::gentoo' '=dev-util/monodevelop-0.12::gentoo' --add-to-world-spec '( dev-util/monodevelop )'

#

_________________
You kinda have to sneak up on a mac...
- PC vs MAC (http://www.youtube.com/watch?v=iEAGmBRC1dc)
Back to top
View user's profile Send private message
Morpheuzz
n00b
n00b


Joined: 26 Oct 2004
Posts: 14
Location: Belgium

PostPosted: Mon Apr 30, 2007 1:11 pm    Post subject: Webrsync Reply with quote

I switched to paludis yesterday, without significant problems. However, i don't find an web-rsync option.
Is it possible to do a webrsync with paludis?
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5720
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sun May 06, 2007 8:17 pm    Post subject: Reply with quote

paludis 0.24.1 is out and I like what I see :D

hopefully this will fix some major annoyances with slots ...

http://paludis.pioto.org/news.html
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.3.0-r2
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
truc
Advocate
Advocate


Joined: 25 Jul 2005
Posts: 3199

PostPosted: Sun May 06, 2007 8:46 pm    Post subject: Reply with quote

kernelOfTruth wrote:
paludis 0.24.1 is out and I like what I see :D

hopefully this will fix some major annoyances with slots ...

http://paludis.pioto.org/news.html


Hello there, zxy is not here, and he was asked to make a new paludis support thread when 0.24.1 would be out, so..

here it is: [PALUDIS] Support thread (current v. 0.24.1) - Part 3 !
_________________
The End of the Internet!
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Mon May 07, 2007 5:43 am    Post subject: Reply with quote

Locked. Continue in thread mentioned above.
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 18, 19, 20
Page 20 of 20

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum