Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Trying to install Gentoo on my PS3
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
Omen_20
n00b
n00b


Joined: 22 Jan 2007
Posts: 1

PostPosted: Mon Jan 22, 2007 9:52 pm    Post subject: Trying to install Gentoo on my PS3 Reply with quote

Hi I'm trying to install Gentoo Linux on my PS3. I followed these two sets of directions:
http://ps3wiki.qj.net/index.php/Partition_and_get_ready
http://ps3wiki.qj.net/index.php/Gentoo_Howto

I've done everything right up until booting the installtion cd in the PS3. It boots up, shows the penguins and runs some USB drivers. The first time I did this it got to DHCP and put a [!!] error beside it. It then went on running USB drivers, then went to a blank black screen where it just set there.

Then I decided maybe it couldnt find my home network through its wireless thats built into the PS3. So I booted the PS3 back into its native OS. Checked to see if it was getting online properly, it was. I then decided to switch the PS3 from its onboard wifi to a wireless network adapter I used to use for my PS2. I set the PS3 to wired, and plugged in the device. It went online just fine. I then set it's default OS back to Other OS and rebooted it back into Linux.

This time it came up it never had a [!!] error. But it then still went to the USB drivers and then to a blank black screen.

On another forum its been brought to my attention that it may be because I dont have a mouse plugged in. I do have a USB keyboard plugged in but no mouse of any kind. It was also brought to my attention that my display settings may be screwing things up. My PS3 display settings are set to accept 480i, 480p, 720p, and 1080i. I'm running in Component on a 720p LCD.

Does anyone know why I keep getting a blank black screen? Any help would be appreciated.
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7974

PostPosted: Tue Jan 23, 2007 6:16 am    Post subject: Reply with quote

Moved from Installing Gentoo to Gentoo on Alternative Architectures.
Back to top
View user's profile Send private message
rangerpb
Developer
Developer


Joined: 19 Jan 2005
Posts: 147

PostPosted: Thu Jan 25, 2007 3:06 pm    Post subject: blank screen Reply with quote

If you are getting a blank screen after you boot your kernel (after the kboot prompt) it likely is the video mode. Does the minimal cdrom boot correctly? If so, cat /proc/cmdline and take a peek at the video settings there. Then remount your rootfs and fix the /etc/kboot.conf there. Perhaps your video settings differ and your monitor is not capable of the default settings in the rootfs kboot.conf file.

You can also find us on IRC and we can help you troubleshoot. Good luck.

BTW, I didnt quite understand your thread on wireless but Linux cannot use the PS3 onboard wireless *yet*.
_________________
-->
rangerpb
<--
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum