Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xfce 4.4
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 13, 14, 15  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
WakkaDojo
Apprentice
Apprentice


Joined: 26 Sep 2007
Posts: 174
Location: Massachusetts

PostPosted: Wed Oct 03, 2007 6:07 pm    Post subject: Super slow xfce terminal when composite enabled Reply with quote

Whenever I have composite windows enabled on xfce4, and I run the xfce terminal, everything gets really slow. I don't have this problem with any other applications; firefox, pidgin, xterm, wterm, you name it -- they all get a little slower when I enable composite windows (as expected), but there is a significant lag when the xfce terminal runs. I had trouble finding a solution for this problem on the internet, does anyone here think they can help?
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7907

PostPosted: Thu Oct 04, 2007 8:24 am    Post subject: Reply with quote

Merged the above post.

In addition to the discussion in this topic, a bug has been filed with Xfce upstream.
Back to top
View user's profile Send private message
ilm
Guru
Guru


Joined: 29 Jun 2006
Posts: 310
Location: Brisbane, Australia

PostPosted: Thu Oct 04, 2007 9:53 pm    Post subject: Reply with quote

IIRC, there's been posts in this thread before about Terminal being slow, not necessarily to do with composite.
Back to top
View user's profile Send private message
dodo1122
Guru
Guru


Joined: 02 Sep 2006
Posts: 347
Location: York, England

PostPosted: Fri Oct 05, 2007 3:11 pm    Post subject: Reply with quote

ilm wrote:
IIRC, there's been posts in this thread before about Terminal being slow, not necessarily to do with composite.


True, it's horribly slow, even though i don't use composite.


dodo
Back to top
View user's profile Send private message
96140
Retired Dev
Retired Dev


Joined: 23 Jan 2005
Posts: 1324

PostPosted: Fri Oct 05, 2007 6:03 pm    Post subject: Reply with quote

--

Last edited by 96140 on Fri Sep 13, 2013 9:04 am; edited 1 time in total
Back to top
View user's profile Send private message
disi
Veteran
Veteran


Joined: 28 Nov 2003
Posts: 1354
Location: Out There ...

PostPosted: Sat Oct 06, 2007 5:40 am    Post subject: Reply with quote

I haven't installed xfce since a while and now I am so amazed about all the new features, without making the desktop as giant as Gnome or KDE :D
Back to top
View user's profile Send private message
WakkaDojo
Apprentice
Apprentice


Joined: 26 Sep 2007
Posts: 174
Location: Massachusetts

PostPosted: Sun Oct 07, 2007 1:39 am    Post subject: Reply with quote

Yeah, I was on Ubuntu (with gnome) before I recently switched over to gentoo with xfce. I have to say xfce has proven a lot more capable than I thought. It's small and fast, but not nearly as stripped down as I was led to believe.

Anyway, so far as the xfce terminal goes, I just switched to aterm. I would vouch for it over xfce terminal: it is very configurable and super fast. Maybe it's a little more complicated to configure than the xfce terminal, but it's nothing an hour on the internet can't teach you.
Back to top
View user's profile Send private message
mueli
Retired Dev
Retired Dev


Joined: 05 Dec 2006
Posts: 14
Location: Graz - Austria

PostPosted: Tue Jan 15, 2008 10:22 am    Post subject: @Gergan Penkov composite patch Reply with quote

I've just found the suggested patch of Gergan but I have to say that it didn't help with my slowdown. xfce-terminal is still really slow, especially on switching workspace with an open terminal. Can I support you in any way to find the problem? I couldn't found a bug report on bgo about this topic ... can anyone launch a bug report? (jacobs always marks my reports as duplicates - I think I'm to silly for reporting bugs ;) )

g, Mueli

EDIT:
Sry - just found the info that there is already a bug report on xfce. The info about disabling composite solved my problem. In spite of everything a durable solution would be nice ....
_________________
"To Err is Human. But to Make a Real Mess You Need a
Computer Too" - Dan Rather
Back to top
View user's profile Send private message
mrgamer
Apprentice
Apprentice


Joined: 09 Dec 2003
Posts: 151
Location: Italy, near Rome

PostPosted: Sat Jan 19, 2008 10:12 am    Post subject: Re: @Gergan Penkov composite patch Reply with quote

mueli wrote:
Sry - just found the info that there is already a bug report on xfce. The info about disabling composite solved my problem. In spite of everything a durable solution would be nice ....


i've read that aswell, problem is... composite extension is required for run compiz/beryl, and that's why this is a very bad solution.
on the bugreport there is a patch for xfce-terminal-0.2.7-svn, that's not included in gentoo distribution as release 0.2.8

ideas on how/if we can include it in the ebuild ? the thing that makes me mad is that xubuntu works flawlessly with xfce 4.4.1 and its old packages
_________________
>>> Live or exist.. it's only your choice.<<<
Back to top
View user's profile Send private message
mueli
Retired Dev
Retired Dev


Joined: 05 Dec 2006
Posts: 14
Location: Graz - Austria

PostPosted: Sat Jan 19, 2008 10:50 am    Post subject: patch aply Reply with quote

Have you already tried to apply the patch to 0.2.8? Perhaps the effort for modifing the patch isn't high. Today I am busy but could you please post the (link to the) patch and I will have a look.

g, mueli
_________________
"To Err is Human. But to Make a Real Mess You Need a
Computer Too" - Dan Rather
Back to top
View user's profile Send private message
mrgamer
Apprentice
Apprentice


Joined: 09 Dec 2003
Posts: 151
Location: Italy, near Rome

PostPosted: Sat Jan 19, 2008 11:36 am    Post subject: Reply with quote

here it is: http://bugzilla.xfce.org/attachment.cgi?id=966 , directly from http://bugzilla.xfce.org/show_bug.cgi?id=2818

it's dated 27/01/2007 tho :roll:
_________________
>>> Live or exist.. it's only your choice.<<<
Back to top
View user's profile Send private message
mueli
Retired Dev
Retired Dev


Joined: 05 Dec 2006
Posts: 14
Location: Graz - Austria

PostPosted: Sat Jan 19, 2008 2:52 pm    Post subject: Reply with quote

Ok - but this is more or less the same patch as of Gergan Penkov presented here in this thread. I have already ported and applied this patch. I haven't debugged to see if
Code:
gdk_screen_is_composited(screen)
really returns true if composite is on but in fact the patch didnt' help for me either.

So we have to find more information on this ....

g, mueli

p.s.: I haven't further investigated because by disabling composite my problem was solved and I do not use compiz/beryl. But that doesn't mean I am not interested in solving the problem. What about the the connection of this bug to vte?
_________________
"To Err is Human. But to Make a Real Mess You Need a
Computer Too" - Dan Rather
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2, 3 ... 13, 14, 15
Page 15 of 15

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum