Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
MySql update
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
DArtagnan
l33t
l33t


Joined: 30 Apr 2002
Posts: 942
Location: Israel, Jerusalem

PostPosted: Tue Jun 18, 2002 4:57 am    Post subject: MySql update Reply with quote

Hi guys,
This morning started with mysql update as following:
rothsupport voicu # emerge -p -u world

These are the packages that I would merge, in order.

Calculating world dependencies ...done!
[ebuild U ] dev-db/mysql-3.23.49-r2 to /

Ok...sems to an update there so i tried to update my current:
rothsupport voicu # emerge -u world
Calculating world dependencies ...done!
>>> emerge dev-db/mysql-3.23.49-r2 to /
...
...
...
checking for BerkeleyDB... supplied
configure: error: didn't find valid BerkeleyDB: invalid version 3.2.9 (must be version 3.2.3h or 3.2.9a)

!!! ERROR: The ebuild did not complete successfully.
!!! Function src_compile, Line 105, Exitcode 1
!!! bad ./configure

!!! emerge aborting on /usr/portage/dev-db/mysql/mysql-3.23.49-r2.ebuild .

Nice huh? :-) Anyone knows what is going on?
I don't have BerkeleyDB in my mashine...and I don't want too.
Many thanks
_________________
All for one and one for All
--

MACPRO machine...
Back to top
View user's profile Send private message
mksoft
l33t
l33t


Joined: 28 May 2002
Posts: 844

PostPosted: Tue Jun 18, 2002 9:33 am    Post subject: Reply with quote

If think mysql needs BerkeleyDB (as well as other packages).

Try to remerge it (it is called db), before emerging mysql.
_________________
There's someone in my head but it's not me - Pink Floyd
Back to top
View user's profile Send private message
DArtagnan
l33t
l33t


Joined: 30 Apr 2002
Posts: 942
Location: Israel, Jerusalem

PostPosted: Tue Jun 18, 2002 9:35 am    Post subject: Reply with quote

Of some reason "emerge -p db" returns me nothing!
But "emerge -p sys-libs/db" works perfect.

Portage2 bug?
_________________
All for one and one for All
--

MACPRO machine...
Back to top
View user's profile Send private message
mksoft
l33t
l33t


Joined: 28 May 2002
Posts: 844

PostPosted: Tue Jun 18, 2002 9:38 am    Post subject: Reply with quote

Could be. I haven't upgraded to portage2 yet, and on my system emerge db works.
_________________
There's someone in my head but it's not me - Pink Floyd
Back to top
View user's profile Send private message
DArtagnan
l33t
l33t


Joined: 30 Apr 2002
Posts: 942
Location: Israel, Jerusalem

PostPosted: Tue Jul 02, 2002 8:50 pm    Post subject: Reply with quote

I got the error again and ofcorse tried to emerge db as you said some time ago and then emerge mysql.
This time it doesn't work...

!!! ERROR: The ebuild did not complete successfully.
!!! Function src_compile, Line 54, Exitcode 1
!!! bad ./configure

!!! emerge aborting on /usr/portage/dev-db/mysql/mysql-3.23.51-r1.ebuild .
_________________
All for one and one for All
--

MACPRO machine...
Back to top
View user's profile Send private message
Dalrain
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jul 2002
Posts: 136
Location: Wooster, OH USA

PostPosted: Tue Jul 02, 2002 10:05 pm    Post subject: MySQL funkyness Reply with quote

I'll also confirm the error; I'm getting the exact same problem (to the letter)

Guess I'll just keep watching this thread as well, I'm anxious for a fix. I also tried re-emerging db, which didn't seem to really help with this particular problem. Hmm..well, if anyone wants more input, feel free to post a reply and I can post more of the same error :)
Back to top
View user's profile Send private message
DArtagnan
l33t
l33t


Joined: 30 Apr 2002
Posts: 942
Location: Israel, Jerusalem

PostPosted: Tue Jul 02, 2002 10:08 pm    Post subject: Reply with quote

I FIXED THE PROBLEM :-)
Add to USE var. in /etc/make.conf this:
USE="-berkdb"

Then try emerge mysql
_________________
All for one and one for All
--

MACPRO machine...
Back to top
View user's profile Send private message
Dalrain
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jul 2002
Posts: 136
Location: Wooster, OH USA

PostPosted: Wed Jul 03, 2002 2:03 am    Post subject: Reply with quote

Hmmm...well, while that works, do we really want to just totally disable it? Seems like we're kind of avoiding the root of the problem taking that solution. Thank you very much for posting it, and I may end up going ahead and using that, but are there any other ways that don't workaround the problem?
Back to top
View user's profile Send private message
proxy
Apprentice
Apprentice


Joined: 20 Apr 2002
Posts: 253
Location: Chantilly, VA

PostPosted: Wed Jul 03, 2002 6:28 am    Post subject: Reply with quote

this is how i worked around it:

Code:

emerge unmerge sys-libs/db
emerge /usr/portage/sys-libs/db/db-3.2.3h-r4.ebuild (version it is asking for)
emerge -u mysql
emerge clean
emerge sys-libs/db


not very fun, but it works :P
Back to top
View user's profile Send private message
mglauche
Retired Dev
Retired Dev


Joined: 25 Apr 2002
Posts: 564
Location: Germany

PostPosted: Wed Jul 03, 2002 6:02 pm    Post subject: Reply with quote

as far as i remember the berkely DB backend from mysql isn't worth the trouble. The MyISAM or the InnoDB table handlers offer far more stability and flexibility.

IIRC berkelyDB was some sort of playground when there was only MyISAM, so you are really not missing much if u use -berkdb in the USE settings :)
Back to top
View user's profile Send private message
brain
Apprentice
Apprentice


Joined: 16 May 2002
Posts: 229
Location: Farmington Hills, MI

PostPosted: Wed Jul 03, 2002 6:02 pm    Post subject: Same problem... Reply with quote

I'm having the same issue.

Perhaps someone could update the build for the correct berkelyDB version? (3.2.9a)
_________________
--brain
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum