Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
revdep-rebuild errors out complaining about php
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Johnyp
Guru
Guru


Joined: 23 Mar 2005
Posts: 301

PostPosted: Wed Jan 17, 2007 7:26 am    Post subject: revdep-rebuild errors out complaining about php Reply with quote

Following the upgrade guide for MySQL upgrade 4.1->5 and got this during revdep-rebuild

Code:


....

All prepared. Starting rebuild...
emerge --oneshot  =dev-lang/php-4.4.2 =dev-lang/php-5.1.6-r4 =dev-libs/cyrus-sasl-2.1.22 =dev-perl/DBD-mysql-2.9007 =mail-mta/postfix-2.2.10 =net-libs/courier-authlib-0.58
..........
Calculating dependencies
emerge: there are no ebuilds to satisfy "=dev-lang/php-4.4.2".


revdep-rebuild failed to emerge all packages
you have the following choices:

- if emerge failed during the build, fix the problems and re-run revdep-rebuild
    or
- use -X or --package-names as first argument (trys to rebuild package, not exact
  ebuild)
    or
- set ACCEPT_KEYWORDS="~<your platform>" and/or /etc/portage/package.unmask
  (and remove /root/.revdep-rebuild.5_order to be evaluated again)
    or
- modify the above emerge command and run it manually
    or
- compile or unmerge unsatisfied packages manually, remove temporary files and
  try again (you can edit package/ebuild list first)

To remove temporary files, please run:
rm /root/.revdep-rebuild*.?_*

_________________
Gentoo Unanswered Questions- Give it a try!
Back to top
View user's profile Send private message
VolkerK
n00b
n00b


Joined: 17 Jan 2007
Posts: 6

PostPosted: Wed Jan 17, 2007 7:30 am    Post subject: Reply with quote

Quote:
ls -l /usr/portage/dev-lang/php/
total 144
-rw-r--r-- 1 portage portage 30001 Nov 27 01:06 ChangeLog
-rw-r--r-- 1 portage portage 11629 Nov 27 01:06 Manifest
drwxr-xr-x 2 portage portage 4096 Jan 16 03:37 files
-rw-r--r-- 1 portage portage 157 Sep 4 2005 metadata.xml
-rw-r--r-- 1 portage portage 14932 Jul 20 16:35 php-4.3.11-r5.ebuild
-rw-r--r-- 1 portage portage 15378 Nov 12 04:37 php-4.4.4-r6.ebuild
-rw-r--r-- 1 portage portage 15389 Oct 27 14:17 php-4.4.4-r8.ebuild
-rw-r--r-- 1 portage portage 10457 Jul 20 16:35 php-5.0.5-r5.ebuild
-rw-r--r-- 1 portage portage 15389 Nov 4 12:05 php-5.1.6-r6.ebuild
-rw-r--r-- 1 portage portage 15400 Oct 27 14:17 php-5.1.6-r8.ebuild
There is no ebuild for php-4.4.2 anymore.
Try
Code:
emerge -av dev-lang/php
then remove the temp files and re-run revdep
Code:
rm /root/.revdep-rebuild*
revdep-rebuild -X
Back to top
View user's profile Send private message
Johnyp
Guru
Guru


Joined: 23 Mar 2005
Posts: 301

PostPosted: Wed Jan 17, 2007 7:37 am    Post subject: Reply with quote

so why is it trying to install 4.4.2 when there is 4.4.4 in portage?
_________________
Gentoo Unanswered Questions- Give it a try!
Back to top
View user's profile Send private message
Johnyp
Guru
Guru


Joined: 23 Mar 2005
Posts: 301

PostPosted: Wed Jan 17, 2007 7:43 am    Post subject: Reply with quote

can i force it to install 4.4.4 instead of 4.4.2?
_________________
Gentoo Unanswered Questions- Give it a try!
Back to top
View user's profile Send private message
VolkerK
n00b
n00b


Joined: 17 Jan 2007
Posts: 6

PostPosted: Wed Jan 17, 2007 7:47 am    Post subject: Reply with quote

You currently have php-4.4.2 installed and revdep tries to re-emerge the exact same version
Quote:
emerge --oneshot =dev-lang/php-4.4.2 =dev-lang/php-5.1.6-r4
Do you have a need for php4 and php5 installed side-by-side?
Maybe
Code:
emerge -av =dev-lang/php-4.4.4-r8 =dev-lang/php-5.1.6-r4
will do the trick then.
Back to top
View user's profile Send private message
Johnyp
Guru
Guru


Joined: 23 Mar 2005
Posts: 301

PostPosted: Wed Jan 17, 2007 7:52 am    Post subject: Reply with quote

Hi,
yes - i'm still using php4 to run my site. Last time i checked it's software wasn't php5 compatible, so i'm running both at the same time. Thanks, i'll give it a try and update this topic
_________________
Gentoo Unanswered Questions- Give it a try!
Back to top
View user's profile Send private message
Johnyp
Guru
Guru


Joined: 23 Mar 2005
Posts: 301

PostPosted: Wed Jan 17, 2007 8:13 am    Post subject: Reply with quote

It just says that php-4.4.4-r8 is masked by ~x86 ! and i've looked around and can't find where it would be masked. None of the portage config files seem to even mention dev-lang/php-4*.....What's going on here!?
_________________
Gentoo Unanswered Questions- Give it a try!
Back to top
View user's profile Send private message
VolkerK
n00b
n00b


Joined: 17 Jan 2007
Posts: 6

PostPosted: Wed Jan 17, 2007 8:55 am    Post subject: Reply with quote

oops, according to http://packages.gentoo.org/search/?sstring=php php-4.4.4-r6 is the latest stable package. Either emerge this version or use
Code:
ACCEPT_KEYWORDS="~x86" emerge -av =dev-lang/php-4.4.4-r8 =dev-lang/php-5.1.6-r4



Johnyp wrote:
can't find where it would be masked.
It's masked by keyword within the ebuild file
/usr/portage/dev-lang/php/php-4.4.4-r8.ebuild wrote:
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
Back to top
View user's profile Send private message
Johnyp
Guru
Guru


Joined: 23 Mar 2005
Posts: 301

PostPosted: Wed Jan 17, 2007 9:10 am    Post subject: Reply with quote

Arrgggghhh!

I'm not feeling the love here.... i'm getting error after error...Anyone? What am i doing wrong ?






Code:
Unpacking courier-authlib-0.58.tar.bz2 to /var/tmp/portage/courier-authlib-0.58/work
QA Notice: USE Flag 'elibc_uclibc' not in IUSE for net-libs/courier-authlib-0.58

 * Cannot find $EPATCH_SOURCE!  Value for $EPATCH_SOURCE is:
 *
 *   /usr/portage/net-libs/courier-authlib/files/0.58-remove-obselete-macro.patch
 *   ( 0.58-remove-obselete-macro.patch )


!!! ERROR: net-libs/courier-authlib-0.58 failed.
Call stack:
  ebuild.sh, line 1546:   Called dyn_unpack
  ebuild.sh, line 708:   Called src_unpack
  courier-authlib-0.58.ebuild, line 52:   Called epatch '/usr/portage/net-libs/courier-authlib/files/0.58-remove-obselete-macro.patch'
  eutils.eclass, line 198:   Called die

!!! Cannot find $EPATCH_SOURCE!
!!! If you need support, post the topmost build error, and the call stack if relevant.


revdep-rebuild failed to emerge all packages
you have the following choices:

- if emerge failed during the build, fix the problems

_________________
Gentoo Unanswered Questions- Give it a try!
Back to top
View user's profile Send private message
VolkerK
n00b
n00b


Joined: 17 Jan 2007
Posts: 6

PostPosted: Wed Jan 17, 2007 9:29 am    Post subject: Reply with quote

Do you use an overlay for this ebuild?

The lines 37 - 59 of "my" /usr/portage/net-libs/courier-authlib/courier-authlib-0.58.ebuild are
Code:

src_unpack() {
        if ! has_version 'dev-tcltk/expect' ; then
                ewarn 'The dev-tcltk/expect package is not installed.'
                einfo 'Without it, you will not be able to change system login passwords.'
                einfo 'However non-system authentication modules (LDAP, MySQL, PostgreSQL,'
                einfo 'and others) will work just fine.'
        fi
        unpack ${A}
        cd ${S}
        sed -e"s|^chk_file .* |&\${DESTDIR}|g" -i.orig authmigrate.in
        use elibc_uclibc && sed -i -e 's:linux-gnu\*:linux-gnu\*\ \|\ linux-uclibc:' config.sub
        if ! use gdbm ; then
                epatch ${FILESDIR}/configure-db4.patch
        fi
        sed -i -e'/for dir in/a@@INDENT@@/etc/courier-imap \\' ${S}/authmigrate.in
        sed -i -e'/for dir in/a@@INDENT@@/etc/courier/authlib \\' ${S}/authmigrate.in
        sed -i -e"s|@@INDENT@@|         |g" ${S}/authmigrate.in
        sed -i -e"s|\$sbindir/makeuserdb||g" ${S}/authmigrate.in

        eautoreconf
}

src_compile() {
line 52 beeing sed -i -e'/for dir in/a@@INDENT@@/etc/courier/authlib \\' ${S}/authmigrate.in which is quite different from
Quote:
courier-authlib-0.58.ebuild, line 52: Called epatch
:?:

Does a
Code:
emerge --sync
fix it?
Back to top
View user's profile Send private message
Johnyp
Guru
Guru


Joined: 23 Mar 2005
Posts: 301

PostPosted: Wed Jan 17, 2007 7:18 pm    Post subject: Reply with quote

I've looked at my /usr/portage/net-libs/courier-authlib/courier-authlib-0.58.ebuild and here is what it says

Code:
src_unpack() {
   unpack ${A}
   cd "${S}"
   sed -e "s|^chk_file .* |&\${DESTDIR}|g" -i.orig authmigrate.in
   use elibc_uclibc && sed -i -e 's:linux-gnu\*:linux-gnu\*\ \|\ linux-uclibc:' config.sub
   if ! use gdbm ; then
      epatch "${FILESDIR}/${PV}-configure-db4.patch"
   else
      epatch "${FILESDIR}/${PV}-remove-obsolete-macro.patch"
   fi
   sed -i -e'/for dir in/a@@INDENT@@/etc/courier-imap \\' ${S}/authmigrate.in
   sed -i -e'/for dir in/a@@INDENT@@/etc/courier/authlib \\' ${S}/authmigrate.in
   sed -i -e"s|@@INDENT@@|      |g" ${S}/authmigrate.in
   sed -i -e"s|\$sbindir/makeuserdb||g" ${S}/authmigrate.in

   eautoreconf
}

_________________
Gentoo Unanswered Questions- Give it a try!
Back to top
View user's profile Send private message
Johnyp
Guru
Guru


Joined: 23 Mar 2005
Posts: 301

PostPosted: Wed Jan 17, 2007 7:41 pm    Post subject: Reply with quote

Ahhhhh! After playing around some more with it and using some of the sugestions from this thread in different order i have made it work! All is good now.

Everyone - Thank you very-very much for help, i don't know if i would ever decide to use Gentoo if it wasn't for noob friendly community!

_________________
Gentoo Unanswered Questions- Give it a try!
Back to top
View user's profile Send private message
VolkerK
n00b
n00b


Joined: 17 Jan 2007
Posts: 6

PostPosted: Wed Jan 17, 2007 9:34 pm    Post subject: Reply with quote

see http://sources.gentoo.org/viewcvs.py/gentoo-x86/net-libs/courier-authlib/courier-authlib-0.58.ebuild?r1=1.12&r2=1.13
Take a look at the dates. The error was there for only 12 hours ;)
Back to top
View user's profile Send private message
moocha
Watchman
Watchman


Joined: 21 Oct 2003
Posts: 5722
Location: Cluj-Napoca, Romania

PostPosted: Thu Jan 18, 2007 12:08 am    Post subject: Reply with quote

VolkerK wrote:
oops, according to http://packages.gentoo.org/search/?sstring=php php-4.4.4-r6 is the latest stable package. Either emerge this version or use
Code:
ACCEPT_KEYWORDS="~x86" emerge -av =dev-lang/php-4.4.4-r8 =dev-lang/php-5.1.6-r4



Johnyp wrote:
can't find where it would be masked.
It's masked by keyword within the ebuild file
/usr/portage/dev-lang/php/php-4.4.4-r8.ebuild wrote:
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
Please, please, please do not recommend using ACCEPT_KEYWORDS on the command line in any circumstances. Command-line environment variable overrides are NOT persistent, hence the next time the user will try to re-emerge that package either directly or via a system or world update portage will select the stable (arch) package instead of the one from the ~arch branch. Additionally, and perhaps even more evil, if you use the command line override then all the new dependencies pulled in by that package will also come from the ~arch branch, which is most likely not what the user intended.
Use /etc/portage/package.keywords for stuff like this, otherwise you run a high risk of breaking the hapless users' systems. I know you meant well, but this is a pretty big one :).
_________________
Military Commissions Act of 2006: http://tinyurl.com/jrcto

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
-- attributed to Benjamin Franklin
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum