Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
amd64: Microphone not working with ALSA driver hda-intel
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Sat Jan 06, 2007 3:22 pm    Post subject: amd64: Microphone not working with ALSA driver hda-intel Reply with quote

Hi,

I am experiencing problems with ALSA on my new laptop. It's a Acer 5102Wlmi. I have a ATI integrated soundcard:

Code:

# lspci |grep Audio
00:14.2 Audio device: ATI Technologies Inc SB450 HDA Audio (rev 01)


According to the ALSA website, this card uses driver hda-intel.

I have tried both the alsa driver built-in in the kernel and the driver provided by the package alsa-driver. If I use the alsa-driver package, I get the same issues as described in this post:

http://forums.gentoo.org/viewtopic-t-496491-highlight-acer+5102.html

On the other hand, if I include ALSA support on the kernel (it's built-in), everything works good, except that I cannot use the microphone.
I am using a headset. With kmix I have raised the volume of microphone to the higest value. But when I try to record something:

Code:

# arecord test.wav
Recording WAVE 'test.wav' : Unsigned 8 bit, Rate 8000 Hz, Mono
Aborted by signal Interrupt...


I get an empty wav file (44 bytes).

Same behaviour is observed using krec. Using skype and calling "Skype Test Call", my message is not recorded at all: if fact, I don't get 10 sec of silence, but a null message.
It seems like it's recording form /dev/null...

Anybody understand what's happening?
_________________
Darkman
Back to top
View user's profile Send private message
NaN
Tux's lil' helper
Tux's lil' helper


Joined: 02 Feb 2003
Posts: 93
Location: England

PostPosted: Mon Jan 15, 2007 3:15 pm    Post subject: Reply with quote

I had similar problems, also with Intel hda although not on the same machine.

I solved the microphone input by manually editing the file /etc/asound.state

On my system I scolled down to controls 21 and 23, both labelled "Capture Volume" and changed the volume values to 22. The maximum is 31, but I found 31 tended to clip a lot.

I didn't know how to get alsa to adopt the new values, so I just rebooted the machine. (:->

The microphone (and line input) works now. However I have a different problem with Skype. The first call is perfect, but when I try to make sbsequent calls I get nothing - a null message as you described. The microphone still works fine in other recording apps, so I suspect this is a Skype problem.

Hope this helps
David.
Back to top
View user's profile Send private message
irondog
l33t
l33t


Joined: 07 Jul 2003
Posts: 715
Location: Voor mijn TV. Achter mijn pc.

PostPosted: Mon Jan 15, 2007 8:06 pm    Post subject: Reply with quote

Same problem here. There are two problems. One is the hda-intel driver, the other one is skype. For me toggling some settings after booting works to enable the microphone for arecord, editing asound.state as described probably works just as well. If it works in arecord, it works for skype.

Skype-1.3.0.53 is broken: sometimes it works, but after a few calls it stops. You could use an older beta. Version 1.3.0.50 works without problems for me. It's not in portage anymore, but if you search well, you'll find it.

Best regards,
a hda-intel user.
_________________
Alle dingen moeten onzin zijn.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum