Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200701-03 ] Mozilla Thunderbird: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1540

PostPosted: Thu Jan 04, 2007 9:26 pm    Post subject: [ GLSA 200701-03 ] Mozilla Thunderbird: Multiple vulnerabili Reply with quote

Gentoo Linux Security Advisory

Title: Mozilla Thunderbird: Multiple vulnerabilities (GLSA 200701-03)
Severity: high
Exploitable: remote
Date: January 04, 2007
Bug(s): #158571
ID: 200701-03

Synopsis


Multiple vulnerabilities have been reported in Mozilla Thunderbird, some of
which may allow the remote execution of arbitrary code.


Background


Mozilla Thunderbird is a popular open-source email client from the
Mozilla Project.


Affected Packages

Package: mail-client/mozilla-thunderbird
Vulnerable: < 1.5.0.9
Unaffected: >= 1.5.0.9
Architectures: All supported architectures

Package: mail-client/mozilla-thunderbird-bin
Vulnerable: < 1.5.0.9
Unaffected: >= 1.5.0.9
Architectures: All supported architectures


Description


Georgi Guninski and David Bienvenu discovered buffer overflows in the
processing of long "Content-Type:" and long non-ASCII MIME headers.
Additionally, Frederik Reiss discovered a heap-based buffer overflow in
the conversion of a CSS cursor. Different vulnerabilities involving
memory corruption in the browser engine were also fixed. Mozilla
Thunderbird also contains less severe vulnerabilities involving
JavaScript and Java.


Impact


An attacker could entice a user to view a specially crafted email that
will trigger one of these vulnerabilities, possibly leading to the
execution of arbitrary code. An attacker could also perform cross-site
scripting attacks, leading to the exposure of sensitive information,
like user credentials. Note that the execution of JavaScript or Java
applets is disabled by default and enabling it is strongly discouraged.


Workaround


There are no known workarounds for all the issues at this time.


Resolution


All Mozilla Thunderbird users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=mail-client/mozilla-thunderbird-1.5.0.9"

All Mozilla Thunderbird binary release users should upgrade to the
latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=mail-client/mozilla-thunderbird-bin-1.5.0.9"


References

CVE-2006-6497
CVE-2006-6500
CVE-2006-6501
CVE-2006-6502
CVE-2006-6503
CVE-2006-6505


Last edited by GLSA on Tue Oct 25, 2011 4:23 am; edited 2 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum