Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
installing gentoo / chroot-problem on alphaserver
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
equinox0r
l33t
l33t


Joined: 18 Feb 2004
Posts: 614

PostPosted: Fri Dec 29, 2006 12:36 pm    Post subject: installing gentoo / chroot-problem on alphaserver Reply with quote

hi,

i have an alphaserver 2100 and trying to install gentoo. it fails at the step to chroot to my new environment with:
FATAL: kernel too old.

i bootet the legacy kernel (option 1) with no extra kernel parameters, because the standard kernel freezed the machine while booting the kernel/detecting network hardware.

any suggestions?


happy new year ^^
equinox0r
_________________
AMD 2400+ XP | 1024 MB RAM | ATI Radeon 9600Pro
Gentoo Base System version 1.4.16 | Portage 2.0.51.19 | 2.6.11-gentoo-r9 Kernel
Back to top
View user's profile Send private message
equinox0r
l33t
l33t


Joined: 18 Feb 2004
Posts: 614

PostPosted: Sat Dec 30, 2006 3:08 pm    Post subject: Reply with quote

no answers so far ... *push*

so does anyone have a clue why the livecd legacy kernel does not support chroot?
_________________
AMD 2400+ XP | 1024 MB RAM | ATI Radeon 9600Pro
Gentoo Base System version 1.4.16 | Portage 2.0.51.19 | 2.6.11-gentoo-r9 Kernel
Back to top
View user's profile Send private message
creideiki
n00b
n00b


Joined: 19 Feb 2003
Posts: 59
Location: Linköping, Sweden

PostPosted: Sun Dec 31, 2006 10:18 am    Post subject: Reply with quote

I don't have any Alpha systems, so I don't know what kernels you've been using, but I have seen that error before. It was on a system using kernel 2.6 and NPTL, and I tried to boot it from a LiveCD running kernel 2.4.

The problem wasn't chroot as such, it was that the Bash binary on the hard drive, which chroot tried to execute, needed NPTL but the LiveCD kernel didn't provide it. In my case, getting a LiveCD with a 2.6 kernel fixed it. In your case, I'd try looking for a stage tarball that's old enough that it doesn't use NPTL. Perhaps these ones work?
Back to top
View user's profile Send private message
equinox0r
l33t
l33t


Joined: 18 Feb 2004
Posts: 614

PostPosted: Wed Jan 03, 2007 2:04 pm    Post subject: Reply with quote

it worked perfectly, thx ..

but now the project is freezed, because my scsi-drives are only 2gb big and with 1,5gb on disc i have no more free inodes on the device, so that i have to get a new scsi hdd.. *gna*
_________________
AMD 2400+ XP | 1024 MB RAM | ATI Radeon 9600Pro
Gentoo Base System version 1.4.16 | Portage 2.0.51.19 | 2.6.11-gentoo-r9 Kernel
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum