Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
audio cd toimimaan??
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Finnish
View previous topic :: View next topic  
Author Message
luukkpe
n00b
n00b


Joined: 30 Mar 2005
Posts: 15

PostPosted: Fri Dec 29, 2006 3:32 pm    Post subject: audio cd toimimaan?? Reply with quote

Ongelma on "taas yksi" audio cd ei suostu toimimaan, kscd ilmoittaa et tarkista oikeudet levyä ei voi ladata. Myöskään k3b ei edes tunnista asemaa, mutta esim. gentoo asennusromppu liittyy ja näkyy (toimii siis), mut audio cd ei. Laitan tohon kopion fstabista.

# /etc/fstab: static file system information.
#
# noatime turns off atimes for increased performance (atimes normally aren't
# needed; notail increases performance of ReiserFS (at the expense of storage
# efficiency). It's safe to drop the noatime options if you want and to
# switch between notail / tail freely.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#
# See the manpage fstab(5) for more information.
#

# <fs> <mountpoint> <type> <opts> <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/hda1 /boot ext2 defaults,noatime 1 2
/dev/hda3 / reiserfs noatime 0 1
/dev/hda2 none swap sw 0 0
/dev/cdroms/cdrom0 /mnt/cdrom auto noauto,user 0 0
#/dev/fd0 /mnt/floppy auto noauto 0 0
/dev/hda4 /mnt/win vfat noauto,users,exec,umask=000 0 0
/dev/hdb1 /mnt/omat ntfs-3g noauto,users,exec,umask=000 0 0
# NOTE: The next line is critical for boot!
proc /proc proc defaults 0 0

# glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
# POSIX shared memory (shm_open, shm_unlink).
# (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
# use almost no memory if not populated with files)
shm /dev/shm tmpfs nodev,nosuid,noexec 0 0


Saattaa olla tyhymä ongelma, mut näit mulla riittää. Silti Gentoossa pysyn, opin hitaasti mutta varmasti. Ai nii meinas ihan unohtuu mites toi dvd puoli toimis.
Back to top
View user's profile Send private message
tmr
n00b
n00b


Joined: 19 Sep 2002
Posts: 48
Location: Finland

PostPosted: Fri Dec 29, 2006 8:20 pm    Post subject: Reply with quote

Audio-CD:itä ei pysty mounttaamaan, koska kyseiset lätyt eivät sisällä minkäänlaista tiedostojärjestelmää.
Back to top
View user's profile Send private message
luukkpe
n00b
n00b


Joined: 30 Mar 2005
Posts: 15

PostPosted: Fri Dec 29, 2006 10:43 pm    Post subject: niinpä niin Reply with quote

Jos yksinkertainen kysymys saa yksinkertaisen vastauksen niin miksi ihmeessä ette perusta salaseuraa, haluan oppia ymmärtämään gentoota, jos joku viksu neuvos
Back to top
View user's profile Send private message
tmr
n00b
n00b


Joined: 19 Sep 2002
Posts: 48
Location: Finland

PostPosted: Sat Dec 30, 2006 7:23 pm    Post subject: Re: niinpä niin Reply with quote

Joo, oli turhan pikaseen luettu kysymys. Minun veikkaus on, että käyttäjä ei kuulu cdrom ryhmään, asian voi tarkistaa komennolla 'groups'.

Jos käyttäjä ei ole cdrom-ryhmässä:
1) komenna 'gpasswd -a käyttäjä cdrom'.
2) Kirjaudu ulos (siis KDE:stä ja kaikista konsoleista, jos epävarma niin uudelleenkäynnistys) jne.
3) Kirjaudu takaisin ja kokeile uudestaan.

Jos taas on, vika on joku muu..
Back to top
View user's profile Send private message
luukkpe
n00b
n00b


Joined: 30 Mar 2005
Posts: 15

PostPosted: Fri Jan 05, 2007 7:33 am    Post subject: audio cd toimimaan Reply with quote

Pitääkin kokelilla tota, ja sori et moitin teitä auttajia, niin monet bropleemat on selvinnyt teidän avullaja (':oops:')
Back to top
View user's profile Send private message
luukkpe
n00b
n00b


Joined: 30 Mar 2005
Posts: 15

PostPosted: Fri Jan 05, 2007 10:32 am    Post subject: Nyt toimii cd:t Reply with quote

olin kyll tyhymä ko en tota tajunnut, et pitäähän se kuulua cdrom ryhmään. No nyt toimii oikee hyvin. (':lol:')
Toinen kyssäri on et kuis saan dvd:t näkyy/kuuluu, pitääkö fstab:iin jotain muutoksia tehdä.
Back to top
View user's profile Send private message
Obi-Lan
Apprentice
Apprentice


Joined: 21 Jan 2005
Posts: 230
Location: Riihimäki

PostPosted: Fri Jan 05, 2007 9:35 pm    Post subject: Reply with quote

Data DVD vai elokuva DVD? Data DVD voi mounttia niinkuin normi cd:nkin, elokuva DVD vaatii oman ohjelman esim. ogle tai mieluummin mplayer.
Back to top
View user's profile Send private message
luukkpe
n00b
n00b


Joined: 30 Mar 2005
Posts: 15

PostPosted: Sat Jan 06, 2007 8:58 am    Post subject: Kiiitti neuvoista Reply with quote

Homma pelittää muuten ihan ok, mutta en saa päivittäneeksi ollenkaan järjestelmää. Enkä myöskään saa asennetuksi Gnomea, aina on joku error. Tossa loppuosa gnome-lightin as. yrityksestä.

>>> Emerging (13 of 55) dev-python/pyopengl-2.0.0.44 to /
* PyOpenGL-2.0.0.44.tar.gz MD5 ;-) ... [ ok ]
* PyOpenGL-2.0.0.44.tar.gz RMD160 ;-) ... [ ok ]
* PyOpenGL-2.0.0.44.tar.gz SHA1 ;-) ... [ ok ]
* PyOpenGL-2.0.0.44.tar.gz SHA256 ;-) ... [ ok ]
* PyOpenGL-2.0.0.44.tar.gz size ;-) ... [ ok ]
* checking ebuild checksums ;-) ... [ ok ]
* checking auxfile checksums ;-) ... [ ok ]
* checking miscfile checksums ;-) ... [ ok ]
* checking PyOpenGL-2.0.0.44.tar.gz ;-) ... [ ok ]
>>> Unpacking source...
>>> Unpacking PyOpenGL-2.0.0.44.tar.gz to /var/tmp/portage/pyopengl-2.0.0.44/work
* Applying config.diff ... [ ok ]
* Applying pyopengl-2.0.0.44-fix_togl.patch ... [ ok ]

!!! ERROR: dev-python/pyopengl-2.0.0.44 failed.
Call stack:
ebuild.sh, line 1546: Called dyn_unpack
ebuild.sh, line 708: Called src_unpack
pyopengl-2.0.0.44.ebuild, line 34: Called built_with_use 'dev-lang/python' 'tk'
eutils.eclass, line 1617: Called die

!!! dev-lang/python-2.4.3-r1 does not actually support the tk USE flag!
!!! If you need support, post the topmost build error, and the call stack if relevant.

Miun hoonolla enklannilla en saa muuta tollkua ko toi dev-python/py..... kenkkuilee, mutta mitä voin tehdä?

tux ~ # emerge --update --deep --newuse world
Calculating world dependencies... done!

!!! Error: the =kde-base/khelpcenter-3.5* package conflicts with another package;
!!! the two packages cannot be installed on the same system together.
!!! Please use 'emerge --pretend' to determine blockers.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

tossa on kun yritän päivittää, mikä on vikana?? meneekö taas kerran as. uusiksi vai mikä avuksi :(
Mulla on tosiaan toi enkku nii kehnoo etten jymmärrä juuri pätkääkään, et ihan selkokielellä jos joku voisi auttaa.
Back to top
View user's profile Send private message
Obi-Lan
Apprentice
Apprentice


Joined: 21 Jan 2005
Posts: 230
Location: Riihimäki

PostPosted: Sat Jan 06, 2007 11:43 am    Post subject: Reply with quote

Ensimmäinen error kertoo, että sinulla on USE flägeissä (eli lipuissa) merkitty tk, josta toi python paketti ei tykkää. Tämän voit korjaa:

Code:

echo 'dev-lang/python -tk' >> /etc/portage/package.use
emerge python


Toinen errori kertoo, että sinulla on jokin paketti joka estää khelpcenterin asentamisen. Ensinnäkin voit lyhentää tuon käyttämäsi komennon seuraavalla:

Code:

emerge -uDN world


Ja jos lisäät optioihin p:n niin saat listan mitä toi haluaa päivittää ja siellä lukee myös mikä paketti estää tuon asentumisen, siinä rivillä tais lukee block, joten voit pastee sen rivin vaikka sitten tänne, eli seuraavasti:

Code:

emerge -uDNp world
Back to top
View user's profile Send private message
Flammie
Developer
Developer


Joined: 02 Jun 2003
Posts: 633
Location: Dublin, Ireland

PostPosted: Sat Jan 06, 2007 1:17 pm    Post subject: Reply with quote

Obi-Lan wrote:
Ensimmäinen error kertoo, että sinulla on USE flägeissä (eli lipuissa) merkitty tk, josta toi python paketti ei tykkää. Tämän voit korjaa:

Code:

echo 'dev-lang/python -tk' >> /etc/portage/package.use
emerge python



Tarkalleen ottaen luulisin, että ongelma on tosin siinä, että jokin ebuildi haluaa tietää onko pythonissa tk-tuki päällä vai ei, mutta vanhempi pythonin ebuildi ei tätä kerro. Ongelma toki korjaantuu yllä mainitulla ratkaisulla, mutta vain siksi, että sen sivuvaikutuksena python päivittyy versioon jonka ebuildi osaa kertoa tk:nsa tilasta.
Back to top
View user's profile Send private message
luukkpe
n00b
n00b


Joined: 30 Mar 2005
Posts: 15

PostPosted: Sat Jan 06, 2007 2:09 pm    Post subject: Päivitys Reply with quote

Nyt sain päivityksen toimimaan, yksikertaisesti vaan --umergellä poistelin sitä mukaa "palikat" jotka heitti herjaa. Käytän xfce4, mut kde:stä oli asennettuna vaan kdebase saadakseni käynnistyksen valintaruudulle (kai sen valintaruudun olis saaanut xfce4:äänkin)
Gnomen haluan asentaa koska se on minusta käytännölisin työpöytä, mutta nyt näyttää hyvältä Poistin myös coldplugin koska sekin herjas, enkä tiedä tarviiko sitä ollenkaan (Slackwaressa ei ainakaan).

Kiitoksia hyvistä neuvoista
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Finnish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum